Αποστολέας Θέμα: Τυποποίηση vs Σκέψης  (Αναγνώστηκε 10003 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #15 στις: 06 Απρ 2011, 11:41:47 μμ »
ακριβώς αυτή είναι η ιδέα.
Απλά παρατηρώ ότι αν δώσω την άσκηση σε μαθητή που δεν έχει κάνει ταξινόμηση, μπορεί να τη λύσει έτσι, αλλά αν τη δώσω σε μαθητές που έχουν κάνει ταξινόμηση τότε 9 στους 10 θα χρησιμοπιήσουν μια "επαναλαμβάνομενη" ταξινόμηση και ήθελα να θιξω το θέμα
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Keep Growing

  • Ομάδα διαγωνισμάτων 2011
  • *
  • Μηνύματα: 2023
  • Παναγιώτης Πέντσας Γυμνάσιο Σορωνής
    • Περισσότερες πληροφορίες για μένα
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #16 στις: 06 Απρ 2011, 11:43:23 μμ »
Πράγματι, πολύ απλή και αποτελεσματική η λύση του Ευριπίδη.
Μπορεί να γίνει και μια παραλλαγή, βάζοντας στο παιχνίδι και τους αρνητικούς αριθμούς.
Σε αυτή την περίπτωση θα πρέπει να αρικοποιήσουμε αρχικά τον πίνακα με τον ελάχιστο ακέραιο.
Ο Έρωτας (του Εκπ/κου Πληροφορικού) στ' αλώνια της καλδέρας (του υπνωτισμού).

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #17 στις: 06 Απρ 2011, 11:47:16 μμ »
Παναγιώτη τι εννοείς? δεν το κατάλαβα. Κάποια παραλλαγή της εκφώνησης?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Keep Growing

  • Ομάδα διαγωνισμάτων 2011
  • *
  • Μηνύματα: 2023
  • Παναγιώτης Πέντσας Γυμνάσιο Σορωνής
    • Περισσότερες πληροφορίες για μένα
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #18 στις: 06 Απρ 2011, 11:51:26 μμ »
Να, λέω αν όλοι οι αριθμοί που θα διαβάζονται είναι αρνητικοί, για να μπορεί να δουλέψει ο αλγόριθμος, θα πρέπει ο πίνακας ΜΑΧ[Ν] αρχικά να αρχικοποιηθεί με τον μικρότερο ακέραιο (-max) και όχι με το 0. Είναι λεπτομέρεια,  αλλά καλό είναι να το γνωρίζουν οι μαθητές.
Ο Έρωτας (του Εκπ/κου Πληροφορικού) στ' αλώνια της καλδέρας (του υπνωτισμού).

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #19 στις: 07 Απρ 2011, 12:01:53 πμ »
ααα κατάλαβα
λοιπόν δεν αρχικοποιείς τον πίνακα, απλά διαβάζεις στην αρχή Ν στοιχεία, τα βάζεις στον πίνακα και στη συνέχεια διαβάζεις τα υπόλοιπα ένα ένα.

Τώρα με αυτό που είπες μου θύμησες μια άσκηση που λέει "να διαβάζει αριθμούς και να υπολογίζει τον μικρότερο θετικό και τον μεγαλύτερο αρνητικό",
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #20 στις: 07 Απρ 2011, 10:16:59 πμ »
Βρες κάθε φορά τον χειρότερο και δες αν αυτός που ήρθε είναι καλύτερός του.
Αν ναι βαλτόν στην θέση του.

Τόσο απλό!!!
 όταν λέμε Ν μεγαλύτεροι δεν θέλουμε να είναι και ταξινομημένοι, απλά να είναι οι καλύτεροι, τώρα σε ποια σειρά θα είναι δεν μας ενδιαφέρερει

Έτσι όμως χάνουμε την σειρά με την οποία διαβάστηκαν.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #21 στις: 07 Απρ 2011, 10:32:45 πμ »
Ναι βρε, αυτή είναι η λύση για την πρώτη (εύκολη) έκδοση της άσκησης που μπορεί να δοθεί σε μαθητές.

Εσύ έλυσες κατευθείαν τη 2η έκδοση που είναι απαραραίτητη και η σειρά. Αυτό είναι πιο δύσκολο
Απλά ο σκοπός που υπάρχει η 2η έκδοση είναι για να αποτρέψει τον μαθητή από το να κάνει την εύκολη συνταγή με την ταξινόμηση. Γενικά αν βάλεις στο παιχνίδι και τη σειρά με την οποία έρχονται ο μαθητής δεν μπορεί να κάνει ταξινόμηση, έτσι όμως δυσκολεύει πολύ


Έτσι όμως χάνουμε την σειρά με την οποία διαβάστηκαν.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #22 στις: 07 Απρ 2011, 11:06:58 πμ »
Γιατί δεν ακολουθείτε μια πολύ απλή λύση;

1. είσοδος όλων των στοιχείων σε πίνακα
2. ταξινόμηση
3. Εμφάνιση των Ν (οσωνδήποτε) μεγαλύτερων

ssimaiof

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 23
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #23 στις: 07 Απρ 2011, 11:10:06 πμ »
Κώδικας: [Επιλογή]
! Να γράψετε αλγόριθμο ο οποίος να διαβάζει αριθμούς μέχρι να δοθεί 0.
! Να εμφανίζει τους Ν μεγαλύτερους αριθμούς με τη σειρά που τους διάβασε.
ΠΡΟΓΡΑΜΜΑ Ν_Μεγαλύτεροι
ΣΤΑΘΕΡΕΣ
  Ν = 5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Μεγ[Ν]                ! Πίνακας με τους Ν Μεγαλ. αριθμούς
  ΑΚΕΡΑΙΕΣ: Α, Κ, Θ, i
ΑΡΧΗ
  Κ <- 0                          ! Μετράει το πλήθος των καταχωρημένων ααριθμών στον Μεγ
  ΓΡΑΨΕ 'Δώστε έναν αριθμό :  '
  ΔΙΑΒΑΣΕ Α
  Θ <- 1                          ! Κρατάμε τη θέση του μικρότερου στον Μεγ
  ΟΣΟ Α <> 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ Κ < Ν ΤΟΤΕ                 ! Τους πρώτους Ν αριθμούς
      Κ <- Κ + 1                  !   απλά τους καταχωρούμε στον Μεγ
      Μεγ[Κ] <- Α                 !
      ΑΝ Α < Μεγ[Θ] ΤΟΤΕ          !   και Κρατάμε τη θέση του μικρότερου στον Μεγ
        Θ <- Κ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ Α > Μεγ[Θ] ΤΟΤΕ          ! Αν ο αριθμός είναι μεγαλ. από το μικρότ. στοιχεό του Μεγ
        ΓΙΑ i ΑΠΟ Θ ΜΕΧΡΙ Ν - 1   !   Από τη θέση του μικρότερου
          Μεγ[i] <- Μεγ[i + 1]    !     Μετέφερε τα στοιχεία μία θέση πριν
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ          !     ελευθερώνοντας την τελευταία θέση
        Μεγ[Ν] <- Α               !   Στην τελευταία θέση βάλε τον αριθμό
        Θ <- 1                    ! Βρες τη θέση του νέου μικρότερου στοιχείου στον Μεγ
        ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν
          ΑΝ Μεγ[i]<Μεγ[Θ] ΤΟΤΕ
            Θ <- i
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Δώστε έναν αριθμό :  '
    ΔΙΑΒΑΣΕ Α
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Κ             ! Εμφάνισε τους μεγαλύτερους αριθμούς
    ΓΡΑΨΕ Μεγ[i], '  '
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
[/font]

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #24 στις: 07 Απρ 2011, 11:46:25 πμ »
Γιατί δεν ακολουθείτε μια πολύ απλή λύση;

1. είσοδος όλων των στοιχείων σε πίνακα
2. ταξινόμηση
3. Εμφάνιση των Ν (οσωνδήποτε) μεγαλύτερων

Γιατί ο πίνακας που προκύπτει είναι δυναμικός.

Δεν υπάρχει ομοιότητα με το περσινό θέμα 3. Εκεί μπορούμε να έχουμε κανονικά στατική δομή.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #25 στις: 07 Απρ 2011, 11:53:42 πμ »
Κι όμως, αφού έχουμε αλγόριθμο δεν μας ενδιαφέρει το πλήθος των στοιχείων του πίνακα, μπορώ να έχω όσα στοιχεία θέλω

στον αλγόριθμο δεν καθορίζω σε κανένα σημείο πόσα στοιχεία θα χρειαστώ και φυσικά υπάρχουν γλώσσες προγραμματισμού που υλοποιούν δυναμικούς πίνακες

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #26 στις: 07 Απρ 2011, 11:58:05 πμ »
ακριβώς, εδώ υπάρχει τιμή φρουρός, δεν ξέρεις το μέγεθος του πίνακα παρά μόνο όταν έχει περάσει το τελευταίο στοιχείο, οπότε πρέπει να δουλέψεις με δυναμικούς πίνακες.
Πράγματι δεν είναι το ίδιο με το θέμα 3, αλλά ο γενικότερος προβληματισμός παραμένει ο ίδιος. Δηλαδή από τη μια έχεις μια λύση που προκύπτει με μια απλή σκέψη (θέση<-θέση+1) και από την άλλη κάνεις ταξινόμηση και αναζήτηση.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #27 στις: 07 Απρ 2011, 11:59:50 πμ »
Χμμ... βλέπω ότι ο Παναγιώτης το αντιμετωπίζει στην πιο γενική μορφή του.
Λέτε να αλλάξω την εκφώνηση και να βάλω πρόγραμμα?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #28 στις: 07 Απρ 2011, 12:01:58 μμ »
Κι όμως, αφού έχουμε αλγόριθμο δεν μας ενδιαφέρει το πλήθος των στοιχείων του πίνακα, μπορώ να έχω όσα στοιχεία θέλω

στον αλγόριθμο δεν καθορίζω σε κανένα σημείο πόσα στοιχεία θα χρειαστώ και φυσικά υπάρχουν γλώσσες προγραμματισμού που υλοποιούν δυναμικούς πίνακες

Καλώς ή κακώς υπάρχει αυτή η σύμβαση μέσα στο βιβλίο. Ότι δηλαδή οι πίνακες είναι στατικοί. Δεν  με πειράζει η στατικότητα των πινάκων αλλά ο ορισμός που το βιβλίο δίνει και ο τρόπος που χειρίζεται τους πίνακες στην ψευδογλώσσα και αυτό επειδή πιστεύω ότι υπάρχει ασυνέπεια.

Παναγιώτη νομίζω δεν έχει νόημα να συζητάμε συνεχώς τα ίδια. Δεν θέλω να εμπλακώ πάλι σε μια τέτοια κουβέντα. Οι απόψεις του καθενός έχουν διατυπωθεί πολλές φορές.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Τυποποίηση vs Σκέψης
« Απάντηση #29 στις: 07 Απρ 2011, 12:03:25 μμ »
Αυτό ακριβώς έκανα Στάθη, επανέλαβα προτάσεις που έχω διαβάσει στο παρελθόν

Καλή συνέχεια...