Αποστολέας Θέμα: ψευδογλώσσα και πίνακες  (Αναγνώστηκε 24471 φορές)

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 599
    • Ανάπτυξη Εφαρμογών
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #46 στις: 02 Ιούν 2010, 01:01:11 πμ »
Παράθεση
Φυσικά και όχι, αλλά πως θα μπορούσε να γίνει αυτό? Υπάρχει έστω έναελάχιστο σημείο από το οποίο μπορεί κάποιος με παρερμηνεία να θωρήσειότι μπορεί να μπει δείκτης αρνητικός αριθμός? .

Προσωπικά θα μπορούσα. Γιατί να μην μπορεί να γίνει; Αφού στο αλγόριθμο μπορούμε να χρησιμοποιούμε και να θεωρούμε τον πίνακα όπως θέλουμε ή όπως τον θεωρούν κάποιες γλώσσες προγραμματισμού, εγώ βάζω και αρνητικούς δείκτες. Που είναι το πρόβλημα; Η Pascal δεν το χρησιμοποιεί; (Αυτό γιατί κάποιοι παρουσιάσανε κώδικά στη C για να στηρίξουν τα επιχειρήματά τους). Αν λοιπον κάποιος θεωρεί λάθος την παρακάτω απάντηση:
Παράθεση
Nα γίνει αλγόριθμος, ο οποίος να διαβάζει 500 ακέραιους αριθμούς από-10 μέχρι 10. Να εμφάνίζει τον αριθμό που εμφανίζεται τις περισσότερεςφορές.


για κ από 1 μέχρι 500
     διάβασε Α[κ]
τέλος_επανάληψης


για αρ από -10 μέχρι 10
    Συχν[αρ]<-0
    για κ από 1 μέχρι 500
       αν Α[κ] = αρ τότε
            Συχν[αρ]<-Συχν[αρ]+1
       τέλος_αν
    τέλος_επανάληψης
τέλος_επανάληψης
......
ας ψάξει εκεί κοντά θα βρίσκεται και η απάντηση, γιατί η χρήση πινάκων πρέπει να θεωρείται λάθος στο Γ΄θέμα.

Παράθεση
Επίσης με την ευκαιρία θα ήθελα να σημειώσω ότι όταν η ΕΠΥ ή η ΠΕΚΑΠδηλώνουν αυτά που δηλώνουν πρέπει να είναι αρκετά προσεκτικοί και νασκέφτονται λίγο τις προεκτάσεις των επιχειρημάτων τους στα δεδομένα τουμαθήματος.   
Όταν λέω προεκτάσεις Βαγγέλη δεν εννοώ ότι η άσκηση δεν μπορεί να λυθεί με πίνακες, απλά ότι αλλάζουν κάποια δεδομένα στο μάθημα ως προς την χρήση πινάκων. Του χρόνου να μας απαντήσουν η ΕΠΥ και η ΠΕΚΑΠ τι θα λέμε στους μαθητές μας σε παρόμοιες ασκήσεις, σε ασκήσεις με τιμή φρουρό (γιατί και αυτές λύνονται με πίνακες πλεον ή και αν δεν λύνονται 1 με 2 μόρια θα χαθούν άρα συμφέρει να τις λύσω με πίνακες), αλλά και με τους αρνητικούς δείκτες.
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #47 στις: 02 Ιούν 2010, 01:04:17 πμ »

 Όταν λέω προεκτάσεις Βαγγέλη δεν εννοώ ότι η άσκηση δεν μπορεί να λυθεί με πίνακες,

Τελικά πέρα από τις αντιθέσεις μας εδώ μέσα, όλοι μας, ίσως να μην είμαστε τόσο μακριά όσο φαίνεται...

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 599
    • Ανάπτυξη Εφαρμογών
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #48 στις: 02 Ιούν 2010, 01:10:22 πμ »
Τέλος πάντων νομίζω ότι καταλαβαινόμαστε. :) :)
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #49 στις: 02 Ιούν 2010, 01:10:34 πμ »
Κώστα είσαι άδικος και σκληρός.

Το αντιγράφω όπως ακριβώς το έγραψα αλλού, σβήνοντας ένα κομμάτι που δεν σε αφορά μιας και εσύ επώνυμα βγαίνεις και εκτίθεσαι.

...Δεν θέλω να μακρυγορήσω και να γεμίσω σελίδες με ιστορικά γεγονότα και να απαριθμήσω τους λόγους για τους οποίους δεν πρέπει να φερόμαστε αλαζωνικά σε ανθρώπους που φαντάστηκαν, έστησαν, έγραψαν και έδωσαν στον κλάδο ένα μάθημα που εξετάζεται πανελλαδικά.

Οι συγγραφείς του βιβλίου διδάσκουν σε κάποιους από τους φοιτητές τριτοβάθμιων τμημάτων πληροφορικής σε Αθήνα και Θεσσαλονίκη Αλγοριθμική και είναι οι ίδιοι που έχουν "βγάλει" εκατοντάδες καθηγητές δευτεροβάθμιας, έχουν πλούσιο συγγραφικό έργο, έχουν "εκτεθεί" επώνυμα στη διεθνή και την ελληνική κοινότητα είτε ως εκπρόσωποι ενός επιστημονικού σωματείου τού κλάδου των πληροφορικών, είτε με το έργο τους (Ο Τάκης Πολίτης βρίσκεται κρατούμενος αυτή τη στιγμή από τους Ισραηλινούς, συμμετέχοντας ως ακτιβιστής Στο ένα καράβι για τη Γάζα). Μην τα ισοπεδώνουμε όλα.


Επιπλέον θα έλεγα το εξής. Μήπως είναι ώρα να κοιτάξουμε και λίγο πίσω και να γυρίσουμε σε αυτά που μας διδάξανε στα πανεπιστήμια. Εμφανίστηκε το βιβλίο του Μισυρλή (ΕΚΠΑ), το σχόλιο του Θεοτόκη (ΙΟΝΙΟ), ίσως να υπάρχουν και άλλα που υποστηρίζουν ή απορρίπτουν κάποιους από τους ισχυρισμούς μας... Ίσως.

Είναι η ώρα που χρειαζόμαστε επιμόρφωση. Διότι είμαστε πολύ καλοί γνώστες της δουλειάς μας, αλλά κολλήσαμε στη δουλειά μας... Η ΕΠΥ και είμαι βέβαιος και η ΠΕΚΑΠ θα είναι παρούσες τις επόμενες ημέρες. Σεμινάρια, ημερίδα Αθήνα & Θεσσαλονίκη, εκδόθηκε ο τόμος με τίτλο Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλλον, Παρελθόν, Παρόν και Μέλλον (http://www.epy.gr/aepp/aepp.php).

Αυτό που χρειαζόμαστε είναι ένα διδακτικό συμβόλαιο και νομίζω ότι οι ενώσεις μας μπορούν να το "γράψουν".

Επίσης με την ευκαιρία θα ήθελα να σημειώσω ότι όταν η ΕΠΥ ή η ΠΕΚΑΠ δηλώνουν αυτά που δηλώνουν πρέπει να είναι αρκετά προσεκτικοί και να σκέφτονται λίγο τις προεκτάσεις των επιχειρημάτων τους στα δεδομένα του μαθήματος.   
« Τελευταία τροποποίηση: 02 Ιούν 2010, 02:03:28 πμ από sdoukakis »

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #50 στις: 02 Ιούν 2010, 01:16:06 πμ »
Κώστα, επιμένω πως το θέμα δεν έχει σχέση με άγνωστο μέγεθος πίνακα και ασκήσεις που λύνονται με τιμή φρουρό. Δεν χρειάζεται να πηγαίνουμε στα άκρα, δεν υποστηρίζουμε όλοι τα ίδια πράγματα. Θέλω να πιστεύω πως δεν έχουμε πόλεμο και πως δεν υπάρχουν στρατόπεδα!

Πάντως πέραν του βιβλίου, και των εξετάσεων θα προτιμούσα τα πράγματα να ήταν πιο χαλαρά όσον αφορά τέτοιου είδους "λάθη". Θα ήθελα όμως να κάνουμε μία τέτοια κουβέντα υπό καλύτερες συνθήκες και όχι υπό την πίεση όλου αυτού του μπάχαλου που έγινε τις τελευταίες μέρες.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 599
    • Ανάπτυξη Εφαρμογών
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #51 στις: 02 Ιούν 2010, 01:33:19 πμ »
Παράθεση
..Δεν θέλω να μακρυγορήσω και να γεμίσω σελίδες με ιστορικά γεγονότακαι να απαριθμήσω τους λόγους για τους οποίους δεν πρέπει να φερόμαστεαλαζωνικά σε ανθρώπους που φαντάστηκαν, έστησαν, έγραψαν και έδωσανστον κλάδο ένα μάθημα που εξετάζεται πανελλαδικά.

Οι συγγραφείς του βιβλίου διδάσκουν σε κάποιους από τους φοιτητές τριτοβάθμιων τμημάτων πληροφορικής σε Αθήνα και Θεσσαλονίκη Αλγοριθμική και είναι οι ίδιοι που έχουν "βγάλει" εκατοντάδες καθηγητέςδευτεροβάθμιας, έχουν πλούσιο συγγραφικό έργο, έχουν "εκτεθεί" επώνυμαστη διεθνή και την ελληνική κοινότητα είτε ως εκπρόσωποι ενόςεπιστημονικού σωματείου τού κλάδου των πληροφορικών, είτε με το έργοτους (Ο Τάκης Πολίτης βρίσκεται κρατούμενος αυτή τη στιγμή από τουςΙσραηλινούς, συμμετέχοντας ως ακτιβιστής Στο ένα καράβι για τη Γάζα).Μην τα ισοπεδώνουμε όλα..
Δεν κατάλαβα Σπύρο, γιατί θεωρείς ότι ισοπεδώνω κάποιους. Επειδή έχω αντίθετη άποψη από αυτούς; Εγώ απλά έκανα μία ερώτηση: Αν θεωρήσουμε ότι πρέπει η χρήση πίνακα να θεωρηθεί ολόσωστη, πως διδάσκουμε του χρόνου το μάθημα; Θεωρούμε στους αλγόριθμους τους πίνακες στατικούς ή να το πω καλύτερα τους θεωρούμε στατικούς όπως τους θεωρούμε στη Γλώσσα; Στην τιμή φρουρό μπορώ να βάλω πίνακα, θεωρώντας ότι αυτός είναι τεράστιου μεγέθους και αν όχι πόσα μόρια θα χαθούν 1 με 2 μόρια. Αρνητικοί δείκτες επιτρέπονται στους αλγόριθμους; Τα ερωτήματα μπορεί να φαίνονται αλλά δεν είναι ειρωνικά. Φίλε δεν είναι μακριά η νέα χρονιά. 



Παράθεση
Πάντως πέραν του βιβλίου, και των εξετάσεων θα προτιμούσα τα πράγματανα ήταν πιο χαλαρά όσον αφορά τέτοιου είδους "λάθη". Θα ήθελα όμως νακάνουμε μία τέτοια κουβέντα υπό καλύτερες συνθήκες και όχι υπό τηνπίεση όλου αυτού του μπάχαλου που έγινε τις τελευταίες μέρες.
Στάθη εδώ έχεις απόλυτο δίκιο.
« Τελευταία τροποποίηση: 02 Ιούν 2010, 01:49:18 πμ από ntzios kostas »
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #52 στις: 02 Ιούν 2010, 01:46:27 πμ »
Είναι ακραίο το παράδειγμα που δίνεις. Δεν θα το εξετάσει η επιτροπή και δεν θα το διδάξει ούτε ένας εκπαιδευτικός. Αν μας τύχει να το διορθώσουμε θα εξαρτηθεί από διάφορες παραμέτρους.

Όμως δεν καταλαβαίνω την επίθεση σε επιστημονικές ενώσεις αντί της ΚΕΕ. Η ΚΕΕ ερμήνευσε με το δικό της τρόπο το βιβλίο και στηρίχθηκε σε κάτι που δεν λέει το βιβλίο. Έκανε ένα επιστημονικό άλμα και δεν της βγήκε. Η ΕΠΥ θα κάνει άμεσα ημερίδα. Θα προσπαθήσει να ξεκαθαρίσει το θολό τοπίο που ξαναλέω δημιούργησε η ΚΕΕ. Κανένας άλλος.

Για το λόγο αυτό επαναλαμβάνω:

Είναι η ώρα που χρειαζόμαστε επιμόρφωση. Διότι είμαστε πολύ καλοί γνώστες της δουλειάς μας, αλλά κολλήσαμε στη δουλειά μας... Η ΕΠΥ και είμαι βέβαιος και η ΠΕΚΑΠ θα είναι παρούσες τις επόμενες ημέρες. Σεμινάρια, ημερίδα Αθήνα & Θεσσαλονίκη, εκδόθηκε ο τόμος με τίτλο Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλλον, Παρελθόν, Παρόν και Μέλλον (http://www.epy.gr/aepp/aepp.php).

Αυτό που χρειαζόμαστε είναι ένα διδακτικό συμβόλαιο και νομίζω ότι οι ενώσεις μας μπορούν να το "γράψουν".
« Τελευταία τροποποίηση: 02 Ιούν 2010, 02:04:02 πμ από sdoukakis »

gouvasg

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 67
    • Ο ιστότοπός μου
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #53 στις: 02 Ιούν 2010, 03:21:59 πμ »
Αυτό που χρειαζόμαστε είναι ένα διδακτικό συμβόλαιο και νομίζω ότι οι ενώσεις μας μπορούν να το "γράψουν".
Σπύρο για την ΕΠΥ να μην σχολιάσω γιατί, αν το κάνει, μάλλον θα μας βάλει να το πληρώσουμε!!! (βλέπε σεμιάριο για την ΑΕΠΠ πριν από λίγους μήνες)
Σε όλες τις (θετικές τουλάχιστο) επιστήμες, υπάρχει ένα διδακτικό συμβόλαιο...
Απλά στη φυσική όταν μπαίνει μια δύσκολη άσκηση που διαπραγματευεται το νόμο του Νεύτωνα οι αντίρήσεις είναι του στυλ:
Δεν ισχύει ο νόμος του Νεύτωνα πια γιατί έχουμε την θεωρία της σχετικότητας, οπότε αν ο μαθητής έλυσε την άσκηση με την θεωρία της σχετικότητας πρέπει να "πάρει" όλες τις μονάδες γιατί είναι επιστημονικά σωστή
Αν δεν έκανε τις σωστές υποθέσεις και παραδοχές κατά τη λύση της δεν πειράζει, μην ζητάμε και πολλά από τους μαθητές...
 Νομίζω ότι και στην δική μας υπάρχουν οι απαραίτητες παραδοχές!
Το βιβλίο ήταν υπέροχο όταν πρωτομπήκε στα σχολεία (τότε που είχαμε δικαίωμα να κάνουμε pascal στον πίνακα)
Ο Τάκης Πολίτης είναι φυλακή γιατί δεν υπέγραψε το κείμενο που δεν μπορούσε να διαβάσει (Αλγοριθμική σκέψη ονομάζεται αυτό ή αλγοριθμική ψυχή;)
Και το ΠΙ νομίζω ότι θέλει πάνω απο 15 χρόνια για να διαμορφώσει απαιτούμενες αλλαγές στο βιβλίο και ίσως πάνω από 20 για να δημιουργήσει ασκησιολόγιο στα επιλογής...

edit: Θέλω wireless internet στο βαθμολογικό για να πάω να βαθμολογήσω γιατί δεν προλαβαίνω!!! :-)
« Τελευταία τροποποίηση: 02 Ιούν 2010, 03:36:49 πμ από gouvasg »
Γεώργιος Γκούβας
Μηχ. Η/Υ-Σ
www.gouvas.eu

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2448
  • I 'm not young enough to know everything
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #54 στις: 02 Ιούν 2010, 09:20:43 πμ »
Κώστα, επιμένω πως το θέμα δεν έχει σχέση με άγνωστο μέγεθος πίνακα και ασκήσεις που λύνονται με τιμή φρουρό.

Στάθη θέλω να ξεκαθαρίσω κάτι στη γνώμη σου. Θεωρείς ότι αν δεχτούμε τη λύση με πίνακα στο θέμα Γ (δηλαδή δεχτούμε το:
Διάβασε Ν
Για ι από 1 μέχρι Ν
  Διάβασε α[ι]
Τέλος_επανάληψης

Αυτό δε μας υποχρεώνει να δεχτούμε την τοποθέτηση σε πίνακα στοιχείων που εισάγονται με τιμή φρουρό; Εννοώ

ι<-0
Διάβασε χ
Όσο χ <>0 επανάλαβε
   ι<-ι+1
   Α[ι]<-χ
   Διάβασε χ
Τέλος_επανάληψης
 

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #55 στις: 02 Ιούν 2010, 09:37:34 πμ »
Σόρρυ που "κόβω" αλλά το ερώτημα είναι τόσο ξεκάθαρο και απλό που προκαλεί για μια άμεση απάντηση:
Η απάντηση είναι κατηγορηματικά όχι !

Επίσης, ο παρακάτω είναι και δικός μου φόβος:
Διότι είμαστε πολύ καλοί γνώστες της δουλειάς μας, αλλά κολλήσαμε στη δουλειά μας...
Φιλικά,
Γιώργος Θαλασσινός

jkapsi

  • Θαμώνας
  • ***
  • Μηνύματα: 25
  • jkapsouras@aiia.csd.auth.gr
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #56 στις: 02 Ιούν 2010, 09:47:00 πμ »
Στάθη θέλω να ξεκαθαρίσω κάτι στη γνώμη σου. Θεωρείς ότι αν δεχτούμε τη λύση με πίνακα στο θέμα Γ (δηλαδή δεχτούμε το:
Διάβασε Ν
Για ι από 1 μέχρι Ν
  Διάβασε α[ι]
Τέλος_επανάληψης

Αυτό δε μας υποχρεώνει να δεχτούμε την τοποθέτηση σε πίνακα στοιχείων που εισάγονται με τιμή φρουρό; Εννοώ

ι<-0
Διάβασε χ
Όσο χ <>0 επανάλαβε
   ι<-ι+1
   Α[ι]<-χ
   Διάβασε χ
Τέλος_επανάληψης
 

Το έχω ξαναστείλει, νομίζω πως με την παρακάτω παραδοχή λύνεται το πρόβλημα που αναφέρεις. Θα ήθελα τη γνώμη σου.


Μπορούμε να κάνουμε μια παραδοχή (έτσι κι αλλιώς η ψευδογλώσσα και η γλώσσα όλο παραδοχές είναι):

Διάβασε Ν
!παραδοχή πως δημιουργούμε πίνακα Ν θέσεων - ο πίνακας είναι στατικός, δεν μπορούμε να διαγράψουμε, ούτε να εισάγουμε νέους κόμβους
Για ι από 1 μέχρι Ν
     !προσπελαύνω τους κόμβους και κάνω ότι θέλω με τον στατικό μου πίνακα
Τέλος_επανάληψης

Στις ασκήσεις που ανφέρεστε εσείς, σε κανένα σημείο του προγράμματος δεν είναι γνωστό το μέγεθος του πίνακα (ούτε με τη χρήση μιας μεταβλητής Ν). Σε κώδικα όπως ο παρακάτω:
Αρχή_επανάληψης
     !Εισαγωγή και επεξεργασία δεδομένων
Μέχρις_ότου < συνθήκη >

Δεν μπορούμε να χρησιμοποιήσουμε πίνακα αφού θα γίνεται επ' άπειρον ( όσο θέλει ο χρήστης ) εισαγωγή νέων κόμβων.

Πιστεύω πως με την παραπάνω παραδοχή και το πρόβλημα λύνεται αλλά και η γλώσσα και ψευδογλώσσα ορίζονται ακριβέστερα. Επιπλέον ξεχωρίζουν ακόμη καλύτερα τα προβλήματα στα οποία μπορούμε να οργανώσουμε τα δεδομένα σε πίνακα (όταν ο αριθμός των δεδομένων - κόμβων είναι από ένα σημείο και έπειτα σταθερός - Ν) και σ' αυτά που δεν μπορούμε να χρησιμοποιήσουμε στατικές δομές (άγνωστο μέχρι και το τέλος του προγράμματος πόσα δεδομένα - κόμβοι θα χρειαστούν)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2448
  • I 'm not young enough to know everything
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #57 στις: 02 Ιούν 2010, 10:26:32 πμ »
Σόρρυ που "κόβω"

Παρακαλώ  :)

[...]αλλά το ερώτημα είναι τόσο ξεκάθαρο και απλό που προκαλεί για μια άμεση απάντηση:
Η απάντηση είναι κατηγορηματικά όχι !

Γιατί δεν μπορώ;

Επιτρέπεται το παρακάτω;
Διάβασε ν
Για ι από 1 μέχρι ν
   Διάβασε α[ι]
Τέλος_επανάληψης
Διάβασε α[ν+1]

jkapsi

  • Θαμώνας
  • ***
  • Μηνύματα: 25
  • jkapsouras@aiia.csd.auth.gr
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #58 στις: 02 Ιούν 2010, 10:33:15 πμ »
Γιατί δεν μπορώ;

Επιτρέπεται το παρακάτω;
Διάβασε ν
Για ι από 1 μέχρι ν
   Διάβασε α[ι]
Τέλος_επανάληψης
Διάβασε α[ν+1]

Αυτό λέω, υπάρχει κενό στον ορισμό, στο βιβλίο.

Πρέπει το μέγεθος του πίνακα να φαίνεται κάπου, και από το σημείο στο οποίο ορίζεται το (σταθερό) μέγεθός του να μην μπορεί να αλλάξει με εισαγωγή νέων κόμβων.

Αν είχες δηλώσει τον πίνακα να είναι ν+1 θέσεων τότε ο κώδικας θα ήταν σωστός. Αν τον είχες δηλώσει να είναι ν θέσεων θα ήταν λάθος.
Έτσι πως παρουσιάζεται η ψευδογλώσσα στο βιβλίο νομίζω πως δεν μπορούμε να πούμε αν ο κώδικας που παραθέτεις είναι σωστός ή λάθος

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2448
  • I 'm not young enough to know everything
Απ: ψευδογλώσσα και πίνακες
« Απάντηση #59 στις: 02 Ιούν 2010, 10:43:11 πμ »
jkapsi το θέμα που συζητάμε είναι το εξής:
Έστω ότι δεχόμαστε σα σωστό το:
Διάβασε Ν
Για ι από 1 μέχρι Ν
  Διάβασε α[ι]
Τέλος_επανάληψης

Η ερώτηση είναι αν είμαστε υποχρεωμένοι ή όχι να θεωρήσουμε σωστό και το:
ι<-0
Διάβασε χ
Όσο χ <>0 επανάλαβε
   ι<-ι+1
   Α[ι]<-χ
   Διάβασε χ
Τέλος_επανάληψης 
 

Με άλλα λόγια η ορθότητα του πρώτου συνεπάγεται την ορθότητα και του δεύτερου ή μήπως γίνεται να θεωρήσουμε σωστό το πρώτο και λάθος το δεύτερο;
Μιλάμε για ψευδογλώσσα.