Ψηφοφορία

Πιστεύετε ότι η λύση με πίνακες στο Θέμα Γ  :

Είναι λάθος - να κοπούν 3-5 μονάδες
28 (8.2%)
Είναι λάθος - να κοπούν 1-2 μονάδες
23 (6.7%)
Είναι σωστή αλλά όχι ιδανική - να κοπούν 1-2 μονάδες
29 (8.5%)
Είναι σωστή αλλά όχι ιδανική - να μην κοπούν μονάδες
108 (31.7%)
Είναι σωστή - να μην κοπούν μονάδες
153 (44.9%)

Σύνολο ψηφοφόρων: 339

Αποστολέας Θέμα: Ημερήσια 2010  (Αναγνώστηκε 168227 φορές)

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: Ημερήσια 2010
« Απάντηση #705 στις: 28 Μάι 2010, 11:25:30 μμ »
Πολύ συζήτηση για το ΘΕΜΑΓ στο forum. Διδάσκω το μάθημα επτά χρόνια σε σχολείο, βλέπω την αγωνία των (καλών) μαθητών όταν σε ρωτάνε να τους δώσεις απαντήσεις σε θέματα που το βιβλίο και το τετράδιο δεν έχει ξεκάθαρες λύσεις.
Ερώτηση: Εάν ζητηθεί το παράδειγμα 2 στην σελ. 188-189 να μετατραπεί σε αλγόριθμο πως θα γινόταν; θα είχε διαφορά από την λύση με την βοήθεια πινάκων που έδωσαν πολλοί μαθητές;

Ευχαριστώ!!

giannhs555

  • Οπαδός
  • **
  • Μηνύματα: 15
Απ: Ημερήσια 2010
« Απάντηση #706 στις: 28 Μάι 2010, 11:25:58 μμ »
Το να χρησιμοποιήσω στατική δομή χωρίς να χρησιμοποιήσω όλους τουςκόμβους που απαγορεύεται;;; Αναιρεί αυτό την στατικότητα της;;; Τοβιβλίο δεν έχει μέσα τέτοιο παράδειγμα;;;;;

 
Όχι βέβαια δεν απαγορεύεται. Αλλά πώς είσαι σίγουρος ότι δεν ξεπερνάς το πλήθος των κόμβων, τους οποίους δεν ξέρω ποιοι μαθητές και με ποιον τρόπο δηλώσαν το πλήθος τους;

=============================================================
ΤΑ ΠΡΟΓΡΑΜΜΑΤΑ ΠΟΥ ΥΠΑΡΧΟΥΝ ΣΕ ΕΦΑΡΜΟΓΕΣ ΔΕΝ ΚΑΛΥΠΤΟΥΝ ΤΑ ΚΑΘΕ ΑΠΙΘΑΝΗ ΠΕΡΙΠΤΩΣΗ ΑΛΛΑ ΕΧΟΥΝ ΚΑΠΟΙΕΣ ΠΡΟΔΙΑΓΡΑΦΕΣ. ΓΙΑ ΠΑΡΑΔΕΙΓΜΑ ΤΙ ΘΑ ΣΥΜΒΕΙ ΑΝ ΟΛΟΙ ΣΗΚΩΣΟΥΜΕ ΤΟ ΚΙΝΗΤΟ ΜΑΣ ΝΑ ΚΑΝΟΥΜΕ ΜΙΑ ΚΛΗΣΗ ΤΑΥΤΟΧΡΟΝΑ!

ΣΥΝΕΠΩΣ ΑΝ ΟΙ ΣΧΟΛΙΚΟΙ ΑΓΩΝΕΣ ΓΙΝΟΝΤΑΙ ΣΤΗΝ ΕΛΛΑΔΑ ΕΝΑΣ ΠΙΝΑΚΑΣ 10.000.000 ΘΕΣΕΩΝ ΔΕ ΘΑ ΗΤΑΝ ΑΡΚΕΤΟΣ? ΦΥΣΙΚΑ Ο ΑΛΓΟΡΙΘΜΟΣ ΔΕΝ ΕΙΝΑΙ ΑΠΟΔΟΤΙΚΟΣ ΑΛΛΑ ΟΧΙ ΛΑΘΟΣ!

Aesmade

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Πειτε μου... κατι
« Απάντηση #707 στις: 28 Μάι 2010, 11:26:42 μμ »


Πειτε μου...κατι... σε μενα, εναν αγανακτισμενο μαθητη του 16-17...

(Σχολικο Βιβλιο σελ. 189)

Η εκφώνηση λέει πως το Ν είναι από 2 μέχρι 100 και ο Χ είναι 100 θέσεων, οπότε είναι δεκτό.
Εμένα θα μου απαντήσει κανείς; ;_;
Παιδιά εγώ εκτός της παπαριάς που έγινε με τους πίνακες έκανα το λάθος στο Γ4 να βρω όχι τον αριθμό των αθλητών που πλησίασαν το ρεκόρ αλλά τα ονόματά τους. Υποθέτω θα μου κόψουν 2 ή άντε 3, αφού ήταν το μισό Γ4, το οποίο έπιανε 6, και τους αθλητές τους βρήκα αλλά αντι να τους μετρήσω έγραψα τα ονόματά τους;

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: Ημερήσια 2010
« Απάντηση #708 στις: 28 Μάι 2010, 11:27:30 μμ »
Για να υποστηρίξω και το επιχείρημα του συναδέλφου Σούλα:

σελ. 56 βιβλίο καθηγητή, Λύσεις ασκήσεων:

ΔΤ8.
To πρόβλημα αυτό ακολουθεί τον αλγόριθμο Ελάχιστη_Μέγιστη1 που δόθηκε
στο Παράδειγμα 3 (τιμές θερμοκρασίας από Μετεωρολογικό Κέντρο) του Τετρα-
δίου του Μαθητή.Χρειάζεται μόνο να δοθεί η κατάλληλη τιμή στις μεταβλητές
MIN και MAX σε σχέση με την εκφώνηση του προβλήματος
.Επομένως εάν δοθούν
αρχικά
ΜΙΝ ←1000000
ΜΑΧ ←0
δεν θα υπάρξει πρόβλημα με τον υπολογισμό του μικρότερου και του μεγαλύ-
τερου αριθμού προσπελάσεων.

Δεν το λέω εγώ, το αγαπημένο μας βιβλίο το λέει και μάλιστα σε εμάς, τους καθηγητές.....

Αλλά τώρα πια όλοι έχουμε γίνει τέλειοι και γράφουμε
Αν ι  = 1 τότε μιν <-- πρώτη τιμή

Τι θέλω να πω : θεωρούμε ότι υπάρχει ένα μέγιστο μέγεθος με βάση το βιβλίο μας.

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #709 στις: 28 Μάι 2010, 11:28:17 μμ »
Η εκφώνηση λέει πως το Ν είναι από 2 μέχρι 100 και ο Χ είναι 100 θέσεων, οπότε είναι δεκτό.
Εμένα θα μου απαντήσει κανείς; ;_;

Ότι ήταν το σημερινό θέμα Γ. Πληρώνουμε την οδηγία της ΚΕΕ στους φυσικά αδυνάτους. Κάνανε λάθος εκεί πάμε με το λάθος. Αυτό έχει γίνει. Πήραμε το λάθος αγκαλιά και προχωράμε!!!!!
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #710 στις: 28 Μάι 2010, 11:28:38 μμ »
Η εκφώνηση λέει πως το Ν είναι από 2 μέχρι 100 και ο Χ είναι 100 θέσεων, οπότε είναι δεκτό.
Εμένα θα μου απαντήσει κανείς; ;_;

Ότι ήταν το σημερινό θέμα Γ. Πληρώνουμε την οδηγία της ΚΕΕ στους φυσικά αδυνάτους. Κάνανε λάθος εκεί πάμε με το λάθος. Αυτό έχει γίνει. Πήραμε το λάθος αγκαλιά και προχωράμε!!!!!
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: Ημερήσια 2010
« Απάντηση #711 στις: 28 Μάι 2010, 11:29:07 μμ »

Όχι βέβαια δεν απαγορεύεται. Αλλά πώς είσαι σίγουρος ότι δεν ξεπερνάς το πλήθος των κόμβων, τους οποίους δεν ξέρω ποιοι μαθητές και με ποιον τρόπο δηλώσαν το πλήθος τους;


να μου ζήταγαν πρόγραμμα να το έδειχνα...

SuperTz

  • Βετεράνος
  • ****
  • Μηνύματα: 51
Απ: Ημερήσια 2010
« Απάντηση #712 στις: 28 Μάι 2010, 11:29:15 μμ »
Τώρα που έπεσε ο ρυθμός απαντήσεων, να καταθέσω και εγώ τις απόψεις μου για το αν η ΚΕΕ πέτυχε ή όχι τους στόχους της
Θέμα Α: ευχάριστο είναι πως δεν απευθυνόταν σε όσους έκανα στείρα απομνημόνευση αλλά σε κάποιο σημαντικό βαθμό κατανόησαν λίγο καλύτερα τα πράγματα. Σε καλή κατεύθυνση, με περιθώρια βελτίωσης
Θέμα Β: Τραγικό ότι έδινε 20 μονάδες. Το έτρεχα και το ξαναέτρεχα, να δω που έχω κάνει λάθος και έχει τόσες λίγες επαναλήψεις!
Θέμα Δ: Αρκετός όγκος εκφώνησης σε σχέση με το τι απαιτούσε προγραμματιστικά. Και ο όγκος δουλειάς στο Δ.4 δυσανάλογα μεγάλος για τις μονάδες που έδινε
Θέμα Γ: Να αφήσουμε καλύτερα την κριτική. Όταν η "αντιπαράθεση" ανάμεσα σε διδάσκοντες έχει ξεφύγει, όταν όλοι προσπαθούμε να πατήσουμε είτε σε "λεπτά" σημεία στο βιβλίο είτε στο τι κάνουν οι διάφορες πραγματικές γλώσσες, το Θέμα Γ είναι σαφές ότι ΑΠΕΤΥΧΕ το σκοπό που ενδεχομένως να είχε. Προσωπικά έχω από το μεσημέρι ανεβάσει στο site του φροντιστηρίου μου λύση με πίνακες και χωρίς πίνακες, λέγοντας ότι θεωρώ καλύτερη τη λύση χωρίς πίνακες, λόγω σπατάλης μνήμης (με βάση το κεφάλαιο 8) χωρίς σε κανένα σημείο να θεωρώ ότι δε λύνεται με πίνακα. Τα επιχειρήματα έχουν χιλιοειπωθεί, δε θα τα αναπαράγω.

Συνολικά: Έγινε εξέταση σε πολύ μικρό μέρος της διδακτέας ύλης (αφού 6, 8, 9, 10 δεν εξετάστηκαν ουσιαστικά και το 7 μόνο για θεωρία στο Α.1) και οδήγησε σε μεγάλη αντιπαράθεση ανάμεσα στους διδάσκοντες, τόσο σε επίπεδο σχολείου όσο και εκτός αυτού, για το "επίμαχο" Θέμα Γ. Η δική μου γνώμη είναι ότι πρέπει του χρόνου να κρατήσουν τα θετικά από τα θέματα αυτά και να αποφύγουν τα αρνητικά

Και μια ερώτηση προς όλους τους συναδέλφους: Την επόμενη χρονιά τι θα κάνετε με τη Θεωρία; Θα τη διδάσκετε, όπως τα προηγούμενα χρόνια, ή θα ρισκάρετε με βάση τα φετινα θέματα; Ποιος μας λέει ότι του χρόνου δε θα έχουμε ξανά ερωτήσεις τύπου: "H Java είναι αντικειμενοστραφής Γλώσσα" και "Να αναφέρετε τα κριτήρια που πρέπει να πληροί ένας αλγόριθμος";

Συγνώμη για το μέγεθος του ποστ

gkoubaroulis

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Ημερήσια 2010
« Απάντηση #713 στις: 28 Μάι 2010, 11:30:11 μμ »
Διαγώνισμα 2 κεφαλαίων και τίποτα άλλο ΜΠΡΑΒΟ!!!. Μάλλον είναι για λόγω περικοπής της ύλης που ανακοίνωσε σήμερα το υπουργείο.
Στις επαναληπτικές θα βάλουν μόνο απο το πρώτο.
 :D ::)

periptero

  • Νέος
  • *
  • Μηνύματα: 7
  • ΠΕ20
Απ: Ημερήσια 2010
« Απάντηση #714 στις: 28 Μάι 2010, 11:30:31 μμ »
Πέστε μου τη διαφορά ανάμεσα στους δύο αλγορίθμους υλοποίησης και αν θα πρέπει να κόψουμε βαθμό σε  κάποιον από τους 2 μαθητές που δημιούργησαν τους 2 αλγορίθμους.

Ι<--1
ΟΣΟ Ι <20 ΕΠΑΝΑΛΑΒΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Ι<--1
ΑΝ Ι<2 ΤΟΤΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΑΝ
ΑΝ Ι<3 ΤΟΤΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΑΝ
...
...
...
ΑΝ Ι<20 ΤΟΤΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΑΝ

και χωρίς ρητή εντολή να χρησιμοποιηθεί δομή επανάληψης.
έγκειται στη φιλοσοφία της επιστημονικής λύσης?

dmitry

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Ημερήσια 2010
« Απάντηση #715 στις: 28 Μάι 2010, 11:31:53 μμ »
Καλησπέρα συνάδελφοι...διαβάζοντας και τις 47 σελίδες της αντιπαράθεσης..καταλήγω ότι είμαστε πολύ εγωκεντρικοί που αφήσαμε να ξεσπάσει τόσος θόρυβος, που το μόνο που κάνει είναι να σπάσει τα νεύρα των κουρασμένων μαθητών μας.Ας περιμένουμε μια ΕΠΙΣΗΜΗ τοποθέτηση και μέχρι τότε, ηρεμία.Αυτό είναι που χρειάζεται αυτή τη στιγμή.Προσωπικά πιστεύω ότι δεν θα αδικηθεί κανείς τελικά.(ότι και άν σημαίνει αυτό)

Καλά αποτελέσματα σε όλους τους μαθητές και ψυχραιμία. :)

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #716 στις: 28 Μάι 2010, 11:37:15 μμ »
Πέστε μου τη διαφορά ανάμεσα στους δύο αλγορίθμους υλοποίησης και αν θα πρέπει να κόψουμε βαθμό σε  κάποιον από τους 2 μαθητές που δημιούργησαν τους 2 αλγορίθμους.

Ι<--1
ΟΣΟ Ι <20 ΕΠΑΝΑΛΑΒΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Ι<--1
ΑΝ Ι<2 ΤΟΤΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΑΝ
ΑΝ Ι<3 ΤΟΤΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΑΝ
...
...
...
ΑΝ Ι<20 ΤΟΤΕ
ΓΡΑΨΕ Ι+5
Ι<--Ι+1
ΤΕΛΟΣ_ΑΝ

και χωρίς ρητή εντολή να χρησιμοποιηθεί δομή επανάληψης.
έγκειται στη φιλοσοφία της επιστημονικής λύσης?





Εγώ έχω ένα καλύτερο.


ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
ΓΡΑΨΕ Ι+5
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΝΑ ΠΑΡΩ ΠΑΡΑΠΑΝΩ ΜΟΡΙΑ ΑΠΟ ΕΣΕΝΑ; ΟΛΥΜΠΙΑΔΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΕΧΟΥΜΕ; ΣΤΙΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΔΕΝ ΕΞΕΤΑΖΟΝΤΑΙ ΒΕΛΤΙΣΤΕΣ ΛΥΣΕΙΣ!!
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

trelosmathitis

  • Νέος
  • *
  • Μηνύματα: 6
    • teotsik@hotmail.com
Απ: Ημερήσια 2010
« Απάντηση #717 στις: 28 Μάι 2010, 11:37:48 μμ »
δηλαδή παιδιά άμα έχω λάθος τις δύο πρώτες εντολές του Β θέματος και μετα την λύσω κανονικά (με βάση το παραπάνω λάθος) από τα 20 πόσα θα μου κόψουν???

Μωυσιάδης Βασίλης

  • ΚΕΠΛΗΝΕΤ
  • *
  • Μηνύματα: 9
Απ: Ημερήσια 2010
« Απάντηση #718 στις: 28 Μάι 2010, 11:39:47 μμ »
Θα ήθελα να πω την άποψη μου για το Θέμα Γ με ένα παράδειγμα ενός άλλου ερωτήματος των εξετάσεων.

Καταρχήν συμφωνώ ότι αν θέλουμε να αντιμετωπίσουμε τους αλγόριθμους με αυστηρά προγραμματιστική σκέψη η χρήση πινάκων είναι λάθος. Αλλά στο βιβλίο υπάρχει παντού μία χαλαρότητα στην υλοποίηση ενός αλγορίθμου.

Σαν παράδειγμα γράφω στην συνέχεια το ερώτημα Α4 λυμένο.

Εκφώνηση
--------------------------------------------------------------------------
Έστω πίνακας table με Μ γραμμές και Ν στήλες που περιέχει
αριθμητικές τιμές. Δίνεται ο παρακάτω αλγόριθμος που
υπολογίζει το άθροισμα κατά γραμμή, κατά στήλη και
συνολικά.


Αλγόριθμος Αθρ_Πίνακα
Δεδομένα // m, n, table //
sum <- 0
Για i από 1 μέχρι m
  row <- 0
Τέλος_επανάληψης
Για j από 1 μέχρι n
  col [j] <- 0
Τέλος_επανάληψης

Για i από 1 μέχρι m
  Για j από 1 μέχρι n
    sum <- sum + table[i,j]
    row <- row + table[i,j]
    col[j] <- col[j] + table[i,j]
  Τέλος_επανάληψης
Τέλος_επανάληψης
Αποτελέσματα // row, col, sum //
Τέλος Αθρ_Πίνακα


Και τα ερωτήματα μου είναι τα εξής (αν πάλι θεωρήσουμε ότι ένας αλγόριθμος είναι αυστηρά δομημένος):

1. Ποιος μου λέει ότι η γραμμή Δεδομένα (// m, n, table //) δημιουργεί έναν δισδιάτατο πίνακα table. Επειδή έτσι λέει η εκφώνηση?
2. Ποιος μου λέει ότι η γραμμή Δεδομένα (// m, n, table //) δημιουργεί έναν δισδιάτατο πίνακα table (m x n) και όχι (n x m). Επειδή έτσι λέει η εκφώνηση? Ή μήπως επειδή έβαλα πρώτα το m και μετά το n.

Αν θέλουμε λοιπόν να είμαστε αυστηροί στην γραφή των αλγορίθμων θα πρέπει να είμαστε παντού και όχι εκεί που θέλουμε να μας βγει διαφορετική η άσκηση.

Βεβαίως και συμφωνώ ότι σε αυστηρά πλαίσια η επίλυση με πίνακες είναι λάθος αλλά λόγω της χαλαρότητας των αλγορίθμων θα έπρεπε να γίνει από την επιτροπή   η διευκρίνιση ότι η επίλυση δεν πρέπει να γίνει πινακές.

Ολοκληρώνοντας, άποψη μου είναι ότι δεν πρέπει να κοπούν βαθμοί και αν κοπούν να είναι 2 με 3 και το οποίο θα πρέπει να εφαρμοστεί Πανελλαδικά και όχι κατά την κρίση του κάθε εξεταστή ή βαθμολογικού κέντρου.

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: Ημερήσια 2010
« Απάντηση #719 στις: 28 Μάι 2010, 11:40:12 μμ »
Αύριο στην ενημέρωση των βαθμολογητών θα γίνει το έλα να δεις. Θα πρέπει να έχουν όλα τα βαθμολογικά την ίδια πολιτική βαθμολόγησης.
Τα θέματα γενικά ήταν για μη παπαγάλους. Εάν δεν υπήρχε και η οδηγία από την ΚΕΕ για το ΘΕΜΑΓ, θα μιλάγαμε για τα καλύτερα θέματα που έχουν μπει μέχρις στιγμής. Αν και προσωπικά νομίζω ότι κάτι θα έπρεπε να μπει και από υποπρογράμματα.
Κοιτάμε μπροστά και να μην αδικήσουμε τους μαθητές στην βαθμολόγηση. Φτάνει η συζήτηση για το ΘΕΜΑΓ.

Καληνύχτα συνάδελφοι!!