Αποστολέας Θέμα: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????  (Αναγνώστηκε 4306 φορές)

afroditi

  • Νέος
  • *
  • Μηνύματα: 4
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« στις: 24 Φεβ 2010, 11:57:48 πμ »
Καλημέρα σας!
Είμαι μαθήτρια και καινουργια στο Στέκι!Χαίρομαι πολύ που σας βρήκα γιατί έχω ερωτηση....
Ο καθηγητής στο σχολείο είπε πως βάζουμε όνομα μετα το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ, ενώ ο καθηγητής στο φροντιστήριο μου είπε πως δε βάζουμε.Τελικά τι ισχύει? γιατί μπερδεύτηκα...
Ευχαριστώ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #1 στις: 24 Φεβ 2010, 12:00:44 μμ »
Είναι πολύ απλό
Στο σχολείο θα βάζεις όνομα μετά το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Στο φροντιστήριο δεν θα βάζεις
Στις εξετάσεις λογικά είναι σωστά και τα 2, αλλά καλύτερα να μην βάλεις
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

afroditi

  • Νέος
  • *
  • Μηνύματα: 4
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #2 στις: 24 Φεβ 2010, 12:08:23 μμ »
Eυχαριστώ πολύ για την άμεση απάντηση...Δηλαδή δεν υπαρχει κάτι στανταρ?Οι διορθωτές στις Πανελλήνιες ποιο θα πιάσουν ως σωστό?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #3 στις: 24 Φεβ 2010, 12:13:54 μμ »
δεν θα σου κόψει κάποιος για αυτό, μην ανησυχείς
και τα δύο σωστά είναι, απλά επειδή στο βιβλίο τα περισσότερα προγράμματα δεν έχουν όνομα δίπλα στο ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ, προτιμάμε την λύση αυτή για αυτό το "πρόβλημα"
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Λάμπρος Μπουκουβάλας

  • Η παιδεία είναι: στους φτωχούς, ΠΛΟΥΤΟΣ. Στους πλούσιους, ΣΤΟΛΙΔΙ. Στους νέους, ΚΑΙ ΤΑ ΔΥΟ (Διογένης) !
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 1226
    • Το μπλογκάκι μου
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #4 στις: 24 Φεβ 2010, 01:49:04 μμ »
Προτιμούμε το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ χωρίς όνομα... Το αστείο είναι ότι σε πολλές λυμένες ασκήσεις δε χρησιμοποιείται το όνομα και ότι το τετράδιο μαθητή στη σελ. 88 χρησιμοποιεί και το όνομα, στη σελ. 91 δεν το χρησιμοποιεί, στη σελ. 92 το χρησιμοποιεί (εκτός αν έχω την παλαιά version & το έχουν διορθώσει) κ.λπ........ Ανάλογα βλέπεις και στο σχολ. βιβλίο.

Εγώ θα πρότεινα να μη χρησιμοποιείς το όνομα του προγράμματος όταν αυτό τελειώνει. Δεν υπάρχει πάντως "σωστό και λάθος" σε αυτή την περίπτωση.
Λάμπρος Μπουκουβάλας
MSc - MRes

http://blogs.sch.gr/lambrosbouk

Ο Θουκυδίδης  (που τον διαβάζουν οι ξένοι, αλλά όχι εμείς)  έγραφε: «Αταλαίπωρος τοις πολλοίς η ζήτησις της αληθείας, και επί τα ετοίμα μάλλον τρέπονται» (Ι, 20, 3). Οι περισσότεροι δηλαδή αναζητούν αβασάνιστα την αλήθεια και στρέφονται σε ό,τι βρίσκουν έτοιμο. Δεν προβληματίζονται…

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #5 στις: 24 Φεβ 2010, 03:11:36 μμ »
Το συγκεκριμένο θέμα αποτελεί ένα ακόμα λάθος-παράλειψη του διδακτικού πακέτου.

Ωστόσο,

αν ζητούμενο είναι η συνέχεια και η ομοιομορφία-ομοιογένεια σε σχέση με την ψευδογλώσσα θα ήταν προτιμότερο να μπαίνει το όνομα του προγράμματος μετά την εντολή Τέλος_προγράμματος.

Από την άλλη δεν προσφέρει κάτι στο συνολικό πρόγραμμα η ύπαρξη ή μη του ονόματος μετά τη δηλωτική εντολή Τέλος_προγράμματος.

Σε αυτή την κατεύθυνση και στο σημείο που βρισκόμαστε (έχει διδαχθεί τόσα χρόνια το συγκεκριμένο θέμα και με τους δύο τρόπους) είναι δύσκολο να αποφασίσεις αν θα πρέπει να το διορθώσεις και αν έχει και αξία να το διορθώσεις...

Σ

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #6 στις: 24 Φεβ 2010, 04:10:08 μμ »
Εγώ δε βάζω όνομα, χωρίς αυτό να σημαίνει ότι αν κάποιος μαθητής βάλει το θεωρώ λάθος. Δεν είναι κάτι ουσιαστικό.
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #7 στις: 24 Φεβ 2010, 10:08:10 μμ »
Προσωπικά βρίσκω ενοχλητικό και ανούσιο που πρέπει να βάζουμε το όνομα του αλγόριθμου και στην ψευδογλώσσα
Κώδικας: [Επιλογή]
Αλγόριθμος  αλγ1
  ....
Τέλος  αλγ1
Λες και επρόκειτο να τελειώσει κάποιος άλλος Αλγόριθμος εκεί ?   :D

Θα έβρισκα απλούστερο το Τέλος_Αλγόριθμου  σε συμφωνία με το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Και εν τέλει, γιατί δίνουμε ονόματα στους αλγόριθμους και στα προγράμματα? Κανέναν πρακτικό λόγο δεν βρίσκω. Για να έχουμε περισσότερους συντακτικούς κανόνες? Πώς το εξηγούμε αυτό στους μαθητές?
Φιλικά,
Γιώργος Θαλασσινός

poursali

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 920
    • Στέφανος-Κων/νος Πουρσαλίδης
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #8 στις: 24 Φεβ 2010, 10:13:18 μμ »

Και εν τέλει, γιατί δίνουμε ονόματα στους αλγόριθμους και στα προγράμματα? Κανέναν πρακτικό λόγο δεν βρίσκω. Για να έχουμε περισσότερους συντακτικούς κανόνες? Πώς το εξηγούμε αυτό στους μαθητές?

για να λες τωρα θα γραψουμε την Ταξινομηση_Φυσσαλιδας και να υπαρχει συνενοηση. καλο το βρισκω να μπαινει ονομα στην αρχη.. στο τελος ειναι ανουσιο
μετρον αριστον
είμαι τζαμπατζής, χρησιμοποιώ λίνουξ

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3190
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #9 στις: 25 Φεβ 2010, 08:41:19 πμ »
έχετε δίκιο, είναι ανούσιο
τόσο όσο και στην ψευδογλώσσα

Για αυτό εγώ προτείνω στους μαθητές μου να κάνουν ό,τι και στην ψευδογλώσσα, ώστε απλά να τα αντιμετωπίζουν με τον ίδιο τρόπο όλη τη χρονιά

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #10 στις: 25 Φεβ 2010, 07:37:26 μμ »
είναι όντως ανούσιο αλλά είναι πιο συνεπές με την δομή του αλγορίθμου να μπαίνει και το όνομα.

Η πρακτική δείχνει ότι μπερδεύει λιγότερο τον μαθητή γιατί είναι πιο ομοιόμορφο.

Έχει επίσης το πλεονέκτημα ότι ξεχωρίζει νοητικά το πρόγραμμα από τη συνάρτηση και την διαδικασία στην οποία δεν μπαίνει το όνομα στο τέλος. Θυμηθείτε και ένα θέμα 2 από επαναληπτικές πανελλήνιες που είχε το όνομα στο ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και δεν το είχε στο ΤΕΛΟΣ_ΔΙΑΔΙΑΚΑΣΙΑΣ και ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ (2005 ?)

Όσο για το να μην έμπαινε καθόλου το όνομα και στον αλγόριθμο και στο πρόγραμμα, μολονότι δεν είναι κάτι σημαντικό, εμένα τουλάχιστον μου θυμίζει γλώσσες που χρησιμοποιούν ομάδες εντολών μέσα σε begin ... end ή άγκιστρα. Θέλω να πω με αυτό ότι τότε θα έπρεπε ίσως να μην υπάρχει (αναλογικά) τέλος_αν, τέλος_επανάληψης κτλ αλλά τέλος παντού.

Λάμπρος Μπουκουβάλας

  • Η παιδεία είναι: στους φτωχούς, ΠΛΟΥΤΟΣ. Στους πλούσιους, ΣΤΟΛΙΔΙ. Στους νέους, ΚΑΙ ΤΑ ΔΥΟ (Διογένης) !
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 1226
    • Το μπλογκάκι μου
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #11 στις: 26 Φεβ 2010, 10:39:42 πμ »
Να ζήσει η συγγραφική ομάδα με το "ενιαίο" σχολικό βιβλίο... :o

Διδάσκουμε το μάθημα εδώ και 10 χρόνια, κι όμως αναγκαζόμαστε να έχουμε τέτοιες απορίες... Τι να πω, περίμενα όσο περνούν τα χρόνια να είχαμε καλύτερα βιβλία... Τέλος πάντων, σταματώ τη γκρίνια και λέω ότι από τη στιγμή που το βιβλίο δεν ξεκαθαρίζει τον κανόνα που θέλει να τηρούμε, αλλά χρησιμοποιεί και τις δύο εναλλακτικές, αυτό σιωπηρά και έμμεσα σημαίνει ότι και τα δύο είναι σωστά...

Το θέμα μας δεν είναι να μαντέψουμε τι είναι σωστό ούτε να κάνουμε σύγκριση με παρόμοια μαθήματα & πραγματικές γλώσσες. Συγκρίνουμε ανόμοια πράγματα.
Λάμπρος Μπουκουβάλας
MSc - MRes

http://blogs.sch.gr/lambrosbouk

Ο Θουκυδίδης  (που τον διαβάζουν οι ξένοι, αλλά όχι εμείς)  έγραφε: «Αταλαίπωρος τοις πολλοίς η ζήτησις της αληθείας, και επί τα ετοίμα μάλλον τρέπονται» (Ι, 20, 3). Οι περισσότεροι δηλαδή αναζητούν αβασάνιστα την αλήθεια και στρέφονται σε ό,τι βρίσκουν έτοιμο. Δεν προβληματίζονται…

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 599
    • Ανάπτυξη Εφαρμογών
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #12 στις: 26 Φεβ 2010, 10:59:59 πμ »
Τι σημασία έχουν όλα αυτά. Αν δηλαδή ένας μαθητής γράψει απλά Τέλος αντί για ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ είναι λάθος; Προς θεού. Για μένα καλά κάνει το βιβλίο και είναι κάπου ασυνεπές στη σύνταξη κάποιων εντολών, ώστε να επιτρέπουμε και εμείς τέτοιες ανούσιες ασυνέπειες που θα έχει ένα γραπτό.
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1089
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #13 στις: 10 Μάρ 2010, 09:45:34 πμ »
Προσωπικά ,ένας μαθητής βάλει -δεν βάλει το όνομα στο ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ είναι το ίδιο.
Ισως είναι καλύτερα να το βάλει γιατι το χρησιμοποιεί στο αλγόριθμο

Εκτος από το βιλίο και από το τετράδιο μαθητή που αλλού το χρησιμοποιεί και αλλού όχι,
το ίδιο γίνεται και στις πανελλήνιες με θέματα αλλα και λύσεις που έχουν δοθεί από την ΚΕΞ
οπότε δεν νομίζω ότι χρειάζεται να επιμενουμε σε αυτό.

Γιάννης Σ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 146
    • -
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #14 στις: 15 Μάρ 2010, 01:04:18 πμ »
Νομίζει στις περιπτώσεις που μιλάμε για πρόγραμμα σε ΓΛΩΣΣΑ τα πράγματα είναι απλά: Στη ΓΛΩΣΣΑ δε χρειάζεατι το όνομα δίπλα στο ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ οπότε...
Στους αλγορίθμους είναι πιο μπερδεμένα. Ας πούμε εμφάνισε ή εκτύπωσε;
 :o

joyjohnnickname

  • Φοιτητής στο Τμήμα Μηχανικών Πληροφορικής και Τηλεπικοινωνιών του Πανεπιστημίου Δυτικής Μακεδονίας
  • Οπαδός
  • **
  • Μηνύματα: 17
  • Be the change you want to see in the world
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #15 στις: 02 Απρ 2010, 11:34:07 πμ »
Πάντως για αυτό που είπατε για το βιβλίο, αν σκεφτείτε ότι θεωρείται από τα καλύτερα βιβλία για το Λύκειο, φανταστείτε πως είναι τα άλλα! Πάντως σαν ύλη θεωρείται καλό... Όσο για το θέμα με τα ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ κλπ, συμφωνώ με μία παραπάνω ιδέα... Να βάζουμε σε όλα "Τέλος". Αφού αναφέρουμε το είδος (Αλγόριθμος ή ΠΡΟΓΡΑΜΜΑ) στην αρχή. Έτσι δεν θα μπερδεύονται οι μαθητές και με το διάγραμμα ροής (Πόσες φορές έχω δει στην έλλειψη του τέλους "Τέλος_όνομα_αλγορίθμου"...). Για αυτό που ανέφερε ο κύριος Λάμπρος Μπουκουβάλας πιστεύω πως έχει διορθωθεί, τουλάχιστον σε αυτές τις σελίδες το δικό μου τετράδιο μαθητή γράφει απλά "ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ"  :angel:
Σ.Παπαλουκάς (Μηχανικός Η/Υ και Πληροφορικής): "Βασικά, με τα μωρά,
πριν φτάσουν τα 2 τους χρόνια, δεν μπορείς να κάνεις και πολλά,
γιατί δεν είναι interactive..." (!)


sdancer75

  • Οπαδός
  • **
  • Μηνύματα: 15
  • “I am easily satisfied only with the very best.”
    • Paradox Interactive
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #16 στις: 21 Απρ 2010, 11:03:18 πμ »
Καλημέρα σας!
Είμαι μαθήτρια και καινουργια στο Στέκι!Χαίρομαι πολύ που σας βρήκα γιατί έχω ερωτηση....
Ο καθηγητής στο σχολείο είπε πως βάζουμε όνομα μετα το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ, ενώ ο καθηγητής στο φροντιστήριο μου είπε πως δε βάζουμε.Τελικά τι ισχύει? γιατί μπερδεύτηκα...
Ευχαριστώ

Σε κάθε πρόγραμμα και σε οποιαδήποτε γλώσσα προγραμματισμού υπάρχει αρχή και τέλος. Αν δεν το βάλεις είσαι λάθος διότι οποιοσδήποτε compiler ή interpreter θα σου βγάλει λάθος πριν καν προλάβεις να τρέξεις το πρόγραμμα (δηλαδή κάτι σαν synatax error).
G. Papaioannou

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #17 στις: 21 Απρ 2010, 11:28:20 πμ »
Πάντως η ψευδογλώσσα δεν έχει ΑΡΧΗ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #18 στις: 21 Απρ 2010, 12:11:47 μμ »
Σε κάθε πρόγραμμα και σε οποιαδήποτε γλώσσα προγραμματισμού υπάρχει αρχή και τέλος. Αν δεν το βάλεις είσαι λάθος διότι οποιοσδήποτε compiler ή interpreter θα σου βγάλει λάθος πριν καν προλάβεις να τρέξεις το πρόγραμμα (δηλαδή κάτι σαν synatax error).

Έχω την εντύπωση ότι η afroditi ρωτάει άλλο πράγμα...: Αν δεξιά από το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πρέπει να μπαίνει και το όνομα το προγράμματος στη ΓΛΩΣΣΑ...

Λάμπρος Μπουκουβάλας

  • Η παιδεία είναι: στους φτωχούς, ΠΛΟΥΤΟΣ. Στους πλούσιους, ΣΤΟΛΙΔΙ. Στους νέους, ΚΑΙ ΤΑ ΔΥΟ (Διογένης) !
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 1226
    • Το μπλογκάκι μου
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #19 στις: 21 Απρ 2010, 12:20:29 μμ »
Μην μας διαφεύγει κ. Παπαϊωάννου ότι απευθυνόμαστε σε μαθητές, οι οποίοι διδάσκονται μια ψεύτικη γλώσσα απλά για να πάρουν μια ιδέα, χωρίς να έχουν σοβαρό θεωρητικό υπόβαθρο. Συμφωνώ με το Νίκο, η απορία της Αφροδίτης οφείλεται σε ασάφεια του σχολικού βιβλίου.
Λάμπρος Μπουκουβάλας
MSc - MRes

http://blogs.sch.gr/lambrosbouk

Ο Θουκυδίδης  (που τον διαβάζουν οι ξένοι, αλλά όχι εμείς)  έγραφε: «Αταλαίπωρος τοις πολλοίς η ζήτησις της αληθείας, και επί τα ετοίμα μάλλον τρέπονται» (Ι, 20, 3). Οι περισσότεροι δηλαδή αναζητούν αβασάνιστα την αλήθεια και στρέφονται σε ό,τι βρίσκουν έτοιμο. Δεν προβληματίζονται…

sdancer75

  • Οπαδός
  • **
  • Μηνύματα: 15
  • “I am easily satisfied only with the very best.”
    • Paradox Interactive
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #20 στις: 21 Απρ 2010, 04:52:52 μμ »
Μην μας διαφεύγει κ. Παπαϊωάννου ότι απευθυνόμαστε σε μαθητές, οι οποίοι διδάσκονται μια ψεύτικη γλώσσα απλά για να πάρουν μια ιδέα, χωρίς να έχουν σοβαρό θεωρητικό υπόβαθρο. Συμφωνώ με το Νίκο, η απορία της Αφροδίτης οφείλεται σε ασάφεια του σχολικού βιβλίου.

Δε διαφωνώ μαζί σου, αλλά ακόμη και τη ΓλωσσοΜάθεια να χρησιμοποιήσεις θα βρείς την εντολή ΑΡΧΗ. Δεν είναι βέβαια σε καμία περίπτωση σοβαρό λάθος, αλλά εγώ προσωπικά στην αξιολόγηση των γραπτών αφαιρώ μονάδες για τη συγκεκριμένη παράλληψη από τα γραπτά τα οποία δεν θεωρώ τέλεια. Πάντως σαν συμπέρασμα είναι ότι και να το βάλεις, δεν πρόκειται να χάσεις μονάδες σε καμία περίπτωση οπότε γιατί όχι ? Τώρα αν χρειάζεται το όνομα μετά το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ αυτό είναι προαιρετικό αλλά συνήθως δεν μπαίνει.

G. Papaioannou