Αποστολέας Θέμα: Πολλαπλή επιλογή ερώτηση  (Αναγνώστηκε 2966 φορές)

gkark

  • Θαμώνας
  • ***
  • Μηνύματα: 20
  • Γράψτε το προσωπικό σας σλόγκαν!
Πολλαπλή επιλογή ερώτηση
« στις: 09 Ιαν 2006, 11:27:54 πμ »
Χαιρετώ όλους τους συναδέρφους που ασχολούνται και συμμετέχουν σε αυτό το καταπληκτικό forum. θέλω να ακούσω τις απόψεις σας στο παρακάτω θέμα: Έστω ότι δίνεται  μια άσκηση στην οποία περιέχεται μια κλίμακα τιμών για μια μεταβλητή πχ η παρακάτω:

0<=χ<1000
1001<=χ<2000
2001<=χ<3000
3001<χ

πια απο τις παρακάτω διατυπώσεις είναι η σωστή:
1)
Αν χ>0 τότε
  Αν χ<1000 τοτε
     ....
  αλλιώς_αν χ<2000 τότε
   ....
  αλλιώς_αν χ<3000 τότε
   ....
  αλλιώς
  ....
  τέλος_αν
τέλος_αν

2)Αν χ>0 τότε
  Αν (χ>=0) και (χ<1000) τοτε
     ....
  αλλιώς_αν (χ>=1001) και (χ<2000) τότε
   ....
  αλλιώς_αν (χ>=2001) και (χ<3000) τότε
   ....
  αλλιώς_αν χ>30001 τότε
  ....
  τέλος_αν
τέλος_αν


andrika

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 136
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #1 στις: 09 Ιαν 2006, 12:29:16 μμ »
Καλημερα και καλη χρονια.
Κατα την γνωμη μου καμια εκδοχη δεν ειναι σωστη διοτι αν δοθει χ=0 τοτε δεν θα μπει μεσα σε καμια αν.Πιο σωστο θα ηταν το εξης:
1)Αν χ>=0 τότε
  Αν χ<1000 τοτε
....
  αλλιώς_αν χ<2000 τότε
   ....
  αλλιώς_αν χ<3000 τότε
   ....
  αλλιώς
  ....
  τέλος_αν
τέλος_αν

2)  Αν (χ>=0) και (χ<1000) τοτε
....
  αλλιώς_αν (χ>=1001) και (χ<2000) τότε
   ....
  αλλιώς_αν (χ>=2001) και (χ<3000) τότε
   ....
  αλλιώς_αν χ>30001 τότε
  ....
  τέλος_αν


gkark

  • Θαμώνας
  • ***
  • Μηνύματα: 20
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #2 στις: 09 Ιαν 2006, 01:15:05 μμ »
Επανέρχομαι και διορθώνο την αρχική διατύπωση ως εξής
1)
Αν χ>=0 τότε
  Αν χ<1000 τοτε
....
  αλλιώς_αν χ<2000 τότε
   ....
  αλλιώς_αν χ<3000 τότε
   ....
  αλλιώς
  ....
  τέλος_αν
τέλος_αν

2)Αν χ>=0 τότε
  Αν  χ<1000 τοτε
....
  αλλιώς_αν (χ>=1001) και (χ<2000) τότε
   ....
  αλλιώς_αν (χ>=2001) και (χ<3000) τότε
   ....
  αλλιώς_αν χ>30001 τότε
  ....
  τέλος_αν
τέλος_αν

Θέλω να εστιάσω όχι στο γεγονός αν η μεταβλητή χ πάρει την τιμη 0 και ελεγχθεί στην εξωτεριή εντολή αν, αλλά στο γεγονός, αν η μεταβλητή χ πάρει τιμές μεταξύ 1000 και 1001 ή μεταξύ 2000 και 2001. Τότε ποια απο τις παραπάνω διατυπώσεις θεωρείτε ότι είναι η σωστή;

Πολλές εκφωνήσεις ασκήσεων δίνουν τις κλίκακες τιμών χωρίς να προσδιορίζουν τι θα γίνει αν η μεταβλητή πάρει μια τιμή που βρίσκειται στο ενδιάμεσο μεταξύ το τέλος μιας κλίμακας και την αρχή της αλλης. Τοτε τι πρέπει να κάνει ένας μαθητής και πως πρέπει να διατυπώσει καλύτερα τις κλίμακες τιμών με την χρήση της εντολή αν αλλιώς-αν ;

« Τελευταία τροποποίηση: 09 Ιαν 2006, 01:18:59 μμ από gkark »

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #3 στις: 09 Ιαν 2006, 11:04:35 μμ »
Νομίζω ότι συνήθως διευκρινίζεται αν το χ είναι ακέραιος ή πραγματικός αριθμός.

**Έτσι αν το χ είναι ακέραιος και οι δυο εκφράσεις είναι σωστές.
**Αν το χ είναι πραγματικός τότε η πρώτη περίπτωση είναι σωστή διότι για τιμή π.χ. 2000.1 πραγματοποιείται η αντίστοιχη ομάδα εντολών ενώ στη δεύτερη έκφραση δεν πραγματοποιείται τίποτα. Εξαρτάται βέβαια τι θέλεις να κάνεις, αν θέλεις δηλαδή να αποκλείσεις ή όχι κάποιες τιμές όπως αυτές μεταξύ 1000 και 1001 κ.ο.κ.

Με λίγα λόγια δεν θα μπορούσα να γενικεύσω μια απάντηση διότι εξαρτάται από την εκφώνηση της άσκησης και το τι θέλεις να κάνεις.
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3190
  • I love you 3000
    • Panagiotis Tsiotakis
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #4 στις: 10 Ιαν 2006, 09:44:41 πμ »

Μια τέτοια συζήτηση είχα για κάποια πινακάκια που έχω φτιάξει σε κάποιες ασκήσεις. Προφανώς αν η πόσότητα είναι πραγματική το πινακάκι πρέπει να είναι σαφές για το αν και σε ποιο σημείο του διαστήματος υπάρχει ισότητα.

Μάλλον η καλύτερη διατύπωση είναι λεκτικά:

π.χ. μέχρι και 1000
      από 1000 μέχρι και 2000
      από 2000 μέχρι και 3000
      από 3000 και άνω


Με εκτίμηση,

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5024
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #5 στις: 10 Ιαν 2006, 10:46:58 πμ »
Πάντως εγώ τη δεύτερη μέθοδο δεν την προτιμώ σε καμία περίπτωση. Αν π.χ. το όριο αλλαγής μιας κλίμακας είναι το 2000, δεν έχει νόημα να βλέπουμε στον κώδικα 2001 και να μπλεκόμαστε. Δηλαδή θα την προτιμούσα ως:

[glossa]Αν χ>0 τότε
  Αν (χ>0) και (χ<1000) τοτε
....
  αλλιώς_αν (χ>1000) και (χ<2000) τότε
   ....
  αλλιώς_αν (χ>2000) και (χ<3000) τότε
   ....
  αλλιώς_αν χ>3000 τότε
  ....
  τέλος_αν
τέλος_αν[/glossa]
Έτσι δουλεύει και με πραγματικούς και με ακέραιους.

gkark

  • Θαμώνας
  • ***
  • Μηνύματα: 20
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #6 στις: 11 Ιαν 2006, 11:45:28 μμ »
Μήπως όμως είναι εσκεμένα έτσι γραμμένα τα πινακάκια, ώστε  να θέλουν να δίξουν ότι η μεταβλητή δεν μπορέι να πάρει ορισμένες τιμές; πχ τις τιμές μεταξύ 1000 και 1001;
Αυτό κατα την γνώμη μου πρέπει ή να διευκρινίζεται ή να απορρέει σαν συμπέρασμα απο την εκφώνηση της άσκησης; Διευκρινίζεται όμως ή αφήνεται στην κρίση του μαθητή;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3190
  • I love you 3000
    • Panagiotis Tsiotakis
Re: Πολλαπλή επιλογή ερώτηση
« Απάντηση #7 στις: 13 Ιαν 2006, 08:43:37 πμ »
Όταν η ποσότητα που διερευνάται είναι πραγματική (π.χ. ποσό σε &#8364;), πρέπει τα διαστήματα των πινάκων να είναι διαδοχικά...