Αποστολέας Θέμα: Απορια με των δομημενο προγραμματισμο και τους αλγοριθμους  (Αναγνώστηκε 2063 φορές)

Xristos4

  • Νέος
  • *
  • Μηνύματα: 5
Καλησπέρα σε ολους,

Λοιπον ήθελα να ρωτησω αν ο δομημένος προγραμματισμος και γενικα οι αλγοριθμοι μπορεις να τους γραψεις στο γλωσσομαθεια διοτι ας πουμε προσπαθησα και εβαζα των παρακάτω κωδικα

Προγραμμα ταδε
ΑΡΧΗ
ΔΙΑΒΑΣΕ Α,Β
Γ<- Α+Β
ΕΜΦΑΝΙΣΕ Γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

σε καθε περίπτωση το Εμφανισε δεν το αναγνωριζε το γλωσσομαθεια ως εντολή καθώς μου έλεγε επίσης οτι λάθος είναι και το Γ<- Α+Β

Κανονικά έτσι οπως έγραφα των κώδικα έπρεπε να ήταν σωστο δεν ξερω βεβαια άν το γλωσσομαθεια ειναι το ιδιο για αυτες τις εντολές. Πειτε την γνωμη σας

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Η Γλωσσομάθεια είναι βοήθημα για το μάθημα της Ανάπτυξης Εφαρμογών του Γενικού Λυκείου και υλοποιεί την γλώσσα προγραμματισμού που ορίζεται σε αυτό το μάθημα (ΓΛΩΣΣΑ).

Απ'όσο ξέρω δεν υπάρχει βοήθημα για τον ψευδοκώδικα του δομημένου προγραμματισμού των ΕΠΑΛ.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1084
Η Γλωσσομάθεια είναι βοήθημα για το μάθημα της Ανάπτυξης Εφαρμογών του Γενικού Λυκείου και υλοποιεί την γλώσσα προγραμματισμού που ορίζεται σε αυτό το μάθημα (ΓΛΩΣΣΑ).

Απ'όσο ξέρω δεν υπάρχει βοήθημα για τον ψευδοκώδικα του δομημένου προγραμματισμού των ΕΠΑΛ.

Με μικρές τροποποιήσεις στον αλγόριθμο μπορεί να χρησιμοποιήσει το δικό σου Στάθη.
Για όποιον θελει να δοκιμάσει www.pseudoglossa.gr

karinakis

  • Θαμώνας
  • ***
  • Μηνύματα: 44
στη γλωσσομάθεια θα πρέπει να κάνεις οπωσδήποτε δήλωση μεταβλητών και αντί για ΕΜΦΑΝΙΣΕ να χρησιμοποιήσεις το ΓΡΑΨΕ. Δοκίμασε το παρακάτω και θα δεις ότι τρέχει κανονικά. Άλλωστε όλους τους αλγορίθμους που έχεις σε ψευδοκώδικα μπορείς να χρησιμοποιείς τη Γλώσσα για να τους τρέχεις


ΠΡΟΓΡΑΜΜΑ ταδε
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Γ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α, Β
  Γ <- Α + Β
  ΓΡΑΨΕ Γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1084
Καλύτερα δοκίμασε το www.pseudoglossa.gr