Αποστολέας Θέμα: ΠΑΡΑΓΩΓΟΣ ΟΠΟΙΑΣΔΗΠΟΤΕ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ  (Αναγνώστηκε 2234 φορές)

Yuris

  • Νέος
  • *
  • Μηνύματα: 6
Κώδικας: [Επιλογή]
!ΠΡΟΓΡΑΜΜΑ ΤΟ ΟΠΟΙΟ ΥΠΟΛΟΓΙΖΕΙ ΤΗΝ ΠΑΡΑΓΩΓΟ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ ΜΕ ΘΕΤΙΚΟΥΣ ΕΚΘΕΤΕΣ<=100!
!ΦΥΣΙΚΑ ΑΝ ΚΑΠΟΙΟΣ ΘΕΛΕΙ ΜΕΓΑΛΥΤΕΡΗ ΣΥΝΑΡΤΗΣΗ , ΜΠΟΡΕΙ ΑΠΛΑ ΝΑ ΑΥΞΗΣΕΙ ΤΙΣ ΔΙΑΣΤΑΣΕΙΣ ΤΩΝ ΠΙΝΑΚΩΝ Α, Γ!
ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΓΩΓΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Ν , Β
  ΠΡΑΓΜΑΤΙΚΕΣ: Α[101] , Γ[101]
  ΛΟΓΙΚΕΣ: ΣΤΑΘΕΡΟΤΗΤΑ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΘΕΤΙΚΟ ΑΚΕΡΑΙΟ Ν ΜΕΧΡΙ 100 Ο ΟΠΟΙΟΣ ΘΑ ΑΝΤΙΠΡΟΣΩΠΕΥΕΙ'
  ΓΡΑΨΕ 'ΤΟΝ ΜΕΓΙΣΤΟΒΑΘΜΙΟ ΜΙΑΣ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ'
  ΔΙΑΒΑΣΕ Ν
  ΟΣΟ Ν > 100 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΩΣΑΤΕ ΤΙΜΗ ΜΕΓΑΛΥΤΕΡΗ ΤΟΥ 100 , ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ Ν <= 100'
    ΓΡΑΨΕ 'ΑΛΛΙΩΣ ΑΝ ΚΑΠΟΙΟΣ ΘΕΛΕΙ ΜΕΓΑΛΥΤΕΡΗ ΣΥΝΑΡΤΗΣΗ , ΜΠΟΡΕΙ '
    ΓΡΑΨΕ 'ΑΠΛΑ ΝΑ ΑΥΞΗΣΕΙ ΤΙΣ ΔΙΑΣΤΑΣΕΙΣ ΤΩΝ ΠΙΝΑΚΩΝ Α, Γ'
    ΔΙΑΒΑΣΕ Ν
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΣΤΑΘΕΡΟΤΗΤΑ <-- ΨΕΥΔΗΣ
  ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
    ΑΝ Ν = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ΣΥΝΑΡΤΗΣΗ ΘΑ ΕΙΝΑΙ ΣΤΑΘΕΡΗ , ΟΠΟΤΕ Η ΠΑΡΑΓΩΓΟΣ ΕΙΝΑΙ f΄(x)=0'
      ΣΤΑΘΕΡΟΤΗΤΑ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ'
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^',Ι
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΣΤΑΘΕΡΟΤΗΤΑ = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'ΙΔΟΥ Η ΣΥΝΑΡΤΗΣΗ f(x)='
    ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
      ΑΝ Α[Ι+1] = 0 ΤΟΤΕ
        ΓΡΑΨΕ_'+0'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1]=1 ΚΑΙ Ι=1 ΤΟΤΕ
        ΓΡΑΨΕ_'+Χ'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1]=1 ΚΑΙ Ι = Ν ΤΟΤΕ
        ΓΡΑΨΕ_'(Χ^',Ι,')'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1]=1 ΤΟΤΕ
        ΓΡΑΨΕ_'+(Χ^',Ι,')'
      ΑΛΛΙΩΣ_ΑΝ Ι = 1 ΤΟΤΕ
        ΓΡΑΨΕ_'+(',Α[Ι+1],'Χ',')'
      ΑΛΛΙΩΣ_ΑΝ Ι = Ν ΤΟΤΕ
        ΓΡΑΨΕ_'(',Α[Ι+1],'Χ^',Ι,')'
      ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
        ΓΡΑΨΕ_'+(',Α[Ι+1],')'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ_'+(',Α[Ι+1],'Χ^',Ι,')'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Β <-- 0
    ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
      Γ[Ι+1] <-- Α[Ι+1]*(Ν+Β)
      Β <-- Β-1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'ΙΔΟΥ Η ΠΑΡΑΓΩΓΟΣ f΄(x)='
    ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
      ΑΝ Ι-1>=0 ΤΟΤΕ
        ΑΝ Γ[Ι+1] > 0 ΤΟΤΕ
          ΑΝ Γ[Ι+1] = 0 ΤΟΤΕ
            ΓΡΑΨΕ_''
          ΑΛΛΙΩΣ_ΑΝ Ι = Ν ΚΑΙ Ι = 2 ΤΟΤΕ
            ΓΡΑΨΕ_ Γ[Ι+1],'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι = Ν ΤΟΤΕ
            ΓΡΑΨΕ_ Γ[Ι+1],'Χ^',Ι-1
          ΑΛΛΙΩΣ_ΑΝ Ι-1 =1 ΤΟΤΕ
            ΓΡΑΨΕ_'+',Γ[Ι+1],'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι-1 = 0 ΤΟΤΕ
            ΓΡΑΨΕ_'+',Γ[Ι+1]
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_'+',Γ[Ι+1],'Χ^',Ι-1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΑΝ Ι = Ν ΚΑΙ Ι = 2 ΤΟΤΕ
            ΓΡΑΨΕ_'-',Α_Τ(Γ[Ι+1]),'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι-1 =1 ΤΟΤΕ
            ΓΡΑΨΕ_'-',Α_Τ(Γ[Ι+1]),'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι-1 = 0 ΤΟΤΕ
            ΓΡΑΨΕ_'-',Α_Τ(Γ[Ι+1])
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_'-',Α_Τ(Γ[Ι+1]),'Χ^',Ι-1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΟΙ ΔΙΟΡΘΩΣΕΙΣ  :)
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy." -
-- Martin Luther King Jr.