Αποστολέας Θέμα: Άλλος τρόπος για μέγιστο στοιχείο σε πίνακα?  (Αναγνώστηκε 1577 φορές)

bookitsa

  • Οπαδός
  • **
  • Μηνύματα: 15
Μπορούμε σε αναζήτηση μεγίστου στοιχείου σε πίνακα(μονοδιάστατο) αντί από τον τρόπο που γράφεται σε όλα τα βιβλία δηλαδή,να δηλώσουμε σε μία μεταβλητή max την πρώτη θέση του πίνακα και μετά σε μία loop από τη 2η θέση του πίνακα μέχρι την τελευταία να ελέγχουμε το κάθε στοιχείο του πίνακα με το max, να κάνουμε το εξής:????
α<--0
Για i από 1 μέχρι 5
   Αν Πιν>α τότε 
       α<--Πιν
   Τέλος_αν
Τέλος_επανάληψης

                                                                               

coletsos

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Άλλος τρόπος για μέγιστο στοιχείο σε πίνακα?
« Απάντηση #1 στις: 01 Απρ 2008, 01:24:28 πμ »
Φυσικά και μπορείς, αρκεί να είναι σίγουρα τα στοιχεία του πίνακα μεγαλύτερα του μηδενός γιατί αλλιώς θα σου μείνει μέγιστο το μηδέν

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3165
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Άλλος τρόπος για μέγιστο στοιχείο σε πίνακα?
« Απάντηση #2 στις: 01 Απρ 2008, 01:38:16 πμ »
Αν τύχει (μπορεί να συμβεί), όλα τα στοιχεία να είναι αρνητικά, θα επιστραφεί ως μέγιστο το 0, που είναι λάθος. Για αυτό αρχικοποιούμε με μια τιμή που ΥΠΑΡΧΕΙ στον πίνακα (πχ την πρώτη)

bookitsa

  • Οπαδός
  • **
  • Μηνύματα: 15
Απ: Άλλος τρόπος για μέγιστο στοιχείο σε πίνακα?
« Απάντηση #3 στις: 01 Απρ 2008, 01:47:03 πμ »
έχετε δίκιο :)
ευχαριστώ πολύ