Αποστολέας Θέμα: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008  (Αναγνώστηκε 27445 φορές)

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #30 στις: 07 Μάι 2008, 08:24:28 πμ »
Lev, καλημέρα.

Αυτό που λες είναι σωστό. 
Αν ζητούσαμε και αυτό τότε το Θ4 θα γινόταν πολύ βαρύ !!!
Άλλωστε ένα πρόσθετο (στο τέλοςτου Θ4)  υποδεικνύει στον μαθητή ότι δεν απαιτείται.

Ανδρέας

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2444
  • I 'm not young enough to know everything
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #31 στις: 07 Μάι 2008, 08:50:45 πμ »
Τα έχω λύσει,απλώς έχω μια απορία για το 4ο θέμα και δεν ξέρω αν πρέπει να την γράψω τώρα ή μετά.
Ουσιαστικά δεν μας απαγορεύει κανένας να βαθμολογήσουμε 2 φορές την ίδια χώρα.Δηλαδή ζητείται έλεγχος
 για την ύπαρξη της χώρας που βαθμολογούμε
έλεγχος για το αν βαθμολογούμε τον εαυτό μας
αλλά δεν υπάρχει έλεγχος για το αν έχουμε ξαναψηφίσει την ίδια χώρα (όχι οτι είναι δύσκολο να γίνει)

Είχα υπόψη μου αυτή την παραλλαγή αλλά υπάρχουν 2 λύσεις: η εύκολη και η δύσκολη.
Η εύκολη είναι να ελέγξεις αν η συγκεκριμένη θέση του πίνακα που πας να βαθμολογήσεις έχει 0 ή κάτι άλλο. Αν έχει 0 σημαίνει ότι δεν πήρε προηγουμένως βαθμολογία. Αν έχει μη μηδενική τιμή σημαίνει ότι μια χώρα πάει να ξαναψηφίσει την ίδια.
Η δύσκολη λύση είναι να κρατάς πίνακα με το ποιες άλλες χώρες έχει ήδη ψηφίσει κάθε φορά η χώρα και να κάνεις αναζήτηση κάθε φορά.

Επειδή ο μαθητής μπορεί να στραφεί στη δύσκολη σκέψη μπορεί τελικά να τα μπλέξει και να χάσει και τα άλλα ερωτήματα καθώς θα μπλέξει με τους βρόχους.
Έτσι αυτό το θέμα εγώ τουλάχιστο δεν το πρότεινα και είχα κατά νου να πω τα παραπάνω στην περίπτωση που το πρότεινε κάποιος άλλος. Ήδη τον ελέγχουμε αρκετά το μαθητή.
Στην τάξη πάντως, αφού λύσουμε την άσκηση, κάνω την ερώτηση «Πως θα μπορούσαμε να ελέγξουμε αν μια χώρα πάει να ψηφίσει κάποια άλλη 2 φορές;» Και συζητάμε την εύκολη λύση.

Lev

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #32 στις: 07 Μάι 2008, 02:31:46 μμ »
ευχαριστώ για τις διευκρινήσεις,(και εγώ όταν το έλυνα στην εύκολη λύση στράφηκα δηλ απαίτηση το Β[ι,θέση]=0)απλώς ένας μαθητής μου σήμερα( δεν το έχω βάλει αλλά όπως είπα οι μαθητές μου είναι του στεκιού) με ρώτησε και αυτός αν απαιτείται και οτι εκεί είχε σκαλώσει οπότε σας δίνω δίκιο που δεν υπάρχει σαν απαίτηση.Και πάλι συγχαρητηρια για τα θέματα.Τελευταία ερώτηση.Είναι βαρύ για πανελλήνιες το 4ο ή όχι?Πάντως εμένα μου άρεσε πολύ και δεν το βρήκα βαρύ,αλλά οι μαθητές μου με παρακαλάνε να μην βάλω κάτι τέτοιο στο διαγώνισμα

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3136
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #33 στις: 07 Μάι 2008, 02:57:02 μμ »
Το θέμα 4 του διαγωνίσματος ... έχει πέσει στις εξετάσεις. Είναι ίδιο με το θέμα 4 των εσπερινών 2005 (δείτε και http://users.kor.sch.gr/ptsiotakis/aepp/aepp_panel_esp_2005.htm ).

Η μορφή του στο διαγώνισμα είναι πιο σύνθετη:
1. Οι δείκτες προέρχονται ως προϊόν αναζήτησης (το επιστρέφει η συνάρτηση)
2. Οι πόντοι δε διαβάζονται, αλλά αντλούνται απο πίνακα.


papaluk

  • Μηχ. Η/Υ & Πληρ. ΠΕ19
  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 94
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #34 στις: 08 Μάι 2008, 03:53:37 μμ »
Εφόσον η ομάδα διαγωνισμάτων δεν έχει πρόβλημα ανεβάζω λύσεις που έδωσε ομάδα μαθητών
Το μεγάλο πρόβλημα τους ήταν ποιός θα κάτσει να πληκτρολογήσει.. τελικά μέχρι το 3ο θέμα έδωσαν λύσεις, για το 4ο υποσχέθηκαν μέχρι εξετάσεις να πληκτρολογήσουν  :) τη λύση.

Οι λύσεις έχουν ελεγχθεί, αλλά όταν έγραφαν κανονικά το διαγώνισμα.. όχι σε ηλεκτρονική μορφή

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #35 στις: 09 Μάι 2008, 09:17:06 μμ »
Η λύση που προτείνω για το ΘΕΜΑ 3.
Η λύση που έδωσαν η ομάδα μαθητών πιστεύω ότι δεν καλύπτει όλες τις περιπτώσεις του προβλήματος
Το έκανα σε μορφή προγράμματος ώστε να δω εάν τρέχει σωστά.
Οπότε πιστεύω είναι εύκολη η μετατροπή σε μορφή αλγορίθμου.

Υ.Γ1.Αν έχετε καμία απορία ή παρατήρηση στον τρόπο επίλυσης της άσκησης, παρακαλώ γράψτε.

Υ.Γ2.Ευχαριστώ και καλή επιτυχία σε όλους μας και ειδικά στους μαθητές.
VR in Computing

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #36 στις: 10 Μάι 2008, 01:11:01 μμ »
Μια διόρθωση.

Και όταν κερδίζει το ποσό που ποντάρει αφαιρείται.


Ανδρέας

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #37 στις: 10 Μάι 2008, 01:13:57 μμ »
Δηλαδή

   ΑΡΧΙΚΟ_ΠΟΣΟ <- ΑΡΧΙΚΟ_ΠΟΣΟ - ΠΟΝΤ_ΠΟΣΟ
   
  ΑΝ ΚΕΡΔΙΣΕ = ΑΛΗΘΗΣ ΤΟΤΕ
      ΑΡΧΙΚΟ_ΠΟΣΟ <- ΑΡΧΙΚΟ_ΠΟΣΟ + ΜΑΧ
  ΤΕΛΟΣ_ΑΝ

   ΓΡΑΨΕ 'ΠΟΣΟΣ ΓΙΑ ΠΟΝΤΑΡΙΣΜΑ', ΑΡΧΙΚΟ_ΠΟΣΟ

Ανδρέας

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #38 στις: 10 Μάι 2008, 02:26:23 μμ »
@papaluk
Μια παρατήρηση με πολύ μικρή σημασία:
...
Κώδικας: Text
  1. εμφάνισε "απομ&#8051;νει το ποσό των ", απ, " €"
  2. Αν απ>0 τότε
  3.  Εμφάνισε "θες να συνεχίσεις; Αν ναι π&#8055;εσε Ν ή ν"
  4.  Διάβασε επ
  5. Τέλος_αν
  6. Μέχρις_ότου επ&#8800;"N" ή επ&#8800;"ν" ή απ=0
  7.  

Αν στην πρώτη φορά που παίξει χάσει όλα τα λεφτά τότε η επ δεν θα έχει πάρει ακόμα τιμή και ο έλεγχος δεν θα μπορεί να γίνει σωστά, εκτός αν υποθέσουμε ότι οι μεταβλητές αρχικοποιούνται από μόνες τους πράγμα όμως που δεν είναι σύμφωνο με το βιβλίο.
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #39 στις: 10 Μάι 2008, 07:08:43 μμ »
Αν απ>0 τότε
  Εμφάνισε "θες να συνεχίσεις; Αν ναι πίεσε Ν ή ν"
  Διάβασε επ
αλλιώς
  επ <- 'Ο' ! οπότε καλύπτεται το να χάσει όλα  του τα λεφτά την 1η φορά

Τέλος_αν
Μέχρις_ότου επ≠"N" ή επ≠"ν" ή απ=0

Ανδρέας

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #40 στις: 10 Μάι 2008, 07:21:06 μμ »
Θ4 - Λύση.

Ανδρέας

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #41 στις: 10 Μάι 2008, 08:20:43 μμ »
Ανδρέα έχεις δίκιο

το διορθωμένο :

    ΑΝ ΚΕΡΔΙΣΕ = ΨΕΥΔΗΣ ΤΟΤΕ
      ΜΑΧ <- 0
    ΑΛΛΙΩΣ
      ΜΑΧ <- ΚΕΡΔΟΣ1
      ΑΝ ΚΕΡΔΟΣ2 > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- ΚΕΡΔΟΣ2
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ΚΕΡΔΟΣ3 > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- ΚΕΡΔΟΣ3
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ '+', ΜΑΧ – ΠΟΝΤ_ΠΟΣΟ! αφαιρείτε το ποσό που πόνταρα
    ΤΕΛΟΣ_ΑΝ

VR in Computing

rodotheos

  • Θαμώνας
  • ***
  • Μηνύματα: 35
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #42 στις: 13 Μάι 2008, 05:13:44 μμ »
Μια λύση για το 3ο Θέμα
Περιμένω παρατηρήσεις.
 
« Τελευταία τροποποίηση: 14 Μάι 2008, 12:21:04 μμ από rodotheos »

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #43 στις: 13 Μάι 2008, 06:09:02 μμ »
ΔΩΣΤΕ ΤΟ ΠΟΣΟ ΤΟΥ ΣΤΟΙΧΗΜΑΤΟΣ

Ανδρέας

rodotheos

  • Θαμώνας
  • ***
  • Μηνύματα: 35
Απ: Τελικό Διαγώνισμα - Προσομοίωση 2007-2008
« Απάντηση #44 στις: 14 Μάι 2008, 11:48:03 πμ »
Ανδρέα,
μπορείς να γίνεις λιγάκι πιο σαφής;

Θ.