Αποστολέας Θέμα: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)  (Αναγνώστηκε 10234 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2450
  • I 'm not young enough to know everything
Το παρακάτω θέμα έπεσε στις εξετάσεις του 2001

Δίνεται τ΅ή΅α αλγορίθ΅ου
   Χ ← Α
   Αρχή_επανάληψης
       Χ ← Χ + 2
       Εκτύπωσε το Χ
   Μέχρις_ότου Χ >= Μ
Να δώσετε τη δο΅ή επανάληψης "Για … από … ΅έχρι …βή΅α" η οποία τυπώνει ακριβώς τις ίδιες τι΅ές ΅ε το πιο πάνω τ΅ή΅α αλγορίθ΅ου.

Έχει κανείς υπόψη του ποια απάντηση δόθηκε από την επιτροπή θεμάτων σα σωστή; Εμένα μέ παίδεψε και νομίζω ότι την έλυσα κάπως αθέμιτα. Υπάρχει καμιά απλή λύση;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #1 στις: 04 Δεκ 2007, 03:27:13 μμ »
Δεν ξέρω για την απάντηση της επιτροπής, αλλά τι λες για το παρακάτω;
Κώδικας: Text
  1.   Χ ← Α
  2.   Χ ← Χ + 2
  3.   Εκτύπωσε το Χ
  4.   Για Χ από Α+2 μέχρι Μ με_βήμα 2
  5.     Εκτύπωσε το Χ
  6.   τέλος_επανάληψης
  7.  

Όσο για το (=) στη Μέχρις_ότου Χ >= Μ, πιστεύω ότι είναι λάθος, θα έπρεπε να έχει Μέχρις_ότου Χ > Μ.

Αν για κάποιον διεστραμμένο λόγο όντως εννοούσαν Χ >= Μ, τότε μπορεί να γραφεί έτσι:
Κώδικας: Text
  1.   Χ ← Α
  2.   Χ ← Χ + 2
  3.   Εκτύπωσε το Χ
  4.   τελική_τιμή ← Α+2
  5.   Για Χ από Α+2 μέχρι Μ-2 με_βήμα 2
  6.     Εκτύπωσε το Χ
  7.     τελική_τιμή ← Χ
  8.   τέλος_επανάληψης
  9.   Αν τελική_τιμή < Μ τότε
  10.     Χ &#8592; Χ + 2
  11.     Εκτύπωσε το Χ
  12.   τέλος_αν
  13.  

Τα παραπάνω χωρίς έλεγχο λόγω βιασύνης...

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #2 στις: 04 Δεκ 2007, 06:05:09 μμ »
Δεν είμαι σίγουρος αλλά αν θυμάμαι καλά (πέρασαν 6 χρόνια) δόθηκε η προφανής λάθος απάντηση απο την επιτροπή

Για Χ απο Α+2 μέχρι Μ+2 με_βήμα 2
..........
το οποίο ισύχει μόνο όταν Α<=Μ.

Θα ψάξω τα χαρτιά μου για να το επιβεβαιώσω. Ελπίζω να το βρω στο αρχείο μου ...
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Αλεξόπουλος Ανδρέας

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #3 στις: 04 Δεκ 2007, 08:30:37 μμ »
Όσο για το (=) στη Μέχρις_ότου Χ >= Μ, πιστεύω ότι είναι λάθος, θα έπρεπε να έχει Μέχρις_ότου Χ > Μ.

Η εκφώνηση έχει και το ίσον στο Μέχρις_Ότου, άρα δεν μπορούμε να το παραβλέψουμε. Μια λύση που έγραψα τώρα και φαίνεται να δουλεύει σωστά σε κάθε περίπτωση είναι η εξής:
Κώδικας: [Επιλογή]
Χ<-Α
Χ<-Χ+2
Τύπωσε το Χ
Για Χ Από Α+2 Μέχρι Μ-1 Με_Βήμα 2
   Τύπωσε το (Χ+2)
Τέλος_Επανάληψης

Δηλαδή
1)γράφω μια φορά τις εντολές του βρόχου πριν από το Για, για να εξασφαλίσω ότι θα εκτελεστούν τουλάχιστον μια φορά, ανεξάρτητα από τις αρχικές τιμές του Α και του Μ,
2)αρχική τιμή του μετρητή βάζω το Α+2 αφού το Χ έχει αυξηθεί κατά 2 όταν αρχίζει η επανάληψη του Για, και τελική τιμή το (Μ-1) αφού υπάρχει το (Χ>=Μ) στο Μέχρις_Ότου
3)τυπώνουμε το (Χ+2) και όχι το Χ μέσα στην επανάληψη αφού αν προσέξουμε το βήμα (δηλαδή το Χ<-Χ+2), αυξάνεται πριν από το εκτύπωσε και όχι στο τέλος της επανάληψης όπως γίνεται συνήθως


alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #4 στις: 04 Δεκ 2007, 09:32:13 μμ »
Άμα είναι λάθος είμαστε υποχρεωμένοι να το παραβλέψουμε, ακόμα κι αν δεν εντοπίστηκε τότε και δεν είχε δοθεί σχετική διευκρίνηση από την επιτροπή. Δεν (θα) είναι το μόνο εσφαλμένο θέμα που έχει πέσει σε πανελλαδικές...

Δεν ορίζεται τύπος δεδομένων, άρα οι αριθμοί μπορεί να περιέχουν δεκαδικά. Επομένως το να αφαιρέσουμε -1 από το Μ δεν λύνει το πρόβλημα.

Ακολουθεί παράδειγμα με τις 3 υλοποιήσεις, όπου φαίνεται ότι δεν είναι ισοδύναμες.

Κώδικας: Text
  1. ΠΡΟΓΡΑΜΜΑ Δοκιμή
  2. ΣΤΑΘΕΡΕΣ
  3.   Α = 1
  4.   Μ = 3.5
  5. ΜΕΤΑΒΛΗΤΕΣ
  6.   ΠΡΑΓΜΑΤΙΚΕΣ: Χ, τελική_τιμή
  7. ΑΡΧΗ
  8.   ΓΡΑΨΕ 'Αρχικό:'
  9.   Χ <- Α
  10.   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  11.     Χ <- Χ + 2
  12.     ΓΡΑΨΕ Χ
  13.   ΜΕΧΡΙΣ_ΟΤΟΥ Χ >= Μ
  14.  
  15.   ΓΡΑΨΕ 'ʼλκης'
  16.   Χ <- Α
  17.   Χ <- Χ + 2
  18.   ΓΡΑΨΕ Χ
  19.   τελική_τιμή <- Α + 2
  20.   ΓΙΑ Χ ΑΠΟ Α + 2 ΜΕΧΡΙ Μ - 2 ΜΕ_ΒΗΜΑ 2
  21.     ΓΡΑΨΕ Χ
  22.     τελική_τιμή <- Χ
  23.   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  24.   ΑΝ τελική_τιμή < Μ ΤΟΤΕ
  25.     Χ <- Χ + 2
  26.     ΓΡΑΨΕ Χ
  27.   ΤΕΛΟΣ_ΑΝ
  28.  
  29.   ΓΡΑΨΕ 'Ανδρέας'
  30.   Χ <- Α
  31.   Χ <- Χ + 2
  32.   ΓΡΑΨΕ Χ
  33.   ΓΙΑ Χ ΑΠΟ Α + 2 ΜΕΧΡΙ Μ - 1 ΜΕ_ΒΗΜΑ 2
  34.     ΓΡΑΨΕ Χ + 2
  35.   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  36. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
  37.  

Κώδικας: Text
  1. Αρχικό:
  2. 3.00
  3. 5.00
  4. ʼλκης
  5. 3.00
  6. 5.00
  7. Ανδρέας
  8. 3.00
  9.  

Υ.Γ. για μένα το να χρειαστούμε καμία 10ριά υλοποιήσεις μέχρι να βρούμε κάποια ισοδύναμη είναι από μόνο του απόδειξη ότι το = ήταν λάθος...   ::)

Αλεξόπουλος Ανδρέας

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #5 στις: 04 Δεκ 2007, 09:59:02 μμ »
οκ, απλώς εγώ θεώρησα ότι οι αριθμοί είναι ακέραιοι (μάλλον λανθασμένα αφού δεν το λέει πουθενά), οπότε έχεις δίκιο στην απάντηση που δίνεις.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #6 στις: 04 Δεκ 2007, 10:02:12 μμ »
Στην ψευδογλώσσα επειδή δεν έχουν οριστεί οι τύποι δεδομένων συνήθως θεωρούμε τους αριθμούς πραγματικούς, εκτός αν ζητάει συγκεκριμένα ακεραίους το πρόβλημα...

Αλεξόπουλος Ανδρέας

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #7 στις: 04 Δεκ 2007, 10:51:56 μμ »
Στην ψευδογλώσσα επειδή δεν έχουν οριστεί οι τύποι δεδομένων συνήθως θεωρούμε τους αριθμούς πραγματικούς, εκτός αν ζητάει συγκεκριμένα ακεραίους το πρόβλημα...

Χωρίς να θέλω να αμφισβητήσω αυτά που λες, μιας και είσαι πιο παλιός και πιο έμπειρος στον χώρο από εμένα, υπάρχει κάπου αυτό γραμμένο ή απλά το θεωρούμε έτσι γενικά; Θέλω να πω, πως το "συνήθως θεωρούμε" δεν αποτελεί μια τεκμηριωμένη απάντηση για να το πεις σε ένα παιδί και πολύ εύκολα δημιουργεί παρερμηνείες σε μια άσκηση, όπως και στην συγκεκριμένη που εγώ την έλυσα για ακεραίους κι εσύ για πραγματικούς.
Εκτός αν το γράφει κάπου και μου έχει διαφύγει εμένα.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #8 στις: 04 Δεκ 2007, 11:43:25 μμ »
Αντρέα αναλυτική αιτιολόγηση αύριο γιατί τώρα τρέχω με τις διορθώσεις του βιβλίου. :-\

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2450
  • I 'm not young enough to know everything
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #9 στις: 05 Δεκ 2007, 01:04:53 πμ »
Άλκη για Α=0 και Μ=4 νομίζω πως στραβώνει και η δικιά σου λύση.
Εννοείται φυσικά ότι θέλουμε και το = αφού αυτό ζητάει η εκφώνηση και μιλάμε για πανελλήνιες.
Νομίζω πως δίκαια διαμαρτύρομαι.
Εμένα η άσκηση με παίδεψε. Έχω κάνει μια απόπειρα απόδειξης (με ένα σωρό ακροβασίες) και πάλι δεν είμαι σίγουρος ότι δε σκαλώνει κάπου το πράγμα...
Αλήθεια... αν μας δώσουν ένα υποψήφιο ισοδύναμο κώδικα πως καταλαβαίνουμε αν είναι σωστή λύση; Κάνοντας ένα σωρό δοκιμές (που τελικά δεν αποδεικνύουν τίποτα) ή θα πρέπει να ζητάμε και απόδειξη από τα παιδιά; 

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #10 στις: 05 Δεκ 2007, 01:33:16 πμ »
Όντως στραβώνει, θέλει κοίταγμα λίγο στα όρια και στα +-2 αλλά νομίζω ότι το σκεπτικό είναι σωστό. Διόρθωση αύριο...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3153
  • to Iterate is human to Recurse divine
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #11 στις: 05 Δεκ 2007, 08:53:55 πμ »

  Νομίζω ότι το παρακάτω δουλεύει για ακέραιους, για πραγματικούς δεν το έχω δει ακόμα, μήπως βγαίνει με  ακέραιο μέρος.
    Πάντως δεν πιστεύω ότι κάποιος μαθητής θα σκεφτόταν την περίπτωση να είναι τα Χ, Α, Μ πραγματικοί, και θα ήθελα να υποθέσω ότι η επιτροπή είχε στο μυαλό της ακέραιους.

Κώδικας: [Επιλογή]
ΓΙΑ Χ ΑΠΟ Α+2 ΜΕΧΡΙ Μ + (Μ mod 2) ΜΕ ΒΗΜΑ 2
      Εκτύπωσε το Χ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #12 στις: 05 Δεκ 2007, 09:23:42 πμ »
Νομίζω ότι η επιτροπή δεν είχε στο μυαλό της ακεραίους, αλλά να μην υπήρχε το (=). Αλλιώς είναι υπερβολικά δύσκολο θέμα για μαθητή, ακόμα και με ακέραιους.

Με την παρακάτω αλλαγή νομίζω ότι δουλεύει σωστά είτε για ακέραιους είτε για πραγματικούς. Δοκίμασα ΓΙΑ Α, Μ ΑΠΟ -10 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 0.5 οπότε το λέω με σχετική ασφάλεια.

Κώδικας: Text
  1.       Χ <- Α
  2.       Χ <- Χ + 2
  3.       ΓΡΑΨΕ Χ  
  4.       τελική_τιμή <- Χ
  5.       ΓΙΑ Χ ΑΠΟ Α + 4 ΜΕΧΡΙ Μ - 2 ΜΕ_ΒΗΜΑ 2
  6.         ΓΡΑΨΕ Χ  
  7.         τελική_τιμή <- Χ
  8.       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  9.       Χ <- τελική_τιμή
  10.       ΑΝ Χ < Μ ΤΟΤΕ
  11.         Χ <- Χ + 2
  12.         ΓΡΑΨΕ Χ  
  13.         ΑΝ Χ < Μ ΤΟΤΕ
  14.           Χ <- Χ + 2
  15.           ΓΡΑΨΕ Χ  
  16.         ΤΕΛΟΣ_ΑΝ
  17.       ΤΕΛΟΣ_ΑΝ
  18.  

Γιώργο, όσο για την απόδειξη ότι όντως ισχύει, εδώ έχει αποδειχτεί ότι δεν μπορεί να κατασκευαστεί αλγόριθμος που να καταλαβαίνει αν κάποιο πρόγραμμα τερματίζει ή όχι... Πολλά ζητάς! Για μένα οι μόνες ψευτο-αποδείξεις είναι "μα είναι οφθαλμοφανέςTM" καθώς και αν βγάζει τα ίδια αποτελέσματα για όλο το πεδίο τιμών της εισόδου (Α και Μ).

Το τελική_τιμή το έβαλα επειδή δεν είναι σωστό να χρησιμοποιούμε την τιμή του μετρητή Χ μετά από τη ΓΙΑ.

Αλεξόπουλος Ανδρέας

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #13 στις: 05 Δεκ 2007, 11:42:07 πμ »
Το τελική_τιμή το έβαλα επειδή δεν είναι σωστό να χρησιμοποιούμε την τιμή του μετρητή Χ μετά από τη ΓΙΑ.

Κι αυτό το λέει κάπου; Με ένα γρήγορο ξεφύλλισμα που έκανα πάλι τώρα στο βιβλίο δεν το είδα να αναφέρεται κάπου. Δηλαδή το ακόλουθο είναι λάθος;
Κώδικας: [Επιλογή]
α<-0
Για ι Από 0 Μέχρι 5 Με_Βήμα 2
   α<- α + ι
Τέλος_Επανάληψης
Εμφάνισε α, ι
Φαντάζομαι όλοι έχουμε δει τέτοιες ασκήσεις που ζητάν να εμφανιστεί η τιμή ενός μετρητή αφού έχει τελειώσει η ΓΙΑ. Αν ισχύει ότι δεν μπορούμε να τον χρησιμοποιήσουμε μετά το Τέλος_Επανάληψης, τότε είναι λάθος.

Επίσης, δεν μου απάντησες γιατί όταν σε έναν αλγόριθμο έχουμε 'ΔΙΑΒΑΣΕ Χ', θεωρούμε το Χ σαν πραγματικό αν δεν αναφέρεται κάτι άλλο;


alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5059
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μετατροπή Μέχρις_ότου σε Για (θέμα εξετάσεων)
« Απάντηση #14 στις: 05 Δεκ 2007, 12:02:50 μμ »
Αντρέα, για την τιμή μετά το ΓΙΑ κάνε μια αναζήτηση στο φόρουμ, έχει αναφερθεί παλιότερα.

Για τους πραγματικούς:
Παράθεση από: Βιβλίο καθηγητή, σελίδα 72
Όπως θα παρατήρησε ήδη ο αναγνώστης, στο ρεπερτόριο των εντολών της ψευδογλώσσας δεν υπάρχουν δηλώσεις τύπων δεδομένων των χρησιμοποιούμενων μεταβλητών. Κάτι τέτοιο δεν είναι απαραίτητο στο επίπεδο της αλγοριθμικής ψευδογλώσσας. Για παράδειγμα ένας αλγόριθμος που βρίσκει τον ελάχιστο ν αριθμών, είναι ο ίδιος είτε οι αριθμοί είναι ακέραιοι, είτε πραγματικοί. Αν από τα δεδομένα του προβλήματος πρέπει να δηλωθεί ο τύπος των μεταβλητών, τότε αυτό γίνεται στην εκφώνηση. Ωστόσο δεν είναι λάθος στις περιπτώσεις αυτές να συμπληρώνεται ο τύπος των μεταβλητών στη γραμμή των δεδομένων.

Από τις δύο τελευταίες προτάσεις καταλαβαίνω ότι αν δεν δίνεται ειδική διευκρίνηση, τότε οι αλγόριθμοι θα πρέπει να ισχύουν και για ακέραιους και για πραγματικούς.

Κι αφού οι πραγματικοί είναι υπερσύνολο των ακεραίων, αρκεί οι αλγόριθμοι που φτιάχνουμε να ισχύουν για πραγματικούς.