Αποστολέας Θέμα: ΜΕΤΑΤΡΟΠΗ ΑΠΟ ΠΟΛΛΑΠΛΗ ΕΠΙΛΟΓΗ ΣΕ ΕΜΦΩΛΕΥΜΕΝΗ  (Αναγνώστηκε 2167 φορές)

droopy

  • Θαμώνας
  • ***
  • Μηνύματα: 36
  • you know what... i'm happy
ΕΣΤΩ ΟΤΙ ΔΙΝΕΤΑΙ ΤΟ ΤΜΗΜΑ ΑΛΓΟΡΙΘΜΟΥ:

ΔΙΑΒΑΣΕ ΜΟ
ΑΝ ΜΟ<0 Ή ΜΟ>20 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΛΑΘΟΣ ΜΕΣΟΣ ΟΡΟΣ"
ΑΛΛΙΩΣ_ΑΝ Μ0<10 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΑΠΟΡΡΙΠΤΕΤΑΙ"
ΑΛΛΙΩΣ_ΑΝ Μ0<15 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΜΕΤΡΙΑ"
ΑΛΛΙΩΣ_ΑΝ ΜΟ<18
   ΕΜΦΑΝΙΣΕ "ΠΟΛΥ ΚΑΛΑ"
ΑΛΛΙΩΣ
   ΕΜΦΑΝΙΣΕ "ΑΡΙΣΤΑ"
ΤΕΛΟΣ_ΑΝ

ΚΑΙ ΘΕΛΟΥΜΕ ΝΑ ΤΟΝ ΜΕΤΑΤΡΕΨΟΥΜΕ ΣΕ ΙΣΟΔΥΝΑΜΟ ΜΕ ΕΜΦΩΛΕΥΜΕΝΑ ΑΝ.

ΔΙΑΒΑΣΕ ΜΟ
ΑΝ ΜΟ<0 Ή ΜΟ>20 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΛΑΘΟΣ ΜΕΣΟΣ ΟΡΟΣ"
ΑΛΛΙΩΣ
ΑΝ Μ0<10 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΑΠΟΡΡΙΠΤΕΤΑΙ"
ΑΛΛΙΩΣ
ΑΝ Μ0<15 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΜΕΤΡΙΑ"
ΑΛΛΙΩΣ
ΑΝ ΜΟ<18
   ΕΜΦΑΝΙΣΕ "ΠΟΛΥ ΚΑΛΑ"
ΑΛΛΙΩΣ
   ΕΜΦΑΝΙΣΕ "ΑΡΙΣΤΑ"
ΤΕΛΟΣ_ΑΝ

ΕΙΝΑΙ ΣΩΣΤΟ?
ΥΠΑΡΧΕΙ ΚΑΠΟΙΟΣ ΚΑΝΟΝΑΣ ΓΕΝΙΚΟΤΕΡΑ ΣΤΗΝ ΜΕΤΑΤΡΟΠΗ ΠΟΛΛΑΠΛΩΝ ΕΠΙΛΟΓΩΝ ΣΕ ΕΜΦΩΛΕΥΜΕΝΕΣ?

ΕΥΧΑΡΙΣΤΩ







EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: ΜΕΤΑΤΡΟΠΗ ΑΠΟ ΠΟΛΛΑΠΛΗ ΕΠΙΛΟΓΗ ΣΕ ΕΜΦΩΛΕΥΜΕΝΗ
« Απάντηση #1 στις: 24 Σεπ 2007, 06:31:37 μμ »
Δεν νομίζω ότι υπάρχει κάποια συνταγή για τη μετατροπή. Ίσως το ότι οι συνθήκες που ακολουθούν είναι κάθε φορά μέσα στο αλλιώς του προηγούμενου. Το παραπάνω βέβαια δεν ειναι απόλυτα σωστό καθότι δεν έχουν μπει τα τέλος_αν σωστά. Δλδ.

ΔΙΑΒΑΣΕ ΜΟ
ΑΝ ΜΟ<0 Ή ΜΟ>20 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΛΑΘΟΣ ΜΕΣΟΣ ΟΡΟΣ"
ΑΛΛΙΩΣ
ΑΝ Μ0<10 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΑΠΟΡΡΙΠΤΕΤΑΙ"
ΑΛΛΙΩΣ
  ΑΝ Μ0<15 ΤΟΤΕ
   ΕΜΦΑΝΙΣΕ "ΜΕΤΡΙΑ"
   ΑΛΛΙΩΣ
     ΑΝ ΜΟ<18
       ΕΜΦΑΝΙΣΕ "ΠΟΛΥ ΚΑΛΑ"
     ΑΛΛΙΩΣ
   ΕΜΦΑΝΙΣΕ "ΑΡΙΣΤΑ"
     ΤΕΛΟΣ_ΑΝ
    Τέλος_αν
  Τέλος_αν
Τέλος_αν
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

droopy

  • Θαμώνας
  • ***
  • Μηνύματα: 36
  • you know what... i'm happy
Απ: ΜΕΤΑΤΡΟΠΗ ΑΠΟ ΠΟΛΛΑΠΛΗ ΕΠΙΛΟΓΗ ΣΕ ΕΜΦΩΛΕΥΜΕΝΗ
« Απάντηση #2 στις: 24 Σεπ 2007, 06:33:31 μμ »
ΕΧΕΙΣ ΔΙΚΙΟ. ΤΑ ΞΕΧΑΣΑ...  :o

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2448
  • I 'm not young enough to know everything
Απ: ΜΕΤΑΤΡΟΠΗ ΑΠΟ ΠΟΛΛΑΠΛΗ ΕΠΙΛΟΓΗ ΣΕ ΕΜΦΩΛΕΥΜΕΝΗ
« Απάντηση #3 στις: 24 Σεπ 2007, 11:52:49 μμ »
Ίσως σου φανεί χρήσιμο το παρακάτω
http://alkisg.mysch.gr/steki/index.php?topic=707.msg4041#msg4041