Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Μήνυμα ξεκίνησε από: Κανένας στις 16 Μάι 2019, 05:31:33 μμ

Τίτλος: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: Κανένας στις 16 Μάι 2019, 05:31:33 μμ
Προσομοιωμένο Διαγώνισμα του σχολικού έτους 2018-2019 στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον (ΑΕΠΠ) μαζί με ενδεικτικές λύσεις.

Το διαγώνισμα συνέταξε και επιμελήθηκε ομάδα εκπαιδευτικών πληροφορικής:  Μαρία Αναστοπούλου, Νικηφόρος  Μανδηλαράς,  Μανώλης  Αργυρός για τα σχολεία των Κυκλάδων και της Δωδεκανήσου.

Συντονισμός: Κωνσταντίνος Ζέρβας, Συντονιστής Εκπαιδευτικού Έργου Πληροφορικής ΠΕ86  για Κυκλάδες και Δωδεκάνησα, 1ο ΠΕ.Κ.Ε.Σ/ Περιφερειακή Διεύθυνση Εκπαίδευσης Νοτίου Αιγαίου.
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: wmaster στις 17 Μάι 2019, 06:36:28 πμ
Καλημέρα,
πολύ ωραία και επιμελημένα θέματα, Ευχαριστούμε.
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: Καραμαούνας Πολύκαρπος στις 17 Μάι 2019, 12:54:51 μμ
Ωραίο διαγώνισμα. Συνημμένα μερικές επισημάνσεις.
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: wmaster στις 17 Μάι 2019, 01:22:04 μμ
Οι ενδεικτικές λύσεις είναι σωστές στο ερώτημα Γ4.
Μ=(100+1) DIV 2, ΔΗΛ, 75
M= (76+100) DIV 2 ΔΗΛ 88
Μ=(89+100) DIV 2 ΔΗΛ 94

Στο ερώτημα Δ6 ξέφυγε ένα ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ στο αρχικό διάβασμα, όπως απαντηθεί και στο Δ3 :
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ! Διάβασμα στοιχείων
               ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 21
                 ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 20
                    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                                ΔΙΑΒΑΣΕ Θ[κ, λ]
                       ΜΕΧΡΙΣ_ΟΤΟΥ Θ[κ, λ]  >= 1 ΚΑΙ Θ[κ,λ] <= 20
                     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
.......
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: Καραμαούνας Πολύκαρπος στις 17 Μάι 2019, 01:39:32 μμ
Συμφωνώ ως προς το Γ4
Διαφωνώ ως προς το Δ6: "Σε περίπτωση λανθασμένης εισαγωγής να εμφανίζεται
μήνυμα και να επανεισάγονται όλες οι θέσεις τερματισμού του
συγκεκριμένου αγώνα
"

Έτσι που έχει απαντηθεί, επανεισάγονται όλες οι θέσεις τερματισμού όλων των αγώνων.
Τίτλος: Εναλλακτική λύση του Δ
Αποστολή από: Κανένας στις 17 Μάι 2019, 08:10:07 μμ
Επισυνάπτεται αρχείο με εναλλακτική λύση του θέματος Δ
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: annastasios στις 19 Μάι 2019, 04:05:06 μμ
πολύ ωραία θέματα, Μπράβο και ευχαριστούμε για το μοίρασμα!
στο θέμα Α3 θεωρείς το Κ ακέραιο?
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: tanius76 στις 19 Μάι 2019, 10:59:45 μμ
Η σειριακή Αναζήτηση μπορεί να χρησιμοποιηθεί σε ταξινομημένους πίνακες. Σ/Λ ;

Με βάση την λογική είναι Σωστό
Όμως στο βιβλίο σελίδα 166 γράφει : " Χρησιμοποιείται όμως υποχρεωτικά για πίνακες που δεν είναι ταξινομημένοι"
Τι λέτε;
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: petrosp13 στις 19 Μάι 2019, 11:00:51 μμ
Να μην τεθεί ως θέμα..
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: tanius76 στις 19 Μάι 2019, 11:03:46 μμ
Να μην τεθεί ως θέμα..
αν τεθεί ; κάντε το σταυρό σας!
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: alkisg στις 19 Μάι 2019, 11:51:11 μμ
Νομίζω ότι ο ποιητής εννοεί "αν δεν είναι ταξινομημένοι, τότε θα πρέπει να χρησιμοποιήσουμε υποχρεωτικά την σειριακή αναζήτηση, αφού η δυαδική δεν δουλεύει",
και δεν εννοεί "τη σειριακή τη χρησιμοποιούμε μόνο σε μη ταξινομημένους πίνακες και απαγορεύεται να τη χρησιμοποιήσουμε σε ταξινομημένους".

Επομένως δεν αντιτίθεται στο Σ/Λ που έθεσες.
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: Κανένας στις 21 Μάι 2019, 11:38:09 μμ
πολύ ωραία θέματα, Μπράβο και ευχαριστούμε για το μοίρασμα!
στο θέμα Α3 θεωρείς το Κ ακέραιο?
Σωστά, πρέπει η τιμή του Κ να είναι φυσικός αριθμός
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: junior στις 25 Μάι 2019, 01:09:35 πμ
Σωστά, πρέπει η τιμή του Κ να είναι φυσικός αριθμός

Γιατί πρέπει η τιμή του Κ να είναι φυσικός αριθμός;
Δύναται να είναι και πραγματικός αριθμός.

Σ <- 0
ΔΙΑΒΑΣΕ Κ
ΓΙΑ i ΑΠΟ  Κ  ΜΕΧΡΙ  0  ΜΕ_ΒΗΜΑ -2
   ΑΝ i <> 0 ΤΟΤΕ
         Σ <- Σ + i ^ 2
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: junior στις 25 Μάι 2019, 01:40:10 πμ
Η σειριακή Αναζήτηση μπορεί να χρησιμοποιηθεί σε ταξινομημένους πίνακες. Σ/Λ ;

Με βάση την λογική είναι Σωστό
Όμως στο βιβλίο σελίδα 166 γράφει : " Χρησιμοποιείται όμως υποχρεωτικά για πίνακες που δεν είναι ταξινομημένοι"
Τι λέτε;

Η απάντηση είναι απλή. Με βάση την ΛΟΓΙΚΗ, κάτι που υποχρεωτικά χρησιμοποιείται σε μία περίπτωση, δεν σημαίνει αυτόματα ότι απαγορεύεται να χρησιμοποιηθεί (υποχρεωτικά ή προαιρετικά) σε άλλη περίπτωση. Η απάντηση είναι ξεκάθαρα Σ.

Απλά στην προκειμένη περίπτωση, αν ο πίνακας είναι ταξινομημένος, τότε χρησιμοποιούμε πιο αποδοτικό αλγόριθμο, χωρίς αυτό να σημαίνει ότι δεν μπορεί να χρησιμοποιηθεί η σειριακή, διότι δεν θα δουλέψει ή θα δώσει λάθος αποτελέσματα.

Αν η ερώτηση ήταν:
Η σειριακή Αναζήτηση ενδείκνυται/συνιστάται να χρησιμοποιηθεί σε ταξινομημένους πίνακες. Σ/Λ ;
Τι θα απαντούσαμε; Καλό είναι να μην μπει τέτοια ερώτηση επειδή η αποδοτικότητα αλγορίθμων είναι εκτός ύλης;
Τίτλος: Απ: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ
Αποστολή από: junior στις 25 Μάι 2019, 01:54:16 πμ
Οι ενδεικτικές λύσεις είναι σωστές στο ερώτημα Γ4.
Μ=(100+1) DIV 2, ΔΗΛ, 75
M= (76+100) DIV 2 ΔΗΛ 88
Μ=(89+100) DIV 2 ΔΗΛ 94

Είναι:
Μ=(1+100) DIV 2, ΔΗΛ, 50
Μ=(51+100) DIV 2, ΔΗΛ, 75
Μ=(76+100) DIV 2, ΔΗΛ, 88
Μ=(89+100) DIV 2, ΔΗΛ, 94