Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Μονοδιάστατοι πίνακες => Μήνυμα ξεκίνησε από: Νίκος Αδαμόπουλος στις 21 Μάρ 2015, 11:38:59 μμ

Τίτλος: Ακέραιος δείκτης πίνακα στα "Βασικά στατιστικά μεγέθη"
Αποστολή από: Νίκος Αδαμόπουλος στις 21 Μάρ 2015, 11:38:59 μμ
Αν θεωρούμε ότι:
α) ο τελεστής  / δίνει εξ ορισμού πραγματικού τύπου αποτέλεσμα
β) οι δείκτες στους πίνακες πρέπει να είναι ακέραιοι
τότε στο παράδειγμα του σχολικού βιβλίου με τα βασικά στατιστικά μεγέθη (σελ. 188 της παλιάς έκδοσης, βλ: http://alkisg.mysch.gr/steki/index.php?topic=1436.0) υπάρχει προβληματάκι!
 
!Υπολογισμός διαμέσου
ΑΝ Ν MOD 2 =0 TOTE
    Διάμεσος <- (X[N/2]+X[N/2+1])/2
ΑΛΛΙΩΣ
    Διάμεσος <- X[(N+1)/2]
ΤΕΛΟΣ_ΑΝ
Τίτλος: Απ: Ακέραιος δείκτης πίνακα στα "Βασικά στατιστικά μεγέθη"
Αποστολή από: andreas_p στις 22 Μάρ 2015, 06:23:54 μμ
!Υπολογισμός διαμέσου
ΑΝ Ν MOD 2 =0 TOTE
    Διάμεσος <- (X[N div 2]+X[N div 2+1])/2
ΑΛΛΙΩΣ
    Διάμεσος <- X[(N+1) div 2]
ΤΕΛΟΣ_ΑΝ