Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Αλγοριθμική και Προγραμματισμός => Διερμηνευτής της ΓΛΩΣΣΑΣ => Μήνυμα ξεκίνησε από: Kosmas στις 16 Σεπ 2014, 08:08:52 μμ

Τίτλος: Πρόβλημα με παραγωγή εκτελέσιμου αρχείου
Αποστολή από: Kosmas στις 16 Σεπ 2014, 08:08:52 μμ
Γεια σας, είμαι καινούργιος στο φόρουμ και είμαι μαθητής της 3ης λυκείου. Σήμερα είχα το πρώτο μάθημα στην Ανάπτυξη Εφαρμογών και δουλέψαμε στο Διερμηνευτή της Γλώσσας κάνοντας μια απλή πρόσθεση. Έτσι είπα να το κατεβάσω στο σπίτι και να δουλέψω λίγο πάνω σ'αυτό... Έκανα ό,τι είχα να κάνω, η εκτέλεση δουλεύει κανονικά αλλά μόλις τρέχω το εκτελέσιμο σταματάει στο σημείο που πρέπει ο χρήστης να πληκτρολογήσει τον όρο στον οποίο θέλει να βγάλει το αποτέλεσμα...

Κώδικας: [Επιλογή]
Αλγόριθμος ΠΡΑΞΕΙΣ
Εμφάνισε 'Πληκρολογήστε δύο αριθμούς διαχωρίζοντάς τους με ΕΝΤΕΡ.'
Διάβασε α
Εμφάνισε 'Όρος Α: ', α
Διάβασε β
Εμφάνισε 'Όρος Β: ', β
Αν α = 0 και β = 0 τότε
  Αρχή_επανάληψης
    Εμφάνισε 'Τουλάχιστον ένας όρος πρέπει να είναι μεγαλύτερος από το μηδέν.'
    Εμφάνισε 'Παρακαλώ πληκρολογήστε δύο αριθμούς.'
    Διάβασε α
    Εμφάνισε 'Όρος Α:', α
    Διάβασε β
    Εμφάνισε 'Όρος Β:', β
  Μέχρις_ότου α ≠ 0 ή β ≠ 0
Τέλος_αν
Εμφάνισε 'Επιλέξτε μία πράξη από τις παρακάτω.'
Εμφάνισε '1) Πρόσθεση, 2) Αφαίρεση, 3) Πολλαπλασιασμός, 4) Διαίρεση'
Εμφάνισε '5) Ημίτονο, 6) Συνημίτονο, 7) Εφαπτομένη, 8) Συνεφαπτομένη'
Εμφάνισε '9) Τετραγωνική Ρίζα'
Αρχή_επανάληψης
  Διάβασε δ
  Αν δ ≥ 2 τότε
    Εμφάνισε 'Παρακαλώ περιμένετε...'
  Τέλος_αν
  Αν δ = 1 τότε
    γ ← α + β
    Εμφάνισε 'Αποτέλεσμα πράξης: ', α, ' + ', β, ' = ', γ
  αλλιώς_αν δ = 2 τότε
    γ ← α - β
    Εμφάνισε 'Αποτέλεσμα πράξης: ', α, ' - ', β, ' = ', γ
  αλλιώς_αν δ = 3 τότε
    γ ← α* β
    Εμφάνισε 'Αποτέλεσμα πράξης: ', α, ' * ', β, ' = ', γ
  αλλιώς_αν δ = 4 τότε
    Αν β = 0 τότε
      Εμφάνισε 'Η διαίρεση είναι αδύνατη. Ο παρανομαστής είναι μηδέν.'
    αλλιώς
      γ ← α/ β
      Εμφάνισε 'Αποτέλεσμα πράξης: ', α, ' / ', β, ' = ', γ
    Τέλος_αν
  αλλιώς_αν δ = 5 τότε
    Αν β ≠ 0 τότε
      Εμφάνισε 'Επιλέξτε τον όρο που επιθυμείτε. (Α ή Β)'
      Διάβασε ψ
      Αν ψ = 'α' ή ψ = 'Α' τότε
        γ ← ΗΜ(α)
        Εμφάνισε 'Ημίτονο της γωνίας: ', α, ' = ', γ, ' μοίρες.'
      Τέλος_αν
      Αν ψ = 'β' ή ψ = 'Β' τότε
        γ ← ΗΜ(β)
        Εμφάνισε 'Ημίτονο της γωνίας: ', β, ' = ', γ, ' μοίρες.'
      Τέλος_αν
    Τέλος_αν
  αλλιώς_αν δ = 6 τότε
    Αν β ≠ 0 τότε
      Εμφάνισε 'Επιλέξτε τον όρο που επιθυμείτε. (Α ή Β)'
      Διάβασε ψ
      Αν ψ = 'α' ή ψ = 'Α' τότε
        γ ← ΣΥΝ(α)
        Εμφάνισε 'Συνημίτονο της γωνίας: ', α, ' = ', γ, ' μοίρες.'
      Τέλος_αν
      Αν ψ = 'β' ή ψ = 'Β' τότε
        γ ← ΣΥΝ(β)
        Εμφάνισε 'Συνημίτονο της γωνίας: ', β, ' = ', γ, ' μοίρες.'
      Τέλος_αν
    Τέλος_αν
  αλλιώς_αν δ = 7 τότε
    Αν β ≠ 0 τότε
      Εμφάνισε 'Επιλέξτε τον όρο που επιθυμείτε. (Α ή Β)'
      Διάβασε ψ
      Αν ψ = 'α' ή ψ = 'Α' τότε
        γ ← ΕΦ(α)
        Εμφάνισε 'Εφαπτομένη της γωνίας: ', α, ' = ', γ, ' μοίρες.'
      Τέλος_αν
      Αν ψ = 'β' ή ψ = 'Β' τότε
        γ ← ΕΦ(β)
        Εμφάνισε 'Εφαπτομένη της γωνίας: ', β, ' = ', γ, ' μοίρες.'
      Τέλος_αν
    Τέλος_αν
  αλλιώς_αν δ = 8 τότε
    Αν β ≠ 0 τότε
      Εμφάνισε 'Επιλέξτε τον όρο που επιθυμείτε. (Α ή Β)'
      Διάβασε ψ
      Αν ψ = 'α' ή ψ = 'Α' τότε
        γ ← ΣΥΝ(α)/ ΗΜ(α)
        Εμφάνισε 'Συνεφαπτομένη της γωνίας: ', α, ' = ', γ, ' μοίρες.'
      Τέλος_αν
      Αν ψ = 'β' ή ψ = 'Β' τότε
        γ ← ΣΥΝ(β)/ ΗΜ(β)
        Εμφάνισε 'Συνεφαπτομένη της γωνίας: ', β, ' = ', γ, ' μοίρες.'
      Τέλος_αν
    Τέλος_αν
  αλλιώς_αν δ = 9 τότε
    Αν β ≠ 0 τότε
      Εμφάνισε 'Επιλέξτε τον όρο που επιθυμείτε. (Α ή Β)'
      Διάβασε ψ
      Αν ψ = 'α' ή ψ = 'Α' τότε
        Αν α < 0 τότε
          Εμφάνισε 'Αδύνατη η εύρεση της τετραγωνικής ρίζας του αριθμού ', α, '.'
        αλλιώς
          γ ← Τ_Ρ(α)
          Εμφάνισε 'Τετραγωνική ρίζα του αριθμού: ', α, ' = ', γ, '.'
        Τέλος_αν
      Τέλος_αν
      Αν ψ = 'β' ή ψ = 'Β' τότε
        Αν β < 0 τότε
          Εμφάνισε 'Αδύνατη η εύρεση της τετραγωνικής ρίζας του αριθμού ', α, '.'
        αλλιώς
          γ ← Τ_Ρ(β)
          Εμφάνισε 'Τετραγωνική ρίζα του αριθμού: ', β, ' = ', γ, '.'
        Τέλος_αν
      Τέλος_αν
    Τέλος_αν
    Αν ψ ≠ 'α' και ψ ≠ 'β' και ψ ≠ 'Α' και ψ ≠ 'Β' τότε
      Εμφάνισε 'Λανθασμένος αριθμητικός όρος.'
    Τέλος_αν
  αλλιώς
    Εμφάνισε 'Λανθασμένη επιλογή πράξης.'
    Εμφάνισε 'Παρακαλώ επιλέξτε τον αντίστοιχο αριθμό της πράξης.'
    Εμφάνισε '1) Πρόσθεση, 2) Αφαίρεση, 3) Πολλαπλασιασμός, 4) Διαίρεση'
    Εμφάνισε '5) Ημίτονο, 6) Συνημίτονο, 7) Εφαπτομένη, 8) Συνεφαπτομένη'
    Εμφάνισε '9) Τετραγωνική ρίζα'
  Τέλος_αν
Μέχρις_ότου δ ≥ 1 και δ ≤ 9
Τέλος ΠΡΑΞΕΙΣ
Τίτλος: Απ: Πρόβλημα με παραγωγή εκτελέσιμου αρχείου
Αποστολή από: alkisg στις 17 Σεπ 2014, 08:47:37 πμ
Εμένα μια χαρά μου τρέχει, δες τη συνημμένη εικόνα, μπορείς να βγάλεις κι εσύ screenshot από το σημείο που σου κολλάει, και να πεις τι συμβαίνει αν π.χ. εκεί γράψεις κάποιο νούμερο και πατήσεις Enter;
Τίτλος: Απ: Πρόβλημα με παραγωγή εκτελέσιμου αρχείου
Αποστολή από: Kosmas στις 17 Σεπ 2014, 02:08:22 μμ
Κολλάει από το ημίτονο και μετά απ' ότι φαίνεται...