Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Μήνυμα ξεκίνησε από: Laertis στις 14 Απρ 2011, 12:22:39 πμ

Τίτλος: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Laertis στις 14 Απρ 2011, 12:22:39 πμ
Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 εφ'όλης της ύλης απο την ομάδα διαγωνισμάτων του στεκιού.

μαζί με τις ενδεικτικές λύσεις

Αλλαγή στις ενδεικτικές λύσεις   8/5/2011
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: poursali στις 14 Απρ 2011, 12:35:11 πμ
συνάδελφε, σε openoffice τα σύμβολα δεν εμφανίζονται... αν μπορείς βάλτο σε pdf :)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: asimos_alex στις 14 Απρ 2011, 12:31:30 μμ
( συγχαρητήρια σε όλους τους συναδέρφους που δίνουν σε αυτή την σπουδαία προσπάθεια του στεκιού ό,τι μπορούν. Ελπίζω κάποια στιγμή να ανταποδώσω κι εγώ κάτι από τα πολλά που έχω πάρει από τις συζητήσεις τόσα χρόνια στο στέκι )

Πολύ καλό το διαγώνισμα, μόνο που ΄χω δυο-τρεις παρατηρήσεις με την π ρ ό χ ε ι ρ η  ματιά που πρόλαβα:

α. προφανώς στο Α1 η εντολή είναι έγκυρη κι επομένως η μεταβλητή x είναι λογική. Αυτή η μορφή, ωστόσο, της εκχώρησης της τιμής λογικής έκφρασης βρίσκεται πουθενά διατυπωμένη στα σχολικά εγχειρίδια; (προφανώς τη διδάσκετε για να τη βάλετε στο διαγώνισμα, αλλά εγώ δεν έχω κάνει το ίδιο -κακώς?-)
β. ίσως λ ί γ ο  παραπάνω από ότι "πρέπει" για τον "μέσο" μαθητή η ανάγκη αλγοριθμικομαθηματικής σκέψης (πχ Α3, Α4, Α5) στο 1ο θέμα.
γ. πολύ μεγάλες σε έκταση οι εκφωνήσεις των δυο ασκήσεων. για μένα δεν είναι κακό αυτό, εφόσον κάτι τέτοιο συνήθως σημαίνει καλά διατυπωμένα προβλήματα, αλλά δυστυχώς παρατηρώ πως σε πολλές περιπτώσεις -πέρα από το έξτρα άγχος- δημιουργεί πρόβλημα σε μαθητές με μειωμένες δυνατότητες χρήσης της ελληνικής (κι αυτοί δεν είναι ούτε λίγοι κατά τη γνώμη μου)

Κατά τα άλλα το διαγώνισμα πηγαίνει το παιχνίδι ένα βήμα πιο μπροστά (για ακόμη μια χρονιά) με τρόπο ουσιαστικό, εποικοδομητικό και σύγχρονο.

Να είστε όλοι καλά
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: methenitis στις 14 Απρ 2011, 12:48:42 μμ
Πολύ ωραίο διαγώνισμα. Τα συγχαρητήρια μου.
Ιδιαίτερα απο θεωρία μου άρεσε περισσότερι το Α2 , που έιχε την αναφορά με δεδομένα και ζητούμενα ενός προβλήματος και το Α5.
Το θέμα Β λίγο μεγάλο αλλά πολύ καλό.
Οι ασκήσεις μου φάνηκαν στο σωστό βαθμό δυσκολία (για το tosteki παντα).
Σίγουρα οι μαθητές θα δυσκολευτούν να τις βγάλουν. Ιδιαίτερα το Θεμα 3 , τα κορίτσια θα αντιμετωπίσουν ενα επιπλέον πρόβλημα όσες δεν γνωρίζουν την διαδικασία των πεναλτυ. Για αυτό πιστεύω και η εκτενής περιγραφή.

Εμείς μπορούμε να δώσουμε καμία προτεινωμενη λύση στα θέματα?

Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 14 Απρ 2011, 12:57:06 μμ
Ακριβώς αυτή είναι η ιδέα. Το ότι δεν υπάρχει στο σχολικό βιβλίο δεν σημαίνει ότι είναι λάθος. Απλά επειδή δεν χρησιμοποιείται ξενίζει λίγο.  Θα προσπαθήσω να εξηγήσω το σκεπτικό

Από τη στιγμή που μια έκφραση αποτιμάται σε Αληθής/Ψευδής μπορεί να μπει σε οποιοδήποτε σημείο μπορεί να μπουν οι τιμές Αληθής/Ψευδής. Αυτός είναι και ο στόχος. Είναι δηλαδή καθαρά θέμα κατανόησης.
π.χ. το παρακάτω σετ εντολών
χ <- 5
Α <- (χ > 0)

είναι σαν να λέγαμε
Α <- Αληθής

άλλο παράδειγμα
λέμε   Όσο Βρέθηκε = Αληθής Επανάλαβε
αλλά το Όσο Βρέθηκε Επανάλαβε  δεν σε ξενίζει πάλι ;
Σκέψου όμως να έγραφες
Όσο (χ>0) = Αληθής Επανάλαβε
δεν δείχνει έλλειμα κατανόησης ή έστω ανασφαλειας όσον τη χρήση λογικών εκφράσεων και μεταβλητών; άσχετα αν είναι σωστό.

α. προφανώς στο Α1 η εντολή είναι έγκυρη κι επομένως η μεταβλητή x είναι λογική. Αυτή η μορφή, ωστόσο, της εκχώρησης της τιμής λογικής έκφρασης βρίσκεται πουθενά διατυπωμένη στα σχολικά εγχειρίδια; (προφανώς τη διδάσκετε για να τη βάλετε στο διαγώνισμα, αλλά εγώ δεν έχω κάνει το ίδιο -κακώς?-)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: gthal στις 14 Απρ 2011, 01:00:30 μμ
Συνάδελφοι σας ευχαριστούμε για τα εποικοδομητικά σας σχόλια.
@asimos_alex  θέλω να απαντήσω τη γνώμη μου μόνο πάνω σ' αυτό (αν και απάντησε ήδη ο evry)
Αυτή η μορφή, ωστόσο, της εκχώρησης της τιμής λογικής έκφρασης βρίσκεται πουθενά διατυπωμένη στα σχολικά εγχειρίδια; (προφανώς τη διδάσκετε για να τη βάλετε στο διαγώνισμα, αλλά εγώ δεν έχω κάνει το ίδιο -κακώς?-)
Δε νομίζω ότι είναι κάτι που χρειάζεται να διατυπωθεί ή διδαχθεί ιδιαιτέρως :  κάθε συνθήκη αποτιμάται τελικά σε μια λογική τιμή έτσι δεν είναι ;  και κάθε λογική τιμή μπορεί να εκχωρηθεί σε μια λογική μεταβλητή. Γιατί λοιπόν να μην μπορεί να γραφτεί αυτό  x <- α > β  ;
(βασικά, συμβαίνει με την ίδια λογική που γίνεται κι αυτό :  y <-  5+2  : πρώτα αποτιμάται η έκφραση στα δεξιά και το αποτέλεσμα εκχωρείται στην y - δεδομένου βέβαια ότι η y είναι αριθμητική )
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Παναγιώτης Τσιωτάκης στις 14 Απρ 2011, 01:38:22 μμ
Θέμα 1Δ
επαναληπτικές 2008
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 14 Απρ 2011, 02:38:19 μμ
Ωραίο και απαιτητικό! To Δ6 μου θυμίζει επαναληπτικές 2010 με τους πληθυσμούς.
Μ'αρέσει πολύ η ερώτηση Β2. 2  (ρόλος της Τ)!
Όμως κάτι με αλφαριθμητικά θα πέσουν στο 3ο η 4ο (το είδα πρόσφατα στον ύπνο μου  :D χαχα!)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 15 Απρ 2011, 11:09:23 πμ
Είναι λογικό όταν βλέπουμε εκ των υστέρων ένα θέμα να μας φέρνει στο νου σημεία από άλλα θέματα. Στο τέλος τέλος όλα τα θέματα κάτι θα θυμίζουν. Βέβαια το Δ6 δεν έχει και τόσο σχέση με το περσινό των επαναληπτικών. Εκεί ουσιαστικά ζητούσε να ελεγχθεί αν υπάρχουν μέσα στον πίνακα δυο συνεχόμενες θέσεις με την τιμή -1, κάτι "σχετικά απλό"...
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: lykos στις 16 Απρ 2011, 09:18:42 μμ
Συγχαρητήρια + ευχαριστώ κι' από μένα. Πολύ καλά θέματα. Κατάλαβες γράφεις, δεν κατάλαβες έχασες...
Μ' άρεσαν ιδιαίτερα, τα Α4.1 α) και Α5
Στο 4ο θα δυσκολευτούν και καλοί μαθητές με το Αν μηκος MOD 10 <τελεστής> <τιμή> τότε ...
Και μια παρατήρηση για το 4ο: Ισως να ήταν καλύτερα να μην δίνονται οι παράμετροι της συνάρτησης, διότι με κατάλληλη προεργασία στον πίνακα κατάστασης λαμπτήρων, η παράμετρος "πλήθος λαμπτήρων" δεν είναι απαραίτητη...
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Peandbal στις 17 Απρ 2011, 05:24:37 μμ
Συγχαρητήρια, οι μαθητές μου θα το βρουν πολύ ενδιαφέρον.
Θα επανέλθω με σχόλια τους.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: jim_st στις 19 Απρ 2011, 01:36:01 πμ
Συγχαρητήρια, μ' αρέσουν πολύ τα δύο πρώτα θέματα!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: dbenis στις 21 Απρ 2011, 12:20:47 μμ
συγχαρητηρια!!!!!! + ευχαριστώ πολυ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: ΤΙΜ στις 26 Απρ 2011, 10:55:59 πμ
ΣΥΓΧΑΡΗΤΗΡΙΑ ΠΟΛΥ ΚΑΛΟ , ΣΑΣ ΕΥΧΑΡΙΣΤΩ ΠΟΛΥ ΓΙΑ ΤΗΝ ΠΡΟΣΠΑΘΕΙΑ ΠΟΥ ΚΑΝΕΤΕ  ;)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: zoidel στις 26 Απρ 2011, 07:09:01 μμ
Πολύ καλό διαγώνισμα!Συγχαρητήρια . Όσο για την εκχώρηση τιμής σε λογική μεταβλητή ,εδώ και χρόνια στο τελικό επαναληπτικό που βάζω η μια ερώτηση σωστού λάθους είναι . Η μεταβλητή Α<- 100 DIV 80=1 είναι λογικού τύπου. Δεν με προβλημάτισε ποτέ ότι μπορεί να είναι λάθος
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: dimitra στις 26 Απρ 2011, 09:37:58 μμ
Συνάδελφοι, καταπληκτική δουλειά για μια ακόμη φορά, συγχαρητήρια!!
Το 4ο θέμα μου άρεσε πάρα πολύ, εκείνος/η που το εμπνεύστηκε πρέπει να έχει πολύ φαντασία!
Επίσης, μου άρεσε το Β, ξεφεύγει λίγο από τα τυποποιημένα.
Λιγότερο ..αγαπημένο το Α4α (το οποίο για δεδομένη έξοδο ζητά τις τιμές της εισόδου), νομίζω θα μπερδέψει.
Πάντως θεωρώ ότι το 3ο και 4ο είναι δύσκολα. Ο άριστος θα ιδρώσει για να βγάλει ειδικά το 4ο. Αλλά είναι πολύ καλή η κλιμάκωση των υποερωτημάτων, οπότε και ο μέτριος μπορεί να το φτάσει μέχρι ένα ικανοποιητικό σημείο.
Ευχαριστούμε!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: StefAlex στις 29 Απρ 2011, 11:54:20 πμ
Μπορώ να πω ότι είναι πολύ καλύτερο το διαγώνισμα  από αυτό του ΟΕΦΕ.

Μήπως πρέπει να δοθούν και οι προτεινόμενες λύσεις  ή είναι νωρίς ακόμα ??
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 29 Απρ 2011, 03:12:19 μμ
οι προτεινόμενες λύσεις θα δοθούν σε λίγες μέρες, υπομόνη.
Φυσικά όποιος θέλει να δώσει μια δικιά του λύση μέχρι τότε μπορεί να το κάνει
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: ggfiogos στις 30 Απρ 2011, 10:57:04 πμ
Ενα πολύ καλό διαγώνισμα αλλά πάρα πολύ απαιτητικό. Ο καλός μαθητής δύσκολα θα το βγάλει σε 3 ώρες, πόσο άλλον ο μέτριος. Εκτός βέβαια αν έχει εξασκηθεί σε παρόμοια θέματα.

3ο και 4ο θέμα πολύ μεγάλα (3ο θέλει πολύ σκέψη και το 4ο έχει πολλά ερωτήματα). Πάντα κατά την γνώμη μου!

Ευχαριστώ πολύ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Laertis στις 30 Απρ 2011, 05:13:07 μμ
Τα διαγωνίσματα του στεκιού θέλουμε να διαφέρουν απο τα υπόλοιπα. Και νομίζω ότι κανένας απο εμάς στην ομάδα διαγωνισμάτων δε θεώρησε εύκολα ή μέτρια δυσκολίας τα διαγωνίσματα που βγάζουμε εδώ και πολύ καιρό. Υπάρχει σκοπός και φιλοσοφία πίσω απο αυτό....

Βατά και απλά διαγωνίσματα μπορεί να βρει ο κάθε συνάδελφος σχεδόν παντού, απο ιστοσελίδες φροντιστηρίων και εφημερίδων, διάφορα και ποικίλλα βοηθήματα του εμπορίου μέχρι προσωπικές ιστοσελίδες συναδέλφων.
Θα θεωρούσα ανούσια τη συμμετοχή μου σε ένα ακόμη "μια απο τα ίδια" διαγώνισμα.

Ευχαριστώ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: andreas_p στις 01 Μάι 2011, 12:15:49 πμ
Γιώργο, δε χρειάζεται να απολογείσαι ...

Τα θέματα είναι εξαιρετικά σε διατύπωση και κατανόηση.

Ενδεικτικά αναφέρω την αντίδραση μαθήτριας (άσχετης με ποδόσφαιρο), στο θέμα Γ :

"Είναι απολύτως κατανοητό και σαφές.  Τώρα το κουπί (της σκέψης) πρέπει να το ... τραβήξω μόνη μου"

Τώρα αν απαιτούν ένα άλλο μονοπάτι σκέψης, διαφορετικό από την τυποποίηση  ...

Άλλωστε αυτή είναι η φιλοσοφία των θεμάτων !

Γιώργο, επειδή φέτος, απείχα απ' τη διαδικασία, αν επιθυμείς μπορώ να αναλάβω και να στείλω τις λύσεις (μαζί με το run time ... σε ΓΛΩΣΣΑ) των ΘΕΜ. Γ και Δ.

Α

Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: karinakis στις 01 Μάι 2011, 06:23:57 μμ
Συνάδελφοι, βλέποντας τα θέματα από το τελικό διαγώνισμα θα ήθελα να κάνω και εγώ κάποιες παρατηρήσεις :

α) ορισμένα θέματα ήταν σίγουρα πολύ καλά και ανταποκρίνονται στο επίπεδο των εξετάσεων ή καλύτερα στο επίπεδο των μαθητών.
β) στο σύνολό τους τα θέματα ήταν πάρα πολλά και αμφιβάλλω αν έστω και ένας μαθητής - ακόμη και καλός - θα μπορέσει να αντεπεξέλθει μέσα σε 3 ώρες. Τώρα αν η συντακτική ομάδα θεωρεί ότι πρέπει ο μαθητής να διαβάζει μία φορά το θέμα και να το γράφει λες και είναι κομμάτι της ιστορίας που έχει αποστηθίσει τότε λυπάμαι... μάλλον οδηγούμε τους μαθητές μας στην παπαγαλία και δε νομίζω ότι είναι αυτό το ζητούμενο του συγκεκριμένου μαθήματος.
γ) θα ήθελα να μου πει κάποιος από την συντακτική ομάδα, στο σχολείο του έκανε συνέχεια τέτοια θέματα και προετοίμαζε τους μαθητές για το συγκεκριμένο επίπεδο...;;;;
δ) σκοπός μας πιστεύω δεν είναι να δείξουμε πόσο δύσκολα θέματα μπορούμε να βάλουμε για να μην έχουν τη δυνατότητα να τα λύσουν οι μαθητές αλλά να είμαστε αρωγοί στην προσπάθεια των μαθητών μας.
ε) στο σύνολό τους τα συγκεκριμένα θέματα (έκταση, βάθμος δυσκολίας, απαιτήσεις στο κάθε υποερώτημα) δεν ανταποκρίνονται καθόλου μα καθόλου στα θέματα των πανελλαδικών όπως τα έχουμε δει μέχρι τώρα
στ) το στέκι πάντα βοηθούσε τους μαθητές και πιστεύω σκοπός του ήταν και είναι να συνεχίσει να το κάνει. Τώρα αν κάποιοι θεωρούν ότι μέσα από ένα διαγώνισμα πρέπει να κάνουν επίδειξη γνώσεων τότε λυπάμαι αλλά έχουμε χάσει το στόχο μας και παύουμε να είμαστε παιδαγωγοί...

και ένα τελευταίο....

ας μην ξεχνάμε ότι το διαγώνισμα το βλέπουν και μαθητές. Και σίγουρα ακόμη και οι καλυτεροι με αυτά που αντίκρυσαν απογοητεύτηκαν. Η ψυχολογία των μαθητών είναι πολύ σημαντική για την επιτυχία τους. Ως καθηγητές τους έχουμε την υποχρέωση να στεκόμαστε δίπλα τους και όχι να τους στριμώχνουμε στον τοίχο μέσα από δύσκολα θέματα.... ας δουλέψουμε λίγο και την ψυχολογία των μαθητών και όχι να κοιτάμε μόνο πως θα κάνουμε επίδειξη γνώσεων μέσα από δύσκολα θέματα. Λίγες μέρες πριν τις πανελλαδικές εμείς μάλλον τους διαλύουμε παρά τους βοηθάμε.

Με βάση όλα τα παραπάνω θεωρώ ότι για μία ακόμη φορά το διαγώνισμα είναι δυστυχώς εκτός πραγματικότητας, οπως και όλα τα προηγούμενα χρόνια

Ζητώ συγνώμη για το ύφος μου, εκτιμώ τη δουλειά των συναδέλφων όμως για μένα προέχει ο μαθητής του με την καλή και πατροπαράδοτη έννοια (και όχι φυσικά με την έννοια που δίνει το υπουργείο με το σχετικό του σύνθημα)

Ευχαριστώ

Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: andreas_p στις 01 Μάι 2011, 07:25:31 μμ
Ευχαριστούμε πολύ ...  για την εκτίμησή σου !

Α.Π.

Μέλος της ομάδας  ΑΝΤΙ-παιδαγωγών !!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 01 Μάι 2011, 07:31:37 μμ
Αντρέα μην ασχολείσαι, απαντάμε μόνο σε καλοπροαίρετες κριτικές ;)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: petrosp13 στις 01 Μάι 2011, 07:55:45 μμ
Ειλικρινά, πόση ώρα χρειαζόμαστε εμείς σαν καθηγητές για να γράψουμε τις λύσεις σε αυτά τα θέματα;
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: gpapargi στις 02 Μάι 2011, 11:51:16 πμ
Παιδιά δεκτές οι κριτικές και το συζητάμε.

Αν η ομάδα διαγωνισμάτων έβαζε θέματα με βάση το υπάρχον επίπεδο δυσκολίας των εξετάσεων τότε θα έπρεπε τα θέματα να είναι πάντα εύκολα και βατά δηλαδή το καλύτερο δώρο για ένα μαθητή που παπαγαλίζει και λύνει μόνο τυποποιημένα θέματα. Σε μια τέτοια περίπτωση η ομάδα διαγωνισμάτων του στεκιού (η οποία είναι ανοιχτή σε συμμετοχές προς όλους) δε θα είχε λόγο ύπαρξης αφού τέτοιες ασκήσεις βρίσκει οα καθένας πολύ εύκολα. 

Το στέκι βγάζει θέματα με βάση το επίπεδο δυσκολίας του διδακτικού πακέτου, όπως αυτό φαίνεται στο τετράδιο μαθητή. Υπάρχουν στο τετράδιο ασκήσεις 3 αστέρων που είναι εξ’ ορισμού εντός ύλης αλλά πάνω από το επίπεδο των εξετάσεων. Ένας μαθητής που έχει προετοιμαστεί για να λύνει την τριγωνική σάρωση, να φτιάχνει πίνακα συχνοτήτων σε τελείως τυχαίο μονοδιάστατο, να υπολογίζει τη δυναμοσειρά του συνημιτόνου και να κάνει ανάλυση φυσικού σε πρώτους παράγοντες (όλες αυτές είναι ασκήσεις μέσα από το τετράδιο μαθητή), μπορεί να αντιμετωπίσει τα θέματα.  Και φυσικά δεν είναι αναγκαίο να παίρνουν άριστα. Οι πολύ καλοί πρέπει να ξεχωρίζουν.

Γενικά το πνεύμα της ομάδας είναι να προετοιμάζονται οι μαθητές για όλη την ύλη και όχι για αυτά που συνήθως πέφτουν (ΣΟΣ).
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Keep Growing στις 02 Μάι 2011, 03:41:27 μμ
Το στέκι και η ομάδα διαγωνισμάτων, δεν είναι κάποιος θεσμοθετημένος φορέας του Υπουργείου Παιδείας για να "κινείται" πάνω σε συγκεκριμένη  "τροχιά".
Γιαυτό και το ταξίδι των "επιβατών" έχει ουσιαστικό ενδιαφέρον ...
Το "ταξίδι" προς τη γνώση δεν έχει συγκεκριμένη διαδρομή. Μόνο ο προορισμός είναι γνωστός πριν από την αρχή του ταξιδιού.

...

Καλά "ταξίδια" λοιπόν, και στους "οδηγούς" και στους "επιβάτες".
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Παναγιώτης Τσιωτάκης στις 02 Μάι 2011, 04:06:24 μμ
Ευρυπίδη, με όλο το σεβασμό και χωρίς να παίρνω θέση επί της ουσίας,  δε νομίζω πως η κριτική δεν ήταν κακοπροαίρετη. Ήταν κοσμιότατη, με προσεγμένο λεξιλόγιο και χωρίς ύβρεις. Εκφράζεται μέσω αυτής ένας γενικότερος προβληματισμός που δεν είναι νέος, ούτε φετινός.

Συνάδελφοι, καλό είναι να υπάρχει ελευθερία σε χρήστες, και δη τέτοιου επιπέδου όπως ο @karinakis, να εκφράζουν τη γνώμη τους και τους προβληματισμούς τους.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 02 Μάι 2011, 04:49:58 μμ
Παναγιώτη όπως ξέρεις όλοι οι συνάδελφοι που συμμετέχουν στην ομάδα διαγωνισμάτων διαθέτουν αρκετό από τον προσωπικό τους χρόνο χωρίς κανένα απολύτως όφελος, αφού στο τελικό διαγώνισμα δεν φαίνονται ούτε τα ονόματά τους.  Όταν λοιπόν κάποιος λέει ότι οι συνάδελφοι κάνουν επίδειξη γνώσεων δεν νομίζω ότι αυτό θεωρείται καλοπροαίρετη κριτική.
Και στην τελική, τι νόημα έχει αυτού του είδους η κριτική; Όπως πολύ εύστοχα είπε ο Παναγιώτης (Πέντσας) δεν είμαστε κάποιο θεσμοθετημένο όργανο. Είμαστε μια παρέα (ανοικτή σε όλους) που θέλει να προσφέρει. Όποιος διαφωνεί με τη φιλοσοφία του διαγωνίσματος, μπορεί απλά να μην το χρησιμοποιήσει, δεν υποχρεώνουμε κανέναν.
Αν κάποιος διαφωνεί με κάποιο συγκεκριμένο θέμα πολύ ευχαρίστως να το συζητήσουμε.
Τέλος, αν κάποιος θεωρεί ότι τα θέματα είναι πολλά για 3  ώρες, μπορεί κάλλιστα να χρησιμοποιήσει αυτά που του αρέσουν και να αντικαταστήσει ένα δύσκολο θέμα με ένα δικό του πιο εύκολο, αν θεωρεί ότι οι μαθητές του δεν θα μπορέσουν να ανταπεξέλθουν. Δεν υποχρεώνουμε κανέναν να το χρησιμοποιήσει έτσι. Μπορεί να το χρησιμοποιήσει ή να το τροποποιήσει όπως θέλει.
Η γενική φιλοσοφία όπως το βλέπω εγώ είναι όσο μπορούμε να παράγουμε νέες ιδέες και πρωτότυπες (όχι απαραίτητα δύσκολες) ασκήσεις. Η κατανόηση των βασικών εννοιών και της θεωρίας μπορεί να ελεγχθεί καλύτερα  με πρωτότυπες ασκήσεις και όχι με θέματα τα όποια έχουν “συνηθίσει” οι μαθητές, ούτε φυσικά με απλές ερωτήσεις ανάκλησης.  Εκεί απαντούν μηχανικά χωρίς να σκέφτονται.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: pgrontas στις 02 Μάι 2011, 04:55:32 μμ
Προσπαθούσα να το γράψω μισή ώρα αυτό το μήνυμα αλλά είχα πρόβλημα σύνδεσης και με πρόλαβε ο Ευριπίδης, σε κάποια πράγματα που ήθελα να πω:

Επι της ουσίας συμφωνώ με το Γιώργο: Η κριτική είναι χρήσιμη και μας βοηθάει να γίνουμε καλύτεροι, όταν όμως αυτή είναι  συγκεκριμένη και όχι γενικόλογη και γεμάτη αφορισμούς (πχ. επίδειξη γνώσεων, εκτός πραγματικότητας). Καλό θα ήταν λοιπόν να εστιάζεται σε συγκεκριμένα σημεία του διαγωνίσματος.

Θέλω λοιπόν να απαντήσω στα συγκεκριμένα θέματα της παραπάνω κριτικής:

Επειδή κατά την διάρκεια της χρονιάς κάνω στους μαθητές μου (σε ένα τυπικό λύκειο) όλες τις ασκήσεις που έχουν μπει στα διάφορα διαγωνίσματα του στεκιού και ακούω γκρίνιες του στυλ ότι τόσο δύσκολα δεν μπαίνουν ούτε στο φροντιστήριο, η απάντηση που έδινα και δίνω και εδώ είναι ότι οι διαφορετικές ασκήσεις είναι αυτές που έχουν αξία, γιατί αν κατακτήσεις τον τρόπο σκέψης αυτών τότε μπορείς να κάνεις και τις απλούστερες και φυσικά έχεις και κέρδος σε περίπτωση δύσκολου θέματος.  Καταγράφω επίσης, χωρίς περαιτέρω σχόλιο, ότι οι μαθητές που δεν έχουν επαφή με τυποποιημένες ασκήσεις, έχουν πιο θετική αντιμετώπιση. Επιπλέον σε ό,τι αφορά το είδος και το επίπεδο των θεμάτων των πανελλαδικών, ό,τι λεγεται είναι απλά και μόνο υποθέσεις με βάση την προηγούμενη εμπειρία. Οποιαδήποτε πρόβλεψη είναι εντελώς παρακινδυνευμένη. Κανείς δεν πρέπει να αποκλείει πιο δύσκολα ή/και 'διαφορετικά' θέματα, ειδικά όταν είναι όπως σωστά ανέφερε ο Γιώργος στο πνεύμα του τετραδίου του μαθητή.

Σε ό,τι αφορά την διάρκεια του διαγωνίσματος κανένας από τους μαθητές μου που μίλησα σημέρα και το έλυσαν το Πάσχα δεν διαμαρτυρήθηκε πως δεν πρόλαβε. Επειδή δεν είχα σήμερα ΑΕΠΠ και η παραπάνω συζήτηση έγινε στους διαδρόμους θα σας ενημερώσω για τα αποτελέσματα όταν τα συζητήσουμε (με όσους δυστυχώς έρθουν).

Στο θέμα της αυτοπεποίθησης θεωρώ ότι όντως υπάρχει ένας κίνδυνος, αλλά όλα είναι θέμα σερβιρίσματος. Δεν το παρουσιάζεις ως "ένα διαγώνισμα πανελληνίων". Το παρουσιάζεις ως κάτι πιο δύσκολο από τις πανελλήνιες, επισημαίνοντας και αυτό που έγραψα πριν σχετικά με τις προβλέψεις. Έτσι και αυτός που θα τα πάει καλά θα ανέβει ψυχολογικά (δικαίως) και όποιος δεν τα πάει καλά δεν θα αποθαρρυνθεί. Επίσης δεν χρειάζεται να το δώσεις ως διαγώνισμα, με την έννοια της βαθμολογίας, αλλά ως κάποιες ασκήσεις που σκοπό έχουν να 'προκαλέσουν' τους μαθητές.

Τέλος το διαγώνισμα του Στεκιού δεν είναι υποχρεωτικό να χρησιμοποιηθεί πουθενά. Αν κάποιος διδάσκων κρίνει ότι δεν συμβαδίζει με τους στόχους που έχει θέσει, απλά δεν το χρησιμοποιεί.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Katsadouros_Dhm στις 02 Μάι 2011, 05:15:53 μμ
Παιδιά παραθέτω μια ενδεικτική λύση για το 3ο θέμα, μόνο που το έγραψα σε Γλώσσα για να το τρέξω κιόλας!
Παρατηρήσεις, διορθώσεις, βελτιώσεις (που σιγουρα θα υπάρχουν) στη διάθεσή σας.

ΠΡΟΓΡΑΜΜΑ θεμα_3_στεκι_2011
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: σκορ1, σκορ2, προσπ
  ΧΑΡΑΚΤΗΡΕΣ: ον1, ον2, αποτ1, αποτ2
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώστε το όνομα της 1ης ομάδας:'
  ΔΙΑΒΑΣΕ ον1
  ΓΡΑΨΕ 'Δώστε το όνομα της 2ης ομάδας:'
  ΔΙΑΒΑΣΕ ον2
  προσπ <- 0
  σκορ1 <- 0
  σκορ2 <- 0
  ΟΣΟ ((προσπ <= 5) ΚΑΙ (Α_Τ(σκορ1 - σκορ2) <= 5 - προσπ)) Η (σκορ1 = σκορ2) ΕΠΑΝΑΛΑΒΕ
    προσπ <- προσπ + 1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εκτελεί πέναλτι η ομάδα:', ον1
      ΔΙΑΒΑΣΕ αποτ1
    ΜΕΧΡΙΣ_ΟΤΟΥ αποτ1 = 'ευστοχο' Η αποτ1 = 'αστοχο'
    ΑΝ αποτ1 = 'ευστοχο' ΤΟΤΕ
      σκορ1 <- σκορ1 + 1
    ΤΕΛΟΣ_ΑΝ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εκτελεί πέναλτι η ομάδα:', ον2
      ΔΙΑΒΑΣΕ αποτ2
    ΜΕΧΡΙΣ_ΟΤΟΥ αποτ2 = 'ευστοχο' Η αποτ2 = 'αστοχο'
    ΑΝ αποτ2 = 'ευστοχο' ΤΟΤΕ
      σκορ2 <- σκορ2 + 1
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Το σκορ είναι μετά από ', προσπ, ' προσπάθειες:'
    ΓΡΑΨΕ ον1, ':', σκορ1
    ΓΡΑΨΕ ον2, ':', σκορ2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ σκορ1 > σκορ2 ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΥΠΕΛΛΟΥΧΟΣ 2010-2011:', ον1
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΚΥΠΕΛΛΟΥΧΟΣ 2010-2011:', ον2
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Τίτλος: Απ: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Katsadouros_Dhm στις 02 Μάι 2011, 05:19:22 μμ
Παραθέτω και ενδεικτική λύση στο 4ο θέμα (πολύ λάμπα, ρε παιδιά...  ;D)
Δεν έχω γράψει σχόλια για τις μεταβλητές. Βελτιώσεις επιδέχεται σίγουρα. ( Μπορεί και διορθώσεις...)

ΠΡΟΓΡΑΜΜΑ θεμα_4_στεκι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: μηκος, ι, ξ, πλ[50], κατ[50, 50], σ, σ1, σ2, μεγ_πλ
  ΠΡΑΓΜΑΤΙΚΕΣ: ποσ_καμ[50], συν_ποσ, μεγ_ποσ_καμ
ΑΡΧΗ
  σ <- 0
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Δώστε το μήκος της ', ι, ',ης στοάς'
      ΔΙΑΒΑΣΕ μηκος
    ΜΕΧΡΙΣ_ΟΤΟΥ μηκος >= 20 ΚΑΙ μηκος <= 500
    πλ[ι] <- (μηκος DIV 10)
    σ <- σ + πλ[ι]
    ΓΡΑΨΕ 'Η ', ι, 'η στοά έχει ', πλ[ι], ' λαμπτήρες'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Σε όλες τις στοές υπάρχουν ', σ, ' λαμπτήρες'
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ πλ[ι]
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Δώστε την κατάσταση του ', ξ, 'ου λαμπτήρα της ', ι, ' στοάς:'
        ΔΙΑΒΑΣΕ κατ[ι, ξ]
      ΜΕΧΡΙΣ_ΟΤΟΥ κατ[ι, ξ] = 1 Η κατ[ι, ξ] = 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  σ2 <- 0
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    σ1 <- 0
    ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ πλ[ι]
      ΑΝ κατ[ι, ξ] = 0 ΤΟΤΕ
        σ1 <- σ1 + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ποσ_καμ[ι] <- σ1/πλ[ι]*100
    σ2 <- σ2 + σ1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μεγ_ποσ_καμ <- ποσ_καμ[1]
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 50
    ΑΝ ποσ_καμ[ι] > μεγ_ποσ_καμ ΤΟΤΕ
      μεγ_ποσ_καμ <- ποσ_καμ[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΑΝ ποσ_καμ[ι] = μεγ_ποσ_καμ ΤΟΤΕ
      ΓΡΑΨΕ 'Στην ', ι, 'η στοά έχουμε μέγιστο ποσοστό καμένων λαμπτήρων'
      ΓΡΑΨΕ μεγ_ποσ_καμ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ποσ_καμ[ι] = 100 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ', ι, 'η στοά δεν έχει καθόλου φωτισμό'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  συν_ποσ <- σ2/σ*100
  ΓΡΑΨΕ 'Το συνολικό ποσοστό καμένων λαμπτήρων είναι:', συν_ποσ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    μεγ_πλ <- συν_καμ(κατ, ι, πλ[ι])
    ΓΡΑΨΕ 'Οι περισσότεροι συνεχόμενοι καμένοι στην ', ι, 'η στοά είναι:', μεγ_πλ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ συν_καμ(κατ_1, ι1, πλθ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: κατ_1[50, 50], ι1, πλθ, ξ, κ, μεγ
ΑΡΧΗ
  μεγ <- 0
  κ <- 0
  ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ πλθ
    ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      κ <- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  συν_καμ <- μεγ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: ntzios kostas στις 02 Μάι 2011, 05:24:51 μμ
Νομίζω ότι τα θέματα αυτά πράγματι δεν ειναι για θέματα εξετάσεων ως σύνολο. Μεμονωμένα όμως αν εξαιρέσουμε κάποια ερωτήματα του 4ου θέματος δεν είναι απίθανο να πέσουν. Επιπλέον τα θέματα αυτά είναι μία ευκαιρία για μία δυνατή προπόνηση του μαθητή πριν τις εξετάσεις. Όπως και ο αθλητής των 100 μέτρων, θα τρέξει και 200 και 400, θα κάνει κολύμβηση και θα σηκώσει βάρη, έτσι και ο μαθητής πρέπει να βλέπει και πιο δύσκολα θέματα ώστε να κατέβει πιο δυνατός στο στίβο των εξετάσεων.   
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Laertis στις 02 Μάι 2011, 06:41:59 μμ
Δεκτή η κριτική απο οποιονδήποτε αλλά δε βλέπω Παναγιώτη Τσιωτάκη ποιος περιορίζει την ελευθερία των χρηστών επιπέδου και μη. Αντιθέτως, μέχρι τώρα οι κριτικές, ακομη και οι κακόβουλες, γίνονται απρόσκοπτα μέσα στο Στέκι, οπότε δε θέλω να δημιουργούνται εντυπώσεις ότι λείπει το βήμα απο τους διαφωνούντες.
Απο τη στιγμή όμως που ήμουν συντονιστής σε αυτό το "εκτός πραγματικότητας" διαγώνισμα οφείλω να προστατεύσω τη δουλειά  - που εγώ θεωρώ εξαιρετικά αξιόλογη - των συναδέλφων που ασχολήθηκαν με προσωπικό κόπο και χρόνο, χωρίς κανένα μα κανένα όφελος και χωρίς μαρκίζες με τα ονόματά τους, απο τις ταμπέλες που αποδίδονται όπως επιδειξίες γνώσεων και αντιπαιδαγωγοί.

Είναι εύκολο να χαρακτηρίζεις αλλά δύσκολο να κρατάς χαρακτήρα ... Λυπάμαι.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: merlin στις 02 Μάι 2011, 07:46:15 μμ
Συνάδελφοι θα ήθελα να τοποθετηθώ και εγώ πάνω στα ζητήματα που έχουν δημιουργηθεί.

Αρχικά, με στεναχωρεί που ξεκινά μια αντιπαράθεση και ένας μικρός "πόλεμος" μεταξύ μας με αφορμή ένα διαγώνισμα που έφτιαξαν με προσωπική δουλειά εξαίρετοι συνάδελφοι (όπως σημειώθηκε, χωρίς προσωπικό όφελος).

Πριν κάποιος παρατηρήσει ότι ήμουν στην ομάδα διαγωνισμάτων και στη συνέχεια βγήκα από αυτήν, θέλω να σημειώσω ότι λόγω προσωπικών προβλημάτων δεν μπορούσα να συμμετέχω ενεργά (δεν παρέδωσα ούτε θέμα, ούτε καν σχολίασα), γι' αυτό το λόγο (και μόνο γι΄αυτόν) θεώρησα ότι δε μου αξίζει να φέρω τον τίτλο "μέλος της ομάδας διαγωνισμάτων", τουλάχιστον φέτος.

Μιας και ήμουν όμως μέλος, παρατήρησα κάποια πράγματα που μου άρεσαν πολύ:
1) Υπήρξε απόλυτη ισονομία και όλα έγιναν με δημοκρατικές διαδικασίες
2) Η δουλειά που έπρεπε να γίνει ήταν πολύ δύσκολη και απαιτητική (κάποιοι συνάδελφοι κουράστηκαν πολύ και διέθεσαν πάρα πολύ χρόνο)
3) Το διαγώνισμα, για να φτάσει στη φάση της δημοσίευσης πέρασε από σαράντα κύματα, φυσικά μπορεί να βρεθούν και ατέλειες, αλλά είναι όλα ανθρώπινα.

Θα ήθελα λοιπόν να παρακαλέσω όλους τους συναδέλφους, να δείξουν εκτίμηση για το χρόνο που διατέθηκε, παραθέτοντας μόνο καλοπροαίρετες κριτικές. Προσοχή, όχι πάντα θετικές, απλά καλοπροαίρετες. Θα συνεχίσω σε επόμενο ποστ την κριτική για το διαγώνισμα.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: thanassis33 στις 02 Μάι 2011, 09:23:58 μμ
Κάτι γενικό:
Νομίζω ότι με την δημοσιοποιήση των θεμάτων πρέπει να γίνεται και αντίστοιχη εμφάνιση των ενδεικτικών λύσεων.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: lykos στις 02 Μάι 2011, 09:34:21 μμ
Εγώ ευχαριστώ - ξανά - τους Συνάδελφους που αφιέρωσαν χρόνο για να μας προσφέρουν το Διαγώνισμα.
Τώρα για το "αν είναι δύσκολο" ή "λύνεται ή όχι σε 3 ώρες":
- Το διαγώνισμα - απ' ό, τι κατάλαβα. Και εγκρίνω - δεν προσπαθεί ούτε να μαντέψει "τι θα πέσει" ούτε να προσομοιώσει το βαθμό δυσκολίας των πανελληνίων.
- Οι Μαθητές που θα λύσουν τις ασκήσεις ενός τέτοιου διαγωνίσματος έστω και σε 5 ώρες, θα γράψουν 20 (άντε 19). Οι υπόλοιποι ας προσπαθήσουν, ας λύσουν τα ευκολότερα θέματά του.
- Όσοι Μαθητές το κατέβασαν μόνοι τους έχουν καταλάβει τη φιλοσοφία του διαγωνίσματος. Για τους υπόλοιπους, υπεύθυνοι για να τους εξηγήσουμε σχετικά, είμαστε εμείς.
Ας μην κοιτάμε τα δόντια του χαρισμένου γάιδαρου...

Παράθεση
Νομίζω ότι με την δημοσιοποιήση των θεμάτων πρέπει να γίνεται και αντίστοιχη εμφάνιση των ενδεικτικών λύσεων.
Γιατί??

Βασίλης Λυκοστράτης
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: merlin στις 02 Μάι 2011, 09:42:58 μμ
Λίγα λόγια για το διαγώνισμα:
Το Α1 δε νομίζω ότι θα δημιουργήσει μεγάλο πρόβλημα διότι η εκφώνηση δίνει έτοιμες τις εντολές (που σημαίνει ότι είναι σωστές συντακτικά) και απλά ο μαθητής πρέπει να σκεφτεί τι συμβαίνει, ακόμα και αν δεν την έχει ξαναδεί. Σε περίπτωση που η ερώτηση ήταν:
Είναι σωστή ή λάθος η εντολή
χ <-  α < β,
τότε πιστεύω ότι θα είχαμε τρομερά ποσοστά αποτυχίας.

Το Α2 μου άρεσε σαν ιδέα (αρχική ανάλυση του προβλήματος).
Το Α4α μου άρεσε επίσης, πολύ πρωτότυπο, απαιτεί λογική σκέψη διαφορετική από τα συνηθισμένα. Θα προτιμούσα όμως να δω γραμμένη και τη σκέψη που έκανε ο μαθητής για να βγάλει το κάθε υποερώτημα.

Στο Β2 μου αρέσουν οι ερωτήσεις για το Τ και τη λειτουργία του αλγορίθμου. Πρέπει ο μαθητής να είναι σε θέση να διαπιστώνει τι ακριβώς ρόλο παίζει η κάθε μεταβλητή, αλλά και γενικότερα το σκοπό ενός αλγορίθμου.

Στο Γ θέμα "όλα τα λεφτά" είναι το γεγονός ότι η διαδικασία των πέναλτι σταματάει αιφνιδίως ( ακόμα και πριν τα 5) και όχι μετά από προκαθορισμένο αριθμό εκτελέσεων. Πιστεύω ότι θα δυσκολέψει πολύ τους μαθητές.

Το Δ θέμα είναι "κλασσικό στεκιού" που πρέπει να ιδρώσεις για να βγάλεις 2-3 μοναδούλες σε κάθε υποερώτημα. Ένας μέτριος μαθητής, ψύχραιμος, χωρίς πανικό, θα μπορούσε να βγάλει τα πρώτα ερωτήματα, όμως μόνο οι άριστοι νομίζω ότι θα το βγάλουν όλο σωστό. Φυσικά, αυτό είναι και το ζητούμενο.

Μια γενική διαπίστωση:
Νομίζω ότι είμαστε πολύ μακριά από το να πέσει τέτοιο διαγώνισμα στις πανελλήνιες (κάθε ένα θέμα ξεχωριστά ναι, αλλά όχι όλο μαζί), νομίζω όμως ότι ο στόχος του διαγωνίσματος του στεκιού είναι να προετοιμάσει τους μαθητές σε ενδεχόμενα απαιτητικά θέματα ΚΑΘΕ κατηγορίας (είτε θέμα Α είτε Δ). Δεν είχε λοιπόν νόημα να μπει ένα "εύκολο Α ή Β Θέμα" για να ρεφάρουμε για το Γ και το Δ.

Ας γνωρίζουν οι μαθητές που θα το κατεβάσουν και θα το λύσουν ότι αν τα καταφέρουν σε αυτό, τότε οι πανελλήνιες θα τους φανούν παιχνιδάκι. Αν πάλι δεν τα καταφέρουν, δε σημαίνει ότι δε θα γράψουν καλά στο τέλος. 
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Παναγιώτης Τσιωτάκης στις 02 Μάι 2011, 09:43:51 μμ
παίδες, η προσωπική μου ενασχόληση πλέον με την ΑΕΠΠ είναι ελάχιστη τείνοντας προς το μηδέν  (δόξα το Μεγαλοδύναμο).
το διαγώνισμα το εκτύπωσα, αλλά δεν το έχω δεί, ίσως αν είχα δουλέψει για αυτό να ήμουν πιο ευαίσθητος... ΩΣΤΟΣΟ

τους τελευταίους -πολλούς- μήνες στο στέκι υπάρχει μονίμως ηλεκτρισμός, μια σπίθα αρκεί να ξεκινήσει καυγά και υπάρχουν πολλές παρεξηγήσεις, πιθανώς να μειώνεται η διάθεση αποδοχής της διαφορετικής διάθεσης, αν δούμε μια λέξη που δε μας αρέσει.

Η απάντηση στην κριτική θα μπορούσε να είναι:
- πες και ένα ευχαριστώ πρώτα βρε αδερφέ
- αν δε θες μην το χρησιμοποιήσεις
- κόψε κάποια θέματα και κράτα άλλα
- το διαγώνισμα έχει άλλη φιλοσοφία και όχι τελικού επαναληπτικού 3 εβδομάδες πριν την έναρξη των εξετάσεων
- αν κρίνεις αντιπαιδαγωγικό να βάλεις τελευταία στιγμή ένα διαγώνισμα που θα καταρρακώσει την ψυχολογία των μαθητών σου, χρησιμοποίησέ το ως ασκήσεις ή κάντο την επόμενη χρονιά στο μέσο της προετοιμασίας.

και βέβαια υπάρχουν και άλλα που θα μπορούσαν να ειπωθούν.

Ταμπέλες του στυλ κακοπροαίρετος και άλλες σχετικές χαρακτηρίζουν εξ αρχής την αντίθετη άποψη στη συζήτηση και την εμποδίζουν να αναπτυχθεί....και σε χρήστες που έχουν μετριοπαθές προφίλ στο στέκι όπως ο συνάδελφος. Σε πραγματικά προκλητικά μηνύματα στο παρελθόν δε θυμάμαι τα ίδια αντανακλαστικά.

Εν κατακλείδι, θεωρώ πως η συνεχής εσωστρέφεια δεν ταιριάζει στην κοινότητα. Αν είναι ζητούμενο η συμμετοχή και πέρα από "το σχέδιο για το νέο λύκειο" πρέπει να το ξαναδούμε. Κατά τα άλλα δεν κομίζω δάφνες αλάθητου.

Καλή συνέχεια.... ΠΤ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: pfan στις 02 Μάι 2011, 10:23:42 μμ
Νομίζω ότι ξέρετε την παροιμία έξω από το χορό πολλά τραγούδια λες… Έτσι και εγώ με καλοπροαίρετη διάθεση και χιούμορ θα ασκήσω κριτική σε κάτι για το οποίο το πήρα χωρίς να κοπιάσω καθόλου.
Τα θέματα είναι ωραία, είναι έξυπνα, είναι διαφορετικά αλλά δεν είναι για όλους τους μαθητές και πολύ φοβάμαι ότι είναι για λίγους.

Τώρα θα μου πει κάποιος εσύ δεν είσαι υποχρεωμένη να τα δώσεις σε κανένα μαθητή… όμως έχω δώσει στους μαθητές μου τη διεύθυνση του site και κάποιοι από αυτούς αλλά και άλλοι μαθητές και συνάδελφοι το διαβάζουν και σωστά κάνουν!!
Έτσι θα έλεγα ότι υπάρχει κάποια ευθύνη να δημοσιοποιείς ένα διαγώνισμα σε περίοδο κοντινή στις εξετάσεις. Το να είναι διάσπαρτες ασκήσεις, εύκολες-δύσκολες δεν έχει σημασία, είναι πιο ανώδυνο για το μαθητή. Το να το δώσεις σε άλλο χρόνο επίσης είναι πιο «εύπεπτο». Δεν έχει όμως πια σημασία, τουλάχιστο για φέτος, να μιλάω για το χρόνο παράδοσης του διαγωνίσματος.

Όμως πριν κλείσω θέλω να θυμίσω ότι πέρυσι την ημέρα των εξετάσεων βρέθηκαν ένα σωρό καινούργια μέλη να μιλάνε για τα θέματα των πανελληνίων. Άραγε φέτος πόσα καινούργια μέλη θα έχει το στέκι τις μέρες αυτές;;; Ελπίζω να έχουμε γίνει σοφότεροι από πέρυσι και να μην επαναλάβουμε τα ίδια λάθη, να κρατήσουμε ψυχραιμία και ηρεμία ώστε να μπορέσουμε να βοηθήσουμε τους μαθητές μας. 
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 02 Μάι 2011, 10:29:00 μμ
(πολύ λάμπα, ρε παιδιά...  ;D)

Πολύ λάμπα καμένη... άντε μπας και δούμε λίγο φως στο τούνελ!  ;D
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: sstergou στις 02 Μάι 2011, 10:47:34 μμ
Παιδιά παραθέτω μια ενδεικτική λύση για το 3ο θέμα, μόνο που το έγραψα σε Γλώσσα για να το τρέξω κιόλας!
Παρατηρήσεις, διορθώσεις, βελτιώσεις (που σιγουρα θα υπάρχουν) στη διάθεσή σας.

Το πρόγραμμα δεν τερματίζει πρόωρα σε κάποιες περιπτώσεις (όταν μετά από εύστοχο πέναλτι της πρώτης ομάδας δεν χρειάζεται να ρίξει η δεύτερη).
π.χ. όταν το σκορ είναι 3-1 και εκτελεί η πρώτη και το βάζει.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: jgalano στις 02 Μάι 2011, 10:52:39 μμ
Φέτος για διάφορους λόγους δε συμμετείχα(θα το ήθελα πολύ) στην ομάδα διαγωνισμάτων αλλά ομολογώ ότι το διαγώνισμα σε γενικές γραμμές ήταν πολύ απαιτητικό αλλά αρκετά καλό. (Στο Β θέμα μόνο λίγο μεγάλος ο πίνακας τιμών).
Κατά τ' αλλα νομίζω (χωρίς να γνωρίζω σίγουρα) ότι το φόρτωμα του διαγωνίσματος είναι αποτέλεσμα πολλών καλών ιδεών που είχαν φέτος οι θεματοδότες και προσπάθησαν να τις στριμώξουν σ'ένα διαγώνισμα)
Ίσως να φτιαχνόταν και ένα 2ο διαγώνισμα μαζί με πρόσθετες ιδέες.
Απο την άλλη πιστεύω ότι έγιναν προσπάθειες να δωθούν φρέσκιες και προτότυπες ιδέες σε όσους συναδέλφους παρακολουθούν το στέκι και χρησιμοποιούν κάποιες από αυτές στη δουλειά τους.
Το μόνο που με στενοχωρεί και δεν κατανοώ είναι κάποια πικρά σχόλια από κάποιους και ταυτόχρονα κάποιες ακόμα πιο σκληρές απαντήσεις.
Πιστέυω πως πρέπει να πέσουν οι τόνοι για το καλό της κοινότητας του στεκιού.
Η κοινότητα πρέπει να είναι ανοιχτή σε όλο και περισσότερους συναδέλφους με καλή δίαθεση και όχι να γίνει prive club για λίγους.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 02 Μάι 2011, 11:00:31 μμ
...
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    μεγ_πλ <- συν_καμ(κατ, ι, πλ[ι])
    ΓΡΑΨΕ 'Οι περισσότεροι συνεχόμενοι καμένοι στην ', ι, 'η στοά είναι:', μεγ_πλ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...

Δες πάλι τι ζητάει το Δ5 ερώτημα...!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: sstergou στις 02 Μάι 2011, 11:03:18 μμ
Με τη σειρά μου κι εγώ δυο λόγια για το διαγώνισμα.
1) Το διαγώνισμα ήταν αρκετά πρωτότυπο (ειδικά τα πρώτα 2 θέματα).
2) Το επίπεδο δυσκολίας ήταν αρκετά ανεβασμένο ειδικά στα τελευταία ερωτήματα του δεύτερου θέματος και στο τρίτο.
3) Κατά την γνώμη μου 3 ώρες ήταν λίγες για όλα αυτά τα ζητούμενα.

Νομίζω ότι η συγκεκριμένη δοκιμασία δεν είναι καλή προσομοίωση των πανελληνίων όχι τόσο για την δυσκολία των θεμάτων αλλά κυρίως για την ποσότητά τους. Το έδωσα αυτούσιο μόνο σε καλούς μαθητές προειδοποιώντας τους όμως για όλα τα παραπάνω. Ο σκοπός μου ήταν να τους δώσω κάτι δυνατό προκειμένου να είναι προετοιμασμένοι για εξαιρετικά δύσκολα θέματα στις εξετάσεις. Νομίζω ότι αυτός ο σκοπός επιτεύχθηκε και με το παραπάνω.

Όλα τα θέματα ήθελαν σκέψη και έμπνευση κάτι που μου άρεσε ιδιαίτερα.

Βέβαια για λόγους ψυχολογίας έδωσα ακόμη ένα διαγώνισμα με παλιά θέματα πανελλαδικών.  :angel:
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Katsadouros_Dhm στις 02 Μάι 2011, 11:06:06 μμ
Δες πάλι τι ζητάει το Δ5 ερώτημα...!
Έχεις δίκιο. Έλυσα παραλλαγή του υποερωτήματος... Βρήκα για κάθε στοά το μεγαλύτερο πληθος συνεχόμενων καμένων λαμπτήρων :D
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Katsadouros_Dhm στις 02 Μάι 2011, 11:11:32 μμ
Το πρόγραμμα δεν τερματίζει πρόωρα σε κάποιες περιπτώσεις (όταν μετά από εύστοχο πέναλτι της πρώτης ομάδας δεν χρειάζεται να ρίξει η δεύτερη).
π.χ. όταν το σκορ είναι 3-1 και εκτελεί η πρώτη και το βάζει.
Έχεις δίκιο. Είπαμε θέλουν και οι δύο λύσεις βελτίωση-διόρθωση. Στο ένα τρώμε γκολ και στο άλλο μας καίγονται οι λάμπες :'(
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: ggfiogos στις 02 Μάι 2011, 11:21:50 μμ
Δεν ξέρω σε ποιους αναφέρεστε ως κακοπροαίρετους και δεν θα ήθελα να απαντήσω σε αυτό. Άλλωστε στη δική μου απάντηση ευχαρίστησα.
Η ερώτηση που κάνω προς όλους τους συναδέλφους που τυχαίνει να διδάσκουν το μάθημα φέτος είναι: Μπορεί ένας μαθητής στα πλαίσια και μόνο του σχολικού δίωρου να ανταπεξέλθει σε ένα τέτοιο διαγώνισμα;  Πόσες ασκήσεις εντός σχολικού ωραρίου πάνω στους πίνακες μπορέσατε να λύσετε εκτός από τις τυποποιημένες;

Όταν δημοσιεύετε ένα προϊόν εργασίας να είστε έτοιμοι να δεχθείτε και τις όποιες κριτικές. Άλλωστε, για αυτό δεν υπάρχει το φόρουμ;
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 02 Μάι 2011, 11:38:40 μμ
ΟΚ συνάδελφοι...! Πιθανώς να ήταν μια ατυχής στιγμή... Ας μην το συνεχίζουμε άλλο... και ας εστιάσουμε στη ουσία...
Όλες οι κριτικές είναι καλοδεχούμενες...
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Laertis στις 03 Μάι 2011, 12:06:08 πμ
Όλες οι κριτικές είναι καλοδεχούμενες αρκεί να μην περιέχουν χαρκτηρισμούς και πικρόχολα σχόλια. Μου αρκεί ένα δε μ'αρέσει ή το βρίσκω υπερβολικα μεγάλο ή ότιδήποτε άλλο , αλλά δε μπορώ να δεχτώ οτι είμαι επιδειξιομανής, αντιπαιδαγωγικός και εκτός πραγματικότητας. Είναι προσβλητικό για μένα.

Ευχαριστώ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: kwtakis στις 03 Μάι 2011, 10:20:54 πμ
Παράθεση
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΑΝ ποσ_καμ[ι] = μεγ_ποσ_καμ ΤΟΤΕ
      ΓΡΑΨΕ 'Στην ', ι, 'η στοά έχουμε μέγιστο ποσοστό καμένων λαμπτήρων'
      ΓΡΑΨΕ μεγ_ποσ_καμ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ποσ_καμ[ι] = 100 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ', ι, 'η στοά δεν έχει καθόλου φωτισμό'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Στο Δ4 πρέπει να προσθέσουμε και μια λογική μεταβλητή στον έλεγχο... μετά να ελέγξουμε την τιμή της ώστε να εμφανίσουμε μήνυμα αν δεν υπάρχουν στοές με καθόλου φωτισμό...
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 03 Μάι 2011, 12:10:18 μμ
Αυτό που λες το κάνει παρακάτω.
Δες τη μεταβλητή Υπάρχουν_στοές_χωρίς_φως
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: JR στις 03 Μάι 2011, 01:30:46 μμ
ΣΥΝΑΡΤΗΣΗ συν_καμ(κατ_1, ι1, πλθ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: κατ_1[50, 50], ι1, πλθ, ξ, κ, μεγ
ΑΡΧΗ
  μεγ <- 0
  κ <- 0
  ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ πλθ
    ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      κ <- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  συν_καμ <- μεγ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Άσκοπος έλενχος για το μέγιστο κάθε φορά.

ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
ΑΛΛΙΩΣ
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
       κ <- 0
ΤΕΛΟΣ_ΑΝ

έτσι θα γίνεται έλενχος μόνο όταν παύει το 'σερί'. φιλικά

Όσο για το διαγώνισμα το πρώτο θέμα ήταν απίστευτο!, παραγματικά πολύ όμορφο. όλα τα λεφτά!
Τα υπόλοιπα ήταν κλασσικά.

Χωρίς παρεξήση θα ήθελα να ρωτήσω 'Γιατί τέτοιο όνομα στην συνάρτηση στο τέταρτο θέμα?' χαχα  :angel:


Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: sstergou στις 03 Μάι 2011, 01:37:33 μμ
Άσκοπος έλενχος για το μέγιστο κάθε φορά.

ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
ΑΛΛΙΩΣ
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
       κ <- 0
ΤΕΛΟΣ_ΑΝ


Τώρα γίνεται άσκοπος έλεγχος σε κάθε σερί με άσσους και όχι μηδενικά. Ακόμη όταν το μέγιστο συνεχόμενων μηδενικών είναι στο τέλος της στοάς τότε δεν το συγκρίνουμε με το ήδη υπολογισμένο μέγιστο οπότε χρειάζεται να μπει άλλη μία αν στο τέλος που να το κάνει αυτό.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 03 Μάι 2011, 01:44:20 μμ
Πολύ καλή παρατήρηση αλλά τι θα γίνει όταν το σερί δεν παύει? ;)
Σε αυτή την περίπτωση αν το τελευταίο σερί είναι και το μεγαλύτερο θα υπάρξει πρόβλημα
Σε αυτό που προτείνεις μου φαίνεται ότι χρειάζεται ένας ακόμα ελέγχος έξω από την επανάληψη μήπως το τελευταίο σερί είναι το μεγαλύτερο

Άσκοπος έλενχος για το μέγιστο κάθε φορά.

ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
ΑΛΛΙΩΣ
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
       κ <- 0
ΤΕΛΟΣ_ΑΝ

έτσι θα γίνεται έλενχος μόνο όταν παύει το 'σερί'. φιλικά

Όσο για το διαγώνισμα το πρώτο θέμα ήταν απίστευτο!, παραγματικά πολύ όμορφο. όλα τα λεφτά!
Τα υπόλοιπα ήταν κλασσικά.

Χωρίς παρεξήση θα ήθελα να ρωτήσω 'Γιατί τέτοιο όνομα στην συνάρτηση στο τέταρτο θέμα?' χαχα  :angel:

edit: Στάθη με πρόλαβες
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: andreas_p στις 03 Μάι 2011, 01:53:09 μμ
Η  ΣΥΝΑΡΤΗΣΗ ΣΤΟ   Δ6.

! Δ6 μον 5
ΣΥΝΑΡΤΗΣΗ Συνεχόμενοι(ΚΑ, στοά, λα): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΑ[5, 5], στοά, λα, j, π, αλ, μεγ
ΑΡΧΗ
  αλ <- 0                                              ! αλλαγές
  ΑΝ ΚΑ[στοά, 1] = 1 ΤΟΤΕ
    π <- 0
  ΑΛΛΙΩΣ
    π <- 1         !  η 1η λάμπα καμένη                         
  ΤΕΛΟΣ_ΑΝ
 
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ λα - 1
! 1η περίπτωση  00000 μετράω ...
    ΑΝ ΚΑ[στοά, j] = ΚΑ[στοά, j + 1] ΚΑΙ ΚΑ[στοά, j] = 0 ΤΟΤΕ
      π <- π + 1
! 2η 10 ή 01  συγκρίνω και π <- 1
    ΑΛΛΙΩΣ_ΑΝ ΟΧΙ(ΚΑ[στοά, j] = 1 ΚΑΙ ΚΑ[στοά, j + 1] = 1) ΤΟΤΕ
      αλ <- αλ + 1
      ΑΝ αλ = 1 ΤΟΤΕ
        μεγ <- π
      ΑΛΛΙΩΣ
        ΑΝ π > μεγ ΤΟΤΕ
          μεγ <- π
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
      π <- 1
! 3η 111111  τίποτα ...
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ π <> 0 ΤΟΤΕ
    ΑΝ π > μεγ ΤΟΤΕ
      μεγ <- π
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    μεγ <- 0
  ΤΕΛΟΣ_ΑΝ
  Συνεχόμενοι <- μεγ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΑΠ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 03 Μάι 2011, 02:03:06 μμ
Εξαιρετική παρατήρηση στάθη, στην αρχή δεν το κατάλαβα, αλλά ενώ εκ πρώτης όψεως ο τρόπος που προτείνει ο JR φαίνεται πιο αποδοτικός, ουσιαστικά έχει ακριβώς την ίδια πολυπλοκότητα και στη χειρότερη περίπτωση αλλά ακόμα και στη μέση!!!
Εκτός φυσικά αν θεωρήσουμε ότι οι καμμένοι λαμπτήρες είναι η μειοψηφία

Τώρα γίνεται άσκοπος έλεγχος κάθε σε σερί με άσσους και όχι μηδενικά.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: sstergou στις 03 Μάι 2011, 02:16:38 μμ
Ναι, αρχικά κι εγώ είχα λύσει το θέμα χρησιμοποιώντας τον τρόπο του JR αλλά μόλις είδα την λύση με την σύγκριση σε κάθε μηδενικό κατάλαβα ότι δεν κερδίζουμε και τίποτε παραπάνω... Άσε που γλιτώνεις και την Αν στο τέλος
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: gpapargi στις 03 Μάι 2011, 02:34:12 μμ
Μπορείς και να μαρκάρεις την αρχή [1,0] και το τέλος [0,1] της ακολουθίας μηδενικών και να κάνεις την πράξη.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: JR στις 03 Μάι 2011, 02:51:15 μμ
Πολύ καλή παρατήρηση αλλά τι θα γίνει όταν το σερί δεν παύει? ;)
Σε αυτή την περίπτωση αν το τελευταίο σερί είναι και το μεγαλύτερο θα υπάρξει πρόβλημα
Σε αυτό που προτείνεις μου φαίνεται ότι χρειάζεται ένας ακόμα ελέγχος έξω από την επανάληψη μήπως το τελευταίο σερί είναι το μεγαλύτερο

ουπς το ξέχασα
ναι με έναν έλενχο στο τέλος έξω από την επανάληψη διορθώνεται  :)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Katsadouros_Dhm στις 03 Μάι 2011, 03:31:36 μμ
Παιδιά, η λύση του 3ου θέματος που είχα γράψει χθες θέλει αρκετές αλλαγές, γιατί θεώρησα ότι οι ομάδες ρίχνουν κατά ζεύγη ακόμα και αν είναι άσκοπο, ενώ η άσκηση ζητάει κάθε πέναλτι κάθε ομάδας να λαμβάνεται υπόψη ξεχωριστά. ( Εϊναι αλήθεια ότι είδα τα θέματα γρήγορα, βιαστικά, τώρα κατάλαβα ότι η ομάδα στο στέκι δεν αστειεύεται...)
Φιλικά, Κατσαδούρος Δημήτρης
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: andreas_p στις 03 Μάι 2011, 04:25:08 μμ
ΣΤΕΚΙ 2011 - ΘΕΜΑ Γ.

Η λύση. (μάλλον ... μία λύση)

ΠΡΟΓΡΑΜΜΑ Στέκι_2011_Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ονΑ, ονΒ, απ, απΑ, απΒ
  ΑΚΕΡΑΙΕΣ: π, πΑ, πΒ, γκΑ, γκΒ, υΑ, υΒ
  ΛΟΓΙΚΕΣ: τΑ, τΒ
ΑΡΧΗ
! Α' φάση
  π <- 0                               ! τα (το πολύ) 10 πέναλτι
  πΑ <- 0                                 ! τα πέναλτι της ομ. Α
  πΒ <- 0                                 ! τα πέναλτι της ομ. Β
  γκΑ <- 0                                   ! τα γκολ της ομ. Α
  γκΒ <- 0                                   ! τα γκολ της ομ. Β
  υΑ <- 5                       ! υπόλοιπο των πέναλτι της ομ. Α
  υΒ <- 5                       ! υπόλοιπο των πέναλτι της ομ. Β
  ΓΡΑΨΕ 'Δώσε τα ονόμ. των 2 ομάδων : '
  ΔΙΑΒΑΣΕ ονΑ, ονΒ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    π <- π + 1
    ΑΝ π MOD 2 = 1 ΤΟΤΕ
      ΓΡΑΨΕ 'Ομάδα ', ονΑ
      πΑ <- πΑ + 1
      υΑ <- υΑ - 1
      ΓΡΑΨΕ 'Χτυπάει το ', πΑ, 'ο πέναλτι'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ομάδα ', ονΒ
      πΒ <- πΒ + 1
      υΒ <- υΒ - 1
      ΓΡΑΨΕ 'Χτυπάει το ', πΒ, 'ο πέναλτι'
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Δώσε το αποτέλεσμα (Ε)ύστοχο / (Ά)στοχο : '
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ απ
    ΜΕΧΡΙΣ_ΟΤΟΥ απ = 'Ε' Η απ = 'Α'
    ΑΝ απ = 'Ε' ΤΟΤΕ
      ΑΝ π MOD 2 = 1 ΤΟΤΕ
        γκΑ <- γκΑ + 1
      ΑΛΛΙΩΣ
        γκΒ <- γκΒ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ π = 10 Η (γκΑ - γκΒ) > υΒ Η (γκΒ - γκΑ) > υΑ
! Β' φάση
  ΑΝ γκΑ = γκΒ ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      τΑ <- ΨΕΥΔΗΣ          ! ΔΕΝ το έχει η ομ. Α (το γκολάκι !)
      τΒ <- ΨΕΥΔΗΣ          ! ΔΕΝ το έχει η ομ. Β (το γκολάκι !)
      ΓΡΑΨΕ 'Χτυπάει το (ΕΝΑ) πέναλτι η ομ. ', ονΑ
      ΓΡΑΨΕ 'Δώσε το αποτέλεσμα (Ε)ύστοχο / (Ά)στοχο : '
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ απΑ
      ΜΕΧΡΙΣ_ΟΤΟΥ απΑ = 'Ε' Η απΑ = 'Α'
      ΓΡΑΨΕ 'Χτυπάει το (ΕΝΑ) πέναλτι η ομ. ', ονΒ
      ΓΡΑΨΕ 'Δώσε το αποτέλεσμα (Ε)ύστοχο / (Ά)στοχο : '
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ απΒ
      ΜΕΧΡΙΣ_ΟΤΟΥ απΒ = 'Ε' Η απΒ = 'Α'
      τΑ <- απΑ = 'Ε'
      τΒ <- απΒ = 'Ε'
    ΜΕΧΡΙΣ_ΟΤΟΥ (τΑ = ΑΛΗΘΗΣ ΚΑΙ τΒ = ΨΕΥΔΗΣ) Η (τΑ = ΨΕΥΔΗΣ ΚΑΙ τΒ = ΑΛΗΘΗΣ)
    ΑΝ τΑ ΤΟΤΕ
      ΓΡΑΨΕ ονΑ, '  ΚΥΠΕΛΟΥΧΟΣ 2010 – 11'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ ονΒ, '  ΚΥΠΕΛΟΥΧΟΣ 2010 – 11'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ γκΑ > γκΒ ΤΟΤΕ
      ΓΡΑΨΕ ονΑ, '  ΚΥΠΕΛΟΥΧΟΣ 2010 – 11'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ ονΒ, '  ΚΥΠΕΛΟΥΧΟΣ 2010 – 11'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Α
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Katsadouros_Dhm στις 03 Μάι 2011, 05:44:47 μμ
Θέλω να κοιτάξετε μια ενδεικτική λύση στο 3ο θεμα. (Ξεχάστε την προηγούμενη που έδωσα   ;D)
Χρησιμοποιώ δυο λογικές μεταβλητές για να τερματίσουν τη διαδικασία αν κάποια ομάδα κερδίσει κανονικά ή πρόωρα και δυο μετρητές που μετράνε τις προσπάθειες των ομάδων.

ΠΡΟΓΡΑΜΜΑ θεμα_3_στεκι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: σκορ1, σκορ2, προσπ1, προσπ2
  ΧΑΡΑΚΤΗΡΕΣ: αποτ1, αποτ2, ον1, ον2
  ΛΟΓΙΚΕΣ: φ1, φ2
ΑΡΧΗ
  σκορ1 <- 0
  σκορ2 <- 0
  προσπ1 <- 0
  προσπ2 <- 0
  φ1 <- ΨΕΥΔΗΣ
  φ2 <- ΨΕΥΔΗΣ
  ΓΡΑΨΕ 'Δώστε το όνομα της 1ης ομάδας:'
  ΔΙΑΒΑΣΕ ον1
  ΓΡΑΨΕ 'Δώστε το όνομα της 2ης ομάδας:'
  ΔΙΑΒΑΣΕ ον2
  ΟΣΟ φ1 = ΨΕΥΔΗΣ ΚΑΙ φ2 = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ (Α_Τ(σκορ1 - σκορ2) <= 5 - προσπ1) Η(σκορ1 = σκορ2 ΚΑΙ προσπ1 >= 5) ΤΟΤΕ
      προσπ1 <- προσπ1 + 1
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Δώστε το αποτέλεσμα εκτέλεσης της ', ον1, ' ομάδας:'
        ΔΙΑΒΑΣΕ αποτ1
      ΜΕΧΡΙΣ_ΟΤΟΥ αποτ1 = 'ευστοχο' Η αποτ1 = 'αστοχο'
      ΑΝ αποτ1 = 'ευστοχο' ΤΟΤΕ
        σκορ1 <- σκορ1 + 1
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ 'Η ', ον1, ' έχει εκτελέσει ', προσπ1, ' πεναλτι'
      ΓΡΑΨΕ 'Η ', ον2, ' έχει εκτελέσει ', προσπ2, ' πεναλτι'
      ΓΡΑΨΕ ον1, ':', σκορ1
      ΓΡΑΨΕ ον2, ':', σκορ2
    ΑΛΛΙΩΣ
      φ1 <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ φ1 = ΨΕΥΔΗΣ ΤΟΤΕ
      ΑΝ (Α_Τ(σκορ1 - σκορ2) <= 5 - προσπ2) Η(προσπ2 >= 5) ΤΟΤΕ
        προσπ2 <- προσπ2 + 1
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Δώστε το αποτέλεσμα εκτέλεσης της ', ον2, ' ομάδας:'
          ΔΙΑΒΑΣΕ αποτ2
        ΜΕΧΡΙΣ_ΟΤΟΥ αποτ2 = 'ευστοχο' Η αποτ2 = 'αστοχο'
        ΑΝ αποτ2 = 'ευστοχο' ΤΟΤΕ
          σκορ2 <- σκορ2 + 1
        ΤΕΛΟΣ_ΑΝ
        ΓΡΑΨΕ 'Η ', ον1, ' έχει εκτελέσει ', προσπ1, ' πεναλτι'
        ΓΡΑΨΕ 'Η ', ον2, ' έχει εκτελέσει ', προσπ2, ' πεναλτι'
        ΓΡΑΨΕ ον1, ':', σκορ1
        ΓΡΑΨΕ ον2, ':', σκορ2
      ΑΛΛΙΩΣ
        φ2 <- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ σκορ1 > σκορ2 ΤΟΤΕ
    ΓΡΑΨΕ 'Κυπελλούχος είναι η ', ον1
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Κυπελλούχος είναι η ', ον2
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: ggfiogos στις 03 Μάι 2011, 07:55:44 μμ
Και μια δική μου λύση 3ο Θέμα  που ίσως να θέλει λίγο κοίταγμα παραπάνω στις περιπτώσεις λήξης στα πρώτα 5 πέναλντι!
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΠΕΝΑΛΝΤΙ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΡΟΣΠ, ΣΚΟΡ_Α, ΣΚΟΡ_Β
  ΧΑΡΑΚΤΗΡΕΣ: ΣΟΥΤ, ΟΜ_Α, ΟΜ_Β
  ΛΟΓΙΚΕΣ: ΣΟΥΤ_Α, ΕΛΗΞΕ

ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑΤΑ ΟΜΑΔΩΝ'
  ΔΙΑΒΑΣΕ ΟΜ_Α, ΟΜ_Β
  ΣΟΥΤ_Α <- ΑΛΗΘΗΣ
  ΣΚΟΡ_Α <- 0
  ΣΚΟΡ_Β <- 0

  ΠΡΟΣΠ <- 1
  ΕΛΗΞΕ <- ΨΕΥΔΗΣ
 
  ΟΣΟ ΠΡΟΣΠ <= 10 ΚΑΙ ΕΛΗΞΕ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΣΟΥΤ_Α = ΑΛΗΘΗΣ ΤΟΤΕ
      ΓΡΑΨΕ 'Εκτελεί πέναλτι η ομάδα:', ΟΜ_Α
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΣΟΥΤ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΣΟΥΤ = 'Ε' Η ΣΟΥΤ = 'Α'

      ΑΝ ΣΟΥΤ = 'Ε' ΤΟΤΕ
        ΣΚΟΡ_Α <- ΣΚΟΡ_Α + 1
      ΤΕΛΟΣ_ΑΝ
      ΣΟΥΤ_Α <- ΨΕΥΔΗΣ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Εκτελεί πέναλτι η ομάδα:', ΟΜ_Β
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΣΟΥΤ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΣΟΥΤ = 'Ε' Η ΣΟΥΤ = 'Α'

      ΑΝ ΣΟΥΤ = 'Ε' ΤΟΤΕ
        ΣΚΟΡ_Β <- ΣΚΟΡ_Β + 1
      ΤΕΛΟΣ_ΑΝ
      ΣΟΥΤ_Α <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ΣΚΟΡ_Α, ΣΚΟΡ_Β
   
    ! ΤΡΟΠΟΙ ΛΗΞΗΣ
    ΑΝ Α_Τ(ΣΚΟΡ_Α - ΣΚΟΡ_Β) = 3 ΚΑΙ ΠΡΟΣΠ > 5 ΤΟΤΕ
      ΕΛΗΞΕ <- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ_ΑΝ Α_Τ(ΣΚΟΡ_Α - ΣΚΟΡ_Β) = 2 ΚΑΙ ΠΡΟΣΠ >= 8 ΤΟΤΕ
      ΕΛΗΞΕ <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
   
    ΠΡΟΣΠ <- ΠΡΟΣΠ + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΑΝ ΕΛΗΞΕ = ΨΕΥΔΗΣ ΤΟΤΕ
     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Εκτελεί πέναλτι η ομάδα:', ΟΜ_Α
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
           ΔΙΑΒΑΣΕ ΣΟΥΤ
        ΜΕΧΡΙΣ_ΟΤΟΥ ΣΟΥΤ = 'Ε' Η ΣΟΥΤ = 'Α'
        ΑΝ ΣΟΥΤ = 'Ε' ΤΟΤΕ
           ΣΚΟΡ_Α <- ΣΚΟΡ_Α + 1
        ΤΕΛΟΣ_ΑΝ
       
        ΓΡΑΨΕ 'Εκτελεί πέναλτι η ομάδα:', ΟΜ_Β
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
           ΔΙΑΒΑΣΕ ΣΟΥΤ
        ΜΕΧΡΙΣ_ΟΤΟΥ ΣΟΥΤ = 'Ε' Η ΣΟΥΤ = 'Α'
        ΑΝ ΣΟΥΤ = 'Ε' ΤΟΤΕ
           ΣΚΟΡ_Β <- ΣΚΟΡ_Β + 1
        ΤΕΛΟΣ_ΑΝ
     ΜΕΧΡΙΣ_ΟΤΟΥ ΣΚΟΡ_Α <> ΣΚΟΡ_Β
  ΤΕΛΟΣ_ΑΝ
 
  ΓΡΑΨΕ 'ΚΥΠΕΛΟΥΧΟΣ 2010 – 11'
  ΑΝ ΣΚΟΡ_Α > ΣΚΟΡ_Β ΤΟΤΕ
    ΓΡΑΨΕ ΟΜ_Α
  ΑΛΛΙΩΣ
     ΓΡΑΨΕ ΟΜ_Β
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: avasilis στις 03 Μάι 2011, 08:14:34 μμ
ΠΑΙΔΙΑ ΕΙΝΑΙ ΠΟΛΥ ΚΑΛΗ Η ΔΟΥΛΕΙΑ ΣΑΣ ΑΛΛΑ ΓΙΑ ΕΜΑΣ ΠΟΥ ΔΕΝ ΕΧΟΥΜΕ ΜΕΓΑΛΗ ΕΜΠΕΙΡΙΑ ΜΠΟΡΟΥΜΕ ΝΑ ΕΟΥΜΕ ΚΑΠΟΙΕΣ ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ;
ΣΑΣ ΕΥΧΑΡΙΣΤΩ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 03 Μάι 2011, 08:46:14 μμ
Οι ενδεικτικές λύσεις θα βγουν σύντομα, λίγο υπομονή και κατανόηση
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: amisail στις 04 Μάι 2011, 01:41:00 πμ
Γεια σας και από μένα.

Σας παρακολουθώ πολύ καιρό αλλά τώρα μόλις γράφτηκα με αφορμή το νέο διαγώνισμα και τις λύσεις που θα ήθελα να δώσω.
Μου άρεσε πολύ η δουλειά που έγινε και τα 2 πρώτα θέματα είναι δύσκολα - προτότυπα και προκαλούν να τα λύσεις.
Το Γ είναι το κλασσικά δύσκολο θέμα με τον τερματισμό της διαδικασίας και το Δ πληθωρικό και δύσκολο.
Πιστεύω πως το Α-Β θα μπορούσαν να πέσουν και φέτος αλλά από Γ-Δ δε νομίζω πως λύνονται σε δίωρο...
Οπότε όποιος λύσει τη θεωρία είναι έτοιμος για καλά θέματα ενώ αν λύσει τις ασκήσεις είναι πολύ δυνατός και έτοιμος για όλα...



Παραθέτω τις λύσεις τις θεωρίας (περιμένοντας τις ενδεικτικές) γιατί ήθελα να τις δω από κάποιους για να τις συγκρίνω οπότε ας κάνω την αρχή...

Κώδικας: [Επιλογή]
Θέμα  Α
============
Α1.
1. Σ. Οι μόνες απαντήσεις που μπορεί να έχουν οι συγκριτικοί τελεστές είναι Αληθής ή Ψευδής άρα πρέπει να είναι λογική μεταβλητή.
2. Σ. Και οι χαρακτήρες μπορούν να συγκριθούν με >, < ή =.
3. Λ. Οι λογικές μεταβλητές συγκρίνονται μόνο με = ή <>.
4. Σ. Προκύπτει από το 1 και 3 ότι δεν γίνεται να είναι ίδιου τύπου.
5. Λ. Δεν είναι απαραίτητο και αφού λέει πρέπει είναι λάθος.

Α2.
1. Δεδομένα: 160 μαθητές, τα ονόματά τους και οι βαθμοί τους.
2. Ζητούμενα: Ο μέσος όρος και η εμφάνιση συγκεκριμένων ονομάτων.
3. Κατηγορία με βάση τη δυνατότητα επίλυσής του: Επιλύσιμο. (είναι υπολογιστικό αν ζητούσε με βάση το είδος επίλυσης).
4. Χρήση πίνακα: Ναι, γιατί πρέπει πρώτα να υπολογίζεται ο μέσος όρος και μετά να εμφανίζονται συγκεκριμένα ονόματα που θα πρέπει να έχουν κρατηθεί σε πίνακα.

Α3.
1. Π[3] <-- Π[3] * 1,3
2. Π[10] <-- Π[10] * 0,5
3. Π[1] <-- Π[1] * 3
4. ΑΝ Π[6] > 0 ΤΟΤΕ
ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
5. ΒΡΕΘΗΚΕ <-- ΟΧΙ (ΒΡΕΘΗΚΕ)
6. i <-- Α_Μ (Π[2])

Α4.
α) Α.  Για Ν=28 --> 32, Για Ν<>28 --> 10.
Β.  Για Ν=31 --> 32, Για Ν=9 --> 10.
Γ.  Για Ν=3 --> (1*2*1 + 2*2*2 + 8*2*3) - 16 = 48 – 16 = 32, Για Ν=2 --> (1*2*1 + 2*2*2) - 16 = 10 – 16 = -6.
Δ.  Για Ν=4 --> (22 + 1 + 2 + 3 + 4) = 32.
Άρα η έξοδος είναι το 32 και οι είσοδοι: Α. 28, Β. 31, Γ. 3, Δ. 4.

β)
1. Α[Χ] <-- Χ
2. Α[ι] <-- ι
3. Όσο Χ <= _8_ επανάλαβε || Α[Χ] <-- Χ
4. Α[Χ-1] <-- Χ-1 || Μέχρις_ότου Χ > 8

Α5.
Θα πρέπει να εμφανιστούν 3 κομμάτια Α, Β και Γ:
Α: Για i από i1 μέχρι i2
Για j από j1 μέχρι j2
Εμφάνισε Π[ i , j ]
Τέλος_επανάληψης
Τέλος_επανάληψης

Β: Για i από i1+1 μέχρι i2
Για j από 1 μέχρι j1-1
Εμφάνισε Π[ i , j ]
Τέλος_επανάληψης
Τέλος_επανάληψης

Γ: Για i από i1 μέχρι i2-1
Για j από j2+1 μέχρι 12
Εμφάνισε Π[ i , j ]
Τέλος_επανάληψης
Τέλος_επανάληψης

Κώδικας: [Επιλογή]
Θέμα  Β
============
Β1.
1. (Θέση1) ΑΚΕΡΑΙΕΣ: x, y, κ
(Θέση2) κ <-- Πράξη ( χ, y)

2. (Θέση3) ΣΥΝΑΡΤΗΣΗ Πράξη (α, β): ΑΚΕΡΑΙΑ
(Θέση4) ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

3. Το πρόγραμμα αυτό υπολογίζει πόσες φορές χωράει το χ στο y ή καλύτερα το αποτέλεσμα της ακέραιας διαίρεσης: y DIV χ.

Β2.
1. τελικές τιμές
δ temp T 10η
9 200 6 10 5 15 50 100 150 200 300 400 400

2.  Στο Τ κρατάμε την τελευταία θέση του πίνακα που έγινε αντιμετάθεση.

3. Είναι ένας αλγόριθμος φυσαλίδας για ταξινόμηση των στοιχείων από τον μικρότερο στον μεγαλύτερο (φυσαλίδα ταξινόμησης αύξουσας σειράς). Το Τα βοηθάει να μη γίνονται περιττές αντιμεταθέσεις.

Αν βρείτε λαθάκια θα εκτιμούσα να μου τα πείτε γιατί σίγουρα θα έχω...  :)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: noname στις 04 Μάι 2011, 02:16:49 πμ
Ένα λαθάκι:

4.   ΑΝ Π[6] > 0 ΤΟΤΕ
   ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
   ΑΛΛΙΩΣ
   ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
   ΤΕΛΟΣ_ΑΝ

Το ζητούμενο ήταν χωρίς τη χρήση δομής επιλογής:
ΒΡΕΘΗΚΕ <-- Π[6] > 0
   
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: amisail στις 04 Μάι 2011, 02:33:03 πμ
Ένα λαθάκι:

Το ζητούμενο ήταν χωρίς τη χρήση δομής επιλογής:
ΒΡΕΘΗΚΕ <-- Π[6] > 0


Βεβαίως.... πως μου ξέφυγε...
ευχαριστώ πολύ για τη διόρθωση
δε θα είναι το μοναδικό... :(
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Γιώργος Κατσαούνος στις 04 Μάι 2011, 11:39:16 πμ
Ένα μεγάλο ευχαριστώ στους συναδέλφους που διέθεσαν πολύτιμο χρόνο και κόπιασαν για την δημιουργία του τελικού επαναληπτικού διαγωνίσματος.  Ο τίτλος του και μόνο χαρακτηρίζει ευδιάκριτα και τον προτεινόμενο τρόπο που θα χρησιμοποιηθεί.  Ο βασικός ρόλος όλων μας ως εκπαιδευτικοί είναι να προσαρμόζουμε τα εργαλεία και το υλικό που διαθέτουμε στις ιδιαίτερες απαιτήσεις των μαθητών - τμημάτων - εξετάσεων και λοιπών παραγόντων, κατά την κρίση μας, προσδοκώντας το βέλτιστο αποτέλεσμα.  Το αν θα το δώσουμε όλο σε ένα καλό μαθητή ή θα το περικόψουμε σε ένα μέτριο, αποτελεί λοιπόν καθαρά δικιά μας επιλογή διαμόρφωσης του υλικού.
Και πάλι ένα ευχαριστώ και ένα μπράβο στους συναδέλφους που κόπιασαν, από ένα συνάδελφο που το βρήκε έτοιμο !
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: noname στις 04 Μάι 2011, 01:10:58 μμ
Μια εναλλακτική λύση για το θέμα 3 χωρίς τον διαχωρισμό των δύο φάσεων των πέναλτι. Λειτουργεί με μία μεγάλη επανάληψη και ο έλεγχος για τον τερματισμό για κάθε φάση γίνεται με ανάλογα ΑΝ. Παρακαλώ αν βρείτε λάθη να τα επισημάνετε.

Κώδικας: [Επιλογή]
Αλγόριθμος Θ3
Διάβασε ΟΜ1, ΟΜ2
Π1 <- 0
Π2 <- 0
ΓΚ1 <- 0
ΓΚ2 <- 0
Ι <- 1
ΕΛΗΞΕ <- ΨΕΥΔΗΣ
Όσο ΕΛΗΞΕ = ΨΕΥΔΗΣ επανάλαβε
Αν Ι mod 2 = 1 τότε
Εμφάνισε "Εκτελεί η ομάδα:", ΟΜ1
Π1 <- Π1+1
αλλιώς
Εμφάνισε "Εκτελεί η ομάδα:", ΟΜ2
Π2 <- Π2+1
Τέλος_αν
Αρχή_επανάληψης
Διάβασε ΑΠ
Μέχρις_ότου ΑΠ="ΕΥΣΤΟΧΟ" Ή ΑΠ="ΑΣΤΟΧΟ"
Αν ΑΠ="ΕΥΣΤΟΧΟ" τότε
Αν Ι mod 2 = 1 τότε
ΓΚ1<-ΓΚ1+1
αλλιώς
ΓΚ2<-ΓΚ2+1
Τέλος_αν
Tέλος_αν
Εμφάνισε ΓΚ1, “-”, ΓΚ2
Αν (Π1<5 Ή Π2<5) τότε
Αν (5-Π1<ΓΚ2-ΓΚ1) τότε
ΕΛΗΞΕ <- ΑΛΗΘΗΣ
Τέλος_αν
Αν (5-Π2<ΓΚ1-ΓΚ2) τότε
ΕΛΗΞΕ <- ΑΛΗΘΗΣ
Τέλος_αν
αλλιώς_αν Π1=Π2 τότε
Αν ΓΚ1 <> ΓΚ2 τότε
ΕΛΗΞΕ <- ΑΛΗΘΗΣ
Τέλος_αν
Τέλος_αν
Ι <- Ι +1
Τέλος_επανάληψης
Αν ΓΚ1 > ΓΚ2 τότε
Εμφάνισε ΟΜ1
αλλιώς
Εμφάνισε ΟΜ2
Τέλος_αν
Τέλος Θ3
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: noname στις 04 Μάι 2011, 02:15:49 μμ
Μια ενδεικτική λύση για το θέμα 4. Παρακαλώ αν εντοπίσετε λάθη να τα επισημάνετε.
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Θ4
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Κ, Λ, Μ, ΛΑΜΠ[50], Σ, ΚΑΤ[50, 50], Σ_ΚΑΜ, ΠΛ, ΚΑΜ[50], ΜΑΧ, ΜΑΧ_ΣΤΟΑΣ, ΘΕΣΗ
ΛΟΓΙΚΕΣ: ΥΠΑΡΧΟΥΝ, ΣΚΟΤΕΙΝΗ
ΑΡΧΗ
! Εισαγωγή δεδομένων στον πίνακα ΛΑΜΠ | Πλήθος λαμπτήρων ανά στοά
Σ <- 0
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 50
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ Μ
ΜΕΧΡΙΣ_ΟΤΟΥ (Μ>=20 ΚΑΙ Μ<=500)
! Υπολογισμός πλήθους λαμπτήρων ανά στοά και αποθήκευση στον πίνακα ΛΑΜΠ
ΛΑΜΠ[Κ]<-Μ DIV 10
! Υπολογισμός συνόλου λαμπτήρων σε όλες τις στοές
Σ <- Σ + ΛΑΜΠ[Κ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘ΣΥΝΟΛΟ ΛΑΜΠΤΗΡΩΝ: ’, Σ
! Εισαγωγή δεδομένων στον πίνακα ΚΑΤ | Κατάσταση λαμπτήρων
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 50
! μέχρι το πλήθος των λαμπτήρων της συγκεκριμένης στοάς Κ | ΛΑΜΠ[Κ]
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ ΛΑΜΠ[Κ]
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΚΑΤ[Κ,Λ]
ΜΕΧΡΙΣ_ΟΤΟΥ (ΚΑΤ[Κ,Λ] =0 Ή ΚΑΤ[Κ,Λ] =1)
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! Υπολογισμός καμένων λαμπτήρων
Σ_ΚΑΜ <- 0
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 50
ΠΛ <- 0
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ ΛΑΜΠ[Κ]
ΑΝ ΚΑΤ[Κ,Λ] = 0 ΤΟΤΕ
ΠΛ <- ΠΛ + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! καμένοι ανά στοά
ΚΑΜ[Κ]<-ΠΛ
! καμένοι συνολικά
Σ_ΚΑΜ <- Σ_ΚΑΜ + ΠΛ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! Δεν υπάρχει περίπτωση το Σ να είναι μηδέν εφόσον όλες οι στοές έχουν τουλάχιστον από 1 λαμπτήρα. Ελάχιστο μήκος στοάς 20 μέτρα.
ΓΡΑΨΕ ‘ΠΟΣΟΣΤΟ ΚΑΜΕΝΩΝ ΛΑΜΠΤΗΡΩΝ ΣΕ ΟΛΟΚΛΗΡΟ ΤΟ ΟΡΥΧΕΙΟ ‘, (Σ_ΚΑΜ/Σ)*100
!------------------------------
!Υπολογισμός μέγιστου ΠΟΣΟΣΤΟΥ καμένων/συνολικών ανά στοά
ΜΑΧ <- ΚΑΜ[1]/ΛΑΜΠ[1]
ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 50
ΑΝ ΚΑΜ[Κ]/ΛΑΜΠ[Κ] > ΜΑΧ ΤΟΤΕ
ΜΑΧ <- ΚΑΤ[Κ]/ΛΑΜΠ[Κ]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! Εμφάνιση όσων είναι ίσα με το μέγιστο | Πιθανή ύπαρξη περισσότερων του ενός
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 50
ΑΝ ΚΑΜ[Κ]/ΛΑΜΠ[Κ] = ΜΑΧ ΤΟΤΕ
ΓΡΑΨΕ Κ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! Η μεταβλητή ΥΠΑΡΧΟΥΝ δηλώνει εάν υπάρχουν σκοτεινές στοές
ΥΠΑΡΧΟΥΝ <- ΨΕΥΔΗΣ
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 50
! Η μεταβλητή ΣΚΟΤΕΙΝΗ δηλώνει αν η συγκεκριμένη στοά είναι σκοτεινή
! Έστω ότι είναι σκοτεινή
ΣΚΟΤΕΙΝΗ <- ΑΛΗΘΗΣ
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ ΛΑΜΠ[Κ]
! Αν βρεις έστω και έναν αναμμένο λαμπτήρα τότε δεν είναι σκοτεινή
ΑΝ ΚΑΤ[Κ,Λ] = 1 ΤΟΤΕ
ΣΚΟΤΕΙΝΗ <- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! Αν η συγκεκριμένη στοά είναι σκοτεινή τότε εμφάνισε τον αριθμό της και
! Η μεταβλητή ΥΠΑΡΧΟΥΝ γίνεται αληθής αφού υπάρχουν σκοτεινές στοές
ΑΝ ΣΚΟΤΕΙΝΗ = ΑΛΗΘΗΣ ΤΟΤΕ
ΓΡΑΨΕ Κ
ΥΠΑΡΧΟΥΝ <- ΑΛΗΘΗΣ
ΤΕΛΟΣ_ΑΝ
!Η επανάληψη συνεχίζεται για τον έλεγχο της επόμενης στοάς
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΥΠΑΡΧΟΥΝ = ΨΕΥΔΗΣ ΤΟΤΕ
ΓΡΑΨΕ ‘ΔΕΝ ΥΠΑΡΧΟΥΝ ΣΚΟΤΕΙΝΕΣ ΣΤΟΕΣ’
ΤΕΛΟΣ_ΑΝ
! Υποερώτημα Δ5
! Υπολογισμός μέγιστου πλήθους συνεχόμενων καμένων λαμπτήρων
ΜΑΧ <- -1
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 50
! Κλήση συνάρτησης
ΜΑΧ_ΣΤΟΑΣ <- ΣΥΝΕΧΟΜΕΝΟΙ_ΚΑΜΕΝΟΙ_ΣΤΟΑΣ(ΚΑΤ, ΛΑΜΠ, Κ)
ΑΝ ΜΑΧ_ΣΤΟΑΣ>ΜΑΧ ΤΟΤΕ
ΜΑΧ <- ΜΑΧ_ΣΤΟΑΣ
ΘΕΣΗ <- Κ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘ΜΕΓΙΣΤΟ ΠΛΗΘΟΣ ΣΥΝΕΧΟΜΕΝΩΝ ΚΑΜΕΝΩΝ ΛΑΜΠΤΗΡΩΝ ’, ΜΑΧ, ‘ ΣΤΗ ΣΤΟΑ ‘, ΘΕΣΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!---------------------------------
ΣΥΝΑΡΤΗΣΗ ΣΥΝΕΧΟΜΕΝΟΙ_ΚΑΜΕΝΟΙ_ΣΤΟΑΣ (ΚΑΤ, ΛΑΜΠ, Κ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΚΑΤ[50, 50], ΛΑΜΠ[50], Κ, Λ, ΜΑΧ, Μ
ΛΟΓΙΚΕΣ: DONE
ΑΡΧΗ
Λ<-1
ΜΑΧ<- -1
! Έλεγξε όλους τους λαμπτήρες της στοάς
ΟΣΟ Λ <= ΛΑΜΠ[Κ] ΕΠΑΝΑΛΑΒΕ
Μ <- 0
DONE <- ΑΛΗΘΗΣ
! Όσο βρίσκεις καμένους, μέτρα τους χωριστά από την αρχική επανάληψη
! Χρησιμοποιώ τη μεταβλητή DONE για να αποφύγω να βγω εκτός πίνακα
ΟΣΟ (Λ <= ΛΑΜΠ[Κ] ΚΑΙ DONE=ΑΛΗΘΗΣ) ΕΠΑΝΑΛΑΒΕ
ΑΝ ΚΑΜ[Κ,Λ]=0 ΤΟΤΕ
Μ <- Μ + 1
Λ <- Λ + 1
ΑΛΛΙΩΣ
DONE <- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Αυτοί που μέτρησες είναι οι περισσότεροι μέχρι στιγμής;
ΑΝ Μ>ΜΑΧ ΤΟΤΕ
ΜΑΧ <- Μ
ΤΕΛΟΣ_ΑΝ
! Προχώρα στον επόμενο
! Ήδη το Λ έχει αυξηθεί και παραπάνω, όσο βρίσκω καμένους
Λ<-Λ+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΣΥΝΕΧΟΜΕΝΟΙ_ΚΑΜΕΝΟΙ_ΣΤΟΑΣ <- ΜΑΧ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 04 Μάι 2011, 02:20:00 μμ
@noname
Έχεις σκεφτεί του χρόνου να μπεις στην ομάδα διαγωνισμάτων? ;)
γιατί βλέπω ότι έχεις όρεξη
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: noname στις 04 Μάι 2011, 02:27:11 μμ
Ευχαρίστως!
 :)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: sstergou στις 04 Μάι 2011, 02:31:48 μμ
Μια ενδεικτική λύση για το θέμα 4. Παρακαλώ αν εντοπίσετε λάθη να τα επισημάνετε.
Κώδικας: [Επιλογή]
ΣΥΝΑΡΤΗΣΗ ΣΥΝΕΧΟΜΕΝΟΙ_ΚΑΜΕΝΟΙ_ΣΤΟΑΣ (ΚΑΤ, ΛΑΜΠ, Κ):ΑΚΕΡΑΙΑ



Μια λεπτομέρεια : η συνάρτηση (που είναι και ωραία σαν λύση) πρέπει να πάρει σαν παράμετρο όχι τον πίνακα ΛΑΜΠ αλλά το τρέχων στοιχείο του.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: noname στις 04 Μάι 2011, 02:43:49 μμ
Μια λεπτομέρεια : η συνάρτηση (που είναι και ωραία σαν λύση) πρέπει να πάρει σαν παράμετρο όχι τον πίνακα ΛΑΜΠ αλλά το τρέχων στοιχείο του.


Έχεις απόλυτο δίκιο! Άλλωστε αναγράφεται ξεκάθαρα στην εκφώνηση: "Να δέχεται ως παραμέτρους... το πλήθος των λαμπτήρων της στοάς...".
Ευχαριστώ για την επισήμανση!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 05 Μάι 2011, 12:22:49 μμ
Στο αρχικό μήνυμα του thread ανέβηκαν οι ενδεικτικές λύσεις του διαγωνίσματος. Σε κάποιες περιπτώσεις κρίναμε ότι ήταν καλό να δοθούν 2 λύσεις.

Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: netnick στις 06 Μάι 2011, 03:02:04 πμ
παιδιά γειά σας.

Θα ήθελα να δώσω λίγο περισσότερη σημασία στο Α5
Μόλις είδα το συγκεκριμένο θέμα θεώρησα ότι η απάντηση με τις πολλές ΓΙΑ δεν θα ήταν η ζητούμενη. Έτσι άμεσα έδωσα την παρακάτω, με χρήση μιας μονο επανάληψης (ΟΣΟ) που την θεωρώ πιο κοντινή απάντηση.
Οκ.

Είναι γραμμένη στο διερμηνευτή για άμεση εκτέλεση και έλεγχο...

ΠΡΟΓΡΑΜΜΑ A5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: π[8, 12], ι, κ, ι1, ι2, κ1, κ2, χ
ΑΡΧΗ

! Αρχικοποίηση του πίνακα ώστε να έχουμε τιμές
! με αίσθηση του τι εκτυπώνουμε ...
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 8
    χ <- 100*ι + 1
    ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 12
      π[ι, κ] <- χ
      χ <- χ + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


! Παραδείγματα εκτέλεσης
  ΚΑΛΕΣΕ Εξοδος(π, 3, 4, 5, 8 )
  ΓΡΑΨΕ
 
  ΚΑΛΕΣΕ Εξοδος(π, 3, 4, 3, 12)
  ΓΡΑΨΕ

  ΚΑΛΕΣΕ Εξοδος(π, 3, 4, 4, 1)
  ΓΡΑΨΕ

!για εκτύπωση όλου του πίνακα λοιπόν με μια επανάληψη
! θα έγραφα: ΚΑΛΕΣΕ Εξοδος(π, 1, 1, 8, 12)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!============= ΟΥΣΙΑΣΤΙΚΗ ΑΠΑΝΤΗΣΗ ================================
ΔΙΑΔΙΚΑΣΙΑ Εξοδος(π, ι1, κ1, ι2, κ2)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: π[8, 12], ι, κ, ι1, κ1, ι2, κ2
ΑΡΧΗ
  ι <- ι1
  κ <- κ1
! όσο βρίσκομαι σε μικρότερη γραμμή Η στην ίδια γραμμή αλλά σε μικρότερη στήλη
  ΟΣΟ ι < ι2 Η (ι = ι2 ΚΑΙ κ <= κ2) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ π[ι, κ]
    κ <- κ + 1          ! επόμενο στοιχείο γραμμής
    ΑΝ κ > 12 ΤΟΤΕ   ! άν όμως βγούμε εκτός τότε
      ι <- ι + 1          ! μεταβαίνουμε στην επόμενη γραμμή.
      κ <- 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 06 Μάι 2011, 08:14:24 πμ
Πολύ σωστά έκανες, απλά στο θέμα αυτό είπαμε να δώσουμε την λύση που θα έδινε πιθανότατα ένας μαθητής. Φυσικά και η Όσο είναι πιθανή αλλά νομίζω ότι η λύση με τις πολλές Για είναι πιθανότερο να δοθεί από έναν μαθητή.
Δηλαδή έχω την εντύπωση ότι ένας καθηγητής θα έδινε την απάντηση με την Όσο αλλά ένας μαθητής την απάντηση με τις πολλές Για

Μια άλλη λύση που παρουσιάζει ιδιαίτερο ενδιαφέρον είναι η παρακάτω την οποία έδωσε ο Άλκης, αλλά δεν την βάλαμε τελικά στις λύσεις. Την παραθέτω (με την άδεια ελπίζω του δημιουργού :police:)

Κατά πάσα πιθανότητα έχω ανάποδα τα i με τα j σε σχέση με την εκφώνηση. :)

Σ' αυτήν, τα +/-1 χρειάζονται επειδή οι πίνακες στην (ψευδο)ΓΛΩΣΣΑ είναι 1-based αντί 0-based, αλλιώς θα ήταν πολύ πιο απλή:
Κώδικας: Text
  1.   ΓΙΑ ι ΑΠΟ (j1 - 1)*Ν + i1 - 1 ΜΕΧΡΙ (j2 - 1)*Ν + i2 - 1
  2.     ΓΡΑΨΕ Π[1 + ι MOD Ν, 1 + ι DIV Ν], '  '
  3.   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  4.  

Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: gpapargi στις 06 Μάι 2011, 09:56:51 πμ
Όλοι οι βρόχοι γράφονται και μονή εντολή επανάληψης και αυτό είναι ένα παράδειγμα.

Επειδή μου αρέσει να βλέπω γεωμετρία και συσχετισμούς όπου αυτό είναι δυνατόν, το θέμα αυτό σχετίζεται και με το περυσινό θέμα 3.
Φαντάσου ότι έχεις ένα ηλεκτρονικό ρολόι που δείχνει ώρες και λεπτά και θέλεις να εκτυπώσεις όλες τις ενδείξεις του από τις 10:30 μέχρι τις 12:20. Θα δεις ότι γεωμετρικά είναι η ίδια άσκηση… σαν να πρέπει να βηματίσεις σε ένα πίνακα [24,60]. Πέρυσι είχαμε ζητήσει την αντίστροφη μέτρηση. Αλλάζει η φορά σάρωσης, αλλά το γεωμετρικό σχήμα που είναι πίσω και από τις 2 ασκήσεις είναι ουσιαστικά το ίδιο.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: veni στις 06 Μάι 2011, 10:00:03 μμ
Συγχαρητήρια σε όλους τους συντελεστές για την προσπάθειά τους!

Θα ήθελα να κάνω ένα μικρό σχόλιο σχετικά με το Α2 αφού είδα και τις προτεινόμενες λύσεις.

Ο Μέσος όρος των βαθμών είναι ζητούμενο; ή δεδομένο;
Θεωρώ ότι λόγω μη πλήρους - ασαφούς  εκφώνησης μπορεί να ανήκει και στα δύο (εφόσον βέβαια ο μαθητής το τεκμηριώσει κατάλληλα).
Δεν προκύπτει χωρίς αμφιβολία  από την εκφώνηση το συμπέρασμα ότι ο συνολικός αριθμός των μαθητών του σχολείου είναι 160. Σαφώς βέβαια είναι μία πιθανή ερμηνεία.
Θέλει όμως προσοχή διότι επηρεάζει και το ερώτημα 4 (αναφορικά με τη χρήση πίνακα)

Θα ήθελα τη γνώμη σας σε αυτό.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 06 Μάι 2011, 10:52:58 μμ
Αν το σκέφτεσαι σαν θέμα εξετάσεων, τότε σίγουρα θα υπήρχε πρόβλημα αν κάποιος μαθητής έβαζε τον Μέσο όρο στα Δεδομένα η στα Ζητούμενα.
Για παράδειγμα θα μπορούσε να είναι στα δεδομένα αν υποθέσουμε ότι ο μέσος όρος έχει υπολογιστεί ήδη και υπάρχει στο σύστημα σαν δεδομένο.
Μάλιστα υπήρξαν αρκετοί συνάδελφοι μέσα στην ομάδα που έκαναν το ίδιο σχόλιο με σένα.

Η φιλοσοφία είναι η εξής: ότι υπάρχουν τα δεδομένα και τα ζητούμενα αλλά δεν είναι μόνο αυτά. Υπάρχουν και ενδιάμεσες ποσότητες που υπολογίζονται και αυτές δεν ανήκουν ούτε στα δεδομένα ούτε στα ζητούμενα, δηλαδή στην έξοδο του αλγορίθμου. Με αυτό το σκεπτικό δεν το προσθέσαμε εκεί.

Τέτοια προβλήματα δημιουργούν ερωτήσεις στους μαθητές μέσα από τις οποίες μπορεί να γίνει πολύ εποικοδομητική συζήτηση. Σίγουρα αρκετά θέματα του διαγωνίσματος ίσως να είναι δύσκολο να μπουν σε εξετάσεις είτε λόγω της εκφώνησής τους (δεν μιλάω για ασάφεια αλλά ας πούμε για περισσότερους βαθμούς ελευθερίας στον μαθητή >:D) είτε λόγω της δυσκολίας τους.
Πιστεύω όμως είναι πολύ καλές για ένα διαγώνισμα στην τάξη(3ωρο   :) ) ή να το δώσεις στους μαθητές στο σπίτι και στη συνέχεια να συζητηθούν τα θέματα στην τάξη.

Ο Μέσος όρος των βαθμών είναι ζητούμενο; ή δεδομένο;

Το σχόλιο που λες για τον συνολικό αριθμό πάλι είναι εύστοχο (τέθηκε και αυτό μέσα στην ομάδα) αλλά πιστεύω ότι η φράση
"Δίνονται οι βαθμοί και τα ονόματα 160 μαθητών" προφανώς εννοεί ότι το πλήθος είναι δοσμένο.

Για παράδειγμα σκέψου την άσκηση στο τετράδιο μαθητή που λέει "Δίνονται οι τίτλοι των CD". Είναι προφανές ότι το πλήθος των CD είναι γνωστό και δεδομένο εξαρχής άρα μπορείς να χρησιμοποιήσεις πίνακα. Αφού έχεις από την αρχή στα χέρια σου τα CD ξέρεις ήδη και πόσα είναι. Δηλαδή και το πλήθος είναι δεδομένο όπως και τα CD

Φυσικά το διαγώνισμα μπορεί ο καθένας να το προσαρμόσει στις ανάγκες της τάξης τους τροποποιώντας το ή αφαιρώντας θέματα.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: melina στις 07 Μάι 2011, 11:20:06 μμ
Θέλω να κάνω μία επισήμανση για τις προτεινόμενες λύσεις στο Θέμα Γ. Νομίζω ότι ο αλγόριθμος δεν μπορεί να καλύψει τις πιθανές περιπτώσεις για τον τερματισμό της διαδικασίας των πρώτων 10 πέναλτι με μία μόνο δομή επανάληψης:
διαφορά <- Α_Τ(μ1 - μ2)
Αν π <= 10 τότε
   Αν εκτ1 τότε
      απομένουν ← 5 - ((π - 1) div 2)
   αλλιώς
      απομένουν ← 5 - (π div 2)
   Τέλος_αν
αλλιώς ....
Μέχρις_ότου διαφορά> απομένουν

και ο λόγος είναι ότι όταν έχει εκτελέσει ο 1ος και:
- προηγείται, η μεταβλητή απομένουν πρέπει να έχει τιμή τα γκολ που απομένουν για τον 2ο (5-(π-1)div2)
- χάνει, η μεταβλητή απομένουν πρέπει να έχει τιμή τα γκολ που απομένουν για τον 1ο (5-(π+1)div2)

για παράδειγμα, στο 9ο πέναλτι η 1η ομάδα δεν βάζει γκολ και το σκορ είναι 3-4. Το ματς λήγει χωρίς να χρειαστεί να εκτελέσει η 2η ομάδα το τελευταίο πέναλτι. Όμως στην προτεινόμενη λύση διαφορά=1 και απομένουν=1, άρα συνεχίζει και στο π=10.

Θεωρώ ότι ο πιο ασφαλής τρόπος για να λυθεί η άσκηση σωστά, είναι να γίνει (για τα πρώτα 10 πέναλτι) μια ΟΣΟ με 5 επαναλήψεις και έναν διακόπτη (λογική μεταβλητή) και μέσα σε κάθε επανάληψη να αναπτύσσονται χώρια οι εκτελέσεις της 1ης ομάδας και της 2ης ομάδας. Είναι μακροσκελής λύση αλλά δουλεύει.
Μπορεί κάτι να μου διαφεύγει στη λύση που δώσατε, γιατί έχει κουρκουτιάσει εντελώς το μυαλό μου.

Συγχαρητήρια για τα εμπνευσμένα θέματα.
Μελίνα Εφραιμίδου
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: sstergou στις 08 Μάι 2011, 01:17:10 πμ
Έχεις δίκιο.
Η λάθος λύση είναι δική μου.
Ίσως με 2 επαναλήψεις να είναι πιο κατανοητό. Παρ'όλα αυτα παραθέτω μια νέα λύση πάλι με μία επανάληψη :
Κώδικας: [Επιλογή]
Αλγόριθμος πέναλτι
Διάβασε ο1, ο2
μ1 ← 0
μ2 ← 0
π ← 0

Αρχή_επανάληψης
π ← π + 1
εκτ1 ← π mod 2 = 1
Αν εκτ1 τότε
Εμφάνισε "Εκτελεί η ", ο1
αλλιώς
Εμφάνισε "Εκτελεί η ", ο2
Τέλος_αν
Αρχή_επανάληψης
Διάβασε πεν
Μέχρις_ότου πεν = "ΕΥΣΤΟΧΟ" ή πεν = "ΑΣΤΟΧΟ"
Αν πεν = "ΕΥΣΤΟΧΟ" τότε
Αν εκτ1 τότε
μ1 ← μ1 + 1
αλλιώς
μ2 ← μ2 + 1
Τέλος_αν
Τέλος_αν
Εμφάνισε "Σκορ : ", μ1, " - ", μ2
Αν π <= 10 τότε
!Αν το πέναλτι είναι εύστοχο ελέγχουμε αν κερδίζει η ομάδα που ευστόχησε
Αν πεν = "ΕΥΣΤΟΧΟ" τότε
Αν εκτ1 τότε
διαφορά ← μ1 - μ2
απομένουν ← 5 - ((π - 1) div 2)
αλλιώς
διαφορά ← μ2 - μ1
απομένουν ← 5 - (π div 2)
Τέλος_αν
αλλιώς
!Αν είναι άστοχο, ελέγχουμε αν χάνει η ομάδα που αστόχησε
Αν εκτ1 τότε
διαφορά ← μ2 - μ1
απομένουν ← 5 - (π + 1) div 2
αλλιώς
διαφορά ← μ1 - μ2
απομένουν ← 5 - (π div 2)
Τέλος_αν
Τέλος_αν
αλλιώς
διαφορά ← Α_Τ(μ1 - μ2)
Αν εκτ1 τότε
απομένουν ← 1
αλλιώς
απομένουν ← 0
Τέλος_αν
Τέλος_αν
Μέχρις_ότου διαφορά > απομένουν 
Αν μ1 > μ2 τότε
Εμφάνισε "Κυπελλούχος - ", ο1
αλλιώς
Εμφάνισε "Κυπελλούχος - ", ο2
Τέλος_αν
Εμφάνισε "Σκορ : ", μ1, " - ", μ2
Τέλος πέναλτι

Ελπίζω να μην είναι και αυτή λάθος και ζητώ συγνώμη για την ταλαιπωρία που προκάλεσε η προηγούμενη.

@evry : Πρέπει να αντικατασταθεί η προτεινόμενη λύση με μία που να είναι σωστή..
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: noname στις 08 Μάι 2011, 01:18:45 πμ
Θεωρώ ότι ο πιο ασφαλής τρόπος για να λυθεί η άσκηση σωστά, είναι να γίνει (για τα πρώτα 10 πέναλτι) μια ΟΣΟ με 5 επαναλήψεις και έναν διακόπτη (λογική μεταβλητή) και μέσα σε κάθε επανάληψη να αναπτύσσονται χώρια οι εκτελέσεις της 1ης ομάδας και της 2ης ομάδας. Είναι μακροσκελής λύση αλλά δουλεύει.

Έχεις δίκιο για τη συγκεκριμένη περίπτωση στις προτεινόμενες λύσεις. Αλλά δεν είναι απαραίτητη η χρήση δύο χωριστών επαναλήψεων. Αν θέλεις δες και τη δική μου λύση: http://alkisg.mysch.gr/steki/index.php?topic=3839.msg40909#msg40909
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: evry στις 08 Μάι 2011, 09:01:50 πμ
@melina
Η επισήμανσή σου είναι πάρα πολύ σωστή. Η ιδέα είναι ότι κάθε φορά τα πέναλτι που απομένουν αφορούν αποκλειστικά την ομάδα που χάνει. Στην περίπτωση που έχει παίξει η 2η ομάδα τα πέναλτι που απομένουν είναι τα ίδια για τις 2 ομάδες. Στην περίπτωση όμως που έχει παίξει η πρώτη πρέπει να ελέγξουμε την ομάδα που χάνει.
Μάλιστα Μελίνα η ίδια δίνεις και την απάντηση. Αρκεί να προστεθεί μια απλή δομή επιλογής μόνο για αυτή την περίπτωση με την συνθήκη που περιγράφεις.

Όσοι έχουν κατεβάσει τις λύσεις ας κατεβάσουν το αρχείο πάλι. Μας ξέφυγε μια δομή επιλογής (Αν μ1 < μ2) μέσα στην επανάληψη.
Ευχαριστούμε για την κατανόηση

ΥΓ. Κάποιοι στην ομάδα είχαν πει ότι επειδή η άσκηση αφορά ποδόσφαιρο τα κορίτσια θα έχουν πρόβλημα με την κατανόηση της εκφώνησης. Να λοιπόν που μια γυναίκα μας έβαλε τα γυαλιά :-[
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: papaluk στις 19 Μάι 2011, 08:53:23 μμ
Αν και λίγο καθυστερημένα θεωρώ ότι η προτεινόμενη λύση στο τελευταίο θέμα έχει ένα προβληματάκι..
ΠΛ[Στοά] <-- Μήκος DIV 10, επειδή όμως πουθενά δεν αναφέρεται ότι το Μήκος είναι ακέραιος πιο σωστό θα ήταν
ΠΛ[Στοά] <-- Α_Μ( Μήκος / 10)
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 19 Μάι 2011, 09:03:56 μμ
O διερμηνευτής δεν δέχεται το  <<μήκος div 10>> όταν το μήκος είναι πραγματικός, άρα αναγκαστικά με / και Α_Μ()
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: papaluk στις 19 Μάι 2011, 10:25:23 μμ
Δεν είναι το θέμα ο διερμηνευτής μόνο... αλλά το γεγονός ότι οι τελεστές mod και div λειτουργούν μόνο με ακέραιες τιμές με βάση το σχολικό
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 20 Μάι 2011, 12:33:31 μμ
Άνοιξα ξεχωριστό θέμα με τίτλο "Επιλογή Ακέραιου ή Πραγματικού Τύπου" επειδή καλό είναι να υπάρχει...
http://alkisg.mysch.gr/steki/index.php?topic=3928

...και αντέγραψα/μετακίνησα κάποια σχετικά μηνύματα...
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Λάμπρος Μπουκουβάλας στις 21 Μάι 2011, 07:41:12 μμ
ΠΛ[Στοά] <-- Α_Μ( Μήκος / 10)

την ίδια λύση θα πρότεινα κι εγώ και με πρόλαβε ο papaluk
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: karinakis στις 23 Μάι 2011, 04:25:12 μμ
για άλλη μία φορά αποδείχτηκε ότι το διαγώνισμα το τελικό από το Στέκι δεν είχε καμία μα καμία σχέση με τα θέματα των Πανελλαδικών. Δυστυχώς ίσως κάποιοι απογοητεύτηκαν γιατί έχουν την αίσθηση ότι με δύσκολα θέματα αδικούνται οι μαθητές.... ( η αλήθεια είναι ότι αδικούνται οι ίδιοι από τα φροντιστήρια που κάνουν!!!!)

Άντε και του χρόνου συνάδελφοι!!!!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 23 Μάι 2011, 04:33:15 μμ
Ποιο το νόημα να έχουν σχέση τα θέματα?  Σημασία έχει η προετοιμασία.. και το διαγώνισμα ήταν καλό, με διαφορετικές από τις συνηθισμένες ασκήσεις
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 23 Μάι 2011, 04:33:53 μμ
Εκτός αν δεν κατηγορείς το διαγώνισμα  :P
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Λάμπρος Μπουκουβάλας στις 23 Μάι 2011, 04:45:20 μμ
προσωπικά, δε βλέπω ποτέ κανένα λόγο το διαγώνισμα στο στέκι να θυμίζει των πανελλαδικών. αν τύχει να είναι παρόμοιας δυσκολίας, τότε τόσο το καλύτερο. όμως μου αρέσει πολύ να το χρησιμοποιώ για την προετοιμασία των μαθητών. πάντα τα θέματα των διαγωνισμάτων είναι πολύ ωραία. είναι ο κόπος μερικών συναδέλφων μας, που πρέπει να σεβαστούμε και που πρέπει πάντα να επικροτούμε. κι αν πιστεύουμε ότι μπορούμε να τα καταφέρουμε καλύτερα του χρόνου, ας κάνουμε αίτηση συμμετοχής στην ομάδα διαγωνισμάτων 2012!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Laertis στις 23 Μάι 2011, 08:33:42 μμ
για άλλη μία φορά αποδείχτηκε ότι το διαγώνισμα το τελικό από το Στέκι δεν είχε καμία μα καμία σχέση με τα θέματα των Πανελλαδικών. Δυστυχώς ίσως κάποιοι απογοητεύτηκαν γιατί έχουν την αίσθηση ότι με δύσκολα θέματα αδικούνται οι μαθητές.... ( η αλήθεια είναι ότι αδικούνται οι ίδιοι από τα φροντιστήρια που κάνουν!!!!)

Άντε και του χρόνου συνάδελφοι!!!!

Για άλλη μια φορά είμαι έτοιμος να δεχτώ ως συντονιστής και μέλος της ομάδας διαγωνισμάτων για 5 χρόνια οποιαδήποτε καλόπιστη κριτική.  Αυτό που θέλω όμως να γνωρίζουν όλοι είναι ότι τα διαγωνίσματα του στεκιού δεν είχαν και δεν έχουν σκοπό να αποτελέσουν προσομοίωση εξετάσεων τύπου ΟΕΦΕ αλλά ένα εργαλείο - χρήσιμο ή άχρηστο- στα χέρια των συναδέλφων.
Λυπάμαι που ο συνάδελφος karinakis δε βρήκε εδώ την πηγή των θεμάτων των εξετάσεων που αναζητεί με τόση θέρμη. Ίσως του χρόνου συμμετέχει στην ομάδα και μας καθοδηγήσει με φωτεινά παραδείγματα θεμάτων για να λάμψει το επίπεδο των θεμάτων που αξιώνει να βάζουν οι άλλοι και να χρησιμοποιεί αυτός.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Ganian88 στις 24 Μάι 2011, 12:46:35 μμ
Καταρχήν, συγχαρητήρια για την καλή δουλειά που κάνετε στο Στέκι τόσα χρόνια.

Το φετινό διαγώνισμα, όπως και των προηγούμενων χρόνων, πιστεύω ότι ήταν ένα χρήσιμο εργαλείο με πολλά ενδιαφέροντα σημεία, για όποιον ήθελε να το χρησιμοποιήσει με τη μορφή ασκήσεων στην τάξη και όχι κατ' ανάγκη με τη μορφή "διαγωνίσματος".

Γνωρίζω ότι ίσως είναι κατόπιν εορτής, αλλά επειδή το διαγώνισμα θα μείνει και για τα επόμενα χρόνια, θα ήθελα να επισημάνω ένα σημείο. Στο Α2.4 νομίζω ότι η απάντηση θα έπρεπε να είναι αρνητική, καθώς ναι μεν πρέπει να κρατηθούν τα ονόματα και οι βαθμοί, αλλά αυτό μπορεί να γίνει και με 320 μεταβλητές. Ο μέσος όρος θα υπολογιστεί με μία (μεγαλούτσικη...) εντολή εκχώρησης και μετά χρειάζονται 160 απλές επιλογές του τύπου:

 Αν β1>μο τότε
     Εμφάνισε ον1
 Τέλος_αν   

Συγχαρητήρια και πάλι για την προσπάθειά σας.
 
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 24 Μάι 2011, 12:57:05 μμ
Στο Α2.4 νομίζω ότι η απάντηση θα έπρεπε να είναι αρνητική, καθώς ναι μεν πρέπει να κρατηθούν τα ονόματα και οι βαθμοί, αλλά αυτό μπορεί να γίνει και με 320 μεταβλητές. Ο μέσος όρος θα υπολογιστεί με μία (μεγαλούτσικη...) εντολή εκχώρησης και μετά χρειάζονται 160 απλές επιλογές του τύπου:

 Αν β1>μο τότε
     Εμφάνισε ον1
 Τέλος_αν   

 ???
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 24 Μάι 2011, 01:19:13 μμ
Στο Α2.4 νομίζω ότι η απάντηση θα έπρεπε να είναι αρνητική, καθώς ναι μεν πρέπει να κρατηθούν τα ονόματα και οι βαθμοί, αλλά αυτό μπορεί να γίνει και με 320 μεταβλητές. Ο μέσος όρος θα υπολογιστεί με μία (μεγαλούτσικη...) εντολή εκχώρησης και μετά χρειάζονται 160 απλές επιλογές του τύπου:

 Αν β1>μο τότε
     Εμφάνισε ον1
 Τέλος_αν   


:P Αν οι μαθητές ήταν 1600?
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 24 Μάι 2011, 01:19:48 μμ
???
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Ganian88 στις 24 Μάι 2011, 02:25:31 μμ
:P Αν οι μαθητές ήταν 1600?

Ό,τι δουλειά θα έκανε ένας πίνακας 1600 θέσεων, θα γινότανε με 1600 μεταβλητές.
Στην σελίδα 185 του σχολικού αναφέρει σχετικό παράδειγμα με θερμοκρασίες, όπου αναφέρει ότι η λύση με μεταβλητές είναι (προφανώς) σωστή, αλλά όχι προτιμητέα σε σχέση με τη χρήση πίνακα (επίσης προφανές).
Το ερώτημα, όμως, εδώ ήταν αν είναι απαραίτητη η χρήση πίνακα και όχι αν θα ήταν προτιμότερη.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Stefevan στις 24 Μάι 2011, 02:37:39 μμ
Ναι συμφωνώ αλλά που είναι ο δομημένος προγραμματισμός με τη δομή επανάληψης κτλ? Το σίγουρο είναι πως αν πας σε μια δουλειά και τους δείξεις πρόγραμμα με τόσες μεταβλητές (λέμε τώρα) ενώ μπορεί να γίνει με πίνακα θα το ξανασκεφτούν...  >:D Υπάρχουν περιπτώσεις που κάτι είναι απαραίτητο. Εδώ είναι απαραίτητη η χρήση πίνακα πρώτα πρώτα λόγω θέματος χρόνου και γραμμών κώδικα
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Sergio στις 25 Μάι 2011, 12:30:52 μμ
Ό,τι δουλειά θα έκανε ένας πίνακας 1600 θέσεων, θα γινότανε με 1600 μεταβλητές.
Στην σελίδα 185 του σχολικού αναφέρει σχετικό παράδειγμα με θερμοκρασίες, όπου αναφέρει ότι η λύση με μεταβλητές είναι (προφανώς) σωστή, αλλά όχι προτιμητέα σε σχέση με τη χρήση πίνακα (επίσης προφανές).
Το ερώτημα, όμως, εδώ ήταν αν είναι απαραίτητη η χρήση πίνακα και όχι αν θα ήταν προτιμότερη.


Απόλυτα σωστό.. μπορείς όμως να σκεφτείς κάποιο παράδειγμα στο οποίο (με βάση την προηγούμενη πρόταση) είναι απαραίτητη η χρήση πίνακα ;
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Παναγιώτης Τσιωτάκης στις 25 Μάι 2011, 12:55:05 μμ
το περσινό (και όχι μόνο) θέμα Γ Sergio  :D

Συγγνώμη για το spam
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Sergio στις 25 Μάι 2011, 12:59:01 μμ
το περσινό (και όχι μόνο) θέμα Γ Sergio  :D

Συγνώμη για το spam

καλά .. μπάνια Παναγιώτη :P

Συγγνώμη για το .. άσχετο
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Παναγιώτης Τσιωτάκης στις 25 Μάι 2011, 01:03:14 μμ
τρίτεκνος <- αληθής
ηλικία_min_τέκνου <- 7   ! ηλικία σε μήνες
Όσο τρίτεκνος = αληθής και ηλικία_min_τέκνου <= 12 επανάλαβε
    Εμφάνισε "Σιγά μην κάνεις μπάνιο χαλαρός"
    ηλικία_min_τέκνου <- ηλικία_min_τέκνου + 1/30
Τέλος_επανάληψης
Εμφάνισε "του χρόνου ίσως"
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Sergio στις 25 Μάι 2011, 01:16:21 μμ
Μικρές προσθήκες για λόγους πληρότητας..

τρίτεκνος <- αληθής
άντε_πάλι <- ψευδής
μέρα <- 0

ηλικία_min_τέκνου <- 7   ! ηλικία σε μήνες
Όσο τρίτεκνος = αληθής και ηλικία_min_τέκνου <= 12 επανάλαβε
    Εμφάνισε "Σιγά μην κάνεις μπάνιο χαλαρός"
    ηλικία_min_τέκνου <- ηλικία_min_τέκνου + 1/30
    μέρα <- μέρα + 1
    Αν όχι αντε_πάλι τότε
        άντε_πάλι <- πάμε_γι_άλλο(μέρα)
    Τέλος_αν

Τέλος_επανάληψης

Αν αντε_πάλι τότε
    Εμφάνισε "του χρόνου αποκλείεται"
αλλιώς

    Εμφάνισε "του χρόνου ίσως"
Τέλος_αν
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Ganian88 στις 25 Μάι 2011, 01:43:13 μμ
Απόλυτα σωστό.. μπορείς όμως να σκεφτείς κάποιο παράδειγμα στο οποίο (με βάση την προηγούμενη πρόταση) είναι απαραίτητη η χρήση πίνακα ;
Όχι, δε μπορώ. Ο πίνακας μας λύνει τα χέρια προκειμένου να μη χρησιμοποιήσουμε πολλές διαφορετικές μεταβλητές.
Όπως και να έχει, και για να μείνω στο συγκεκριμένο ερώτημα, η λέξη "απαραίτητο" σημαίνει ότι δεν μπορεί να γίνει με άλλο τρόπο. Άρα θεωρώ ότι η απάντηση θα πρέπει να είναι όχι.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Sergio στις 25 Μάι 2011, 03:38:05 μμ
.. Ο πίνακας μας λύνει τα χέρια προκειμένου να μη χρησιμοποιήσουμε πολλές διαφορετικές μεταβλητές..
..η λέξη "απαραίτητο" σημαίνει ότι δεν μπορεί να γίνει με άλλο τρόπο. Άρα θεωρώ ότι η απάντηση θα πρέπει να είναι όχι.

επομένως, θα μπορούσαμε να θεωρήσουμε τον 4ο διδακτικο στόχο του κεφαλαίου 9 .. άστοχο;

Παράθεση
Να είναι σε θέση ο μαθητής να αποφασίζει αν είναι απαραίτητη η χρήση πίνακα
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Ganian88 στις 25 Μάι 2011, 07:22:16 μμ
επομένως, θα μπορούσαμε να θεωρήσουμε τον 4ο διδακτικο στόχο του κεφαλαίου 9 .. άστοχο;
Όχι βέβαια, διότι η λύση με πίνακα είναι απείρως προτιμότερη και ο μαθητής θα πρέπει να το καταλαβαίνει.

Και είναι προτιμότερη όχι γιατί θα χρειαστούμε τις τιμές και μετά τον υπολογισμό του μέσου όρου,όπως αναφέρεται στις ενδεικτικές λύσεις, αλλά απλώς γιατί χωρίς πίνακα θα χρειαστεί διάβασμα 320 μεταβλητών και 160 δομές επιλογής.

Η ένστασή μου αφορά το εξής: Αν κάποιος μαθητής απαντούσε (όπως μου απάντησε εμένα ένας δικός μου μαθητής) : "'Οχι, δεν είναι απαραίτητη η χρήση πίνακα, αλλά σαφώς είναι η καλύτερη λύση για την αποθήκευση των δεδομένων", θεωρείτε ότι έχει απαντήσει λάθος;
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Sergio στις 26 Μάι 2011, 01:04:07 μμ
.. Αν κάποιος μαθητής απαντούσε (όπως μου απάντησε εμένα ένας δικός μου μαθητής) : "'Οχι, δεν είναι απαραίτητη η χρήση πίνακα, αλλά σαφώς είναι η καλύτερη λύση για την αποθήκευση των δεδομένων", θεωρείτε ότι έχει απαντήσει λάθος;

Θεωρώ πως έχει απαντήσει σωστά στο σκέλος "..'Οχι, δεν είναι απαραίτητη η χρήση πίνακα.." και υποκειμενικά (δηλαδή σηκώνει συζήτηση) στο σκέλος "..είναι η καλύτερη λύση για την αποθήκευση των δεδομένων.."

Το πόσο σωστά έχει απαντήσει συνολικά.. εξαρτάται.  Ανάλογα με τη διατύπωση του ερωτήματος η απάντηση μπορεί να είναι από το ΝΑΙ μέχρι το ΟΧΙ
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: antoniom στις 19 Ιούλ 2011, 12:09:46 πμ
Παιδιά καλησπέρα,

Απευθυνόμενος στην ομάδα των ατόμων που δημιουργούν τα διαγωνίσματα, θα ήθελα να ζητήσω την άδεια να δημοσιεύσω το φετινό διαγώνισμα (όπως και των περασμένων ετών) στην ιστοσελίδα μου (http://www.aepp.edu.gr/)

Με εκτίμηση,
Αντώνης Μπαλασάς
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: gpapargi στις 20 Ιούλ 2011, 09:56:56 πμ
Καλημέρα Αντώνη

Το θέμα συζητήθηκε εντός της ομάδας και μεταφέρω την άποψη.
Όποιος θέλει μπορεί να χρησιμοποιήσει στη σελίδα του το διαγώνισμα αρκεί να αναφέρει ρητά την πηγή (που είναι το στέκι των πληροφορικών) και να βάλει και το link.

Να προσθέσω επίσης ότι τα διαγωνίσματα φτιάχτηκαν ακριβώς για να χρησιμοποιηθούν από όλους ελεύθερα. Συνειδητά η ομάδα διαγωνισμάτων δεν αναφέρει τα ονόματα των μελών της γιατί ενδιαφέρεται κυρίως για την αναβάθμιση του μαθήματος. Κάποιες φορές στο παρελθόν είχαμε δει φαινόμενα όπου κάποιος έπαιρνε το διαγώνισμα και έβαζε το όνομά του από κάτω και το πλάσαρε ως δικό του, ή το έβαζε στη σελίδα του χωρίς να αναφέρει την πηγή (και εμμέσως έπαιρνε το credit αφού ήταν δική του η σελίδα). Δηλαδή ενώ η ίδια η ομάδα διαγωνισμάτων δεν ενδιαφερόταν για να προβληθούν τα μέλη της... κάποιοι άλλοι προσπαθούσαν να προβληθούν μέσω του ξένου διαγωνίσματος. Αυτό είναι κάτι που το καταδικάζουμε όλοι.
Η άποψη της ομάδας είναι λοιπόν ότι το διαγώνισμα χρησιμοποιείται ελεύθερα με μόνο περιορισμό να αναφέρεται ρητά η πηγή και το link. Και φυσικά η ομάδα είναι ανοικτή σε όλους για συμμετοχή.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: antoniom στις 20 Ιούλ 2011, 05:51:59 μμ
Βέβαια είμαι σύμφωνος για την αναφορά στην πηγή.

Άλλωστε σε τέτοιου είδους έργα, το μόνο που εισπράττει ο δημιουργός τους είναι η ηθική αμοιβή και αναγνώριση. Συνεπώς, βεβαίως και θα αναφέρω την πηγή, αλλά επίσης θα πρότεινα οι δουλειές της ομάδας να προστατεύονται με άδεια creative commons (http://www.creativecommons.gr/).

Αντώνης
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: gpapargi στις 21 Ιούλ 2011, 08:31:56 πμ
Το έχουν προτείνει αρκετοί. Μάλλον δε βρήκαμε το χρόνο να το τρέξουμε. Υπήρχαν βέβαια και κάποια αντεπιχειρήματα (πχ από εμένα) αλλά όσο πάει οι φωνές για το creative commons αυξάνονται. Οπότε μάλλον πάμε προς τα εκεί. Λογικά μόλις μαζευτούμε από  το καλοκαίρι και πριν αρχίσει η κατασκευή του νέου διαγωνίσματος (γύρω στο Δεκέμβρη) θα έχουμε το χρόνο να το κουβεντιάσουμε.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: petroszoul στις 08 Μάρ 2012, 05:55:32 πμ
Αγαπητοι συναδελφοι θα ηθελα να παρατηρησω κατι στις ενδεικτικες λυσεις που δωσατε για το διαγωνισμα. Καταρχην ηταν πολυ καλο και δυσκολο και συγνωμη κιολας για την παρατηρηση μου, η οποια περσι που το βγαλατε μου ειχε ξεφυγει και μενα εντελως αλλα φετος που ετοιμαζα ενα διαγωνισμα χρησιμοποιωντας και την ασκηση Α5 απο το διαγωνισμα σας βρηκα καποιο λαθος.
Αν η i1 ειναι κατα ενα μικροτερη απο τη i2 (δλδ i1=i2-1) τοτε η τριτη Για δεν ειναι επιτρεπτη γιατι θα δωσει λαθος αποτελεσματα. Οποτε θα ηταν προτιμοτερο νομιζω να υπηρχε  μια εμφωλευμενη Αν με συνθηκη (i1<i2-1) μεσα στο Αλλιως και πριν απο την τελευταια Για. Συγνωμη και παλι για την διορθωση μου.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Νίκος Αδαμόπουλος στις 08 Μάρ 2012, 02:29:48 μμ
...
Αν η i1 ειναι κατα ενα μικροτερη απο τη i2 (δλδ i1=i2-1) τοτε η τριτη Για δεν ειναι επιτρεπτη γιατι θα δωσει λαθος αποτελεσματα.
...

3η Για εννοείς την:

ΓΙΑ i ΑΠΟ i1+1 ΜΕΧΡΙ i2-1

; ; ;

Αν ναι, τότε στην περίπτωση που αναφέρεις αυτή η Για δεν θα κάνει καμία επανάληψη. Οπότε;
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: accordionman στις 01 Μάι 2013, 09:04:50 πμ
Γειά σας παιδιά. Με αφορμή  το γεγονός οτι δίνω πανελλήνιες σε λίγο καιρό αποφάσισα να ασχοληθώ με τα επαναληπτικά θεματα του Στεκίου. Ετσι , λοιπόν στο θέμα 3 μου καρφώθηκε ιδέα να το λύσω με πίνακες αν και δεν ζητείται κατι τετοιο. Το έλυσα λοιπόν με πίνακες. Το θέμα ειναι όμως  , είναι επιτρέπτη η χρήση πίνακα σ' αυτή την άσκηση?? Ειδα τις λυσεις και δεν χρησιμοποιούνται πίνακες. Θα ήθελα την γνώμη σας.
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: kats8 στις 23 Απρ 2014, 09:49:35 μμ
Καλησπέρα!
Τυγχάνει μήπως κάποιος να έχει χρόνο να ελέγξει αν η παρακατω λυση για το   Γ2 απο το 3ο θεμα
ειναι σωστή;   ::)

http://postimg.org/image/6iiirdoyd/

Συγχωρέστε μου τα λάθη, δεν είμαι καθηγήτρια!
Τίτλος: Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
Αποστολή από: Αποστολάτος Άκης στις 24 Απρ 2014, 02:03:29 πμ
Καλησπέρα!
Τυγχάνει μήπως κάποιος να έχει χρόνο να ελέγξει αν η παρακατω λυση για το   Γ2 απο το 3ο θεμα
ειναι σωστή;   ::)

http://postimg.org/image/6iiirdoyd/

Συγχωρέστε μου τα λάθη, δεν είμαι καθηγήτρια!
Καλησπέρα. Η λύση που δίνεις είναι μια καλή πρωτη προσπάθεια αλλά έχει αρκετά κενα.
1. Στην εκφωνηση λέει να διαβάζεις εναλλάξ τα πέναλτι της ομάδας(ενω εσύ τα διαβάζεις κ τα δυο μαζί)
2. Το διαβασε των ονοματων πρέπει να γίνει μια φορά κ οχι πολλές φορές
3. Η συνθηκη τερματισμού που δίνεις δεν είναι η σωστή.