Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Πολυδιάστατοι πίνακες => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Αναζήτηση => Μήνυμα ξεκίνησε από: nandia στις 15 Μάρ 2008, 06:59:06 μμ

Τίτλος: sos---Syxnotita emfanisis-pososta!!!!!
Αποστολή από: nandia στις 15 Μάρ 2008, 06:59:06 μμ
Geia sas!Me lene nandia kai avrio grafo test stin anaptyksi efarmogon!Exo mia aporia omos kai eimai agxomeni...mporei kapoios na m eksigisei ti kanoume se askiseis pou zitoun sixnotita emfanisis kai pososta??Me paradeigma an einai efkolo.!sas efxaristo!

me ektimisi!!
Τίτλος: Απ: sos---Syxnotita emfanisis-pososta!!!!!
Αποστολή από: Laertis στις 15 Μάρ 2008, 09:41:10 μμ
Τώρα αν σου έλεγα κάνε την προσευχή σου , θα ήμουν πολύ σκληρός ....;  >:D

Περιμένεις τελευταία μέρα πριν το τεστ για να ξεκαθαρίσεις κάτι που δε καταλαβαίνεις ...
Anyway ...
Με τα ποσοστά % έχω παρατηρήσει ότι πάρα πολλοί μαθητέ κολλάνε .
Ένα θα σου πω Νάντια , για να βρεις το % ποσοστό πρέπει να γνωρίζεις το μερικό πλήθος  και το συνολικό πλήθος σε ότι μετράς πχ. μαθητές με βαθμό άνω του 18 (μερικό πλήθος που ικανοποιεί κάποιο κριτήριο έστω α ) σε σύνολο 200 μαθητών (συνολικό πλήθος έστω σ).
Η πράξη που υπολογίζει το ποσοστό % είναι Ποσοστό=(μερικό_πλήθος/συνολικό_πλήθος)*100
π.χ. για το παραπάνω παράδειγμα Ποσοστό=α/σ*100

Για τη συχνότητα εμφάνισης μιας τιμής (σε πίνακα) κάνουμε αναζήτηση και μετράμε πόσες φορές υπάρχει η συγκεριμένη τιμή. Αν εννοείς να βρούμε τη συχνοτητα εμφάνισης όλων των αριθμών σε ένα πίνακα ... θα σε μπλέξω .
Καλύτερα να σου δώσω ένα παράδειγμα.
Υποθέτουμε ότι έχουμε έναν πίνακα Β με τις προφορικές βαθμολογίες 100 μαθητών (ακέραιοι απο 1 μέχρι 20) και θέλουμε να βρούμε τη συχνότητα εμφάνισης κάθε βαθμού

Δεδομενα //Β //   
 Για δ απο 1 μέχρι 20
  Συχνότητα[δ] <--0   ! μηδενίζουμε τον πίνακα των συχνοτήτων
Τέλος_επανάληψης
Για ι απο 1 μέχρι 100
  δ <-- Β[ι]
  Συχνότητα[δ] <-- Συχνότητα[δ] +1   
Τέλος_επανάληψης

Ο πίνακας Συχνότητα κρατά πόσες φορές εμφανίζεται ο κάθε βαθμός στην αντίστοιχη θέση του δλδ, αν θέλεις να εμφανίσεις πόσοι μαθητές έχουν 17 εμφανίζεις το περιεχόμενο της θέσης 17, Εμφάνισε Συχνότητα[17].

Ελπίζω να βοήθησα,αν και δε το πιστεύω, γιατί δε νομίζω ότι έχει αποτέλεσμα το διαδικτυακό μάθημα 5 λεπτών. Πάντως εύχομαι να γράψεις καλά και αύριο και στο τέλος  ;)
Τίτλος: Απ: sos---Syxnotita emfanisis-pososta!!!!!
Αποστολή από: alkisg στις 15 Μάρ 2008, 10:36:02 μμ
Νάντια να παρακαλέσω μόνο να γράφεις με ελληνικά. Εκτός του ότι τα greeklish δεν διαβάζονται ευχάριστα, μπορεί κάποιος να θέλει κάποτε να κάνει αναζήτηση για κάτι σχετικό με το θέμα σου, και με τα greeklish δεν πρόκειται να το βρει.
Μόλις βρεις ευκαιρία πάτα "Τροποποίηση" και ξαναγράψ' το με ελληνικούς χαρακτήρες.