Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Εξετάσεις 2018-2019 => Μήνυμα ξεκίνησε από: evry στις 12 Ιούν 2019, 09:35:40 πμ

Τίτλος: Θέμα 4
Αποστολή από: evry στις 12 Ιούν 2019, 09:35:40 πμ
Εδώ σχολιάζουμε το θέμα 4
Τίτλος: Απ: Θέμα 4
Αποστολή από: marvic στις 12 Ιούν 2019, 10:58:44 πμ
Πολύ απλό Θέμα Δ...
Τίτλος: Απ: Θέμα 4
Αποστολή από: progmat στις 12 Ιούν 2019, 11:29:26 πμ
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ_2019
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΒΑΘ[40, 6], Ι, Κ, ΚΩΔ, ΠΡ, Β, ΣΒ[40], Τ1
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[40], ΑΠ, Τ2

ΑΡΧΗ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 40
    ΔΙΑΒΑΣΕ ΟΝ[Ι]
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΔΙΑΒΑΣΕ ΒΑΘ[Ι, Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΚΩΔ, ΠΡ, Β
    ΑΝ Β > ΒΑΘ[ΚΩΔ, ΠΡ] ΤΟΤΕ
      ΒΑΘ[ΚΩΔ, ΠΡ] <- Β
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'ΥΠΑΡΧΕΙ ΝΕΑ ΛΥΣΗ ΠΡΟΒΛΗΜΑΤΟΣ; ΝΑΙ / ΟΧΙ'
    ΔΙΑΒΑΣΕ ΑΠ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ = 'ΟΧΙ'
  ΚΑΛΕΣΕ ΥΣΒ(ΒΑΘ, ΣΒ)
 
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 40
    ΓΙΑ Κ ΑΠΟ 40 ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
      ΑΝ ΣΒ[Κ - 1] < ΣΒ[Κ] ΤΟΤΕ
        Τ1 <- ΣΒ[Κ - 1]
        ΣΒ[Κ - 1] <- ΣΒ[Κ]
        ΣΒ[Κ] <- Τ1
        Τ2 <- ΟΝ[Κ - 1]
        ΟΝ[Κ - 1] <- ΟΝ[Κ]
        ΟΝ[Κ] <- Τ2
      ΑΛΛΙΩΣ_ΑΝ ΣΒ[Κ - 1] = ΣΒ[Κ] ΤΟΤΕ
        ΑΝ ΟΝ[Κ - 1] > ΟΝ[Κ] ΤΟΤΕ
          Τ2 <- ΟΝ[Κ - 1]
          ΟΝ[Κ - 1] <- ΟΝ[Κ]
          ΟΝ[Κ] <- Τ2
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΥΣΒ(ΒΑΘ, ΣΒ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΒΑΘ[40, 6], ΣΒ[40], Ι, Κ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 40
    ΣΒ[Ι] <- 0
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΣΒ[Ι] <- ΣΒ[Ι] + ΒΑΘ[Ι, Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τίτλος: Απ: Θέμα 4
Αποστολή από: merlin στις 12 Ιούν 2019, 12:04:19 μμ
Η αρχικοποίηση του πίνακα ΒΑΘ πρέπει να είναι με 0 και όχι με Διάβασε.
Επίσης πρέπει μετά την ταξινόμηση να εμφανίζονται και οι σχετικοί πίνακες
Τίτλος: Απ: Θέμα 4
Αποστολή από: falexakos στις 20 Ιούν 2019, 06:22:50 μμ
Γράφει κάποιος στο Δ5, μέσα στο (σωστό) ζεύγος επαναλήψεων της Φυσαλλίδας:
Κώδικας: [Επιλογή]
.......
.......
Αν ΣΒ[j-1]<ΣΒ[j] ή ΣΒ[j-1]=ΣΒ[j] και ΟΝ[j-1]>ΟΝ[j] τότε  ! <--- έτσι, χωρίς παρενθέσεις
  Αντιμετάθεσε ΣΒ[j], ΣΒ[j-1] ! <-- Για συντομία δεν γράφω όλες τις εντολές που τις έχει γράψει σωστά με την προσωρινή μεταβλητή κλπ.
  Αντιμετάθεσε ΟΝ[j],ΟΝ[j-1]
Τέλος_Αν
.......
.......

Εγώ το θεωρώ σωστό, αφού τυπικά η λογική σύζευξη ("και") έχει την προτεραιότητα του πολ/σιασμού, ενώ το "ή" αυτήν της πρόσθεσης.
Άρα είναι σαν να γράφει:
Κώδικας: [Επιλογή]
Αν (ΣΒ[j-1]<ΣΒ[j]) ή (ΣΒ[j-1]=ΣΒ[j] και ΟΝ[j-1]>ΟΝ[j]) τότεΤο ίδιο το σχολ. βιβλίο όμως δεν γράφει για προτεραιότητα των λογικών τελεστών (αν θυμάμαι καλά).
Τι λέτε λοιπόν;

Φώτης

Τίτλος: Απ: Θέμα 4
Αποστολή από: Παναγιώτης Τσιωτάκης στις 20 Ιούν 2019, 07:27:35 μμ
το τετράδιο οδηγιών μελέτης μαθητή (2015) ορίζει ρητά την ιεραρχία των λογικών τελεστών:
1. όχι
2. και
3. ή
 
Τίτλος: Απ: Θέμα 4
Αποστολή από: falexakos στις 21 Ιούν 2019, 08:58:48 πμ
Ναι και έχει και άσκηση πάνω σ' αυτό. Από παλιά μάλιστα. Ένας Βαθμολογητής όμως μου είπε πως αφού δεν γράφει κάτι το ίδιο το σχολικό βιβλίο (Βιβλίο Μαθητή), θεωρεί πως έπρεπε να είχε βάλει παρενθέσεις. Προσωπικά, διδάσκω στους μαθητές μου ακριβώς αυτό: Την προτεραιότητα κάθε τελεστή δηλαδή.
Τέλος πάντων, όντας Συντονιστής, τελικά πέρασε το "δικό μου" και δεν αφαιρέθηκαν μονάδες εδώ.  :)

Ευχαριστώ για την απάντηση και την υπόδειξη.
Τίτλος: Απ: Θέμα 4
Αποστολή από: Παναγιώτης Τσιωτάκης στις 21 Ιούν 2019, 12:27:05 μμ
Οι ισχύουσες οδηγίες διδασκαλίας (σελίδα 6) απαντούν απολύτως στο ζήτημα.

Πιθανώς ο συγκεκριμένος εκπαιδευτικός έχει να διδάξει το μάθημα κάποια χρόνια (δε θα ήταν κακή ιδέα αν έκανε και ένα διάλειμμα γενικότερα).

Καλό καλοκαίρι

(ΥΓ: γνωρίζω ότι καλούνται εκπαιδευτικοί που έχουν διδάξει τα τελευταία 2 χρόνια το πανελλαδικά εξεταζόμενο μάθημα).
Τίτλος: Απ: Θέμα 4
Αποστολή από: falexakos στις 21 Ιούν 2019, 10:20:10 μμ
(ΥΓ: γνωρίζω ότι καλούνται εκπαιδευτικοί που έχουν διδάξει τα τελευταία 2 χρόνια το πανελλαδικά εξεταζόμενο μάθημα).
Πράγματι, καλούνται να βαθμολογήσουν εκπαιδευτικοί που δίδαξαν πέρυσι ή/και διδάσκουν φέτος το μάθημα.  Απλά, μπορεί κάποιος να ήταν π.χ. απ' το 2005 ως το 2010 σε ΓΕΛ, να βρέθηκε σε π.χ. Γυμνάσιο απ' το 2010 ως το 2018 και να δίδαξε -μετά από χρόνια- ΑΕΠΠ το 2018-2019 (δηλ. φέτος).
Προσωπικά π.χ ήμουνα στο ΚΕΠΛΗΝΕΤ απ' το 2012 έως το 2018. Και ενώ έχω διδάξει για χρόνια ΑΕΠΠ (απ' το 2000-2001 έως και το 2011-2012) και είχα ξανακάνει Συντονιστής, επέστρεψα φέτος στο Λύκειο μετά από 6ετη απουσία. Χρειάστηκα κάποιο "φρεσκάρισμα" (η αλήθεια είναι) στην αρχή της φετινής χρονιάς.   :)