Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Μήνυμα ξεκίνησε από: ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ στις 29 Μάι 2019, 05:24:58 μμ

Τίτλος: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ στις 29 Μάι 2019, 05:24:58 μμ
Καλησπέρα σας, προτείνετε τις ιδέες σας και τις προτάσεις σας για την τελευταία επανάληψη και σημαντικά θέματα που πρέπει να προσέξουν οι μαθητές μας στην τελευταία τους επανάληψη. Ευχαριστώ πολύ εκ των προτέρων.
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: Λαμπράκης Μανώλης στις 29 Μάι 2019, 07:55:26 μμ
Καλησπέρα σε όλους

σαν έμπνευση της τελευταίας στιγμής θα έλεγα τα ακόλουθα:

Για Α+Β θέμα

1)  μετατροπές μεταξύ δομών επιλογής
2)  αντιγραφή / συγχώνευση πινάκων (ίσως την "έξυπνη συγχώνευση" για κάτι πιο δύσκολο)
3) πίνακας τιμών με εμφωλευμένες επαναλήψεις
4) πίνακας τιμών με υποπρογράμματα (μου έχει κολλήσει να υπάρχει διαδικασία που να καλεί διαδικασία)
5) θεωρία με μεταγλωττιστές
6) συμμετρικοί πίνακες
7) τετραγωνικοί
8  )   κάποια μαθηματική λειτουργία πχ ελάχιστο κοινό πολλαπλάσιο ή μέγιστος κοινός διαιρρέτης σε κενά

Για Γ θέμα

1) άσκηση με εμφωλευμένες επαναλήψεις (δίχως πίνακα)
2) άσκηση με πίνακα μετρητών (μιας και είναι εκλογές κάτι του στυλ να υπολογίζουμε ψήφους και τέτοια)
3) εύρεση 2 μεγαλύτερων τιμών δίχως χρήση πίνακα

Για Δ θέμα

Εδώ υποθέτω κλασσικά δισδιάστατοι πίνακες με διάφορες λειτουργίες, εδώ βέβαια υπάρχουν πολλές επιλογές ... ένα θέμα που μου έχει κολλήσει --> υπολογισμός γραμμών/στηλών σε δισδιάστατο που έχουν τα στοιχεία τους ήδη σε αύξουσα σειρα πχ

 >:D :laugh: :police:

έτσι να έχουμε να λέμε
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ στις 29 Μάι 2019, 08:20:00 μμ
Μετατροπές γενικά:
 δομών επανάληψης
 Τμήμα προγράμματος  σε κάποια τμήματα του  να γίνει με ισοδύναμα υποπρογράμματα ή το αντίθετο

goto  σε δομημένο και ισοδύναμο  διάγραμμα
Θεωρία :
δομές  δεδομένων  δευτερέουσας μνήμης, πραγματικές και τυπικές παράμετροι,  πολλαπλασιασμό αλλά ρωσικά
Τα είδη  των εκφράσεων και πως διαμορφώνονται με παρενθέσεις κτλ

Τέλος
Πολύ  καλά  η εύρεση  συχνότητας στοιχείων  σε πίνακα και φυσικά παράλληλη  ταξινόμηση
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: pajero1 στις 30 Μάι 2019, 02:55:17 μμ
ένα πολύ ωραίο θέμα είναι: Να γραφεί η εκφώνηση του προγράμματος που ταιριάζει σε συγκεκριμένες εντολές.
Υπάρχει αντίστοιχη άσκηση στο 2 κεφ στο τετραδίο μαθητή. Είναι πολύ εξυπνο και δεν εχει μπει ποτε.
 ;)
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: tdrivas στις 03 Ιούν 2019, 11:11:25 πμ
Αν θέλουμε να πάμε σε αναβάθμιση ποιοτική, θα ήταν ωραίο να δούμε πολλά έτοιμα υποπρογράμματα να δίνονται....
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: tsabatman στις 08 Ιούν 2019, 04:09:43 μμ
Καλησπέρα,γίνεται να εξασφαλίσω χωρίς πίνακα ότι όλες οι πληκτρολογήσεις είναι διαφορετικές?
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: Λαμπράκης Μανώλης στις 08 Ιούν 2019, 04:19:07 μμ
Καλησπέρα

δίχως πίνακα θα πρέπει  καπως να συγκρίνεις πχ τον 5ο αριθμό που θα δώσεις με όλους τους προηγούμενους, οπότε θα χρειαστείς πάρα πολλές βοηθητικές μεταβλητές και πολλές συγκρίσεις  (σε μικρό πλήθος αριθμών), οπότε νομίζω καταλήγουμε σε πίνακα ..  κάτι σχετικό που ίσως θα μπορούσε να ζητηθεί (για κάτι δύσκολο εννοείται) είναι για παράδειγμα να ελεγχθεί πως οι αριθμοί δόθηκαν πχ σε αύξουσα σειρά, όπου αρκεί να συγκρίνουμε κάθε αριθμό μόνο με τον προηγούμενο του (οπότε θα χρειαστεί μόνο μία βοηθητική μεταβλητή η οποία θα ανανεώνεται) ...



Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: tsabatman στις 08 Ιούν 2019, 04:29:29 μμ
Ευχαριστώ πολυ για την αμεση απαντηση καο εγω αυτο σκεφτόμουν
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: tanius76 στις 11 Ιούν 2019, 12:03:03 πμ
Μπορείτε να γράψετε τον αλγόριθμο της έξυπνης συγχώνευσης;  :)
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: Λαμπράκης Μανώλης στις 11 Ιούν 2019, 12:07:56 πμ
Στις οδηγίες μελέτης μαθητή υπάρχει στη σελίδα 62...
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: ntzios kostas στις 11 Ιούν 2019, 07:04:15 μμ
Ελπίζω
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: clitos στις 11 Ιούν 2019, 07:54:39 μμ
Μακάρι Κώστα Μακάρι να ειναι έτσι για τα ΓΕΛ
Στα ΕΠΑΛ σήμερα δεν έγινε αυτό δυστυχώς, δεν ήταν έτσι και δύσκολονόητα θέματα!
Χαιρετίσματα απο Αίγινα Κώστα, long time no see...


Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: tanius76 στις 11 Ιούν 2019, 10:19:13 μμ
Στις οδηγίες μελέτης μαθητή υπάρχει στη σελίδα 62...
Ευχαριστώ πολύ. Δεν ήξερα ότι λέγεται έξυπνη συγχώνευση! ;)
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: ολγα στις 11 Ιούν 2019, 11:39:11 μμ
Το "ΠΡΟΓΡΑΜΜΑ Συγχώνευση2"που υπάρχει στη σελ. 62 στις οδηγίες μελέτης μαθητή δεν είναι "έξυπνη συγχώνευση", αλλά απλώς  "συγχώνευση" και υπάρχει και στο τετράδιο μαθητή σελ. 85.
Το "ΠΡΟΓΡΑΜΜΑ Συγχώνευση1" στη σελ.61 στις οδηγίες μελέτης μαθητή κακώς και αναφέρεται ως συγχώνευση, αφού το βιβλίο σαφώς λέει στη σελ. 166:
"Συγχώνευση δύο πινάκων
Η συγχώνευση είναι μία από τις βασικές λειτουργίες σε πίνακες.Σκοπός της είναι η δημιουργία από τα στοιχεία δύο (ή περισσότερων) ταξινομημένων πινάκων ενός άλλου, που είναι και αυτός ταξινομημένος".
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: evry στις 11 Ιούν 2019, 11:41:54 μμ
Όλγα έχεις δίκιο.
Δεν υπάρχει έξυπνη συγχώνευση! Υπάρχει μόνο συγχώνευση και είναι η γνωστή λειτουργία που ξέρουμε.

https://en.wikipedia.org/wiki/Merge_algorithm (https://en.wikipedia.org/wiki/Merge_algorithm)

Δυστυχώς δυο διαφορετικά βιβλία λένε δυο διαφορετικά πράγματα.
Το παράξενο είναι ότι το λάθος το έχει το καινούργιο βιβλίο και όχι το παλιό που γράφτηκε το 1998!!!
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: Λαμπράκης Μανώλης στις 11 Ιούν 2019, 11:55:38 μμ
Καλησπέρα

αν δεν κάνω λάθος κάπου το είχα διαβάσει στο βιβλίο πως ονομάζεται "έξυπνη" συγχώνευση, δεν το ανέφερα αυστηρά ως "ορισμό" .. όπως και να έχει είναι ωραία σαν άσκηση ..  :laugh: >:D
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: epsilonXi στις 12 Ιούν 2019, 03:57:23 μμ
! έστω πίνακας Α μεγέθους Μ ταξινομημένος σε αύξουσα σειρά
! έστω πίνακας Β μεγέθους Ν ταξινομημένος σε αύξουσα σειρά
! ζητούμενο να δημιουργηθεί ταξινομημένος σε αύξουσα σειρά πίνακας Γ, με όλα τα στοιχεία των Α, Β
! από άποψη λογικής, το ζητούμενο επιτυγχάνεται με μια κατά τη γνώμη μου πολύ πιο απλή διαδικασία από αυτή που παρουσιάζεται στο βιβλίο:


Κώδικας: Bash
  1. χ <-- 1
  2. ψ <-- 1
  3. για θ από 1 μέχρι Μ+Ν
  4.   αν ψ > Ν ή Α[χ] < Β[ψ] τότε
  5.     Γ[θ] <-- Α[χ]
  6.     χ <-- χ + 1
  7.   αλλιώς
  8.     Γ[θ] <-- Β[ψ]
  9.     ψ <-- ψ + 1
  10.   τέλος_αν
  11. τέλος_επανάληψης
  12.  

τώρα, αν θέλουμε να σκεφτούμε την πιθανότητα για index out of size error, που κατ' εμέ είναι θέμα διαχείρισης της διάζευξης από τον compiler, και δε θα έπρεπε να μας απασχολεί, μπορούμε να το σπάσουμε σε 3 περιπτώσεις

Κώδικας: Bash
  1. χ <-- 1
  2. ψ <-- 1
  3. για θ από 1 μέχρι Μ+Ν
  4.   αν ψ > Ν
  5.     Γ[θ] <-- Α[χ]
  6.     χ <-- χ + 1
  7.   αλλιώς_αν Α[χ] < Β[ψ] τότε
  8.     Γ[θ] <-- Α[χ]
  9.     χ <-- χ + 1
  10.   αλλιώς
  11.     Γ[θ] <-- Β[ψ]
  12.     ψ <-- ψ + 1
  13.   τέλος_αν
  14. τέλος_επανάληψης
  15.  
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: ssimaiof στις 12 Ιούν 2019, 07:11:14 μμ
Για τη 2η περίπτωση πρέπει να ξέχασες μία ΑΝ.
Προφανώς μετά το ΑΝ ψ>Ν χρειάζεται και η ΑΛΛΙΩΣ_ΑΝ χ>Μ.
Ολοκληρωμένο :
Κώδικας: Bash
  1.   χ <- 1
  2.   ψ <- 1
  3.   ΓΙΑ θ ΑΠΟ 1 ΜΕΧΡΙ Μ + Ν
  4.     ΑΝ ψ > Ν ΤΟΤΕ
  5.       Γ[θ] <- Α[χ]
  6.       χ <- χ + 1
  7.     ΑΛΛΙΩΣ_ΑΝ χ > Μ ΤΟΤΕ
  8.       Γ[θ] <- Β[ψ]
  9.       ψ <- ψ + 1
  10.     ΑΛΛΙΩΣ_ΑΝ Α[χ] < Β[ψ] ΤΟΤΕ
  11.       Γ[θ] <- Α[χ]
  12.       χ <- χ + 1
  13.     ΑΛΛΙΩΣ
  14.       Γ[θ] <- Β[ψ]
  15.       ψ <- ψ + 1
  16.     ΤΕΛΟΣ_ΑΝ
  17.   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τίτλος: Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
Αποστολή από: epsilonXi στις 13 Ιούν 2019, 01:15:01 πμ
βεβαίως
μα ούτε και η πρώτη είναι σωστή  :D

μάλλον θα κρατήσω αυτό που λες εσύ