Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Δομή επιλογής => Μήνυμα ξεκίνησε από: captain62792 στις 29 Ιούν 2013, 04:23:23 μμ

Τίτλος: Απορια σε ασκηση
Αποστολή από: captain62792 στις 29 Ιούν 2013, 04:23:23 μμ
Αλγοριθμος υπολογισμου του ελαχιστου τριων ακεραιων αριθμων

εχω κολλησει οποιος μπορει να βοηθησει...
Τίτλος: Απ: Απορια σε ασκηση
Αποστολή από: itt στις 29 Ιούν 2013, 05:20:28 μμ
Που έχεις κολλήσει;

Κώδικας: [Επιλογή]
min <- a
Αν b < min ΚΑI b < c
     min <-b
Tέλος_Αν

Αν c < min ΚΑΙ c < b
     min <- c
Tέλος_Αν

Δουλεύει αυτό που έγραψα;Μπορείς να το αποδείξεις;Αν όχι, μπορείς να βρεις ένα παραδείγμα για το οποίο δεν δουλεύει;
Τίτλος: Απ: Απορια σε ασκηση
Αποστολή από: captain62792 στις 29 Ιούν 2013, 05:26:45 μμ
Αλγόριθμος πχ
Διάβασε α, β, γ
min ← α
Εμφάνισε α
Αν β < min και β < γ τότε
  min ← β
  Εμφάνισε β
Τέλος_αν
Αν γ < min και γ < β τότε
  min ← γ
  Εμφάνισε γ
Τέλος_αν
Τέλος πχ


μου εμφανιζει απο τα 3 νουμερα που βαζω το ελαχιστο..
αυτο θελει η ασκηση γτ με μπερδεψε
Τίτλος: Απ: Απορια σε ασκηση
Αποστολή από: itt στις 29 Ιούν 2013, 05:36:02 μμ
Aυτό που έγραψες,εμφανίζει και το a ανεξάρτητα απο το αν είναι το ελάχιστο.Εσύ θες να εμφανίζεις μόνο ελάχιστο,οπότε μετα το τελευταίο Αν,μπορείς να βάλεις  ἐνα
Κώδικας: [Επιλογή]
Εμφάνισε min
Τίτλος: Απ: Απορια σε ασκηση
Αποστολή από: captain62792 στις 29 Ιούν 2013, 05:38:18 μμ
οκ βγηκε.. ευχαριστω πολυ να στε καλα
Τίτλος: Απ: Απορια σε ασκηση
Αποστολή από: captain62792 στις 29 Ιούν 2013, 05:47:10 μμ
.