Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Εξετάσεις 2012-2013 => Μήνυμα ξεκίνησε από: Σπύρος Δουκάκης στις 15 Ιούν 2013, 09:56:11 πμ

Τίτλος: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Σπύρος Δουκάκης στις 15 Ιούν 2013, 09:56:11 πμ
Θέματα Επαναληπτικών Ημερησίων Λυκείων
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: evry στις 15 Ιούν 2013, 10:10:06 πμ
Βάζω και τα εσπερινά στο ίδιο thread. Τα θέματα είναι ακριβώς ίδια, με μια πολύ μικρή διαφορά σε μια φράση (εδώ παίζουμε το παιχνίδι βρείτε τις διαφορές).
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: petrosp13 στις 15 Ιούν 2013, 12:28:22 μμ
Πολύς πίνακας και πολλά κενά για να συμπληωθούν από την φετινή επιτροπή
Αλήθεια, η εύρεση του μικρότερου είναι πρόβλημα βελτιστοποίησης;
Γιατί εγώ δεν βρίσκω σαφή δικαιολόγηση
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 15 Ιούν 2013, 08:22:06 μμ
Η μόνη προφανής δικαιολόγηση (για το βελτιστοποίησης) είναι να βρει κάποιος τον μικρότερο με ταξινόμηση ενώ υπάρχει ο κλασικός (; βέλτιστος) τρόπος .
Πάντως εμένα μου φαίνεται για υπολογιστικό. (Κριτήριο : το είδος της επίλυσης).

Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 15 Ιούν 2013, 08:25:24 μμ
Α1.α 4.

μέσος όρος ενός συνόλου ακεραίων μεταβλητών πρέπει να αποθηκευτεί σε μεταβλητή πραγματικού τύπου.

Τι θα πει  "μέσος όρος ακεραίων μεταβλητών" ;

Μήπως :

μέσος όρος ακεραίων τιμών ;

Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Γιώργος Κατσαούνος στις 16 Ιούν 2013, 12:25:01 μμ
Η μόνη προφανής δικαιολόγηση (για το βελτιστοποίησης) είναι να βρει κάποιος τον μικρότερο με ταξινόμηση ενώ υπάρχει ο κλασικός (; βέλτιστος) τρόπος .
Πάντως εμένα μου φαίνεται για υπολογιστικό. (Κριτήριο : το είδος της επίλυσης).

Α
Αν ψάχνεις (αφαιρετικά) να βρεις την φθηνότερη τιμή τότε είναι Βελτιστοποίηση...
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 16 Ιούν 2013, 02:06:12 μμ
Είναι μια άποψη !  Πείθει όμως ;;

Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: petrosp13 στις 16 Ιούν 2013, 03:33:04 μμ
Αυτό λέω κι εγώ
Άστοχο ερώτημα
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Dinos στις 16 Ιούν 2013, 09:12:08 μμ
ιδιότητα=μικρό
βελτιστοποίηση = περισσότερο μικρό = μικρότερο
ΑΡΑ
η εύρεση του μικρότερου από 5 αριθμούς είναι πρόβλημα βελτιστοποίησης
όπως είναι το φθηνότερο, το χαμηλότερο αλλά και το ακριβότερο, το ψηλότερο.

όσον αφορά στα επαναληπτικά θέματα, το πνεύμα τους μοιάζει (πολύ) με αυτό των κανονικών
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: itt στις 17 Ιούν 2013, 02:42:01 πμ
Άμα ορίσεις την συνάρτηση f(x)=x με domain(f) = {x 1, ... , x 5},τότε το να βρεις το minimum της f είναι πρόβλημα optimization.
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: hobbit στις 06 Ιούλ 2013, 05:36:33 μμ
Έχει δώσει κανείς λύση στο Α3 συμπληρώνοντας μόνο τα κενά; Προσπάθησα να το λύσω σήμερα αλλά δεν τα κατάφερα. Κάθε βοήθεια είναι ευπρόσδεκτη.
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: dimitris76 στις 07 Ιούλ 2013, 10:36:42 πμ
Έχει δώσει κανείς λύση στο Α3 συμπληρώνοντας μόνο τα κενά; Προσπάθησα να το λύσω σήμερα αλλά δεν τα κατάφερα. Κάθε βοήθεια είναι ευπρόσδεκτη.

F <- ΨΕΥΔΗΣ
 i <-1
ΟΣΟ i<=991 ΚΑΙ F=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
J<- 0
ΟΣΟ j<=9 ΚΑΙ S[ j+i ] = W [j+1 ] ΕΠΑΝΑΛΑΒΕ
j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ j=10 ΤΟΤΕ
F <-ΑΛΗΘΗΣ
 ΑΛΛΙΩΣ
i <- i + 1
ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: evry στις 07 Ιούλ 2013, 07:47:44 μμ

Η παρακάτω λύση είναι λάθος

F <- ΨΕΥΔΗΣ
 i <-1
ΟΣΟ i<=991 ΚΑΙ F=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
J<- 0
ΟΣΟ j<=9 ΚΑΙ S[ j+i ] = W [j+1 ] ΕΠΑΝΑΛΑΒΕ
j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ j=10 ΤΟΤΕ
F <-ΑΛΗΘΗΣ
 ΑΛΛΙΩΣ
i <- i + 1
ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ

διότι στην εσωτερική επανάληψη για j=10 η συνθήκη γίνεται

Κώδικας: [Επιλογή]
ΟΣΟ 10<=9 ΚΑΙ S[ 10+i ] = W [10+1 ] ΕΠΑΝΑΛΑΒΕ
δηλαδή έχουμε προσπέλαση πέρα από τα όρια του πίνακα, που σημαίνει ότι παραβιάζεται το κριτήριο της καθοριστικότητας

ΥΓ. Στην γλώσσα/ψευδογλώσσα γίνεται πλήρης αποτίμηση των συνθηκών, δεν έχουμε short-circuit evaluation
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Παναγιώτης Τσιωτάκης στις 07 Ιούλ 2013, 10:32:32 μμ
έχεις πολύ δίκιο, άρα μια επανάληψης λιγότερη και η ερώτηση για το τελευταίο μετά:

F ← ΨΕΥΔΗΣ
i ← 1
ΟΣΟ F = ΨΕΥΔΗΣ ΚΑΙ i <= 991  ΕΠΑΝΑΛΑΒΕ   ! και όχι μέχρι 1000
j ← 0
ΟΣΟ j < 9  ΚΑΙ S[i + j] = W[j + 1] ΕΠΑΝΑΛΑΒΕ
j ← j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ j = 10 KAI S[i + 9] = W[10] ΤΟΤΕ
F ← ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
i ← i + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Λαμπράκης Μανώλης στις 07 Ιούλ 2013, 10:55:04 μμ
καλησπέρα...Παναγιώτη j=10 ή μήπως j=9?? δεν θα γίνει 10 έτσι που είναι το όσο αν δεν κάνω λάθος, το πολύ νά πάρει τιμή 9, και με την συνθήκη που βάζεις ελέγχουμε το δέκατο..
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Λαμπράκης Μανώλης στις 07 Ιούλ 2013, 11:00:11 μμ
και κάτι άλλο τώρα που παρατηρώ  ΟΣΟ F = ΨΕΥΔΗΣ ΚΑΙ i <= 1000 ΕΠΑΝΑΛΑΒΕ ---> μήπως το i Θ πάρει τιμές μέχρι 991 ?? από κει και πάνω αν συγκρίνουμε βγαίνουμε παί από τα όρια του πίνακα, αν το διαβάζω σωστά
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: giagia στις 08 Ιούλ 2013, 02:33:47 πμ
F <- ΨΕΥΔΗΣ
 i <-1
ΟΣΟ i<=991 ΚΑΙ F=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
J<- 0
ΟΣΟ j<=9 ΚΑΙ S[ j+i ] = W [j+1 ] ΕΠΑΝΑΛΑΒΕ
j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ j=10 ΤΟΤΕ
F <-ΑΛΗΘΗΣ
 ΑΛΛΙΩΣ
i <- i + 1
ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ

Μια διόρθωση που χρειάζεται η παραπάνω λύση είναι:
γραμμή 5: ΟΣΟ j<=9 ΚΑΙ S[ j mod 10 + i ] = W [j mod 10 +1 ] ΕΠΑΝΑΛΑΒΕ

Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: petrosp13 στις 08 Ιούλ 2013, 09:17:41 πμ
Θα μπορούσαν να βάλουν κάτι ακόμα πιο διαστημικό για να μιλάμε για μέρες

Θεωρώ ότι οι ασκήσεις συμπλήρωσης κενού σε κώδικα είναι τραγική επιλογή, είτε για κανονικές, είτε για επαναληπτικές, είτε για εσπερινά
Ειδικά όταν αναφέρονται σε τέτοιας δυσκολίας κώδικα

Ο κώδικας είναι (υποτίθεται) δημιουργία ιδέας εκ του μηδενός για την υλοποίηση της λύσης ενός προβλήματος και φυσικά προκύπτουν πολλές και διαφορετικές όμορφες λύσεις
Το να βάλεις έναν καλό προγραμματιστή να σπάει το κεφάλι του για να τελειώσει έναν μισό κώδικα που ξεκίνησε κάποιος άλλος, είναι μάλλον κάτι αντιδεοντολογικό
Και δεν μιλάμε καν για μισοτελειωμένο κώδικα
Μιλάμε για κώδικα που είναι τελειωμένος και απλά πρέπει να μαντέψεις συνθήκες και εντολές!

Συγνώμη για το off topic
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Παναγιώτης Τσιωτάκης στις 08 Ιούλ 2013, 01:01:28 μμ
και κάτι άλλο τώρα που παρατηρώ  ΟΣΟ F = ΨΕΥΔΗΣ ΚΑΙ i <= 1000 ΕΠΑΝΑΛΑΒΕ ---> μήπως το i Θ πάρει τιμές μέχρι 991 ?? από κει και πάνω αν συγκρίνουμε βγαίνουμε παί από τα όρια του πίνακα, αν το διαβάζω σωστά

έχει δίκιο Μανώλη!!! αλλιώς παραβιάζεται ο πίνακας!!
το διορθώνω στο αρχικό μήνυμα
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Λαμπράκης Μανώλης στις 08 Ιούλ 2013, 02:53:48 μμ
Παναγιώτη εγώ θα άλλαζα και το ΑΝ j = 10 KAI S[i + 9] = W[10] ΤΟΤΕ  σε Αν j = 9 και s[i+9] = W[10]....η δευτερη συνθήκη μας διασφαλίζει το δέκατο στοιχείο, αν το j είνια ήδη 10 τι κάνει η δεύτερη συνθήκη??? έτσι κ αλλιώς, αν κάνω κάποιο λάθος διορθώστε με, το j δεν πρόκυται να γίνει 10 έτσι που είνια η δομή του αλγορίθμου....αν κάτι μου έχει ξεφύγει και κάνω κάποιο λάθος παρακαλώ τις γνώμες σας... καλό μεσημέρι σε όλους
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: hobbit στις 08 Ιούλ 2013, 02:58:45 μμ
Στο Αν που βρίσκεται μετά την εσωτερική Όσο έχει 1 κενό.
Συμπέρασμα : Δεν μπορούμε να έχουμε σύνθετη συνθήκη (όπως στις Όσο που έχουν 2 κενά) ;
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: giagia στις 08 Ιούλ 2013, 03:45:57 μμ
Θα μπορούσαν να βάλουν κάτι ακόμα πιο διαστημικό για να μιλάμε για μέρες

Θεωρώ ότι οι ασκήσεις συμπλήρωσης κενού σε κώδικα είναι τραγική επιλογή, είτε για κανονικές, είτε για επαναληπτικές, είτε για εσπερινά
Ειδικά όταν αναφέρονται σε τέτοιας δυσκολίας κώδικα

Ο κώδικας είναι (υποτίθεται) δημιουργία ιδέας εκ του μηδενός για την υλοποίηση της λύσης ενός προβλήματος και φυσικά προκύπτουν πολλές και διαφορετικές όμορφες λύσεις
Το να βάλεις έναν καλό προγραμματιστή να σπάει το κεφάλι του για να τελειώσει έναν μισό κώδικα που ξεκίνησε κάποιος άλλος, είναι μάλλον κάτι αντιδεοντολογικό
Και δεν μιλάμε καν για μισοτελειωμένο κώδικα
Μιλάμε για κώδικα που είναι τελειωμένος και απλά πρέπει να μαντέψεις συνθήκες και εντολές!

Συγνώμη για το off topic
Έχεις απόλυτο δίκιο! Κάτι τέτοια θέματα δίνουν την εντύπωση της "εξυπνάδας" (με την κακή έννοια δυστυχώς)
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: giagia στις 08 Ιούλ 2013, 03:54:00 μμ
Στο Αν που βρίσκεται μετά την εσωτερική Όσο έχει 1 κενό.
Συμπέρασμα : Δεν μπορούμε να έχουμε σύνθετη συνθήκη (όπως στις Όσο που έχουν 2 κενά) ;
Θεωρώ πως η λογική αυτών που έθεταν το θέμα ήταν να ΜΗΝ χρησιμοποιηθεί σύνθετη συνθήκη. Όμως κάτι τέτοιο ΔΕΝ αναφέρεται πουθενά. Η εκφώνηση ζητά να συμπληρωθούν τα κενά. Θα μπορούσε, αντίστροφα, κανείς να ισχυριστεί ότι στις περιπτώσεις των Όσο η εκφώνηση ΑΠΑΙΤΕΙ σύνθετη συνθήκη με τη χρήση του λογικού τελεστή ΚΑΙ (και όχι τυχόν απλή), ενώ στην ΑΝ δίνει ΑΠΟΛΥΤΗ ελευθερία στο χρήστη να χρησιμοποιήσει σύνθετη ή απλή συνθήκη.
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Παναγιώτης Τσιωτάκης στις 09 Ιούλ 2013, 12:28:34 πμ
Παναγιώτη εγώ θα άλλαζα και το ΑΝ j = 10 KAI S[i + 9] = W[10] ΤΟΤΕ  σε Αν j = 9 και s[i+9] = W[10]....η δευτερη συνθήκη μας διασφαλίζει το δέκατο στοιχείο, αν το j είνια ήδη 10 τι κάνει η δεύτερη συνθήκη??? έτσι κ αλλιώς, αν κάνω κάποιο λάθος διορθώστε με, το j δεν πρόκυται να γίνει 10 έτσι που είνια η δομή του αλγορίθμου....αν κάτι μου έχει ξεφύγει και κάνω κάποιο λάθος παρακαλώ τις γνώμες σας... καλό μεσημέρι σε όλους

αν είναι το δέκατο και ισχύει και η άλλη συνθήκη (το 10ο του μινι πινακα να ειναι και το 10 της σειρας που ελεγχω), όχι?
είναι και περασμενη η ώρα...
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Λαμπράκης Μανώλης στις 09 Ιούλ 2013, 12:01:28 μμ
Καλημέρα σε όλους...Παναγιώτη εγώ έχω μπερδευτεί με αυτό το θέμα.....δεν ξέρω αν τα αναλύω και σωστά, αυτό που λέω είναι πως τo j δεν πρόκυται να γίνει 10.....στις δομές όσο ελέγχουμε μέχρι το 9ο στοιχείο (έτσι που μας έχουν δώσει τις συνθήκες των όσο δεν μπορούμε να ελέγξουμε το 10ο γιατί βγαίνουμε εκτός ορίων πίνακα), και με την συνθήκη του Αν από κάτω ελέγχουμε και το δέκατο στοιχείο.... το j αν μετράω καλά έτσι κ αλλιώς δεν μπορεί να πάρει τιμή 10..... οπότε η συνθήκη του Αν j=10 και()θα είναι πάντα Ψευδής.....αυτό συμπεράινω εγώ, επαναλαμβάνω με έχει μπερδέψει και μπορεί να έχω δει κάτι λάθος (πχ τι τιμές μπορεί να πάρει το J)...

ευχαριστώ
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: petrosp13 στις 09 Ιούλ 2013, 12:34:42 μμ
Συνεχίζω, βλέποντας πόσο δυσκολεύει το θέμα (δεν έψαξα καν να βρω λύση)
Αυτό το θέμα ήταν μια άσκηση που κάποιοι άτυχοι μαθητές έπρεπε να λύσουν μέσα σε 10-15 λεπτά για να προλάβουν και τα υπόλοιπα
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 09 Ιούλ 2013, 06:07:33 μμ
Τι να πούμε ;;;

Ο θεματοδότης θα είχε στο μυαλό του την παρακάτω λύση !!!

ΠΡΟΓΡΑΜΜΑ Α3
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: S[1000], W[10], i, j
 ΛΟΓΙΚΕΣ: F
ΑΡΧΗ
  F <- ΨΕΥΔΗΣ
  i <- 1
  ΟΣΟ  i <= 991  ΚΑΙ   ΟΧΙ F  ΕΠΑΝΑΛΑΒΕ
     j <- 0
     ΟΣΟ  j < 10  ΚΑΙ   W[j+1] = S[i+j] ΕΠΑΝΑΛΑΒΕ
         j <- j+1
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΑΝ  j = 10 ΤΟΤΕ
          F <- ΑΛΗΘΗΣ
     ΑΛΛΙΩΣ
       i <- i+1
     ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ F = ΑΛΗΘΗΣ  ΤΟΤΕ
     ΓΡΑΨΕ  i
  ΑΛΛΙΩΣ
     ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Με το εξωτερικό ΟΣΟ (κλασική σειριακή) , όλα  οκ !!

Όμως με το εσωτερικό ΟΣΟ (απουσία λογικής μεταβλητής)  , παραβιάζονται τα όρια του πίνακα ... (Κριτήριο καθοριστικότητας)

Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 09 Ιούλ 2013, 06:10:31 μμ
 ... και συνεχίζω !!

Μήπως μέσα σε 10-15' , απαιτούμε απ'τον μαθητή , το παρακάτω ;;;

Με λογική μεταβλητή.


ΠΡΟΓΡΑΜΜΑ Α3
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: S[1000], W[10], i, j
 ΛΟΓΙΚΕΣ: F, ok
ΑΡΧΗ
  F <- ΨΕΥΔΗΣ
  i <- 1
  ΟΣΟ  i <= 991 ΚΑΙ   ΟΧΙ F ΕΠΑΝΑΛΑΒΕ
     j <- 0
     ok <- ΑΛΗΘΗΣ
     ΟΣΟ  j < 10 ΚΑΙ   ok  ΕΠΑΝΑΛΑΒΕ
         ΑΝ   W[j] <> S[i+j]  ΤΟΤΕ
            ok <- ΨΕΥΔΗΣ
         ΑΛΛΙΩΣ
            j <- j+1
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΑΝ  ok ΤΟΤΕ
          F <- ΑΛΗΘΗΣ
     ΑΛΛΙΩΣ
       i <- i+1
     ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ F = ΑΛΗΘΗΣ  ΤΟΤΕ
     ΓΡΑΨΕ  i
  ΑΛΛΙΩΣ
     ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: kkapel στις 10 Ιούλ 2013, 02:54:30 μμ
F <- ΨΕΥΔΗΣ
i <- 1
ΟΣΟ  i ≤ 991 ΚΑΙ F = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
   j <- 0
   ΟΣΟ j < 9 ΚΑΙ W[j+1] = S[i+j] ΕΠΑΝΑΛΑΒΕ
           j <- j + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΑΝ W[j+1] = S[i+j] ΤΟΤΕ
         F <- ΑΛΗΘΗΣ
   ΑΛΛΙΩΣ
         i <- i + 1
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
     ΓΡΑΨΕ i
ΑΛΛΙΩΣ       
    ΓΡΑΨΕ ‘ΔΕΝ ΒΡΕΘΗΚΕ’
ΤΕΛΟΣ_ΑΝ

Καλησπέρα. Νέος στο Στέκι. Πιστεύω ότι η παραπάνω λύση δουλεύει!
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 10 Ιούλ 2013, 07:43:56 μμ
Και πάλι δεν αποφεύγεται η υπέρβαση των ορίων πίνακα !!


Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: kkapel στις 10 Ιούλ 2013, 09:07:14 μμ
Δεν συμφωνώ γιατί,

...
ΟΣΟ j < 9 ΚΑΙ W[j+1] = S[i+j] ΕΠΑΝΑΛΑΒΕ
        j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...

1) Για j = 9 και i < 991, στη συνθήκη (j < 9) ΚΑΙ (W[j+1] = S[i+j]) εξετάζεται το τελευταίο στοιχείο του πίνακα W[9+1] -> W[10] με το στοιχείο S[1..990 + 9] -> S[10...999]. (δεν έχουμε υπέρβαση ορίων πίνακα)

2) Για j = 9 και i = 991, στη συνθήκη (j < 9) ΚΑΙ (W[j+1] = S[i+j]) εξετάζεται το τελευταίο στοιχείο του πίνακα W[9+1] -> W[10] με το στοιχείο S[991 + 9] -> S[1000]. (δεν έχουμε υπέρβαση ορίων πίνακα)

Στη συνέχεια αφού η εσωτερική επανάληψη τελειώσει για j = 9 ελέγχει αν και τα τελευταία προς έλεγχο στοιχεία των πινάκων (για να συμπληρωθούν 10 συγκρίσεις) είναι ίδια, κτλ

Αν πάλι, η εσωτερική Όσο διακόψει γιατί βρέθηκαν διαφορετικά στοιχεία στους δύο πίνακες, αυτό θα το "βρεί" η Αν μετά την εσωτερική Όσο και θα αυξήσει την τιμή του i.

Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: andreas_p στις 11 Ιούλ 2013, 09:11:32 πμ
   j <- 0
   ΟΣΟ j < 9  ΕΠΑΝΑΛΑΒΕ
           j <- j + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Πόσες επαναλήψεις ;


Α
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: giagia στις 12 Ιούλ 2013, 02:57:37 μμ
Σύνοψη!
Σωστή λύση νο 1: η απ. #11 (dimitris76) με τη διόρθωση στην απ. #16 (giagia)
Σωστή λύση νο 2: η απ. #13 (Παναγιώτης Τσιωτάκης) με τη διόρθωση στην απ. #14 (mkouv - η διόρθωση επαναλαμβάνεται στην απ. #19)
Σωστή λύση νο 3: η απ. #28 (kkapel - ουσιαστικά διόρθωση/βελτίωση της σωστής λύσης νο 2 και - κατά τη γνώμη μου - η πιο πιθανή και λογικό να σκεφτεί ένας μαθητής).
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: ολγα στις 12 Φεβ 2014, 06:35:10 μμ
Διαβάζω και πάλι το ΘΕΜΑ Δ και συγκεκριμένα το Δ2. Θεωρείτε ότι είναι σαφές;
Μήπως ο θεματοδότης αντί " τιμή ποιότητας του καναλιού" ήθελε να πει απλά "κανάλι";
Τίτλος: Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
Αποστολή από: Perarg στις 06 Μάρ 2014, 09:30:52 πμ
Διαβάζω και πάλι το ΘΕΜΑ Δ και συγκεκριμένα το Δ2. Θεωρείτε ότι είναι σαφές;
Μήπως ο θεματοδότης αντί " τιμή ποιότητας του καναλιού" ήθελε να πει απλά "κανάλι";

Συμφωνώ απόλυτα, όπως επίσης θεωρώ άστοχη χρήση λέξεων στο Δ3 β. Να διορθώνει τη ληφθείσα λέξη... Μιλάμε για μαθητές Γ' Λυκείου, που έχουν να διαχειριστούν ένα διαγώνισμα σε 3 ώρες. Το να τους "κάψεις" το μυαλό υποθέτωντας τι εννοεί ο ποιητής με τη λέξη διορθώνει, ενώ στην εκφώνηση δεν αναφέρθηκε ποτέ η έννοια αυτή, είναι τουλάχιστον άδικο.