Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Εξετάσεις 2012-2013 => Μήνυμα ξεκίνησε από: manosteach στις 29 Μάι 2013, 12:52:31 μμ

Τίτλος: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: manosteach στις 29 Μάι 2013, 12:52:31 μμ
Άραγε θα μπορούσα να ανεβάσω τώρα ενδεικτικές λύσεις;
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: Σούλας Βασίλης στις 29 Μάι 2013, 01:42:04 μμ
Πάνω από το μέσο όρο το επίπεδο των φετινών θεμάτων κατά την γνώμη μου. Ανεβάζω λύσεις. Στείλτε μου διορθώσεις γιατί τα έχω κάνει λίγο βιαστικά και σίγουρα θα έχω λαθάκια.
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: Σπύρος Δουκάκης στις 29 Μάι 2013, 01:47:19 μμ
Προτεινόμενες Λύσεις

Διόρθωση σε ένα λαθάκι...

αλλιώς_αν (ΜΟ[i, 1] > 1.8 και ΜΟ[i, 2] ≤ 2) ή (ΜΟ[i, 2] > 3.6 και ΜΟ[i, 2] ≤ 4) τότε

                                     και ΜΟ[i, 1] 

και έκδοση v1 με καλύτερη προέγγιση στην συνθήκη αυτή!

Ευχαριστώ τον συνάδελφο που εντόπισε το λαθάκι!
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: lsourtzo στις 29 Μάι 2013, 02:10:22 μμ
Παραθέτω και εγώ τις λύσεις ... αν κάποιος έχει καμία διαφωνία ... ας ενημερώσει ...
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: soc_h στις 29 Μάι 2013, 02:12:46 μμ
@Σούλας Βασίλης
Ευχαριστώ για τον κόπο που έκανες και τα ανέβασες.
Στο Δ2 αναφέρει πως δεν απαιτείται έλεγχος εγκυρότητας δεδομένων.
Επίσης, αν έχουμε 1 εντολή μετά την αν... χρειάζεται το τέλος_αν;
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: Σούλας Βασίλης στις 29 Μάι 2013, 02:16:25 μμ
Το άλλαξα, έχεις δίκιο. Επίσης είχα και άλλα λαθάκια τα οποία διόρθωσα.
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: soc_h στις 29 Μάι 2013, 02:21:53 μμ
Στο Β2 μπορείς να βάλεις το ακόλουθο (πιο απλό)

Κώδικας: [Επιλογή]
ΝΑ<--0
Για i από 1 μέχρι 100
Αν Π[i]=ΑΛΗΘΗΣ τότε ΝΑ<--ΝΑ+1
Τέλος_επανάληψης
Για i από 1 μέχρι ΝΑ
Π[i]<--ΑΛΗΘΗΣ
Τέλος_επανάληψης
Για i από ΝΑ+1 μέχρι 100
Π[i]<--ΨΕΥΔΗΣ
Τέλος_επανάληψης
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: gthal στις 29 Μάι 2013, 02:47:47 μμ
Τη λύση του Βασίλη έκαναν οι περισσότεροι μαθητές μου.
Δίνω και μια παραλλαγή της για πιο ... άρρωστους   ;)

Κώδικας: [Επιλογή]
ΝΑ<-0
Για i από 1 μέχρι 100
  Αν Π[i]=ΑΛΗΘΗΣ τότε
  ΝΑ<-ΝΑ+1
Τέλος_αν
Τέλος_επανάληψης
Για i από 1 μέχρι 100
  Π[i]<- i<=ΝΑ
Τέλος_επανάληψης
Τίτλος: Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
Αποστολή από: gthal στις 29 Μάι 2013, 02:50:38 μμ
Το καλό με το Β2 ήταν η ελευθερία που αφήνει.
Άλλη μια λύση έξω από τα συνηθισμένα:

Κώδικας: [Επιλογή]
  κ ← 1
  Για ι από 1 μέχρι 100
    Αν Π[ι] τότε
      Για λ από ι μέχρι κ+1 με_βήμα -1
        Π[λ] ← Π[λ-1]
      Τέλος_επανάληψης
      Π[κ] ← Αληθής
      κ ← κ+1
    Τέλος_αν
  Τέλος_επανάληψης