Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Εξετάσεις 2012-2013 => Μήνυμα ξεκίνησε από: petrosp13 στις 17 Μάι 2013, 07:59:59 πμ

Τίτλος: Πανελλαδικές εξετάσεις 2013
Αποστολή από: petrosp13 στις 17 Μάι 2013, 07:59:59 πμ
Καλή αρχή στα καμάρια μας!

 :) :) :)
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: Νίκος Αδαμόπουλος στις 29 Μάι 2013, 02:05:04 πμ
Καλή επιτυχία στους μαθητές!
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: Λαμπράκης Μανώλης στις 29 Μάι 2013, 08:13:50 πμ
Καλημέρα και καλή επιτυχία στους μαθητες (κια σε εμας) !! :D ;D
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: amavidis στις 29 Μάι 2013, 08:58:30 πμ
Καλημερα, καλη επιτυχία στα παιδιά!
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: tsak στις 29 Μάι 2013, 09:18:45 πμ
Ξέρει κανείς περίπου τι ώρα θα αναρτηθούν τα θέματα?
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 09:42:32 πμ
Νομίζω επίσημα στις 11.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: GEG στις 29 Μάι 2013, 09:47:00 πμ
Ξέρει κανείς περίπου τι ώρα θα αναρτηθούν τα θέματα?
Από 10.10 έως 10.40 εκτός απροόπτου...
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: gthal στις 29 Μάι 2013, 09:58:54 πμ
Καλημέρα και καλή επιτυχία σε όλους!
Βλέπω ότι πέρυσι τα ανεβάσαμε εδώ στις 11  !;
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: tsak στις 29 Μάι 2013, 10:40:30 πμ
Η Χημεία βγήκε πάντως πρώτη μόλις τώρα
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: VAIOS στις 29 Μάι 2013, 10:43:23 πμ
Σε ποιό site ανεβαίνουν τα θέματα πρώτα;
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: tsak στις 29 Μάι 2013, 10:44:43 πμ
Εγώ από το Υπουργείο βλέπω
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 10:46:01 πμ
Σε ποιό site ανεβαίνουν τα θέματα πρώτα;

Στο site του Υπουργείου Παιδείας. Για την ώρα είναι κάτω οπότε τώρα πρέπει να τα ανεβάζουν.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: tsak στις 29 Μάι 2013, 10:46:28 πμ
Πρέπει να έχει "καθίσει" ο server.Χαμός  >:D
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: amavidis στις 29 Μάι 2013, 10:46:57 πμ
Εμαθα ότι ειχαμε καθυστερηση στη δυνατη αποχώρηση, μάλλον στις 11
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: gregv στις 29 Μάι 2013, 10:49:53 πμ
Γιατί καθυστέρηση στη δυνατή αποχώρηση. Ήρθε διευκρίνηση;
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 10:59:58 πμ
Στο site του υπουργείου πάντως έχουν ανέβει όλα εκτός από Α.Ε.Π.Π.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: VAIOS στις 29 Μάι 2013, 11:05:58 πμ
Κακός οιωνός το ότι αργούν τα θέματα!!!!
Τίτλος: θεματα ΑΕΠΠ - 2013 - ΕΣΠΕΡΙΝΑ
Αποστολή από: vav στις 29 Μάι 2013, 11:08:02 πμ
http://www.minedu.gov.gr/publications/docs2013/them_plir_kat_d_esp_no_1305.pdf
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 11:09:50 πμ
Κακός οιωνός το ότι αργούν τα θέματα!!!!

Πάντως στα υπόλοιπα της Θετικής και Τεχνολογικής κατεύθυνσης, όπως Μαθηματικά και Φυσική,  τα θέματα ήταν δύστροπα και δύσκολα με κάποια ερωτήματα να ξεφεύγουν από το πνεύμα των εξετάσεων. Ας ελπίσουμε να μην πάρει η μπάλα και την Α.Ε.Π.Π....
Τίτλος: ΘΕΜΑΤΑ ΑΕΠΠ 2013 - ΗΜΕΡΗΣΙΩΝ
Αποστολή από: vav στις 29 Μάι 2013, 11:15:57 πμ
http://www.ert.gr/exams/images/stories/themata-lyseis-2012/them_plir_kat_c_hmer_no_1305.pdf
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: nvacalo στις 29 Μάι 2013, 11:45:33 πμ
δωθηκε παραταση στην δυνατη αποχωρηση γιατι σε πολλα σχολεια πηγαν απο λαθος τα θεματα για τα εσπερινα σχολεια.

Τα θεματα τα θεωρω ευκολα μεχρι το 86/100 με αδικαιολογητα κατα την γνωμη μου πανευκολο θεμα Δ

Αδικαιολογητο επισης κατα την γνωμη μου να ζητανε απο τα παιδια να "ταξινομησουν" χωρις να χρησιμοποιησουν αυτο που μαθαμε ολη την χρονια. Εξεταζουν μονο την φαντασια τους την ωρα που βρισκονται μεσα στο αγχος κατι που δεν μου αρεσει.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: gthal στις 29 Μάι 2013, 11:56:39 πμ
χμμ... δε μου αρέσουν   :-\
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: papaluk στις 29 Μάι 2013, 11:59:59 πμ
Σχετικά με βαθμό δυσκολίας θεμάτων έχεις δίκιο.. αλλά για το θέμα Β2 δεν θα μπορούσαν να ταξινομήσουν καθώς οι λογικές τιμές με βάση το σχολικό δεν μπορούν να συγκριθούν (δεν υπάρχει διάταξη).. οπότε βοήθησαν αρκετά τους μαθητές με την υπόδειξη που έδωσαν
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 12:00:20 μμ
δωθηκε παραταση στην δυνατη αποχωρηση γιατι σε πολλα σχολεια πηγαν απο λαθος τα θεματα για τα εσπερινα σχολεια.

Τα θεματα τα θεωρω ευκολα μεχρι το 86/100 με αδικαιολογητα κατα την γνωμη μου πανευκολο θεμα Δ

Αδικαιολογητο επισης κατα την γνωμη μου να ζητανε απο τα παιδια να "ταξινομησουν" χωρις να χρησιμοποιησουν αυτο που μαθαμε ολη την χρονια. Εξεταζουν μονο την φαντασια τους την ωρα που βρισκονται μεσα στο αγχος κατι που δεν μου αρεσει.

Συμφωνώ μαζί σου nvacalo αν και δεν το επεξεργάστηκα ακόμη το Δ. Όσο για το Β2 έχεις δίκιο...νομίζω ότι από τους περισσότερους θα χαθεί αυτό το ερώτημα...Μια σκέψη είναι:

Κώδικας: [Επιλογή]
ΠΛΗΘΟΣ_Α <- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
            ΑΝ Π[Ι] = ΑΛΗΘΗΣ ΤΟΤΕ
              ΠΛΗΘΟΣ_Α <- ΠΛΗΘΟΣ_Α + 1
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

         ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΛΗΘΟΣ_Α
              Π[Ι] <- ΑΛΗΘΗΣ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
           ΓΙΑ Ι ΑΠΟ ΠΛΗΘΟΣ_Α + 1 ΜΕΧΡΙ 100
                  Π[Ι] <- ΨΕΥΔΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 12:02:17 μμ
Γνώμη μου και το Α4α θα φανεί παράξενο στα παιδιά...λίγοι θα "παίξουν" με τους δείκτες i, j... :(
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: nvacalo στις 29 Μάι 2013, 12:12:05 μμ
Συμφωνώ μαζί σου nvacalo αν και δεν το επεξεργάστηκα ακόμη το Δ. Όσο για το Β2 έχεις δίκιο...νομίζω ότι από τους περισσότερους θα χαθεί αυτό το ερώτημα...Μια σκέψη είναι:

Κώδικας: [Επιλογή]
ΠΛΗΘΟΣ_Α <- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
            ΑΝ Π[Ι] = ΑΛΗΘΗΣ ΤΟΤΕ
              ΠΛΗΘΟΣ_Α <- ΠΛΗΘΟΣ_Α + 1
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

         ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΛΗΘΟΣ_Α
              Π[Ι] <- ΑΛΗΘΗΣ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
           ΓΙΑ Ι ΑΠΟ ΠΛΗΘΟΣ_Α + 1 ΜΕΧΡΙ 100
                  Π[Ι] <- ΨΕΥΔΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Αυτη την λυση προτεινω και εγω!

Για το θεμα Α4α προτεινω:

Για i απο 1 μεχρι 100
    Για j απο i+1 μεχρι 100
         Διαβασε Π[i,j]
    Τ_ΕΠ
Τ_ΕΠ
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: tsabatman στις 29 Μάι 2013, 12:20:18 μμ
ΑΝ ΚΑΠΟΙΟΣ ΕΓΡΑΦΕ ΣΤΟ Β2
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
  ΑΝ Π[Ι]= ΨΕΥΔΗΣ ΚΑΙ Π[Ι+1]= ΑΛΗΘΗΣ ΤΟΤΕ
  ΑΝΤΙΜΕΤΑΘΕΣΕ Π[Ι] , Π[Ι+1]
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΣΟΡΥ ΑΝ ΕΙΝΑΙ ΛΑΘΟΣ ΤΟ ΣΚΕΦΤΗΚΑ ΠΡΟΧΕΙΡΑ

Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: zademan στις 29 Μάι 2013, 12:24:51 μμ
Αυτη την λυση προτεινω και εγω!

Για το θεμα Α4α προτεινω:

Για i απο 1 μεχρι 100
    Για j απο i+1 μεχρι 100
         Διαβασε Π[i,j]
    Τ_ΕΠ
Τ_ΕΠ

Για i από 1 μέχρι 99
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: nvacalo στις 29 Μάι 2013, 12:28:08 μμ
Για i από 1 μέχρι 99

οκ ναι αλλα δεν υπαρχει προβλημα να λεει μεχρι 100!
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 12:32:52 μμ
ΑΝ ΚΑΠΟΙΟΣ ΕΓΡΑΦΕ ΣΤΟ Β2
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
  ΑΝ Π[Ι]= ΨΕΥΔΗΣ ΚΑΙ Π[Ι+1]= ΑΛΗΘΗΣ ΤΟΤΕ
  ΑΝΤΙΜΕΤΑΘΕΣΕ Π[Ι] , Π[Ι+1]
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΣΟΡΥ ΑΝ ΕΙΝΑΙ ΛΑΘΟΣ ΤΟ ΣΚΕΦΤΗΚΑ ΠΡΟΧΕΙΡΑ

Σκέψου ότι μια τυχαία σειρά έστω στα πρώτα 7 στοιχεία είναι Α Α Α Ψ Ψ Ψ Α, τότε απλώς όταν θα φτάσει στα 2 τελευταία θα γίνει μία αντιμετάθεση και τα στοιχεία θα πάρουν τη μορφή Α Α Α Ψ Ψ Α Ψ, και εννοείται θα συνεχιστεί ο βρόχος μέχρι το τέλος χωρίς να γυρίσει πίσω για να διορθώσει εκείνες τις θέσεις...Συμφωνώ με τον nvacalo απλώς ο πρώτος βρόχος πρέπει να τρέχει μέχρι το 99, αλλιώς θα ληφθεί υπ' όψιν και το στοιχείο
Κώδικας: [Επιλογή]
Π[100, 100] το οποίο δε θέλουμε...Δηλαδή κάπως έτσι:

Κώδικας: [Επιλογή]

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
    ΓΙΑ  J ΑΠΟ Ι + 1 ΜΕΧΡΙ 100
      ΔΙΑΒΑΣΕ Π[Ι, J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 12:36:14 μμ
Γιατι μέχρι 99; Αν μείνει το για ι από 1 μέχρι 100, το για j από 101 μέχρι 100 θα εκτελεστεί;
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: nvacalo στις 29 Μάι 2013, 12:37:42 μμ
Σκέψου ότι μια τυχαία σειρά έστω στα πρώτα 7 στοιχεία είναι Α Α Α Ψ Ψ Ψ Α, τότε απλώς όταν θα φτάσει στα 2 τελευταία θα γίνει μία αντιμετάθεση και τα στοιχεία θα πάρουν τη μορφή Α Α Α Ψ Ψ Α Ψ, και εννοείται θα συνεχιστεί ο βρόχος μέχρι το τέλος χωρίς να γυρίσει πίσω για να διορθώσει εκείνες τις θέσεις...Συμφωνώ με τον nvacalo απλώς ο πρώτος βρόχος πρέπει να τρέχει μέχρι το 99, αλλιώς θα ληφθεί υπ' όψιν και το στοιχείο
Κώδικας: [Επιλογή]
Π[100, 100] το οποίο δε θέλουμε...Δηλαδή κάπως έτσι:

Κώδικας: [Επιλογή]

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
    ΓΙΑ  J ΑΠΟ Ι + 1 ΜΕΧΡΙ 100
      ΔΙΑΒΑΣΕ Π[Ι, J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



Το στοιχειο 100,100 δεν θα ληφθει υποψην γιατι η ροη δεν μπαινει στην επαναληψη Για j απο 101 μεχρι 100. Οποτε ειναι σωστο ειτε με 100 ειτε με 99.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 12:55:13 μμ
Το στοιχειο 100,100 δεν θα ληφθει υποψην γιατι η ροη δεν μπαινει στην επαναληψη Για j απο 101 μεχρι 100. Οποτε ειναι σωστο ειτε με 100 ειτε με 99.

Συμφωνώ! Μου διέφυγε η τελευταία επανάληψη, είναι σωστό και με 100! Αφού επεξεργάστηκα το ΘΕΜΑ Γ δε νομίζω ότι είναι και πολύ εύκολο τελικά...Μια πρόχειρη έκδοση που έγραψα:

Κώδικας: [Επιλογή]

   Αλγόριθμος ΘΕΜΑ_Γ_2013
ΑΘΡΟΙΣΜΑ_ΚΕΦ ← 0
ΑΘΡΟΙΣΜΑ_ΑΚΡ ← 0

!ΕΡΩΤΗΜΑ Γ1
Για Ι από 1 μέχρι 30
  Διάβασε ΚΩΔ[Ι]
  Για Κ από 1 μέχρι 30
    Διάβασε ΚΕΦ[Ι, Κ], ΑΚΡ[Ι, Κ]
  Τέλος_επανάληψης
Τέλος_επανάληψης

!ΕΡΩΤΗΜΑ Γ2
Για Ι από 1 μέχρι 30
  Για Κ από 1 μέχρι 10
    ΑΘΡΟΙΣΜΑ_ΚΕΦ ← ΑΘΡΟΙΣΜΑ_ΚΕΦ + ΚΕΦ[Ι, Κ]
    ΑΘΡΟΙΣΜΑ_ΑΚΡ ← ΑΘΡΟΙΣΜΑ_ΑΚΡ + ΑΚΡ[Ι, Κ]
  Τέλος_επανάληψης
  ΜΟ[Ι, 1] ← ΑΘΡΟΙΣΜΑ_ΚΕΦ/ 10
  ΜΟ[Ι, 2] ← ΑΘΡΟΙΣΜΑ_ΑΚΡ/ 10
  ΑΘΡΟΙΣΜΑ_ΚΕΦ ← 0
  ΑΘΡΟΙΣΜΑ_ΑΚΡ ← 0
Τέλος_επανάληψης

!ΕΡΩΤΗΜΑ Γ3
!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΚΕΦΑΛΙ
Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 2 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΚΕΦ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΑΚΡΟ
  Αν ΜΟ[Ι, 2] ≤ 3.6 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 4 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΑΚΡ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΓΕΝΙΚΟΥ ΠΕΔΙΟΥ
  Αν ΠΕΔΙΟ_ΚΕΦ ≥ ΠΕΔΙΟ_ΑΚΡ τότε
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΚΕΦ
  αλλιώς
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΑΚΡ
  Τέλος_αν

  Αν ΠΕΔΙΟ = 1 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΧΑΜΗΛΟΣ SAR"
  αλλιώς_αν ΠΕΔΙΟ = 2 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
  αλλιώς
    Εμφάνισε ΚΩΔ[Ι], "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης

!ΕΡΩΤΗΜΑ Γ4
! ΦΘΙΝΟΥΣΑ ΤΑΞΙΝΟΜΗΣΗ ΣΤΗΛΩΝ ΠΙΝΑΚΑ ΜΟ[30, 2]
! ΘΑ ΧΡΕΙΑΣΤΕΙ ΝΑ ΦΤΙΑΞΟΥΜΕ ΕΝΑΝ ΙΔΙΟ ΠΙΝΑΚΑ ΚΩΔ2[30] ΓΙΑ ΤΗΝ ΕΥΡΕΣΗ ΤΩΝ ΣΩΣΤΩΝ ΚΩΔΙΚΩΝ
!ΟΤΑΝ ΤΑΞΙΝΟΜΗΘΕΙ ΚΑΙ Η ΔΕΥΤΕΡΗ ΣΤΗΛΗ (ΘΑ ΕΧΟΥΝ ΗΔΗ ΤΑΞΙΝΟΜΗΘΕΙ ΜΙΑ ΦΟΡΑ ΟΠΟΤΕ ΔΕ ΘΑ ΕΧΟΥΜΕ ΣΩΣΤΑ ΑΠΟΤΕΛΕΣΜΑΤΑ
! ΑΝ ΤΟΥΣ ΑΦΗΣΟΥΜΕ ΟΠΩΣ ΕΙΝΑΙ
Για Ι από 1 μέχρι 30
  ΚΩΔ2[Ι] ← ΚΩΔ[Ι]
Τέλος_επανάληψης

Για Ν από 1 μέχρι 2
  Για Ι από 2 μέχρι 30
    Για Κ από 30 μέχρι Ι με_βήμα -1
      Αν ΜΟ[Κ - 1, Ν] < ΜΟ[Κ, Ν] τότε
        Αντιμετάθεσε ΜΟ[Κ - 1, Ν], ΜΟ[Κ, Ν]
        Αν Ν = 1 τότε
          Αντιμετάθεσε ΚΩΔ[Κ - 1], ΚΩΔ[Κ]
        αλλιώς
          Αντιμετάθεσε ΚΩΔ2[Κ - 1], ΚΩΔ[Κ]
        Τέλος_αν
      Τέλος_αν
    Τέλος_επανάληψης
  Τέλος_επανάληψης
Τέλος_επανάληψης

Εμφάνισε "ΟΙ ΜΑΘΗΤΕΣ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΜΕΣΟ ΟΡΟ ΣΤΟ ΚΕΦΑΛΙ"
Για Ι από 1 μέχρι 3
  Εμφάνισε ΚΩΔ[Ι], ΜΟ[Ι, 1]
Τέλος_επανάληψης

Εμφάνισε "ΟΙ ΜΑΘΗΤΕΣ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΜΕΣΟ ΟΡΟ ΣΤΑ ΑΚΡΑ"
Για Ι από 1 μέχρι 3
  Εμφάνισε ΚΩΔ2[Ι], ΜΟ[Ι, 2]
Τέλος_επανάληψης

Τέλος ΘΕΜΑ_Γ_2013

Και το θέμα της υπερίσχυσης του μεγαλύτερου πεδίου το βρίσκω δύσκολο σημείο για τα παιδιά...Αν έχετε την καλοσύνη ρίξτε μια ματιά και πείτε μου αν υπάρχουν λάθη. Το παραθέτω και σε doc για καλύτερη επεξεργασία.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 01:03:24 μμ
Το Γ3 νομίζω πως "βγαίνει" και πιο απλά:

Κώδικας: [Επιλογή]
!ΕΡΩΤΗΜΑ Γ3

Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι,1]>(ΜΟ[Ι,2]/2) τότε     ! ΕΛΕΓΧΟΣ ΑΝ ΤΟ ΚΕΦΑΛΙ ΒΓΑΖΕΙ ΠΕΡΙΣΣΟΤΕΡΟ SAR
    Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
      εμφάνισε "ΧΑΜΗΛΟΣ SAR"
    αλλιώς_αν ΜΟ[Ι,1] ≤ 2 τότε
      εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
    αλλιώς
      εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"
    Τέλος_αν
  αλλιώς
    Αν ΜΟ[Ι,2] ≤ 3.6 τότε
      εμφάνισε "ΧΑΜΗΛΟΣ SAR"
    αλλιώς_αν ΜΟ[Ι,2] <= 4 τότε
      εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
    αλλιώς
      εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: manosteach στις 29 Μάι 2013, 01:04:18 μμ
ΑΝ ΚΑΠΟΙΟΣ ΕΓΡΑΦΕ ΣΤΟ Β2
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
  ΑΝ Π[Ι]= ΨΕΥΔΗΣ ΚΑΙ Π[Ι+1]= ΑΛΗΘΗΣ ΤΟΤΕ
  ΑΝΤΙΜΕΤΑΘΕΣΕ Π[Ι] , Π[Ι+1]
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΣΟΡΥ ΑΝ ΕΙΝΑΙ ΛΑΘΟΣ ΤΟ ΣΚΕΦΤΗΚΑ ΠΡΟΧΕΙΡΑ
Ναι θα ήταν λάθος.
Γιατί αν στο Π[1] και στο Π[2] έχει ψευδή και στο π[3] αληθής, το Π[1] δεν θα αλλάξει
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: olga_2703 στις 29 Μάι 2013, 01:11:38 μμ
Στο β2 δε θα μπορούσα να χρησιμοποιήσω ένα επιπλέον πίνακα?
κ<-1
λ<-100
Για ι από 1 μέχρι 100
  Αν Π[ι]=Α τότε
    Β[κ]<-Π[ι]
    κ<-κ +1
 Αλλι'ως
    Β[λ]<-Π[ι]
    λ<-λ-1
  Τ_Αν
Τ_Ε

Για ι από 1 μέχρι 100
  Π[ι]<-Β[ι]
Τ_Ε
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 01:13:52 μμ
Το
Για ι από 1 μέχρι 50
πρέπει να γίνει
Για ι από 1 μέχρι 100
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: olga_2703 στις 29 Μάι 2013, 01:15:15 μμ
Ναι...
Δουλεύει όμως???
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: olga_2703 στις 29 Μάι 2013, 01:16:18 μμ
Στο α4
θα μπορούσε να είναι
Για ι από 1 μέχρι 100
   Διάβασε Π[ι,ι]
Τ_Ε

????
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: manosteach στις 29 Μάι 2013, 01:17:31 μμ
Στο β2 δε θα μπορούσα να χρησιμοποιήσω ένα επιπλέον πίνακα?
κ<-1
λ<-100
Για ι από 1 μέχρι 100
  Αν Π[ι]=Α τότε
    Β[κ]<-Π[ι]
    κ<-κ +1
 Αλλι'ως
    Β[λ]<-Π[ι]
    λ<-λ-1
  Τ_Αν
Τ_Ε

Για ι από 1 μέχρι 100
  Π[ι]<-Β[ι]
Τ_Ε
Πιστεύω πως αυτή η λύση πρέπει να γίνει δεκτή.
Δεν βάζει κάποιο περιορισμό.
Οπότε ΝΑΙ είναι σωστό.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 01:17:48 μμ
Ναι...
Δουλεύει όμως???

Ναι
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: manosteach στις 29 Μάι 2013, 01:18:51 μμ
Στο α4
θα μπορούσε να είναι
Για ι από 1 μέχρι 100
   Διάβασε Π[ι,ι]
Τ_Ε

????
Όχι
Γιατί με αυτό που γράφεις, διαβάζεις μονο τα στοιχεία της διαγωνίου
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 01:19:29 μμ
Στο α4
θα μπορούσε να είναι
Για ι από 1 μέχρι 100
   Διάβασε Π[ι,ι]
Τ_Ε

????

Όχι, διότι το θέμα δεν θέλει την διάβασε για i=j
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: olga_2703 στις 29 Μάι 2013, 01:22:47 μμ
Δικό μου λάθος, μπερδέυτηκα με τα Εσπερινα... :-[
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 01:28:06 μμ
Να ρωτήσω κάτι με τη σειρά μου: το Δ4 βγαίνει σωστά και με όσο και με μέχρις_ότου;
Με άλλα λόγια, αν χρησιμοποιηθεί μέχρις_ότου και η ερώτηση για διακοπή της εισαγωγής μπει στο τέλος του loop, υπάρχει θέμα ως προς την 1η απάντηση του χρήστη;
Επίσης, σε ποια μεταβλητή καταχωρείται η απάντηση δ ή Δ; στη μεταβλητή χώρα ή σε 3η; Το Δ3 είναι σχετικά ασαφές...
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: katif στις 29 Μάι 2013, 01:42:03 μμ
Μια πρόταση για το Γ3
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 30
      ΑΝ 2*ΜΟ[ι,1]>ΜΟ[ι,2] ΤΟΤΕ
          ΜΑΧ<-- 2*ΜΟ[ι,1]
     ΑΛΛΙΩΣ
         ΜΑΧ<--ΜΟ[ι,2]
    ΤΕΛΟΣ_ΑΝ

   ΑΝ ΜΑΧ<=3,6 ΤΟΤΕ
       ΓΡΑΨΕ 'Χαμηλός SAR'
   AΛΛΙΩΣ_ΑΝ ΜΑΧ<=4 ΤΟΤΕ
       ΓΡΑΨΕ 'Κοντά στα όρια'
   ΑΛΛΙΩΣ
       ΓΡΑΨΕ 'Έκτος ορίων'
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: katif στις 29 Μάι 2013, 01:43:01 μμ
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 01:43:15 μμ
Να ρωτήσω κάτι με τη σειρά μου: το Δ4 βγαίνει σωστά και με όσο και με μέχρις_ότου;
Με άλλα λόγια, αν χρησιμοποιηθεί μέχρις_ότου και η ερώτηση για διακοπή της εισαγωγής μπει στο τέλος του loop, υπάρχει θέμα ως προς την 1η απάντηση του χρήστη;
Επίσης, σε ποια μεταβλητή καταχωρείται η απάντηση δ ή Δ; στη μεταβλητή χώρα ή σε 3η; Το Δ3 είναι σχετικά ασαφές...

Σωκράτη νομίζω ότι το Δ3 μας λέει απλώς πότε να σταματήσει αυτός ο βρόχος, μας δίνει δηλαδή απλώς τη συνθήκη. Αφού θα πραγματοποιηθεί αυτή η διαδικασία σίγουρα μια φορά και δε χρειάζεται να ελέγξουμε κάτι από την αρχή τότε κατά την άποψή μου αρκεί να χρησιμοποιηθεί η ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ. Εγώ το υλοποίησα κάπως έτσι:

Κώδικας: [Επιλογή]
  ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ_2013

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, EL[5], ES[5], ΑΠΑΝΤΗΣΗ, Θ
  ΧΑΡΑΚΤΗΡΕΣ: ΧΩΡΑ, ΕΠΙΛΟΓΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ


ΑΡΧΗ
! ΕΡΩΤΗΜΑ Δ1
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    EL[Ι] <- 0
    ES[Ι] <- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΕΡΩΤΗΜΑ Δ2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΧΩΡΑ, ΑΠΑΝΤΗΣΗ
    ΑΝ ΧΩΡΑ = "ES" ΤΟΤΕ
      ΑΝ ΑΠΑΝΤΗΣΗ = 1 ΤΟΤΕ
        ES[1] <- ES[1] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 2 ΤΟΤΕ
        ES[2] <- ES[2] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 3 ΤΟΤΕ
        ES[3] <- ES[3] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 4 ΤΟΤΕ
        ES[4] <- ES[4] + 1
      ΑΛΛΙΩΣ
        ES[5] <- ES[5] + 1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ ΑΠΑΝΤΗΣΗ = 1 ΤΟΤΕ
        EL[1] <- EL[1] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 2 ΤΟΤΕ
        EL[2] <- EL[2] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 3 ΤΟΤΕ
        EL[3] <- EL[3] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 4 ΤΟΤΕ
        EL[4] <- EL[4] + 1
      ΑΛΛΙΩΣ
        EL[5] <- EL[5] + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
                                                    ! ΕΡΩΤΗΜΑ Δ3
    ΓΡΑΨΕ "ΓΙΑ ΔΙΑΚΟΠΗ ΤΗΣ ΕΙΣΑΓΩΓΗΣ ΠΑΤΗΣΤΕ Δ Η δ"
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = 'Δ' Η ΕΠΙΛΟΓΗ = 'δ'

!ΕΡΩΤΗΜΑ Δ4
  ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(EL, ΠΟΣ, Θ)
  ΓΡΑΨΕ "ΓΙΑ ΤΗΝ ΕΛΛΑΔΑ Η ΑΠΑΝΤΗΣΗ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΠΟΣΟΣΤΟ ΗΤΑΝ Η ", Θ, " ΜΕ ΠΟΣΟΣΤΟ ", ΠΟΣ
  ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(ES, ΠΟΣ, Θ)
  ΓΡΑΨΕ "ΓΙΑ ΤΗΝ ΙΣΠΑΝΙΑ Η ΑΠΑΝΤΗΣΗ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΠΟΣΟΣΤΟ ΗΤΑΝ Η ", Θ, " ΜΕ ΠΟΣΟΣΤΟ ", ΠΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΜΑ_Δ_2013

!ΕΡΩΤΗΜΑ Δ5
ΔΙΑΔΙΚΑΣΙΑ ΜΕΓ_ΠΟΣ(Π, ΠΟΣΟΣΤΟ, ΘΕΣΗ)

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[5], ΘΕΣΗ, ΜΑΧ, ΑΘΡΟΙΣΜΑ, Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΣΤΟ

ΑΡΧΗ
  ΜΑΧ <- Π[1]
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 5
    ΑΝ Π[Ι] < ΜΑΧ ΤΟΤΕ
      ΜΑΧ <- Π[Ι]
      ΘΕΣΗ <- Ι
    ΤΕΛΟΣ_ΑΝ
    ΑΘΡΟΙΣΜΑ <- ΑΘΡΟΙΣΜΑ + Π[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΠΟΣΟΣΤΟ <- (ΜΑΧ/ ΑΘΡΟΙΣΜΑ)* 100
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 01:47:29 μμ
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;

Αναφέρουν να μην χρησιμοποιηθεί στην ουσία η τεχνική του αλγορίθμου της ταξινόμησης...οπότε νομίζω ότι θα χάσει μονάδες..
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: petrosp13 στις 29 Μάι 2013, 01:47:49 μμ


Κώδικας: [Επιλογή]
 

! ΕΡΩΤΗΜΑ Δ2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΧΩΡΑ, ΑΠΑΝΤΗΣΗ
    [b]ΑΝ ΧΩΡΑ = "ES" ΤΟΤΕ
        ES[ΑΠΑΝΤΗΣΗ] <- ES[ΑΠΑΝΤΗΣΗ] + 1
    ΑΛΛΙΩΣ
        EL[ΑΠΑΝΤΗΣΗ] <- EL[ΑΠΑΝΤΗΣΗ] + 1
     
    ΤΕΛΟΣ_ΑΝ[/b]
                                                    ! ΕΡΩΤΗΜΑ Δ3
    ΓΡΑΨΕ "ΓΙΑ ΔΙΑΚΟΠΗ ΤΗΣ ΕΙΣΑΓΩΓΗΣ ΠΑΤΗΣΤΕ Δ Η δ"
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = 'Δ' Η ΕΠΙΛΟΓΗ = 'δ'


 :) :)
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: vanalex στις 29 Μάι 2013, 01:50:02 μμ
:) :)

Πολύ σωστά! Τζάμπα παιδεύομαι πιο πάνω... :)
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: soc_h στις 29 Μάι 2013, 02:09:44 μμ
...Αφού θα πραγματοποιηθεί αυτή η διαδικασία σίγουρα μια φορά και δε χρειάζεται να ελέγξουμε κάτι από την αρχή ...
Σε ευχαριστώ για την απάντηση.
Το πιο πάνω πως το ξέρουμε σίγουρα;
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: eftsousis στις 29 Μάι 2013, 02:15:29 μμ
Γνώμη μου και το Α4α θα φανεί παράξενο στα παιδιά...λίγοι θα "παίξουν" με τους δείκτες i, j... :(

Συμφωνώ Αλέξη, τα θέματα Α4 και Β2 ήταν τα πιο δύσκολα να αντιμετωπίσουν οι μαθητές. η άσκηση  είχε μια κλιμάκωση,, το θέμα 4ο ήταν εύκολο και υπήρχε αρκετό γράψιμο στις ασκήσεις. Κάποιος καλά διαβασμένος έγραφε καλά, όχι προς το άριστα όμως.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: eara στις 29 Μάι 2013, 04:40:09 μμ
Αδικαιολογητο επισης κατα την γνωμη μου να ζητανε απο τα παιδια να "ταξινομησουν" χωρις να χρησιμοποιησουν αυτο που μαθαμε ολη την χρονια. Εξεταζουν μονο την φαντασια τους την ωρα που βρισκονται μεσα στο αγχος κατι που δεν μου αρεσει.

Άλλο ένα αρνητικό σημείο στα θέματα το οποίο κατ' εμέ σωστά θίγεις. Δηλαδή το γεγονός ότι ζητούν στην ουσία να ταξινομήσουν τις τιμές, χωρίς τον μοναδικό αλγόριθμο ταξινόμησης που μάθαν στην τρέχουσα με βάση την εξεταστέα ύλη.
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: Γιάννης Αναγνωστάκης στις 29 Μάι 2013, 11:20:59 μμ
Δεν θα έπρεπε η ΠΕΚΑΠ, η ΕΠΕ (έστω μία ένωση ρε παιδιά) να βγει να κάνει μία ανακοίνωση για τα θέματα

Πουθενά δεν είμαστε ρε παιδιά...Καμία εικόνα...
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: Παναγιώτης Τσιωτάκης στις 29 Μάι 2013, 11:41:27 μμ
πριν 8 περίπου ώρες (συνημμένο)
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: Καρκαμάνης Γεώργιος στις 29 Μάι 2013, 11:48:44 μμ
Από το  απόγευμα υπάρχουν αναρτημένες στο διαδίκτυο οι απόψεις και τα σχόλια της ΠΕΚΑΠ για τα θέματα:

http://www.greekinformatics.gr/ekpedeysi/334-ekpedeysi/2986-thematakailyseispliroforikis2013.html (http://www.greekinformatics.gr/ekpedeysi/334-ekpedeysi/2986-thematakailyseispliroforikis2013.html)
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: Γιάννης Αναγνωστάκης στις 30 Μάι 2013, 01:04:17 μμ
Συνάδελφοι συγνώμη, αλλα μπαίνοντας το βράδυ στο site της ΠΕΚΑΠ δεν είδα τίποτα....
Τίτλος: Απ: Πανελλαδικές εξετάσεις 2013
Αποστολή από: itt στις 30 Μάι 2013, 01:16:59 μμ
Μου αρέσει στο σχολιασμό το
Παράθεση
Χαρακτηρίζονται στο
µεγαλύτερο  µέρος  τους  σαφή,  ορθά  διατυπωµένα,  ενώ  κάλυπταν  ένα  σηµαντικό
φάσµα της ύλης.

που προφανώς υποδεικύνει πώς ένα μέρος ήταν ασαφές και ανορθόδοξα διατυπωμένο.Αλλά καμμια αναφορά ποια σημεία απο το διαγώνισμα συγκαταλέγονται σε αυτό το μέρος.