Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Δομή επιλογής => Μήνυμα ξεκίνησε από: MARIA THEOHARI στις 02 Νοέ 2010, 09:23:26 πμ

Τίτλος: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
Αποστολή από: MARIA THEOHARI στις 02 Νοέ 2010, 09:23:26 πμ
Δίνεται η παρακάτω εκφώνηση:
Ένα πάρκινγκ χρεώνει τα οχήματα ως εξής:
1,2 € για όλες τις ώρες και αν υπάρχουν ώρες πάνω από 5, κάθε μια από αυτές χρεώνεται επιπλέον 0,5 €.

Ποιά λύση από τις 2 είναι σωστή;
αν ω<=5 τοτε
    ΧΡ<-- 1,2
Αλλιώς
    χρ<--1,2 + (ω-5)*0,5
τέλος_αν

ή

αν ω<=5 τοτε
    ΧΡ<-- 1,2*ω
Αλλιώς
    χρ<--1,2*ω + (ω-5)*0,5
τέλος_αν


Τίτλος: Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
Αποστολή από: Σπύρος Δουκάκης στις 02 Νοέ 2010, 10:09:33 πμ
Βάσει της εκφώνησης η λύση 1 είναι ok...

Η λύση 2 ερμηνεύει διαφορετικά την διατύπωση του προβλήματος... (κάθε μία από τις πέντε ώρες χρεώνεται με 1.2 ευρώ)...

Δίνεται η παρακάτω εκφώνηση:
Ένα πάρκινγκ χρεώνει τα οχήματα ως εξής:
1,2 € για όλες τις ώρες και αν υπάρχουν ώρες πάνω από 5, κάθε μια από αυτές χρεώνεται επιπλέον 0,5 €.

Ποιά λύση από τις 2 είναι σωστή;
αν ω<=5 τοτε
    ΧΡ<-- 1,2
Αλλιώς
    χρ<--1,2 + (ω-5)*0,5
τέλος_αν

ή

αν ω<=5 τοτε
    ΧΡ<-- 1,2*ω
Αλλιώς
    χρ<--1,2*ω + (ω-5)*0,5
τέλος_αν



Τίτλος: Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
Αποστολή από: Καρκαμάνης Γεώργιος στις 02 Νοέ 2010, 11:28:26 πμ
Η 2η λύση παραπέμπτει σε κλιμακωτό υπολογισμό.
Τίτλος: Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
Αποστολή από: Laertis στις 02 Νοέ 2010, 04:04:08 μμ
Υπάρχει μια ασάφεια στη διατύπωση της άσκησης (τι σημαίνει όλες τις ώρες ;) για το αν για τις 5 ώρες χρεώνονται 1,2 € συνολικά ή ανά ώρα, οπότε η 1η λύση απαντά σωστά την 1η εκφώνηση και η 2η την άλλη.
Τίτλος: Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
Αποστολή από: Vangelis στις 02 Νοέ 2010, 10:34:26 μμ
"Η κατανόηση ενός προβλήματος εξαρτάται σε μεγάλο βαθμό απο την διατύπωσή του"   σελ 6

Εδω είναι σαφές ότι δεν υπάρχει σαφήνεια διατύπωσης.