Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Δομή επιλογής => Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον => Εντολή ΕΠΙΛΕΞΕ => Μήνυμα ξεκίνησε από: clevercitizen στις 04 Οκτ 2009, 01:27:59 μμ

Τίτλος: Από Αν σε Επίλεξε
Αποστολή από: clevercitizen στις 04 Οκτ 2009, 01:27:59 μμ
Συνάδελφοι καλημέρα

Αλγόριθμος Θ
  Διάβασε x,y
  Av x>y τότε
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Αλλιώς_αν x<y τότε
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Αλλιώς
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ

Πώς μπορεί (αν μπορεί) ο παραπάνω αλγόριθμος να μετατραπεί σε Επίλεξε.....Τέλος_Επιλογών?

Έχω μια λύση στο μυαλό μου αλλά περιλαμβάνει και τη δομή επιλογης αν...τέλος_αν.

Ευχαριστώ.

Edit: Με το που έστειλα το θέμα μου ήρθε και η λύση.

Αλγόριθμος Θ
  Διάβασε x,y
  diafora<-- x-y
  Επίλεξε diafora
     Περίπτωση >0
        Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
     Περίπτωση <0
        Εμφάνισε " Ο πρώτος είναι μικρότερος του 2ου"
     Περίπτωση  0
        Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
     Τέλος_Επιλογών
Τέλος Θ

Και έρχομαι να ρωτήσω τώρα
Η δομή σύνθετης επιλογής Αν...αλλιώς_αν...αλλιώς...Τέλος_αν Μπορεί να μετατραπή σε δομή Επίλεξε...Περιπτωση.....Τέλος_επιλογών.
Σωστό ή λάθος?
Μετατρέπονται όλες οι αν σε περιπτωση ή όχι?   
Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: sstergou στις 04 Οκτ 2009, 02:29:31 μμ
Πιστεύω ανάλογα με την συνθήκη και τις μεταβλητές που λαμβάνουν μέρος σε αυτήν.

π.χ. για την
Αν α > 4 ΚΑΙ β < 3 τότε
...
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
....
Τέλος_Αν

δεν νομίζω να γίνεται τίποτε από την στιγμή που στην επίλεξε οι εκφράσεις ελέγχου των περιπτώσεων πρέπει να συγκρίνονται πάντα με τον επιλογέα.


Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: clevercitizen στις 04 Οκτ 2009, 02:42:31 μμ
Πιστεύω ανάλογα με την συνθήκη και τις μεταβλητές που λαμβάνουν μέρος σε αυτήν.

π.χ. για την
Αν α > 4 ΚΑΙ β < 3 τότε
...
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
....
Τέλος_Αν

δεν νομίζω να γίνεται τίποτε από την στιγμή που στην επίλεξε οι εκφράσεις ελέγχου των περιπτώσεων πρέπει να συγκρίνονται πάντα με τον επιλογέα.

H σκέψη που έκανα είναι συνδυασμός αν και επίλεξε
δηλ
Αν α > 4 ΚΑΙ β < 3 τότε
   τ<-- 1
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
   τ<-- 2
Τέλος_Αν
Επίλεξε τ
  περίπτωση 1
  .....
  περίπτωση 2
  .....
  Τέλος_επιλογών

Οπότε έμμεσα χρησιμοποιήσαμε την επίλεξε για να εκτελέσουμε τις εντολές .......


Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: Παναγιώτης Τσιωτάκης στις 04 Οκτ 2009, 09:00:06 μμ
Αλγόριθμος Θ
  Διάβασε x,y
  Av x>y τότε
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Αλλιώς_αν x<y τότε
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Αλλιώς
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ

Πώς μπορεί (αν μπορεί) ο παραπάνω αλγόριθμος να μετατραπεί σε Επίλεξε.....Τέλος_Επιλογών?

Αλγόριθμος Θ
  Διάβασε x,y
  Επίλεξε x
  Περίπτωση > y
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Περίπτωση < y
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Περίπτωση Αλλιώς  ! = y
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ
Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: Παναγιώτης Τσιωτάκης στις 04 Οκτ 2009, 09:01:08 μμ
Πιστεύω ανάλογα με την συνθήκη και τις μεταβλητές που λαμβάνουν μέρος σε αυτήν.

π.χ. για την
Αν α > 4 ΚΑΙ β < 3 τότε
...
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
....
Τέλος_Αν

δεν νομίζω να γίνεται τίποτε από την στιγμή που στην επίλεξε οι εκφράσεις ελέγχου των περιπτώσεων πρέπει να συγκρίνονται πάντα με τον επιλογέα.

Συμφωνώ  ΔΕΝ γίνεται με Επίλεξε
Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: manpap στις 06 Μάι 2010, 12:15:19 πμ
Τώρα μόνο είδα τη σχετική ερώτηση...  :D
Αλγόριθμος Θ
  Διάβασε x,y
  Επίλεξε x
  Περίπτωση > y
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Περίπτωση < y
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Περίπτωση Αλλιώς  ! = y
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ
Λέει κάπου καθαρά στο βιβλίο, αν η λίστα τιμών περιλαμβάνει και μεταβλητές? Είχα την εντύπωση ότι έπρεπε να είναι μόνο σταθερές, διάκριτες τιμές χωρίς να το έχω ψάξει περισσότερο...

Συμφωνώ  ΔΕΝ γίνεται με Επίλεξε
Συμφωνώ  ΔΕΝ γίνεται με ένα Επίλεξε
Υποθέτω ότι μια λύση όπως η παρακάτω θα ήταν αποδεκτή σε πιθανή ζητούμενη μετατροπή
επίλεξε (α > 4 ΚΑΙ β < 3)
  περιπτωση αληθης
    ...
  περιπτωση ψευδης
   επίλεξε (γ > 4 ΚΑΙ α > 5)
     περιπτωση αληθης
      ...
     περιπτωση ψευδης
     ...
    τελος_επιλογων
τελος_επιλογων

Συμφωνω ότι η προτεινόμενη χρήση της επίλεξε είναι άλλη αλλά και το παραπάνω μου φαίνεται σωστό...
όχι τίποτα άλλο, αλλά λέω στους μαθητές μου γενικά ότι η πολλαπλή επιλογή πάντα γίνεται επίλεξε
Αν μπει κάτι τέτοιο σε Σ/Λ π.χ. κάθε πολλαπλή επιλογή μπορεί να εκφραστεί με επίλεξε, ποια θα ήταν η σωστή απαντηση?

Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: Παναγιώτης Τσιωτάκης στις 06 Μάι 2010, 10:11:41 πμ
σωστό φαίνεται και είναι,
αν και η δομή Επίλεξε είναι πολλαπλής επιλογής, οπότε η χρήση της είναι είναι πιο λογικό να πραγματοποιείται για κάλυψη περισσοτέρων από 2 περιπτώσεων
Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: Βασίλης Παπαχρήστος στις 06 Μάι 2010, 09:11:26 μμ
Συνάδελφοι καλημέρα

Αλγόριθμος Θ
  Διάβασε x,y
  Av x>y τότε
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Αλλιώς_αν x<y τότε
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Αλλιώς
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ

Πώς μπορεί (αν μπορεί) ο παραπάνω αλγόριθμος να μετατραπεί σε Επίλεξε.....Τέλος_Επιλογών?

Έχω μια λύση στο μυαλό μου αλλά περιλαμβάνει και τη δομή επιλογης αν...τέλος_αν.

Ευχαριστώ.

Edit: Με το που έστειλα το θέμα μου ήρθε και η λύση.

Αλγόριθμος Θ
  Διάβασε x,y
  diafora<-- x-y
  Επίλεξε diafora
     Περίπτωση >0
        Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
     Περίπτωση <0
        Εμφάνισε " Ο πρώτος είναι μικρότερος του 2ου"
     Περίπτωση  0
        Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
     Τέλος_Επιλογών
Τέλος Θ

Και έρχομαι να ρωτήσω τώρα
Η δομή σύνθετης επιλογής Αν...αλλιώς_αν...αλλιώς...Τέλος_αν Μπορεί να μετατραπή σε δομή Επίλεξε...Περιπτωση.....Τέλος_επιλογών.
Σωστό ή λάθος?
Μετατρέπονται όλες οι αν σε περιπτωση ή όχι?   

Φίλε Clevercitizen θα μπορούσες επίσης να μην χρησιμοποιήσεις καθόλου τη μεταβλητή diafora, ως εξής:
Αλγόριθμος Θ
  Διάβασε x,y
  Επίλεξε x-y
     Περίπτωση >0
        Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
     Περίπτωση <0
        Εμφάνισε " Ο πρώτος είναι μικρότερος του 2ου"
     Περίπτωση  αλλιώς
        Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
     Τέλος_Επιλογών
Τέλος Θ
Τίτλος: Απ: Από Αν σε Επίλεξε
Αποστολή από: Καρκαμάνης Γεώργιος στις 21 Μάρ 2011, 10:38:58 πμ
Όλα σωστά αυτά που λέτε. Αλλά γιατί να ασχολούμαστε ακόμα με την "Επίλεξε";