Αποστολέας Θέμα: Επαναληπτικές Ασκήσεις 2018  (Αναγνώστηκε 2152 φορές)

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Επαναληπτικές Ασκήσεις 2018
« στις: 11 Φεβ 2018, 08:07:25 μμ »
Παραθέτω το περσινό φυλλάδιο, εμπλουτισμένο με 5 νέες ασκήσεις

Η περσινή συζήτηση διανθίστηκε με YouTube videos και τις διορθώσεις του Πολύκαρπου....

Με εκτίμηση,


Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #1 στις: 13 Φεβ 2018, 11:48:10 μμ »


Βίντεο για την άσκηση 2, https://www.youtube.com/watch?time_continue=318&v=y3zho2aV2bs

Το μυαλό βρίσκει τις λύσεις, όταν παύει να σκέφτεται
(Οκ δεν πάει πάντα έτσι).

Eri

  • Καθηγήτρια Πληροφορικής
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 135
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #2 στις: 14 Φεβ 2018, 02:43:27 μμ »


Βίντεο για την άσκηση 2, https://www.youtube.com/watch?time_continue=318&v=y3zho2aV2bs

Το μυαλό βρίσκει τις λύσεις, όταν παύει να σκέφτεται
(Οκ δεν πάει πάντα έτσι).

Παρεμπιπτόντως, εξαιρετική ταινία για όποιον δεν την έχει δει ακόμη!
Και free στο YouTube ολόκληρη.

Με ερέθισμα την ταινία,  κάναμε Coding σε Python (συνάρτηση που εντοπίζει ζεύγος φίλιων που διαβάζονται από το πληκτολόγιο) 
με τους μαθητές του ΕΠΑΛ Ξυλοκάστρου.
Τον παραθέτω για όποιον θέλει...

# -*- coding: cp1253 -*-
#synartisi
def f(x,y):
    sx = 0
    for i in range (1,x):
        if x % i ==0:
            sx+=i
    sy = 0
    for i in range (1,y):
        if y % i ==0:
            sy+=i
    if (sy==x and sx ==y):
        return 1
    else:
        return 0

#kyrios programma
   
a=int(input('δωσε αριθμό:'))
b=int(input('δωσε κιάλλον αριθμό:'))
if f(a,b)==1:
    print 'Eιναι Φιλιοι '
else:
    print 'Δεν ειναι Φιλιοι'
« Τελευταία τροποποίηση: 22 Φεβ 2018, 12:59:53 μμ από Eri »

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 173
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #3 στις: 25 Μάι 2018, 09:02:25 πμ »
οι λυσεις των 4 πρωτων ασκησεων του φυλλαδιου.για την τριτη κραταω μια επιφυλαξη αν καταλαβα σωστα την εκφωνηση
« Τελευταία τροποποίηση: 28 Μάι 2018, 05:31:59 μμ από Κωστας τζιαννης »

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #4 στις: 26 Μάι 2018, 06:24:34 μμ »
οι λυσεις των 4 πρωτων ασκησεων του φυλλαδιου.για την τριτη κραταω μια επιφυλαξη αν καταλαβα σωστα την εκφωνηση



ΠΡΟΓΡΑΜΜΑ IsComing
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: εισΑ, εισΒ, εισΓ
   ΠΡΑΓΜΑΤΙΚΕΣ: Σεσ, μπάντα, τζίρος
   ΧΑΡΑΚΤΗΡΕΣ: τύπος, συνέχεια
ΑΡΧΗ
εισΑ  <- 0
εισΒ  <- 0
εισΓ  <- 0
Σεσ  <- 0
μπάντα  <- 0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ τύπος
   ΑΝ τύπος = 'Α' ΤΟΤΕ
      ΑΝ εισΑ < 400 ΤΟΤΕ
         εισΑ  <- εισΑ + 1
         Σεσ  <- Σεσ + 5
         μπάντα  <- μπάντα + 1
      ΑΛΛΙΩΣ
         ΓΡΑΨΕ 'Όχι διαθέσιμο Α'
      ΤΕΛΟΣ_ΑΝ
   ΑΛΛΙΩΣ_ΑΝ τύπος = 'Β' ΤΟΤΕ
      ΑΝ εισΒ < 300 ΤΟΤΕ
         εισΒ  <- εισΒ + 1
         Σεσ  <- Σεσ + 7
         μπάντα  <- μπάντα + 2
      ΑΛΛΙΩΣ
         ΓΡΑΨΕ 'Όχι διαθέσιμο Β'
      ΤΕΛΟΣ_ΑΝ
   ΑΛΛΙΩΣ
      ΑΝ εισΓ < 400 ΤΟΤΕ
         εισΓ  <- εισΓ + 1
         Σεσ  <- Σεσ + 11
         μπάντα  <- μπάντα + 3
      ΑΛΛΙΩΣ
         ΓΡΑΨΕ 'Όχι διαθέσιμο Γ'
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
   ΓΡΑΨΕ 'Συνέχεια (ΝΑΙ/ΟΧΙ);'
   ΔΙΑΒΑΣΕ συνέχεια
   ΜΕΧΡΙΣ_ΟΤΟΥ συνέχεια = ' ΟΧΙ'

   ΔΙΑΒΑΣΕ τζίρος
   ΑΝ Σεσ + τζίρος < 1000 Η εισΑ + εισΒ + εισΓ < 200 ΤΟΤΕ
      ΓΡΑΨΕ 'όχι αμοιβή μπάντας'
      ΓΡΑΨΕ Σεσ
   ΑΛΛΙΩΣ
      ΓΡΑΨΕ μπάντα + 0.12 * τζίρος
      ΓΡΑΨΕ Σεσ – μπάντα
   ΤΕΛΟΣ_ΑΝ

   ΓΡΑΨΕ 'Cobra Kai https://www.youtube.com/watch?v=EqnmUrp2Nt8 '
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 173
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #5 στις: 26 Μάι 2018, 07:28:44 μμ »
ωραιος παναγιωτη.νομιζω οπως το κανα εγω η μπαντα θα κατεληγε να πληρωσει κι απο πανω.την εβγαλα τη δικη μου λυση.ευχαριστουμε για ολα.γενικα οι εκφωνησεις σου ειναι κατανοητες και οι ασκησεις σου to the point .καλη επιτυχια στους μαθητες σου στις πανελληνιες

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #6 στις: 26 Μάι 2018, 08:00:36 μμ »
Εγω σε ευχαριστώ πολύ.
Η αλήθεια είναι ότι τη συγκεκριμένη εκφώνηση, την άλλαξα λίγο, από την αρχική έκδοση, το ζήτημα με το τζίρο ήταν ασαφές.

Ελπίζω να πρόσεξες και τη μουσική της μπάντας στο τέλος...

Καλή δύναμη.

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #7 στις: 26 Μάι 2018, 08:04:48 μμ »
Μπόνους track

Η τράπεζα Τενεούπολης προσφέρει προνομιακό μηνιαίο επιτόκιο σε ειδικούς καταθετικούς λογαριασμούς, με βάση το ποσό που υπάρχει στον λογαριασμό την τελευταία ημερολογιακή μέρα του μήνα, όπως αποτυπώνεται στον πίνακα (όχι κλιμακωτός υπολογισμός):
Ποσό λογαριασμού (€)                         Επιτόκιο (%)
Μέχρι και 5.000                                      0.75
Άνω των 5.000 μέχρι και 15.000                         1.5
Άνω των 15.000                                       3

Να αναπτύξετε αλγόριθμο σε ΓΛΩΣΣΑ που για διάστημα 5 ετών που ο κ. Αρβίλογλου κατείχε έναν τέτοιο καταθετικό λογαριασμό (και αρχικά δεν είχε χρήματα):
α. Θα διαβάζει ανά μήνα πόσα χρήματα άντλησε και πόσα κατέθεσε.
β. Θα αποδίδει στο τέλος κάθε μήνα τον τόκο και θα τον ενσωματώνει στον καταθετικό λογαριασμό.
Δίνεται επίσης, ότι το επιτόκιο αυξάνεται κατά 0.35% αν για διάστημα τουλάχιστον 4 μηνών ο πελάτης κάνει μόνο κατάθεση στον λογαριασμό και όχι ανάληψη. Το αυξημένο ποσοστό ισχύει μόνο για το διάστημα που δεν πραγματοποιείται ανάληψη. Αν πραγματοποιηθεί δηλαδή ανάληψη χάνεται η αύξηση. Αν στη συνέχεια, υπάρξουν πάλι τουλάχιστον 4 μήνες χωρίς ανάληψη, αποδίδεται εκ νέου το αυξημένο επιτόκιο.
γ. Θα εμφανίζει πόσα χρήματα θα έχει ο λογαριασμός στο τέλος των 5 ετών.
δ. Θα εμφανίζει μήνυμα αν ο κ. Αρβίλογλου αξιοποίησε τελικά το μπόνους επιτοκίου ή όχι.

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 173
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #8 στις: 26 Μάι 2018, 08:13:20 μμ »
ωραιος!και το τραγουδι εννοειται οτι το προσεξα κλασικη ταινια ελπιζω να μην εχει την καταληξη αλλων ταινιων που συνεχιστηκαν μετα απο πολλα χρονια και το αποτελεσμα ηταν απογοητευτικο.

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #9 στις: 26 Μάι 2018, 08:27:26 μμ »
Η πρώτη σεζόν του Cobra Kai ολοκληρώθηκε και οι κριτικές είναι καλές.
Πάντως υπάρχει πολύς δρόμος ακόμη για την εύρεση της ισορροπίας του Daniel και του Johnny.

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 104
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #10 στις: 26 Μάι 2018, 08:29:55 μμ »
Να ξεφύγουμε λίγο από τις εξετάσεις η σειρά τα σπάει!!  :) Βέβαια μας θυμίζει πως μεγαλώνουμε αλλά είναι πολύ καλή!!

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 173
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #11 στις: 26 Μάι 2018, 08:35:37 μμ »
ποιος βλεπει το westworld??ειναι ωραια σειρα παντως για οποιον ενδιαφερεται.εσεις που γραφετε μετα τις πανελληνιες εχετε καιρο.η λυση του μπονους τρακ του παναγιωτη
« Τελευταία τροποποίηση: 26 Μάι 2018, 09:24:48 μμ από Κωστας τζιαννης »

akalest0s

  • Θαμώνας
  • ***
  • Μηνύματα: 36
Απ: Επαναληπτικές Ασκήσεις 2018
« Απάντηση #12 στις: 29 Μάι 2018, 05:59:07 μμ »
Παναγιώτη ευχαριστούμε για τις ασκήσεις, και εννοείται οτι η σειρά (κ η μουσική), τα σπάει!