Τελευταία μηνύματα

Σελίδες: [1] 2 3 4 ... 10
1
Γενικά / Απ: ΓΕΛ: Back to the Past
« Τελευταίο μήνυμα από gbougioukas στις Σήμερα στις 01:31:47 πμ »
Ακόμη, επειδή γίνεται λόγος για απολυτήριο λυκείου τύπου Διεθνούς Baccalauréat, καλό είναι να γνωρίζουμε ότι στο τελευταίο η Πληροφορική είναι ισότιμη (επιλογής) με τις διάφορες Φυσικές Επιστήμες:

https://www.ibo.org/programmes/diploma-programme/curriculum/sciences/
2
Γενικά / Απ: ΓΕΛ: Back to the Past
« Τελευταίο μήνυμα από gbougioukas στις Σήμερα στις 01:02:22 πμ »
Το σχέδιο νόμου που έχει δει το φως τη δημοσιότητας υπαινίσσεται  4-ωρο επιλογής/προσανατολισμού στην Β Λυκείου και 6-ωρο επιλογής/προσανατολισμού  στην Γ'.

https://www.esos.gr/arthra/52375/deite-neo-systima-prosvasis-sta-aei-kai-tis-allages-sto-lykeio

Φυσικά δεν θα πέσω από τα σύννεφα ό,τι και να γίνει...

Υπενθυμίζω ακόμα το σχέδιο νόμου για την Διδακτική Επάρκεια όπου προβλέπει ενότητα Μαθηματικά/Πληροφορική

https://www.esos.gr/arthra/53216/rythmizetai-nomothetika-i-didaktiki-kai-paidagogiki-eparkeia

Ούτε εδώ φυσικά θα πέσω από τα σύννεφα σε κάθε περίπτωση. Ωστόσο, καλό είναι να διατηρούμε ψηλά το επίπεδο..
3
δεν ξερω τι λεει το σχολικο βιβλιο γιατι δεν ειμαι καθηγητης σε σχολειο ομως αν πας στη c,python,c++ κτλ ισχυουν τα εξης.

για ι απο 1 μεχρι 5 με βημα 1
γραψε"γεια σου"
τελος_επαναληψης

θα εκτελεστει 5 φορες

για ι απο 1 μεχρι 5 με βημα -1
γραψε"γεια σου"
τελος_επαναληψης

θα εκτελεστει απειρες φορες και αυτο ειναι λογικο αν τη μετατρεψουμε σε οσο.

ι<-1
ΟΣΟ ι<=5 επαναλαβε
  γραψε"γεια σου"
  ι<-ι-1
τελος_επαναληψης

το προγραμμα θα κρασαρει αφου εμφανισει καποιες χιλιαδες φορες το μηνυμα "γεια σου".το ιδιο και αν εχω βημα μηδεν.αυτα συμβαινουν στις αληθινες
προγραμματιστικες γλωσσες αλλα σε αυτη του λυκειου ουτε οι ιδιοι δεν ξερουν τι εχουν γραψει .στην πραγματικοτητα ομως ακομα κι οταν το βημα δεν ειναι μηδεν αλλα εχω περιπτωση σαν την παραπανω εχω και τοτε ατερμονα βροχο
4
κατα τη γνωμη μου η δυαδικη αναζητηση ειναι ευκολο να γινει κατανοητη αν την παρουσιασεις στα παιδια σαν ενα ειδους παιχνιδι.οσοι θελετε να τη διδαξετε καντε το εξης.πειτε στους μαθητες  σας: θα σκεφτω εναν αριθμο απο το 1 μεχρι 1000  και ο αριθμος αυτος θα ειναι ακεραιος.εσεις μπορειτε να μου λετε εναν αριθμο και γω θα σας απανταω αν ειναι μεγαλυτερος  απο αυτον  που σκεφτηκα,αν ειναι  μικροτερος η αν τον βρηκατε.αν τον βρειτε με τις λιγοτερες προσπαθειες κερδιζετε
5
μια διαφορετικη και πιο συντομη λυση για το προβλημα των εισπραξεων

ΠΡΟΓΡΑΜΜΑ εισπραξεις
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΕΙΣΠΡΑΞΕΙΣ[12], τριμηνου[4]



ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 12
    ΓΡΑΨΕ "δωσε μου τις εισπραξεις του ", ι, "ου μηνα"
    ΔΙΑΒΑΣΕ ΕΙΣΠΡΑΞΕΙΣ[ι]
    ΑΝ ι <= 4 ΤΟΤΕ

      τριμηνου[ι] <- 0
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 0 ΜΕΧΡΙ 11
    τριμηνου[(ι + 3) div 3] <- τριμηνου[(ι + 3) div 3] + ΕΙΣΠΡΑΞΕΙΣ[ι + 1]

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ τριμηνου[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

6
η λυση του 4ου θεματος οεφε που απο οτι ειδα ειχε καποια λαθακια.νομιζω οτι ειναι σωστη απο το λιγο που την δοκιμασα
7
Γενικά / Απ: ΓΕΛ: Back to the Past
« Τελευταίο μήνυμα από ilias_s στις Χθες στις 06:38:46 μμ »
Μην πέσεις από τα σύννεφα αν δεις ότι κάποια στιγμή η αύξηση των ωρών της πληροφορικής στη Β' τάξη γίνει με μετατροπή του 1ωρου μαθήματος γενικής παιδείας σε 2ώρο επιλεγόμενο μάθημα (είτε μεμονομένα είτε ως μάθημα "ομάδας προσανατολισμού").

Κάτι τέτοιο μπορεί να είναι πραγματική αύξηση όταν το βλέπεις από τη σκοπιά των μαθητών, αλλά δε σημαίνει πως και εμείς θα έχουμε περισσότερες ώρες.

Για εμάς, από την άλλη, από άποψη ωρών μπορεί να είναι το ίδιο πράγμα (π.χ σε ένα μικρο λύκειο με 2 τμήματα ανά τάξη) ή και μείωση (σε λύκεια με 3 ή 5 τμήματα ανά τάξη) αν δε βγαίνει ικανοποιητικός αριθμός τμημάτων επιλογής. Για τη Γ' τάξη είναι σημαντικό το πανελλαδικώς εξεταζόμενο μάθημα να είναι απαραίτητο για όσους θέλουν να μπουν στους ηλεκτρολόγους μηχανικούς ή στα τμήματα πληρ/κής (όπως ήταν η τεχνολογική κατεύθυνση).

Αυτό που ισχύει σήμερα είναι ό,τι πιο στρεβλό έχει γίνει τα τελευταία χρόνια και λειτουργεί απαξιωτικά για το μάθημα.
8
Το ότι θα διαβάζει μόνο θετικούς είναι για να μπορεί να οριστεί πράξη mod και όχι για να κάνουμε έλεγχο
Εδώ δεν υπάρχει λογικό λάθος για μένα
Δεν ζητάει να προσθέσουμε γραμμές, ζητάει να διορθώσουμε τις υπάρχουσες γραμμές
Και ένα ακόμα στοιχείο είναι ότι οι μονάδες είναι 10 και υπάρχουν ήδη 5 προφανή λάθη..

Σε αυτό μπερδεύτηκα και εγώ. Μπορούμε να προσθέσουμε και γραμμές;
9
Εισαγωγή στις Αρχές της Επιστήμης των Η/Υ / Διάγραμμα ροής (Απορία)
« Τελευταίο μήνυμα από katsaplias στις Χθες στις 02:49:38 μμ »
Μπορεί κάποιος να μου δείξει το διάγραμμα ροής που αντιστοιχεί στον αλγοριθμο της εικόνας;
10
Τεχνική υποστήριξη / Απ: Ηλεκτρονικό Πρωτόκολλο Σχολείου
« Τελευταίο μήνυμα από Γεώργιος Θεοδώρου στις Χθες στις 10:05:33 πμ »
Στις πρόσφατες διανομές άλλαξε ο εξ ορισμού τρόπος σύνδεσης στη mysql - mariadb

Υπάρχουν δύο εναλλακτικές λύσεις:

--------------------------------------------------------------------------------------------------

Να φτιαχτεί ένας χρήστης πχ protocoluser και να του δοθούν όλα τα δικαιώματα στην βάση δεδομένων protocoldb
Αν γίνει αυτό πρέπει να αλλάξουμε αντίστοιχα τα στοιχεία στο Ηλ. Πρ.

στο αρχείο .env
DB_USERNAME=root protocoluser
DB_PASSWORD=p@ssw@rd νεο pass

config/database.php
'database' => env('DB_DATABASE', 'd@t@b@se'),
'username' => env('DB_USERNAME', 'rootprotocoluser'),
'password' => env('DB_PASSWORD', 'p@ssw@rdνεο pass'),

------------------------------------------------------------------------------------------------

H άλλη λύση που συνήθως υλοποιώ (μέχρι τώρα) είναι να ρυθμιστεί η  mysql να δέχεται είσοδο από το χρήστη root

# sudo mysql -u root

>USE mysql;
>UPDATE user SET plugin='mysql_native_password' WHERE User='root';
>FLUSH PRIVILEGES;
>exit;

-----------------------------------------------------------------------------------------------------------

Το script για εγκατάσταση σε ubuntu ενημερώθηκε

Ευχαριστώ πολύ
Στη διάθεσή σας



Σελίδες: [1] 2 3 4 ... 10