Αποστολέας Θέμα: Τράπεζα Θεμάτων  (Αναγνώστηκε 36942 φορές)

papaluk

  • Μηχ. Η/Υ & Πληρ. ΠΕ19
  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 94
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Τράπεζα Θεμάτων
« Απάντηση #45 στις: 13 Νοέ 2014, 12:18:12 μμ »
Θέμα 19378, η προτεινόμενη λύση με πίνακα... θεωρώ ότι έχει πρόβλημα. Το θέμα έχει αναλυθεί στο φορουμ. Μια άλλη λύση..
Αλγόριθμος Μαθητές
πλ  <-- 0 ! πάνω από τη βάση
αθολ<-- 0
πλολ<-- 0
Μαχ<-- -1
Επανάλαβε
  Διαβασε β
  Αν β<>0 τότε
     Αν β<10 τότε
        πλ<-- πλ + 1
     τέλος_αν
      Αν β > μαχ τότε
           μαχ<-- β
     τέλος_αν
      πλολ<--πλολ + 1
     αθολ<--αθολ + β
  Τέλος_αν
Μέχρις_οτου β=0
Αν πλολ = 0 τότε
   Εμφάνισε “Κανείς μαθητής”
Αλλιώς
        ΜΟολ<--αθολ/πλολ
   Εμφάνισε ΜΟολ, μαχ,πλ
Τέλος_αν
Τέλος Μαθητές

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3111
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Τράπεζα Θεμάτων
« Απάντηση #46 στις: 13 Νοέ 2014, 01:18:01 μμ »
Χτες το βράδυ ολοκληρώσαμε τη λύση των ασκήσεων. Τις μισές τις πήραμε από τον Σπύρο και το Θανάση. Ευχαριστώ όσους συνεργαστήκαμε.
Διόρθωσα και τις παρατηρήσεις του Θανάση κυρίως ως προς την απλή επιλογή
Το αρχείο θα μείνει ανοικτό για όποιον το επιθυμεί για επεξεργασία.

Προσωπικά θα δημιιουργήσω μια προσωπική εκδοχή με σχόλια, αλλαγή στα ονόματα των μεταβλητών (σεβάστηκα τις επιλογές κάθε λύτη και δεν τις άλλαξα), με σκοπό την ομογενοποίηση του κώδικα.
Φυσικά, θα παραθέσω δημόσια την νέα εκδοχή όταν τελειώσω.

Τα θέματα Δ είναι γενικά δύο τύπων:
  • τιμή φρουρός (λύση με Όσο)
  • γνωστό πλήθος επαναλήψεων ή ελάχιστο, μέγιστο στοιχείων (ακόμη και αγνώστου πλήθους)  (λύση με Για)
Και η πρώτη κατηγορία μπορεί να λυθεί με πίνακες σε αυτό το μάθημα, όμως θα το αποφύγω, διότι πρέπει να δουλέψουμε και το Όσο. Αυτό το τελευταίο το επεξεργάζομαι στο μυαλό μου, δεν έχω καταλήξει

Πρόσεξα ότι δεν υπάρχει πουθενά div/mod

Επίσης, κάποια θέματα θέλουν αναδιατύπωση (σοβαρή ενίοτε)  ή απόσυρση

ΥΓ: τα 2/3 της ΑΕΠΠ;; ναι;

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Τράπεζα Θεμάτων
« Απάντηση #47 στις: 13 Νοέ 2014, 01:20:23 μμ »
Θέμα 19378, η προτεινόμενη λύση με πίνακα... θεωρώ ότι έχει πρόβλημα. Το θέμα έχει αναλυθεί στο φορουμ. Μια άλλη λύση..
Αλγόριθμος Μαθητές
πλ  <-- 0 ! πάνω από τη βάση
αθολ<-- 0
πλολ<-- 0
Μαχ<-- -1
Επανάλαβε
  Διαβασε β
  Αν β<>0 τότε
     Αν β<10 τότε
        πλ<-- πλ + 1
     τέλος_αν
      Αν β > μαχ τότε
           μαχ<-- β
     τέλος_αν
      πλολ<--πλολ + 1
     αθολ<--αθολ + β
  Τέλος_αν
Μέχρις_οτου β=0
Αν πλολ = 0 τότε
   Εμφάνισε “Κανείς μαθητής”
Αλλιώς
        ΜΟολ<--αθολ/πλολ
   Εμφάνισε ΜΟολ, μαχ,πλ
Τέλος_αν
Τέλος Μαθητές


Η λύση που δίνεις είναι το ίδιο σωστή με τη λύση με πίνακα. Δες το σχολικό βιβλίο στη σελίδα 44.
Άλλο το μάθημα της ΑΕΠΠ και άλλο το μάθημα της Β' Λυκείου.

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Τράπεζα Θεμάτων
« Απάντηση #48 στις: 13 Νοέ 2014, 01:36:13 μμ »
Συνάδελφοι στο https://introcsprinciples.wordpress.com/ υπάρχουν όλες οι λύσεις των θεμάτων της τράπεζας.

Επίσης, έγινε προσπάθεια να προσδιοριστούν οι αστοχίες των θεμάτων.

athinodor

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Τράπεζα Θεμάτων
« Απάντηση #49 στις: 13 Νοέ 2014, 06:32:56 μμ »
Καλησπέρα συνάδελφοι και συγχαρητήρια για την πολύ καλή δουλειά. Θα ήθελα να ρωτήσω-επισημάνω το εξής. Οι κωδικοί (και οι εκφωνήσεις σε ορισμένα) από τα θέματα της τράπεζας θεμάτων έχουν αλλάξει στο site του Υπουργείου σε σχέση με τις προτεινόμενες λύσεις.

Επίσης παρατήρησα αλλαγή στο πλήθος των θεμάτων. Ενώ αρχικά ήταν 24 τώρα είναι 18.

Το παρατήρησε κανένας άλλος αυτό ή έχω παραισθήσεις λόγω υψηλού πυρετού;

Επίσης βλέποντας λίγο τις εκφωνήσεις βλέπω να έκαναν τα θέματα λίγο πιο εύκολα. Σα να κοίταξαν τις προτεινόμενες λύσεις και να πήραν πίσω τις υπερβολές....

Δεν ξέρω, μπορείτε να το δείτε λίγο κι εσείς;

dimpapadop

  • Βετεράνος
  • ****
  • Μηνύματα: 51
Απ: Τράπεζα Θεμάτων
« Απάντηση #50 στις: 13 Νοέ 2014, 06:36:08 μμ »
Καλησπέρα συνάδελφοι και συγχαρητήρια για την πολύ καλή δουλειά. Θα ήθελα να ρωτήσω-επισημάνω το εξής. Οι κωδικοί (και οι εκφωνήσεις σε ορισμένα) από τα θέματα της τράπεζας θεμάτων έχουν αλλάξει στο site του Υπουργείου σε σχέση με τις προτεινόμενες λύσεις.

Επίσης παρατήρησα αλλαγή στο πλήθος των θεμάτων. Ενώ αρχικά ήταν 24 τώρα είναι 18.

Το παρατήρησε κανένας άλλος αυτό ή έχω παραισθήσεις λόγω υψηλού πυρετού;

Επίσης βλέποντας λίγο τις εκφωνήσεις βλέπω να έκαναν τα θέματα λίγο πιο εύκολα. Σα να κοίταξαν τις προτεινόμενες λύσεις και να πήραν πίσω τις υπερβολές....

Δεν ξέρω, μπορείτε να το δείτε λίγο κι εσείς;

Αν έγινε αυτό, (δεν έλεγξα σήμερα), είναι ακριβώς ο λόγος που γκρίνιαξα χθές εδώ για την "υποστήριξη" (προσέξτε, εντός εισαγωγικών) που έδωσε ο Παναγιώτης παραπάνω στους υπεύθυνους της τράπεζας.

Μας αποσυντονίζουν πλήρως, δεν υπάρχει καμία οργάνωση και καμία σοβαρότητα στους υπεύθυνους της Τράπεζας.
Κάνεις ανάρτηση σε θέματα που περιέχουν τέτοιες ασάφειες, σβήνεις-γράφεις, και ... ...

είναι απίστευτη η προχειρότητα.

athinodor

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Τράπεζα Θεμάτων
« Απάντηση #51 στις: 13 Νοέ 2014, 06:39:43 μμ »
Μπορείς να τσεκάρεις ένα δύο θέματα για να μη νομίζω ότι έχω παραισθήσεις;

dimpapadop

  • Βετεράνος
  • ****
  • Μηνύματα: 51
Απ: Τράπεζα Θεμάτων
« Απάντηση #52 στις: 13 Νοέ 2014, 06:42:12 μμ »
Μπορείς να τσεκάρεις ένα δύο θέματα για να μη νομίζω ότι έχω παραισθήσεις;

24 τα βλέπω ξανά... δεν προλαβαίνω όμως σήμερα να ελέγξω το περιεχόμενο τους.

ελπίζω απλώς, τα υπάρχοντα με ασάφειες να διορθωθούν και να μην γίνει καμία "κασκαρίκα" αυτού του τύπου τελλικά :) με τρόμαξες και ήταν αυτό ακριβώς που σκεφτόμουν χθές. χα χα


athinodor

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Τράπεζα Θεμάτων
« Απάντηση #53 στις: 13 Νοέ 2014, 06:48:55 μμ »
24 τα βλέπω ξανά... δεν προλαβαίνω όμως σήμερα να ελέγξω το περιεχόμενο τους.

ελπίζω απλώς, τα υπάρχοντα με ασάφειες να διορθωθούν και να μην γίνει καμία "κασκαρίκα" αυτού του τύπου τελλικά :) με τρόμαξες και ήταν αυτό ακριβώς που σκεφτόμουν χθές. χα χα

Εγώ κοιτάζω εδώ. Δες το συνημμένο. Τι κάνω λάθος;

athinodor

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Τράπεζα Θεμάτων
« Απάντηση #54 στις: 13 Νοέ 2014, 06:51:01 μμ »
Άκυρο....

Με πείραξε ο πυρετός και κοίταζα τα θέματα ΕΠΑΛ.

Χίλια συγνώμη για την αναστάτωση.

dimpapadop

  • Βετεράνος
  • ****
  • Μηνύματα: 51
Απ: Τράπεζα Θεμάτων
« Απάντηση #55 στις: 13 Νοέ 2014, 06:56:39 μμ »
αλήθεια με αναστάτωσες... :)  (όπως κατάλαβες)

αν και θεωρώ σχεδόν σίγουρο το ότι θα συμβεί. (δεν είναι κακό να διορθωθούν οι "λάθος" εκφωνήσεις)
αλλά όχι και να αλλάξουν τα υπόλοιπα, την βάση στην οποία αρχίσαμε να πατάμε. :)

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 64
Απ: Τράπεζα Θεμάτων
« Απάντηση #56 στις: 13 Νοέ 2014, 09:17:32 μμ »
ΥΓ: τα 2/3 της ΑΕΠΠ;; ναι;
...μάλλον πάνω από τα 3/3, γιατί έχει και περισσότερα θεωρητικά θέματα. Με την ευκαιρία, πού βρίσκεστε στην ύλη; Στο πιο προχωρημένο τμήμα βρισκόμαστε στο "Διάβασε". Εκχώρηση δεν προλάβαμε. Την άλλη εβδομάδα ίσως αν δε χάσουμε κανένα μάθημα. Πώς θα βγει όλη αυτή η ύλη;

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1263
  • There are always possibilities...
Απ: Τράπεζα Θεμάτων
« Απάντηση #57 στις: 13 Νοέ 2014, 09:36:47 μμ »
Σύμφωνώ με το παραπάνω σχόλιο του Θανάση

Παράθεση
... πάντα η κριτική είναι εύκολη, η παραγωγή όμως δύσκολη.

Και για να πούμε και το στραβού το δίκαιο, υπάρχουν θέματα στο βιβλίο που είναι πιο δύσκολα από αυτά της τράπεζας (Για παράδειγμα: 31, 42).
Επίσης ας μην κοιτάμε μόνο το θέμα Δ, τα Β είναι αρκετά βατά.

Στην ύλη είμαι και εγώ στο Διάβασε, έχοντας αρκετά χαμένα μαθήματα.
A man provided with paper, pencil, and rubber, and subject to strict discipline is in effect a universal machine - Alan Turing

georgm

  • Νέος
  • *
  • Μηνύματα: 7
Απ: Τράπεζα Θεμάτων
« Απάντηση #58 στις: 13 Νοέ 2014, 11:00:42 μμ »
Στο πιο προχωρημένο τμήμα κι εγώ είμαι στη Διάβασε, στα άλλα 4 που έχω, χάνω μαθήματα συνέχεια (περίπατος, συνέλευση μαθητών, εκπαιδευτική εκδρομή) και κάνω να τους δω δύο εβδομάδες.

Αναγκαστικά, θα "πατήσω" κι εγώ πάνω στην ΤΘΔΔ (κυρίως 4ο θέμα), εις βάρος, φυσικά, της υπόλοιπης ύλης. Επίσης, έχω σκοπό τα διαγωνίσματα που θα τους βάλω να είναι αποκλειστικά από θέματα ΤΘΔΔ που έχουμε κοιτάξει στην τάξη, και το ίδιο σκέφτομαι και για τα τελικά θέματα (τα δικά μου να είναι δηλαδή και πάλι από την ΤΘΔΔ). Δηλαδή, σκοπεύω να μην καλύψω καν ασκήσεις του βιβλίου, π.χ. div, mod εκτός αν προστεθούν σχετικά θέματα στη συνέχεια.
Δισδιάστατοι, αναζήτηση, ταξινόμηση λογικά (;;; - δε ξέρω πια τι είναι λογικό) θα μπουν στη συνέχεια.
Τέλος, αναγκαστικά, θα είμαι πολύ "ευέλικτος" στη βαθμολογία μου, τόσο στα τετράμηνα, όσο και στις τελικές εξετάσεις.

Θεωρώ, ότι ένα χρήσιμο εργαλείο όπως η ΤΘΔΔ "καίγεται" χωρίς λόγο και, δυστυχώς, τελικά οδηγεί στο αντίθετο από εκείνο που έλεγε εκείνος ο ανεκδιήγητος που έγινε και υπουργός ότι έτσι θα αναγκάζονται οι καθηγητές να βγάζουν την ύλη.

Επίσης, "καταστρέφεται" ένα όμορφο μάθημα που κεντρίζει το ενδιαφέρον πολλών μαθητών-τριών, από το άγχος και την αναμπουμπούλα.

Το κυριότερο, "καίγονται" τα παιδιά. Η φετινή Β είναι πολύ άτυχη.

Οι λύσεις για μένα είναι 2 για να γίνει το μάθημα ανθρώπινο:
1. Φέτος, τώρα, να βγουν οι πίνακες εκτός ύλης και να αποσυρθούν τα σχετικά θέματα που δεν είναι και πολλά. Το είπα στον σύμβουλο μου, θα του το ξαναπώ, δε νομίζω, για να πω την αλήθεια, ότι θα γίνει κάτι τέτοιο, αλλά θυμόμαστε όλοι το επίπεδο των θεμάτων στα πρώτα χρόνια της ΑΕΠΠ.
2. Από του χρόνου το μάθημα να γίνει δίωρο, εις βάρος μάλλον του project, που ως μονόωρο είναι επίσης ανέκδοτο (έχω να τους κάνω επίσης μάθημα εδώ και 2 εβδομάδες).

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 64
Απ: Τράπεζα Θεμάτων
« Απάντηση #59 στις: 13 Νοέ 2014, 11:27:14 μμ »
Τέλος, αναγκαστικά, θα είμαι πολύ "ευέλικτος" στη βαθμολογία μου, τόσο στα τετράμηνα, όσο και στις τελικές εξετάσεις.
+1 , αλλά για ποιο λόγο να είμαστε αναγκασμένοι να καταφύγουμε σε αυτές τις διαδικασίες;
Σύμφωνώ με το παραπάνω σχόλιο του Θανάση
+1 , αλλά...
όταν η κριτική είναι καλόπιστη και εποικοδομητική  θα πρέπει να επιζητείται, ίσως και να λαμβάνεται υπόψη και καμιά φορά. Το μάθημα της Β' είναι μια εξέλιξη που όλοι θεωρώ δεχτήκαμε με ανακούφιση και ενθουσιασμό μετά από τόσα χρόνια άσκοπου βασανισμού (για μας και τους μαθητές μας) με την τεχνολογία επικοινωνιών. Όμως τώρα που είναι αρχή νομίζω ότι καλό είναι να ακούγονται και προτάσεις βελτίωσης από αυτούς που διδάσκουν το μάθημα που άλλοι σχεδίασαν (και τους ευχαριστούμε γι'αυτό). Αυτό δε σημαίνει ούτε ότι το π.σ. ούτε ότι το βιβλίο δεν είναι καλά. Απλώς εκφράζω την αγωνία μου για το μεγάλο όγκο της ύλης, ο οποίος καλό θα ήταν να προσαρμοστεί σε λογικά πλαίσια.

Οι λύσεις για μένα είναι 2 για να γίνει το μάθημα ανθρώπινο:
1. Φέτος, τώρα, να βγουν οι πίνακες εκτός ύλης και να αποσυρθούν τα σχετικά θέματα που δεν είναι και πολλά.
2. Από του χρόνου το μάθημα να γίνει δίωρο.
+1  !!!!!!!!!!!!!!!