Αποστολέας Θέμα: 2004 - Θέμα 3  (Αναγνώστηκε 5035 φορές)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 797
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
2004 - Θέμα 3
« στις: 01 Ιούν 2004, 06:48:12 μμ »
Ας βάλουμε όλα τα σχόλια/ερωτήσεις/παρατηρήσεις σχετικά με το θέμα 3 των εξετάσεων ενιαίων λυκείων το 2004, σε αυτό το χώρο
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

mbathas

  • Βετεράνος
  • ****
  • Μηνύματα: 88
    • mbathas@im.sch.gr
    • blogs.sch.gr/mbathas
ΕΝΑΛΛΑΚΤΙΚΟΣ ΤΡΟΠΟΣ ΛΥΣΗΣ
« Απάντηση #1 στις: 02 Ιούν 2004, 08:33:46 πμ »
Συνάδελφοι
Νομίζω ότι ο πιο προφανής και 'κομψός΄ αλγόριθμος για το θέμα είναι με χρήση εμφωλευμένων δομών επιλογών. Παραθέτω και μια άλλη λύση που υλοποίησε μαθήτριά μου και που κατά τη γνώμη μου είναι σωστή περιμένοντας τυχόν σχόλια σας.

Αλγόριθμος Θέμα_3
Διάβασε βάρος, προορισμός
Αν βάρος<=500 ΚΑΙ προορισμός='Εσ' τότε
    Χρέωση<-- ......
Αλλιώς_αν Βάρος<=500 ΚΑΙ προορισμός='Εξ' τότε
    Χρέση<--.......
Αλλιώς_αν Βάρος<=1000 ΚΑΙ προορισμός='Εσ' τότε
    Χρέση<--.......
Αλλιώς_αν Βάρος<=1000 ΚΑΙ προορισμός='Εξ' τότε
    Χρέση<--.......
Αλλιώς
    Αν προορισμός='Εσ' τότε
        Χρέωση<--.....
    αλλιώς
         Χρέωση<--.....
     Τέλος_αν
Τέλος_αν
Εμφάνισε Χρέωση
Τελος Θέμα_3

Συγχωρέστε τις τελίτσες δεν θυμάμαι τις χρεώσεις απ'έξω.
Όσο για την απουσία ελέγχου έγκυρης καταχώρησης νομίζω ότι η παρατήρηση αυτό ακριβώς υποδυκνύει.
Μιχάλης Μπάθας
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3119
  • Dracarys
    • Panagiotis Tsiotakis
Re: 2004 - Θέμα 3
« Απάντηση #2 στις: 02 Ιούν 2004, 10:20:54 πμ »
Αγαπητοί φίλοι,

Πιο εύκολο θέμα δεν υπάρχει πια από το θέμα 3


Έλεγχος έγκυρης καταχώρησης δεν χρειάζεται αφού θεωρούμε οτι τα δεδομένα εισάγονται σωστά!! Δεν θέλω να πιστέψω οτι αν δεν υπάρχει έλεγχος δεν δίνονται όλα τα μόρια!!

Ο προηγούμενος αλγόριθμος μου φαίνεται σωστός... Παρ'όλα αυτά πιστεύω οτι η συγκεκριμένη μαθήτρια δυσκόλεψε μόνης της τα πράγματα... Το αποτέλεσμα μετράει

Με εκτίμηση,

xaidi

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 111
  • who is WHO!!!!!!
Re: 2004 - Θέμα 3
« Απάντηση #3 στις: 02 Ιούν 2004, 10:55:58 πμ »
πιστεύω ότι ειλικρινά το θέμα αυτό μπορεί να χαρακτηριστεί πανεύκολο.
διάβασα πριν ότι αν δεν έχει γίνει έλεγχος εγκυρότητας τιμών εισόδου κάποιοι μπορούν να κόψουν μονάδες.
εμείς με τους μαθητές μοθ κάναμε πάντα έλεγχο τιμών (είτε το ζητούσε είτε όχι με παρατήρηση), εκτός αν ανέφερε κάπου στην εκφώνηση ότι δεν πρέπει να γίνει όπως και στο συγκεκριμένπ θέμα.
θεωρώ ότι το θέμα ξεκαθάρισε ότι δεν χρειάζεται να γίνει κατι τέτοιο καθαρά. (και ήταν και μια από τις ερωτήσεις των μαθητών ..."το θέμα έλεγε πως δεν χρειάζεται, έτσι δεν είναι;").
τέλος η λύση που έδωσε  φίλος mbathas πιστέυω ότι δεν είναι λάθος αλλα υπάρχει και μια καλύτερη (αν μοθ επιτρεπετε), με σωστότερουσ ελέγχους.
Αλγόριθμος Θέμα_3
Γράψε "δώσε το βάρος της επιστολής"
Διάβασε βάρος
Γράψε "δώσε τον προορισμό της επιστολής"
Διάβασε προορισμός
Αν προορισμός='Εσ' τότε
    Αν Βάρος <=500 τότε
    Χρέωση<-- ......
    Αλλιώς_αν Βάρος<=1000 τότε
    Χρέση<--.......
    Αλλιώς
    Χρέση<--.......
    Τέλος_αν
Αλλιώς
   Αν Βάρος <=500 τότε
    Χρέωση<-- ......
    Αλλιώς_αν Βάρος<=1000 τότε
    Χρέση<--.......
    Αλλιώς
    Χρέση<--.......
    Τέλος_αν
Τέλος_αν
Εμφάνισε Χρέωση
Τελος Θέμα_3


« Τελευταία τροποποίηση: 02 Ιούν 2004, 10:57:52 πμ από xaidi »
Ευχαριστώ,

mbathas

  • Βετεράνος
  • ****
  • Μηνύματα: 88
    • mbathas@im.sch.gr
    • blogs.sch.gr/mbathas
Re: 2004 - Θέμα 3
« Απάντηση #4 στις: 02 Ιούν 2004, 11:02:44 πμ »
Αγαπητέ Παναγιώτη,
πραγματικά το να κοπούν μόρια από την απουσία ελέγχου, τη στιγμή που άλλες χρονιές όταν ζητούσαν έλεγχο το ζητούσαν στην εκφώνηση με μεγάλη σαφήνεια, μου φαντάζει "τρελλό" και δε νομίζω να γίνει.
Όσο για το βαθμό δυσκολίας του 3ου θέματος πιστέυω ότι είναι ακριβώς στο επίπεδο που θα'πρεπε να είναι.Εξετάζει την ικανότητα του μαθητή να υλοποιήσει ένα αλγόριθμο με δομή επιλογής ελέγχοντας δύο κριτήρια.Το βρίσκω ΟΚ.
Μπορεί στα δικά μας μάτια να φαντάζει "παιχνίδι" αν θέλεις, όμως απευθύνεται στα μάτια των παιδιών που στην πλειοψηφία τους έχουν μόνο κάποιους μήνες εξοικείωσης με τον αλγοριθμικό τρόπο σκέψης.
Εξάλλου οι φετινοί "programmers" θα ξεχωρίσουν στο 4ο θέμα πιστεύω!

Με εκτίμηση    
Μιχάλης Μπάθας
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3119
  • Dracarys
    • Panagiotis Tsiotakis
Re: 2004 - Θέμα 3
« Απάντηση #5 στις: 02 Ιούν 2004, 11:10:22 πμ »
Μιχάλη,

πανεύκολο εννοώ οτι είναι στο ΙΔΙΟ ΑΚΡΙΒΩΣ πλαίσιο εδώ και 3-4 χρόνια, που σημαίνει οτι αν το προηγούμενο απόγευμα λύσεις 4-5 ασκήσεις τέτοιες και 4-5 από τις κλασικές ασκήσεις πινάκων παίρνεις 30/40 μόρια των 2 τελευταίων θεμάτων

Κατά τα άλλα είμαστε σύμφωνοι,

mbathas

  • Βετεράνος
  • ****
  • Μηνύματα: 88
    • mbathas@im.sch.gr
    • blogs.sch.gr/mbathas
Re: 2004 - Θέμα 3
« Απάντηση #6 στις: 02 Ιούν 2004, 11:12:27 πμ »
Φίλη xaidi,
σίγουρα η λύση που παραθέτεις,όπως έγραψα και στο προηγούμενο post είναι η πιο προφανής και η πιο 'κομψή'.Αν θέλεις και από πλευράς χρόνου εκτέλεσης η ταχύτερη.
Απλά πιστεύω ότι και η λύση που παραθέτω πιο πάνω πρέπει να πάρει τις μονάδες "κομπλέ".
Υ.Γ.  Γιατί στον αλγόριθμο σου γράφεις ειδοποιητικά μηνύματα;
       (Γράψε "Δώσε το βάρος της επιστολής)
       Νομίζω δε χρειάζεται.

Με εκτίμηση,  
Μιχάλης Μπάθας
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής

mbathas

  • Βετεράνος
  • ****
  • Μηνύματα: 88
    • mbathas@im.sch.gr
    • blogs.sch.gr/mbathas
Re: 2004 - Θέμα 3
« Απάντηση #7 στις: 02 Ιούν 2004, 11:17:39 πμ »
Παναγιώτη συμφωνώ πάνω σ' αυτό που λες, ότι δηλαδή στα θέματα ακολουθείται μία "πεπατημένη".
Πάντως οφείλουμε να ομολογήσουμε ότι υπάρχουν σημάδια βελτίωσης χρόνο με το χρόνο.
Άντε σε δυο-τρία χρόνια θα στρώσουν εκτός και αν το μάθημα αποτελεί μια ανάμνηση παλιά...
Μιχάλης Μπάθας
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: 2004 - Θέμα 3
« Απάντηση #8 στις: 02 Ιούν 2004, 12:23:56 μμ »
Συνάδελφοι  
Καλημέρα
Παραθέτω και μια άλλη λύση που υλοποίησαν τα περισσότερα παιδιά και που κατά τη γνώμη μου είναι σωστή περιμένοντας τυχόν σχόλια σας.

Αλγόριθμος Θέμα_3
Εμφάνισε " .....   "
Διάβασε βάρος
Εμφάνισε "........."
Διάβασε προορισμός
Αν βάρος<=500 τότε
  Αν προορισμός='Εσ' τότε
    Χρέωση<-- 2
  Αλλιώς
    Χρέωση<-- 4,8
  Τέλος_αν
Αλλιώς_αν Βάρος<=1000  
   Αν προορισμός='Εσ' τότε
    Χρέωση<-- 3,5
   Αλλιώς
    Χρέωση<-- 7,2
 Τέλος_αν
Αλλιώς
   Αν προορισμός='Εσ' τότε
    Χρέωση<-- 4,6
   Αλλιώς
    Χρέωση<-- 11,5
 Τέλος_αν
Τέλος_αν

Εμφάνισε " .......",Χρέωση
Τελος Θέμα_3

Σημείωση
Επαειδή βλέπω ότι δεν προτείνεται δεν νομίζω να υπάρχει πρόβλημα στο να χάσει κάποιος μαθητής μονάδες
Περιμένω απάντηση

Αθανασόπουλος Παντελής
Καθηγητής ΠΕ19
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

mbathas

  • Βετεράνος
  • ****
  • Μηνύματα: 88
    • mbathas@im.sch.gr
    • blogs.sch.gr/mbathas
Re: 2004 - Θέμα 3
« Απάντηση #9 στις: 02 Ιούν 2004, 12:32:22 μμ »
Φίλε Παντελή,
σαφώς και είναι σωστή η προσέγγιση, μια απλή αντιστροφή στον έλεγχο βάρους και προορισμού κάνεις στην προτεινόμενη λύση.
Ασφαλώς και πρέπει να πάρει το άριστα.

Με εκτίμηση
Μιχάλης Μπάθας
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3119
  • Dracarys
    • Panagiotis Tsiotakis
Re: 2004 - Θέμα 3
« Απάντηση #10 στις: 03 Ιούν 2004, 08:23:15 πμ »
Παντελή και δική μου μαθήτρια έτσι το έλυσε, πιστεύω οτι είναι 100% σωστό.
Διπλάσιο σε όγκο αλλά σωστό  :)

Με εκτίμηση,
« Τελευταία τροποποίηση: 03 Ιούν 2004, 08:23:56 πμ από ptsiotakis »

bax

  • Επισκέπτης
Re: 2004 - Θέμα 3
« Απάντηση #11 στις: 06 Ιούν 2004, 08:52:01 πμ »
Παραθέτω αυτούσιο τον αλγόριθμο του θέματος 3 όπως τον αντιμετώπισε ένας μαθητής και θα ήθελα τα σχόλιά σας και την γνώμη σας για το πόσες μονάδες θα μπορούσε να πάρει ή να χάσει αντίστοιχα το συγκεκριμένο θέμα.

Αλγόριθμος θέμα3
Για ι από 1 μέχρι 3
Για ξ από 1 μέχρι 2
διάβασε ΠΙΝ[ι,ξ] !Αποθηκεύει τις χρεώσεις σε έναν πίνακα
Τέλος_επανάληψης
Τέλος_επανάληψης
Διάβασε Βάρος
Διάβασε Προορισμό
Αν (Βάρος>0) ΚΑΙ (Βάρος<=500) ΤΟΤΕ
Αν Προορισμός='ΕΣ' ΤΟΤΕ
Έξοδα<-ΠΙΝ[1,1]
αλλιώς
Έξοδα<-ΠΙΝ[1,2]
Τέλος_αν
Τέλος_αν
Αν (Βάρος>500) ΚΑΙ (Βάρος<=1000) ΤΟΤΕ
Αν Προορισμός='ΕΣ' ΤΟΤΕ
Έξοδα<-ΠΙΝ[2,1]
αλλιώς
Έξοδα<-ΠΙΝ[2,2]
Τέλος_αν
Τέλος_αν
Αν (Βάρος>1000) ΚΑΙ (Βάρος<=2000) ΤΟΤΕ
Αν Προορισμός='ΕΣ' ΤΟΤΕ
Έξοδα<-ΠΙΝ[3,1]
αλλιώς
Έξοδα<-ΠΙΝ[3,2]
Τέλος_αν
Τέλος_αν
Εκτύπωσε Έξοδα
Τέλος ΘΕΜΑ 3

Η ένσταση ίσως είναι ότι διαβάζει τις τιμές στον πίνακα ενώ έπρεπε να τις καταχωρεί, κατά τα άλλα θα μπορούσε να θεωρηθεί σωστός ο αλγόριθμος;

George

  • Θαμώνας
  • ***
  • Μηνύματα: 41
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: 2004 - Θέμα 3
« Απάντηση #12 στις: 06 Ιούν 2004, 12:12:55 μμ »
Αγαπητέ bax,
ο αλγόριθμος απαντά σωστά σε όλα τα ερωτήματα της άσκησης και κατα τη γνώμη μου είναι σωστός. Η μόνη ένσταση, όπως επισημαίνεις και εσύ, είναι το διάβασμα του πίνακα με τις χρεώσεις που δεν ανταποκρίνεται στην εκφώνηση της άσκησης. Θα ήταν καλύτερα αν δηλωνόταν στα δεδομένα.
Όμως δεν είμαι διορθωτής και δεν μπορώ να σου πω αν αυτό του στοιχίσει μόρια ή όχι. Ελπίζω το δεύτερο.

xaidi

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 111
  • who is WHO!!!!!!
Re: 2004 - Θέμα 3
« Απάντηση #13 στις: 07 Ιούν 2004, 12:13:35 μμ »
Υ.Γ.  Γιατί στον αλγόριθμο σου γράφεις ειδοποιητικά μηνύματα;  
  (Γράψε "Δώσε το βάρος της επιστολής)
  Νομίζω δε χρειάζεται.
Φίλε mbatha πιστεύω ότι τα μηνύματα πριν το διάβασε είναι "αναγκαία" για την εκτέλεση του αλγορίθμου ώστε ο υποτιθέμενος χρήστης να γνωρίζει τι τιμές θα εισάγει, ειδικά όταν χρειάζεται πολλαπλή εισαγωγή τιμών.  Δεν γνωρίζω αν αφαιρούνται ή όχι μόρια αλλά πιστεύω ότι όταν γράφουμε επίσημα έναν αλγόριθμο -όπως στις εξετάσεις- πρέπει να υπάρχουν για προφανείς λόγους. Οι δικοί μου μαθητές τουλάχιστον το κάνουν.
Ευχαριστώ,

mbathas

  • Βετεράνος
  • ****
  • Μηνύματα: 88
    • mbathas@im.sch.gr
    • blogs.sch.gr/mbathas
Re: 2004 - Θέμα 3
« Απάντηση #14 στις: 07 Ιούν 2004, 01:27:09 μμ »
φίλη xaidi,
εάν ακολουθήσουμε τον τρόπο γραφής του βιβλίου είναι φανερό ότι τέτοιου είδους μηνύματα υπάρχουν μόνο όταν προγραμματίζουμε σε 'ΓΛΩΣΣΑ'. Ο αλγόριθμος υποτίθεται ότι είναι το "προσχέδιο" που γράφουμε με χαρτί και μολύβι και αφού τον υλοποιήσουμε σωστά τονμεταφράζουμε σε πρόγραμμα για να περαστεί στον υπολογιστή.
Nevermind, επί της ουσίας, πιστεύω ότι και να γραφούν τέτοια μηνύματα σε αλγόριθμο δεν είναι λάθος.

Με εκτίμηση,
Μιχάλης Μπάθας
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής