Αποστολέας Θέμα: προβλημα στη ΓΛΩΣΣΑ (μέσα από LTSP)  (Αναγνώστηκε 710 φορές)

bobptz

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
    • blog με ασκήσεις και υλικό για μαθητές
προβλημα στη ΓΛΩΣΣΑ (μέσα από LTSP)
« στις: 04 Φεβ 2014, 12:24:19 μμ »
Το ακόλουθο πρόγραμμα μου βγάζει μήνυμα ότι το μεγι8 πρέπει να χρησιμοποιείται μόνο σαν μέρος έκφρασης και όχι σαν εντολή (στη γραμμή :   ΓΡΑΨΕ μεγι8(10, 20, 15, 340, 56, 2, 45, 60) ).  Όταν κλείνω την εφαρμογη, την ξανανοίγω, το κάνω επικόληση, δουλεύει μια χαρά:

>>>
ΠΡΟΓΡΑΜΜΑ ψψψ
ΑΡΧΗ
  ΓΡΑΨΕ μεγι8(10, 20, 15, 340, 56, 2, 45, 60)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ μεγι8(α1, α2, α3, α4, α5, α6, α7, α8): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α1, α2, α3, α4, α5, α6, α7, α8, μμ
ΑΡΧΗ
  μμ <- 0
  ΑΝ α1 > μμ ΤΟΤΕ
    μμ <- α1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ α2 > μμ ΤΟΤΕ
    μμ <- α2
  ΤΕΛΟΣ_ΑΝ
  ΑΝ α3 > μμ ΤΟΤΕ
    μμ <- α3
  ΤΕΛΟΣ_ΑΝ
  ΑΝ α4 > μμ ΤΟΤΕ
    μμ <- α4
  ΤΕΛΟΣ_ΑΝ
  ΑΝ α5 > μμ ΤΟΤΕ
    μμ <- α5
  ΤΕΛΟΣ_ΑΝ
  ΑΝ α6 > μμ ΤΟΤΕ
    μμ <- α6
  ΤΕΛΟΣ_ΑΝ
  ΑΝ α7 > μμ ΤΟΤΕ
    μμ <- α7
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α8 > μμ ΤΟΤΕ
    μμ <- α8
  ΤΕΛΟΣ_ΑΝ
  μεγι8 <- μμ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ μεγι (α, β): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
ΑΡΧΗ
  ΑΝ α > β ΤΟΤΕ
    μεγι <- α
  ΑΛΛΙΩΣ
    μεγι <- β
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
<<<

Γλώσσα 1.5.1.3
http://pitatzidis.blogspot.gr/.    Σχολείο: http://gymsimantra.blogspot.gr/

server : intel pentium G645 @ 2,9 ghz με 12 gb ram (http://www.cpubenchmark.net/cpu.php?cpu=Intel+Pentium+G645+%40+2.90GHz)
switch:  TP-LINK 24+2G Unmanaged Gigabit-Uplink Switch
Net card: TP-LINK TG-3468